kernel-6.0.7-301
* Thu Nov 03 2022 Justin M. Forbes <jforbes@fedoraproject.org> [6.0.7-0] - Add revert patch for BTF workaround (Justin M. Forbes) - Linux v6.0.7 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
5eeaf6d4b5
commit
f4b82225e9
@ -1,3 +1,6 @@
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/03928964c7af719ea1e4ee7bd5681800543c6ed6
|
||||
03928964c7af719ea1e4ee7bd5681800543c6ed6 Fix up vc4 merge for Pi4
|
||||
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/bf2bceedcc5d66c041165b4db6aea032fd7f4b5c
|
||||
bf2bceedcc5d66c041165b4db6aea032fd7f4b5c drm/simpledrm: Only advertise formats that are supported
|
||||
|
||||
|
@ -124,13 +124,13 @@ Summary: The Linux kernel
|
||||
# define buildid .local
|
||||
%define specversion 6.0.7
|
||||
%define patchversion 6.0
|
||||
%define pkgrelease 300
|
||||
%define pkgrelease 301
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.0.7
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 0
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 300%{?buildid}%{?dist}
|
||||
%define specrelease 301%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.0.7
|
||||
|
||||
@ -3180,6 +3180,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Nov 04 2022 Justin M. Forbes <jforbes@fedoraproject.org> [6.0.7-301]
|
||||
- Fix up vc4 merge for Pi4 (Justin M. Forbes)
|
||||
|
||||
* Thu Nov 03 2022 Justin M. Forbes <jforbes@fedoraproject.org> [6.0.7-0]
|
||||
- Add revert patch for BTF workaround (Justin M. Forbes)
|
||||
- Linux v6.0.7
|
||||
|
@ -42,7 +42,7 @@
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 6 +
|
||||
tools/testing/selftests/net/fib_nexthops.sh | 5 +
|
||||
44 files changed, 609 insertions(+), 199 deletions(-)
|
||||
44 files changed, 607 insertions(+), 201 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index c2144a4bb2ef..4e8ae58e2ec1 100644
|
||||
@ -702,7 +702,7 @@ index 5422363690e7..a5b500811892 100644
|
||||
}
|
||||
|
||||
diff --git a/drivers/gpu/drm/vc4/vc4_hdmi.c b/drivers/gpu/drm/vc4/vc4_hdmi.c
|
||||
index 780a19a75c3f..281f01e8cbca 100644
|
||||
index 780a19a75c3f..4e5bba0822a5 100644
|
||||
--- a/drivers/gpu/drm/vc4/vc4_hdmi.c
|
||||
+++ b/drivers/gpu/drm/vc4/vc4_hdmi.c
|
||||
@@ -2712,9 +2712,16 @@ static int vc4_hdmi_init_resources(struct vc4_hdmi *vc4_hdmi)
|
||||
@ -752,14 +752,20 @@ index 780a19a75c3f..281f01e8cbca 100644
|
||||
int ret;
|
||||
|
||||
/*
|
||||
@@ -2884,6 +2898,25 @@ static int vc4_hdmi_runtime_resume(struct device *dev)
|
||||
@@ -2876,14 +2890,29 @@ static int vc4_hdmi_runtime_resume(struct device *dev)
|
||||
* its frequency while the power domain is active so that it
|
||||
* keeps its rate.
|
||||
*/
|
||||
- ret = clk_set_min_rate(vc4_hdmi->hsm_clock, HSM_MIN_CLOCK_FREQ);
|
||||
+ ret = clk_set_min_rate(vc4_hdmi->hsm_rpm_clock, HSM_MIN_CLOCK_FREQ);
|
||||
if (ret)
|
||||
return ret;
|
||||
|
||||
- ret = clk_prepare_enable(vc4_hdmi->hsm_clock);
|
||||
+ ret = clk_prepare_enable(vc4_hdmi->hsm_rpm_clock);
|
||||
+ if (ret)
|
||||
+ return ret;
|
||||
+
|
||||
if (ret)
|
||||
return ret;
|
||||
|
||||
+ /*
|
||||
+ * Whenever the RaspberryPi boots without an HDMI monitor
|
||||
+ * plugged in, the firmware won't have initialized the HSM clock
|
||||
@ -778,7 +784,7 @@ index 780a19a75c3f..281f01e8cbca 100644
|
||||
if (vc4_hdmi->variant->reset)
|
||||
vc4_hdmi->variant->reset(vc4_hdmi);
|
||||
|
||||
@@ -2905,6 +2938,10 @@ static int vc4_hdmi_runtime_resume(struct device *dev)
|
||||
@@ -2905,6 +2934,10 @@ static int vc4_hdmi_runtime_resume(struct device *dev)
|
||||
#endif
|
||||
|
||||
return 0;
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.0.7.tar.xz) = a7b298fbf3ff5bf759755589748b16428fdf35225013709eeb645bd09368937ed4f7f6c23c70cdfa077e8d20cffa2ee4fbb24e4e3023bafcb46c845aeeaff19e
|
||||
SHA512 (kernel-abi-stablelists-6.0.7.tar.bz2) = 6ecdb77bc89d7ef89adadb1d7a857b56101a2bde8a0b109da23df358a8973beb3b2f2fe35e47b598cc4f6260f13a9dffc3cc6c91231ae43853bd74851d2da8b7
|
||||
SHA512 (kernel-abi-stablelists-6.0.7.tar.bz2) = 50575df9ad09b1048a4159c0c76431aff76f8ca62ebb8c1b0b343926e186add6b729615e1570e24755a1df2f6cec377a571c9dc973231871891516beda4e0aa1
|
||||
SHA512 (kernel-kabi-dw-6.0.7.tar.bz2) = 5aa98ec0bc19d220383ea9d869254b8d998bd7a591206079d254a5249c0d3e7c17391cbe7e4789d63003ee2e2b971ab40255f38b9404462012d17421bd1eb7a4
|
||||
|
Loading…
x
Reference in New Issue
Block a user