kernel-5.7.0-1

* Mon Jun 01 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-1]
- v5.7 rebase
- Fix update_scripts.sh unselective pattern sub (David Howells)
- Updated changelog for the release based on b0c3ba31be3e ("CKI@GitLab")
- Drop the static path configuration for the Sphinx docs (Jeremy Cline)
- Sign off generated configuration patches (Jeremy Cline)
- Use __make macro instead of make (Tom Stellard)
- redhat/configs: Enable CONFIG_SMC91X and disable CONFIG_SMC911X (Prarit Bhargava) [http://bugzilla.redhat.com/1722136]
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2020-06-01 15:02:10 -05:00
parent 42bbfcc428
commit f0c9dd0c81
11 changed files with 43 additions and 34 deletions

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 2f1f5603cf1c..45ce82a03718 100644
index 3d65d1153aac..0e2fb7fe2675 100644
--- a/Makefile
+++ b/Makefile
@@ -479,7 +479,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE

View File

@ -122,7 +122,7 @@ index 8cffa84c9650..6c4e3675601a 100644
data->xport.ops = &hid_rmi_ops;
diff --git a/drivers/input/rmi4/rmi_driver.c b/drivers/input/rmi4/rmi_driver.c
index 190b9974526b..27a65991de0e 100644
index 258d5fe3d395..f7298e3dc8f3 100644
--- a/drivers/input/rmi4/rmi_driver.c
+++ b/drivers/input/rmi4/rmi_driver.c
@@ -182,34 +182,47 @@ void rmi_set_attn_data(struct rmi_device *rmi_dev, unsigned long irq_status,
@ -165,10 +165,10 @@ index 190b9974526b..27a65991de0e 100644
- if (count) {
- kfree(attn_data.data);
- attn_data.data = NULL;
- drvdata->attn_data.data = NULL;
- }
+ kfree(attn_data.data);
+ attn_data.data = NULL;
+ drvdata->attn_data.data = NULL;
if (!kfifo_is_empty(&drvdata->attn_fifo))
- return rmi_irq_fn(irq, dev_id);
@ -294,7 +294,7 @@ index 190b9974526b..27a65991de0e 100644
rmi_f34_remove_sysfs(rmi_dev);
rmi_free_function_list(rmi_dev);
@@ -1218,9 +1236,15 @@ static int rmi_driver_probe(struct device *dev)
@@ -1219,9 +1237,15 @@ static int rmi_driver_probe(struct device *dev)
}
}

View File

@ -57,7 +57,7 @@ Signed-off-by: Laura Abbott <labbott@redhat.com>
1 file changed, 22 insertions(+)
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
index 1faa08c8bbb4..b64444b1bd1a 100644
index 03d6a26687bc..86981f228c90 100644
--- a/drivers/iommu/iommu.c
+++ b/drivers/iommu/iommu.c
@@ -7,6 +7,7 @@

View File

@ -59,7 +59,7 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index f0d118b86287..2f1f5603cf1c 100644
index b668725a2a62..3d65d1153aac 100644
--- a/Makefile
+++ b/Makefile
@@ -1190,7 +1190,13 @@ endef

View File

@ -5344,7 +5344,7 @@ CONFIG_TEST_LIST_SORT=y
# CONFIG_TEST_LOCKUP is not set
# CONFIG_TEST_MEMCAT_P is not set
# CONFIG_TEST_MEMINIT is not set
# CONFIG_TEST_MIN_HEAP is not set
CONFIG_TEST_MIN_HEAP=m
# CONFIG_TEST_OBJAGG is not set
# CONFIG_TEST_OVERFLOW is not set
# CONFIG_TEST_PARMAN is not set

View File

@ -5187,7 +5187,7 @@ CONFIG_TEST_LIVEPATCH=m
# CONFIG_TEST_LOCKUP is not set
# CONFIG_TEST_MEMCAT_P is not set
# CONFIG_TEST_MEMINIT is not set
# CONFIG_TEST_MIN_HEAP is not set
CONFIG_TEST_MIN_HEAP=m
# CONFIG_TEST_OBJAGG is not set
# CONFIG_TEST_OVERFLOW is not set
# CONFIG_TEST_PARMAN is not set

View File

@ -5126,7 +5126,7 @@ CONFIG_TEST_LIST_SORT=y
# CONFIG_TEST_LOCKUP is not set
# CONFIG_TEST_MEMCAT_P is not set
# CONFIG_TEST_MEMINIT is not set
# CONFIG_TEST_MIN_HEAP is not set
CONFIG_TEST_MIN_HEAP=m
# CONFIG_TEST_OBJAGG is not set
# CONFIG_TEST_OVERFLOW is not set
# CONFIG_TEST_PARMAN is not set

View File

@ -5395,7 +5395,7 @@ CONFIG_TEST_LIVEPATCH=m
# CONFIG_TEST_LOCKUP is not set
# CONFIG_TEST_MEMCAT_P is not set
# CONFIG_TEST_MEMINIT is not set
# CONFIG_TEST_MIN_HEAP is not set
CONFIG_TEST_MIN_HEAP=m
# CONFIG_TEST_OBJAGG is not set
# CONFIG_TEST_OVERFLOW is not set
# CONFIG_TEST_PARMAN is not set

View File

@ -30,7 +30,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
%global distro_build 0.rc7.20200529gitb0c3ba31be3e.1
%global distro_build 1
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -69,10 +69,10 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.7.0
%define pkgrelease 0.rc7.20200529gitb0c3ba31be3e.1
%define pkgrelease 1
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc7.20200529gitb0c3ba31be3e.1%{?buildid}%{?dist}
%define specrelease 1%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@ -163,7 +163,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
%define debugbuildsenabled 0
%define debugbuildsenabled 1
# The kernel tarball/base version
%define kversion 5.7
@ -564,7 +564,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-20200529gitb0c3ba31be3e.tar.xz
Source0: linux-5.7.0.tar.xz
Source1: Makefile.rhelver
@ -1303,8 +1303,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-20200529gitb0c3ba31be3e -c
mv linux-20200529gitb0c3ba31be3e linux-%{KVERREL}
%setup -q -n kernel-5.7.0 -c
mv linux-5.7.0 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -1534,7 +1534,7 @@ cp_vmlinux()
%define build_hostldflags %{?build_ldflags}
%endif
%define make make %{?cross_opts} %{?make_opts} HOSTCFLAGS="%{?build_hostcflags}" HOSTLDFLAGS="%{?build_hostldflags}"
%define make %{__make} %{?cross_opts} %{?make_opts} HOSTCFLAGS="%{?build_hostcflags}" HOSTLDFLAGS="%{?build_hostldflags}"
BuildKernel() {
MakeTarget=$1
@ -2104,7 +2104,7 @@ BuildKernel %make_target %kernel_image %{_use_vdso}
%endif
%global perf_make \
make -s EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 prefix=%{_prefix} PYTHON=%{__python3}
%{__make} -s EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 prefix=%{_prefix} PYTHON=%{__python3}
%if %{with_perf}
# perf
# make sure check-headers.sh is executable
@ -2143,16 +2143,16 @@ pushd tools/thermal/tmon/
popd
pushd tools/iio/
# Needs to be fixed to pick up CFLAGS
make
%{__make}
popd
pushd tools/gpio/
# Needs to be fixed to pick up CFLAGS
make
%{__make}
popd
%endif
%global bpftool_make \
make EXTRA_CFLAGS="${RPM_OPT_FLAGS}" EXTRA_LDFLAGS="%{__global_ldflags}" DESTDIR=$RPM_BUILD_ROOT V=1
%{__make} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" EXTRA_LDFLAGS="%{__global_ldflags}" DESTDIR=$RPM_BUILD_ROOT V=1
%if %{with_bpftool}
pushd tools/bpf/bpftool
%{bpftool_make}
@ -2170,7 +2170,7 @@ popd
%if %{with_doc}
# Make the HTML pages.
make PYTHON=/usr/bin/python3 htmldocs || %{doc_build_fail}
%{__make} PYTHON=/usr/bin/python3 htmldocs || %{doc_build_fail}
# sometimes non-world-readable files sneak into the kernel source tree
chmod -R a=rX Documentation
@ -2271,7 +2271,7 @@ tar -h -f - --exclude=man --exclude='.*' -c Documentation | tar xf - -C $docdir
%if %{with_headers}
# Install kernel headers
make ARCH=%{hdrarch} INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr headers_install
%{__make} ARCH=%{hdrarch} INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr headers_install
find $RPM_BUILD_ROOT/usr/include \
\( -name .install -o -name .check -o \
@ -2289,7 +2289,7 @@ mkdir -p $RPM_BUILD_ROOT/usr/tmp-headers
for arch in $HDR_ARCH_LIST; do
mkdir $RPM_BUILD_ROOT/usr/tmp-headers/arch-${arch}
make ARCH=${arch} INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr/tmp-headers/arch-${arch} headers_install
%{__make} ARCH=${arch} INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr/tmp-headers/arch-${arch} headers_install
done
find $RPM_BUILD_ROOT/usr/tmp-headers \
@ -2375,14 +2375,14 @@ pushd tools/thermal/tmon
%{tools_make} INSTALL_ROOT=%{buildroot} install
popd
pushd tools/iio
make DESTDIR=%{buildroot} install
%{__make} DESTDIR=%{buildroot} install
popd
pushd tools/gpio
make DESTDIR=%{buildroot} install
%{__make} DESTDIR=%{buildroot} install
popd
pushd tools/kvm/kvm_stat
make INSTALL_ROOT=%{buildroot} install-tools
make INSTALL_ROOT=%{buildroot} install-man
%{__make} INSTALL_ROOT=%{buildroot} install-tools
%{__make} INSTALL_ROOT=%{buildroot} install-man
popd
%endif
@ -2832,6 +2832,15 @@ fi
#
#
%changelog
* Mon Jun 01 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-1]
- v5.7 rebase
- Fix update_scripts.sh unselective pattern sub (David Howells)
- Updated changelog for the release based on b0c3ba31be3e ("CKI@GitLab")
- Drop the static path configuration for the Sphinx docs (Jeremy Cline)
- Sign off generated configuration patches (Jeremy Cline)
- Use __make macro instead of make (Tom Stellard)
- redhat/configs: Enable CONFIG_SMC91X and disable CONFIG_SMC911X (Prarit Bhargava) [http://bugzilla.redhat.com/1722136]
* Thu May 28 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc7.20200528gitb0c3ba31be3e.1]
- b0c3ba31be3e rebase
- Updated changelog for the release based on 444fc5cde643 ("CKI@GitLab")

View File

@ -1,3 +1,3 @@
SHA512 (linux-20200529gitb0c3ba31be3e.tar.xz) = 8320ecf812b972de6ce45b19027aec0186ab638292998920fbde877d8ed91b474cf768295731b243175c852fcfa044c15dce5d2435b3571c831afd7ff552b499
SHA512 (kernel-abi-whitelists-5.7.0-0.rc7.20200529gitb0c3ba31be3e.1.tar.bz2) = af0d71077bf8ac12ee60414db29b9d8ff1d440ca716c73e60d74605b3c1f980909466e0be24c7440cfea39ae7860c1b18513114302a94bab3aca6cde2458c88f
SHA512 (kernel-kabi-dw-5.7.0-0.rc7.20200529gitb0c3ba31be3e.1.tar.bz2) = 6ede21f3f4edb4e28c14b26a3a4c2e77fa068a82a8ca18f04017fb71b167566b7ae50071455300f1fc77e38b65186782358b876716b3b89fd3b0089dba160f9c
SHA512 (linux-5.7.0.tar.xz) = f05d8229cf4fad24afbe8e92758d1a9344393876e4919150dc4baa76af9813bc16db6f0bda922dfa6e4bb807275e4fee49db87f669acbf909e9be3ab679d6afe
SHA512 (kernel-abi-whitelists-5.7.0-1.tar.bz2) = e593c8c0d452d5d721e77a6fdae971b00402c052b277771fb8c100578fef04faf48d7611b562b0a9c9cf34c15b4344f20c81ad1526210cb65039894a0c6c2779
SHA512 (kernel-kabi-dw-5.7.0-1.tar.bz2) = aae43a3a36a6209c10bf86b6535b65514fa893c1bfc8dc475bcf2b859f3ec7373303660777c1d6d3cf78afe62b8a920c92fd157fed8891e84972ea1f5e5edc99

View File

@ -7,6 +7,6 @@ fi
TARGET=$1
for i in $RPM_SOURCE_DIR/*.$TARGET; do
NEW=`echo $i | sed s/.$TARGET//`
NEW=${i%.$TARGET}
cp $i $NEW
done