kernel-6.2.8-300

* Wed Mar 22 2023 Augusto Caringi <acaringi@redhat.com> [6.2.8-0]
- Add new config option for 6.2.8 (Augusto Caringi)
- Revert "usb: xhci-pci: Set PROBE_PREFER_ASYNCHRONOUS" (Kate Hsuan)
- Linux v6.2.8
Resolves:

Signed-off-by: Augusto Caringi <acaringi@redhat.com>
This commit is contained in:
Augusto Caringi 2023-03-22 15:16:09 -03:00
parent bfcae48dad
commit eead23bc29
8 changed files with 45 additions and 8 deletions

View File

@ -1,3 +1,6 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/d72fed198ee1835d3950d0cb4787b7f3a082ff40
d72fed198ee1835d3950d0cb4787b7f3a082ff40 Revert "usb: xhci-pci: Set PROBE_PREFER_ASYNCHRONOUS"
"https://gitlab.com/cki-project/kernel-ark/-/commit"/14005bf69741499a3df8cb2e74c0dc99c37e9438
14005bf69741499a3df8cb2e74c0dc99c37e9438 NFS: Correct timing for assigning access cache timestamp

View File

@ -4708,6 +4708,7 @@ CONFIG_POWER_MLXBF=m
CONFIG_POWERNV_CPUFREQ=y
CONFIG_POWERNV_CPUIDLE=y
# CONFIG_POWERNV_OP_PANEL is not set
# CONFIG_POWERPC64_CPU is not set
# CONFIG_POWER_RESET_BRCMKONA is not set
# CONFIG_POWER_RESET_BRCMSTB is not set
CONFIG_POWER_RESET_GPIO_RESTART=y
@ -6824,6 +6825,7 @@ CONFIG_TMPFS_INODE64=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_TMPFS_XATTR=y
CONFIG_TMPFS=y
# CONFIG_TOOLCHAIN_DEFAULT_CPU is not set
CONFIG_TORTURE_TEST=m
# CONFIG_TOUCHSCREEN_AD7877 is not set
# CONFIG_TOUCHSCREEN_AD7879 is not set

View File

@ -4207,6 +4207,7 @@ CONFIG_POWER9_CPU=y
CONFIG_POWERNV_CPUFREQ=y
CONFIG_POWERNV_CPUIDLE=y
CONFIG_POWERNV_OP_PANEL=m
# CONFIG_POWERPC64_CPU is not set
# CONFIG_POWER_RESET_BRCMSTB is not set
# CONFIG_POWER_RESET_GPIO_RESTART is not set
CONFIG_POWER_RESET_GPIO=y
@ -6190,6 +6191,7 @@ CONFIG_TMPFS_INODE64=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_TMPFS_XATTR=y
CONFIG_TMPFS=y
# CONFIG_TOOLCHAIN_DEFAULT_CPU is not set
CONFIG_TORTURE_TEST=m
# CONFIG_TOSHIBA_HAPS is not set
# CONFIG_TOSHIBA_WMI is not set

View File

@ -4687,6 +4687,7 @@ CONFIG_POWER_MLXBF=m
CONFIG_POWERNV_CPUFREQ=y
CONFIG_POWERNV_CPUIDLE=y
# CONFIG_POWERNV_OP_PANEL is not set
# CONFIG_POWERPC64_CPU is not set
# CONFIG_POWER_RESET_BRCMKONA is not set
# CONFIG_POWER_RESET_BRCMSTB is not set
CONFIG_POWER_RESET_GPIO_RESTART=y
@ -6801,6 +6802,7 @@ CONFIG_TMPFS_INODE64=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_TMPFS_XATTR=y
CONFIG_TMPFS=y
# CONFIG_TOOLCHAIN_DEFAULT_CPU is not set
CONFIG_TORTURE_TEST=m
# CONFIG_TOUCHSCREEN_AD7877 is not set
# CONFIG_TOUCHSCREEN_AD7879 is not set

View File

@ -4186,6 +4186,7 @@ CONFIG_POWER9_CPU=y
CONFIG_POWERNV_CPUFREQ=y
CONFIG_POWERNV_CPUIDLE=y
CONFIG_POWERNV_OP_PANEL=m
# CONFIG_POWERPC64_CPU is not set
# CONFIG_POWER_RESET_BRCMSTB is not set
# CONFIG_POWER_RESET_GPIO_RESTART is not set
CONFIG_POWER_RESET_GPIO=y
@ -6167,6 +6168,7 @@ CONFIG_TMPFS_INODE64=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_TMPFS_XATTR=y
CONFIG_TMPFS=y
# CONFIG_TOOLCHAIN_DEFAULT_CPU is not set
CONFIG_TORTURE_TEST=m
# CONFIG_TOSHIBA_HAPS is not set
# CONFIG_TOSHIBA_WMI is not set

View File

@ -148,17 +148,17 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specversion 6.2.7
%define specversion 6.2.8
%define patchversion 6.2
%define pkgrelease 300
%define kversion 6
%define tarfile_release 6.2.7
%define tarfile_release 6.2.8
# This is needed to do merge window version magic
%define patchlevel 2
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 300%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.2.7
%define kabiversion 6.2.8
# If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error
@ -3346,6 +3346,11 @@ fi
#
#
%changelog
* Wed Mar 22 2023 Augusto Caringi <acaringi@redhat.com> [6.2.8-0]
- Add new config option for 6.2.8 (Augusto Caringi)
- Revert "usb: xhci-pci: Set PROBE_PREFER_ASYNCHRONOUS" (Kate Hsuan)
- Linux v6.2.8
* Fri Mar 17 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.2.7-0]
- NFS: Correct timing for assigning access cache timestamp (Chengen Du)
- usb: ucsi: Fix ucsi->connector race (Hans de Goede)

View File

@ -21,6 +21,7 @@
drivers/iommu/iommu.c | 22 +
drivers/pci/quirks.c | 24 +
drivers/usb/core/hub.c | 7 +
drivers/usb/host/xhci-pci.c | 7 +-
drivers/usb/typec/ucsi/ucsi.c | 33 +-
drivers/usb/typec/ucsi/ucsi_acpi.c | 2 +-
fs/nfs/dir.c | 2 +-
@ -36,10 +37,10 @@
security/lockdown/Kconfig | 13 +
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
38 files changed, 997 insertions(+), 197 deletions(-)
39 files changed, 1000 insertions(+), 201 deletions(-)
diff --git a/Makefile b/Makefile
index 43cf2c785cb1..f3441e6f1ed6 100644
index 2c90d9b067f4..93b82f038789 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -1031,6 +1032,26 @@ index 97a0f8faea6e..d837548d2024 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/drivers/usb/host/xhci-pci.c b/drivers/usb/host/xhci-pci.c
index fb988e4ea924..6db07ca419c3 100644
--- a/drivers/usb/host/xhci-pci.c
+++ b/drivers/usb/host/xhci-pci.c
@@ -771,12 +771,11 @@ static struct pci_driver xhci_pci_driver = {
/* suspend and resume implemented later */
.shutdown = usb_hcd_pci_shutdown,
- .driver = {
#ifdef CONFIG_PM
- .pm = &usb_hcd_pci_pm_ops,
-#endif
- .probe_type = PROBE_PREFER_ASYNCHRONOUS,
+ .driver = {
+ .pm = &usb_hcd_pci_pm_ops
},
+#endif
};
static int __init xhci_pci_init(void)
diff --git a/drivers/usb/typec/ucsi/ucsi.c b/drivers/usb/typec/ucsi/ucsi.c
index 1cf8947c6d66..086b50968983 100644
--- a/drivers/usb/typec/ucsi/ucsi.c

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.2.7.tar.xz) = 8772cbcf960138de2826c91a86af4bbe2bc3013f4231c7a89592e32b064181267497d05c0e4df693823b701e169fd4da89c994dcaa787581a9bcdaf491940e60
SHA512 (kernel-abi-stablelists-6.2.7.tar.bz2) = ebbd50801a327a6dc91133ada84663aa7199ee69a4f77db97bfd2955e324661dc5846d581b470f442c55c4d830c9e80ef4123b1bbec90682a1ba9c8f086fbcff
SHA512 (kernel-kabi-dw-6.2.7.tar.bz2) = 53d2a6e44a4dda0c33b8801c2eaeb5c91ee9aa7d71dfae2ea4b3cc8673dba278f83ccdc8e88bb2aed9ebd79b1c74ff5ca2345634f31b6e06c4018d535f46a9e3
SHA512 (linux-6.2.8.tar.xz) = 7e7ab30dc4977f60cd97bfc035f99ce6d67ec1f5636c68b7239955e67b7b4681b3aed76a62258988cb2c87f7a3a4ca9d80f38dd86a9451f3a8a4b62dee418a23
SHA512 (kernel-abi-stablelists-6.2.8.tar.bz2) = 4e5efb2e23401f5a96c8cdedeb8c1bcef89f1b17dc159878429bd9ee279cfc34c29aa20eda7fb90b3a8acd6521d67f5e9c4028abd7e69d518815634b0f9bd9aa
SHA512 (kernel-kabi-dw-6.2.8.tar.bz2) = 9c8f60cd5085ae4f0f804db31349e850e730614748f3177c0550bc9877b15cf4de11ad684414ff23071931dcd40fefe4b33f7425c619c6362c877bd56fb4788e