kernel-5.18.9-100

* Sat Jul 02 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.18.9-0]
- Revert "smb3: fix empty netname context on secondary channels" (Justin M. Forbes)
- Revert "smb3: use netname when available on secondary channels" (Justin M. Forbes)
- fedora: arm: enable a couple of QCom drivers (Peter Robinson)
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2022-07-02 10:31:40 -05:00
parent e87dffc473
commit e65b3217d2
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
6 changed files with 66 additions and 9 deletions

View File

@ -1,3 +1,9 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/70b6a2dd3426c05d36f40c5d75e4f4a4d6196a59
70b6a2dd3426c05d36f40c5d75e4f4a4d6196a59 Revert "smb3: fix empty netname context on secondary channels"
"https://gitlab.com/cki-project/kernel-ark/-/commit"/2b7d5f1fa4cd5ece616da1f102894581590036a9
2b7d5f1fa4cd5ece616da1f102894581590036a9 Revert "smb3: use netname when available on secondary channels"
"https://gitlab.com/cki-project/kernel-ark/-/commit"/8c91f362b5c06f3ff01ca58ea67266da928f55b1
8c91f362b5c06f3ff01ca58ea67266da928f55b1 drm/i915: Temporarily disable selective fetch for PSR2 on ADL-P

View File

@ -3074,6 +3074,7 @@ CONFIG_INTERCONNECT_IMX8MM=m
CONFIG_INTERCONNECT_IMX8MN=m
CONFIG_INTERCONNECT_IMX8MQ=m
CONFIG_INTERCONNECT_IMX=m
CONFIG_INTERCONNECT_QCOM_BCM_VOTER=y
CONFIG_INTERCONNECT_QCOM_MSM8916=m
# CONFIG_INTERCONNECT_QCOM_MSM8939 is not set
# CONFIG_INTERCONNECT_QCOM_MSM8974 is not set
@ -5224,7 +5225,7 @@ CONFIG_PHY_QCOM_QUSB2=m
CONFIG_PHY_QCOM_USB_HS_28NM=m
CONFIG_PHY_QCOM_USB_HSIC=m
CONFIG_PHY_QCOM_USB_HS=m
# CONFIG_PHY_QCOM_USB_SNPS_FEMTO_V2 is not set
CONFIG_PHY_QCOM_USB_SNPS_FEMTO_V2=m
CONFIG_PHY_QCOM_USB_SS=m
CONFIG_PHY_ROCKCHIP_DPHY_RX0=m
CONFIG_PHY_ROCKCHIP_DP=m

View File

@ -3058,6 +3058,7 @@ CONFIG_INTERCONNECT_IMX8MM=m
CONFIG_INTERCONNECT_IMX8MN=m
CONFIG_INTERCONNECT_IMX8MQ=m
CONFIG_INTERCONNECT_IMX=m
CONFIG_INTERCONNECT_QCOM_BCM_VOTER=y
CONFIG_INTERCONNECT_QCOM_MSM8916=m
# CONFIG_INTERCONNECT_QCOM_MSM8939 is not set
# CONFIG_INTERCONNECT_QCOM_MSM8974 is not set
@ -5203,7 +5204,7 @@ CONFIG_PHY_QCOM_QUSB2=m
CONFIG_PHY_QCOM_USB_HS_28NM=m
CONFIG_PHY_QCOM_USB_HSIC=m
CONFIG_PHY_QCOM_USB_HS=m
# CONFIG_PHY_QCOM_USB_SNPS_FEMTO_V2 is not set
CONFIG_PHY_QCOM_USB_SNPS_FEMTO_V2=m
CONFIG_PHY_QCOM_USB_SS=m
CONFIG_PHY_ROCKCHIP_DPHY_RX0=m
CONFIG_PHY_ROCKCHIP_DP=m

View File

@ -122,11 +122,11 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specversion 5.18.8
%define specversion 5.18.9
%define patchversion 5.18
%define pkgrelease 100
%define kversion 5
%define tarfile_release 5.18.8
%define tarfile_release 5.18.9
# This is needed to do merge window version magic
%define patchlevel 18
# allow pkg_release to have configurable %%{?dist} tag
@ -3034,6 +3034,11 @@ fi
#
#
%changelog
* Sat Jul 02 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.18.9-0]
- Revert "smb3: fix empty netname context on secondary channels" (Justin M. Forbes)
- Revert "smb3: use netname when available on secondary channels" (Justin M. Forbes)
- fedora: arm: enable a couple of QCom drivers (Peter Robinson)
* Wed Jun 29 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.18.8-0]
- Remove RHJOBS define from fedora-stable-release.sh (Justin M. Forbes)

View File

@ -30,6 +30,7 @@
drivers/nvme/host/nvme.h | 4 +
drivers/pci/quirks.c | 24 ++++
drivers/usb/core/hub.c | 7 ++
fs/cifs/smb2pdu.c | 21 +---
include/linux/efi.h | 24 ++--
include/linux/lsm_hook_defs.h | 2 +
include/linux/lsm_hooks.h | 6 +
@ -42,10 +43,10 @@
security/lockdown/Kconfig | 13 +++
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
44 files changed, 721 insertions(+), 191 deletions(-)
45 files changed, 727 insertions(+), 206 deletions(-)
diff --git a/Makefile b/Makefile
index 6ac3335f65af..5df170f9243f 100644
index 751cfd786c8c..1dbeaa096d9b 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -1516,6 +1517,49 @@ index 1460857026e0..7e1964891089 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/fs/cifs/smb2pdu.c b/fs/cifs/smb2pdu.c
index 6a8a00f28b19..179c1630bf56 100644
--- a/fs/cifs/smb2pdu.c
+++ b/fs/cifs/smb2pdu.c
@@ -543,7 +543,6 @@ assemble_neg_contexts(struct smb2_negotiate_req *req,
struct TCP_Server_Info *server, unsigned int *total_len)
{
char *pneg_ctxt;
- char *hostname = NULL;
unsigned int ctxt_len, neg_context_count;
if (*total_len > 200) {
@@ -571,24 +570,16 @@ assemble_neg_contexts(struct smb2_negotiate_req *req,
*total_len += ctxt_len;
pneg_ctxt += ctxt_len;
+ ctxt_len = build_netname_ctxt((struct smb2_netname_neg_context *)pneg_ctxt,
+ server->hostname);
+ *total_len += ctxt_len;
+ pneg_ctxt += ctxt_len;
+
build_posix_ctxt((struct smb2_posix_neg_context *)pneg_ctxt);
*total_len += sizeof(struct smb2_posix_neg_context);
pneg_ctxt += sizeof(struct smb2_posix_neg_context);
- /*
- * secondary channels don't have the hostname field populated
- * use the hostname field in the primary channel instead
- */
- hostname = CIFS_SERVER_IS_CHAN(server) ?
- server->primary_server->hostname : server->hostname;
- if (hostname && (hostname[0] != 0)) {
- ctxt_len = build_netname_ctxt((struct smb2_netname_neg_context *)pneg_ctxt,
- hostname);
- *total_len += ctxt_len;
- pneg_ctxt += ctxt_len;
- neg_context_count = 4;
- } else /* second channels do not have a hostname */
- neg_context_count = 3;
+ neg_context_count = 4;
if (server->compress_algorithm) {
build_compression_ctxt((struct smb2_compression_capabilities_context *)
diff --git a/include/linux/efi.h b/include/linux/efi.h
index cc6d2be2ffd5..418d814d2eb7 100644
--- a/include/linux/efi.h

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.18.8.tar.xz) = 2aa8c9073cc9f28a9e8242fef263335a2a203b3452de0c6da51b75336f6b1c5304256f90b9c1839b67042d5ded52773607079a7844edad582d040b35ef1b999d
SHA512 (kernel-abi-stablelists-5.18.8-100.tar.bz2) = f0f78357441d101a4266e12a83c1d61f440cc26047b0ab896ef04703a5d2885247d80c25be35de11746dbaec69af7eb14a80f3714917c4d2720c2bc8b1254ca0
SHA512 (kernel-kabi-dw-5.18.8-100.tar.bz2) = 836b6a3c3644df89a1b2030a18fa31afaa27a129ae1744e1c4ded64b8abc10e4708246a2262c6308a71bfb4221743b3769ec41fd38d9bbe9e056ecf7032a4104
SHA512 (linux-5.18.9.tar.xz) = df523ea0a547da055d8ee435192ad0769cc91e7d081da52558f66ae7108525a80353565bd33dd70f6bcdb393e6ba7634971e30cee7d4eb36678d9183558d1e47
SHA512 (kernel-abi-stablelists-5.18.9-100.tar.bz2) = cf67f41e414e1d4c727cc9adeef25d9a8b37e5f0e614a11c260e0cc34b7dfe5bca1384be876017fd18ffaa98ca383c1b611fb205edb4d162d3743efd08d13f6f
SHA512 (kernel-kabi-dw-5.18.9-100.tar.bz2) = 6ffc70c49dacc3546ceef8024538eeeac6629c9d02110b5042287e327cc43ca3756011eb13ea68f1254c8f76ad3e38f61c7252f8301033e9e18aec62ae4c4c8a