kernel-5.13.5-100

* Sun Jul 25 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.5-100]
- kernel-5.13.5-0 (Justin M. Forbes)
- iwlwifi Add support for ax201 in Samsung Galaxy Book Flex2 Alpha (Justin M. Forbes)
- Revert "usb: renesas-xhci: Fix handling of unknown ROM state" (Justin M. Forbes)
- RHEL configs need this too (Justin M. Forbes)
- kernel-5.13.4-0 (Justin M. Forbes)
- Config update for 5.13.4 (Justin M. Forbes)
- kernel-5.13.3-0 (Justin M. Forbes)
- Don't tag a release as [redhat] (Justin M. Forbes)
- platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd() (Yang Yingliang)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-07-25 11:01:04 -05:00
parent a219e71ba3
commit e18ca5ec6c
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
5 changed files with 77 additions and 90 deletions

View File

@ -1,3 +1,9 @@
https://gitlab.com/cki-project/kernel-ark/-/commit/e833c34e56563b0292493c62921e7132a16ceef0
e833c34e56563b0292493c62921e7132a16ceef0 iwlwifi Add support for ax201 in Samsung Galaxy Book Flex2 Alpha
https://gitlab.com/cki-project/kernel-ark/-/commit/7c85609231b2dbb3ea6fa0d9ffb52e9177fd8212
7c85609231b2dbb3ea6fa0d9ffb52e9177fd8212 Revert "usb: renesas-xhci: Fix handling of unknown ROM state"
https://gitlab.com/cki-project/kernel-ark/-/commit/93766a4c0701e9f633071beb75237e11413dcebd
93766a4c0701e9f633071beb75237e11413dcebd platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd()

View File

@ -116,7 +116,7 @@ Summary: The Linux kernel
# The kernel tarball/base version
%define kversion 5.13
%define rpmversion 5.13.4
%define rpmversion 5.13.5
%define stableversion 5.13
%define pkgrelease 100
@ -646,7 +646,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.13.4.tar.xz
Source0: linux-5.13.5.tar.xz
Source1: Makefile.rhelver
@ -801,7 +801,6 @@ Source4001: rpminspect.yaml
%if !%{nopatches}
Patch1: patch-%{stableversion}-redhat.patch
Patch2: usb-renesas-xhci-fix-handling-of-unknown-rom-state.patch
%endif
# empty final patch to facilitate testing of kernel patches
@ -1316,8 +1315,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.13.4 -c
mv linux-5.13.4 linux-%{KVERREL}
%setup -q -n kernel-5.13.5 -c
mv linux-5.13.5 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -1325,7 +1324,6 @@ cp -a %{SOURCE1} .
%if !%{nopatches}
ApplyOptionalPatch patch-%{stableversion}-redhat.patch
ApplyOptionalPatch usb-renesas-xhci-fix-handling-of-unknown-rom-state.patch
%endif
ApplyOptionalPatch linux-kernel-test.patch
@ -2888,7 +2886,20 @@ fi
#
#
%changelog
* Tue Jul 20 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.4-100]
* Sun Jul 25 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.5-100]
- kernel-5.13.5-0 (Justin M. Forbes)
- iwlwifi Add support for ax201 in Samsung Galaxy Book Flex2 Alpha (Justin M. Forbes)
- Revert "usb: renesas-xhci: Fix handling of unknown ROM state" (Justin M. Forbes)
- RHEL configs need this too (Justin M. Forbes)
- kernel-5.13.4-0 (Justin M. Forbes)
- Config update for 5.13.4 (Justin M. Forbes)
- kernel-5.13.3-0 (Justin M. Forbes)
- Don't tag a release as [redhat] (Justin M. Forbes)
- platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd() (Yang Yingliang)
* Sun Jul 25 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.5-0]
- iwlwifi Add support for ax201 in Samsung Galaxy Book Flex2 Alpha (Justin M. Forbes)
- Revert "usb: renesas-xhci: Fix handling of unknown ROM state" (Justin M. Forbes)
- RHEL configs need this too (Justin M. Forbes)
- kernel-5.13.4-0 (Justin M. Forbes)
- Config update for 5.13.4 (Justin M. Forbes)

View File

@ -3,7 +3,6 @@
arch/arm/Kconfig | 4 +-
arch/arm64/Kconfig | 3 +-
.../boot/dts/rockchip/rk3399-pinebook-pro.dts | 2 +-
arch/arm64/boot/dts/rockchip/rk3399.dtsi | 2 +-
arch/arm64/kernel/acpi.c | 2 +-
arch/s390/include/asm/ipl.h | 1 +
arch/s390/kernel/ipl.c | 5 +
@ -27,11 +26,13 @@
drivers/input/rmi4/rmi_driver.c | 124 +++--
drivers/iommu/iommu.c | 22 +
drivers/net/wireguard/main.c | 6 +
drivers/net/wireless/intel/iwlwifi/pcie/drv.c | 1 +
drivers/nvme/host/pci.c | 28 +-
drivers/pci/quirks.c | 24 +
drivers/platform/x86/amd-pmc.c | 248 +++++++++-
drivers/scsi/smartpqi/smartpqi_init.c | 16 +
drivers/usb/core/hub.c | 7 +
drivers/usb/host/xhci-pci-renesas.c | 16 +-
include/linux/acpi.h | 5 +
include/linux/efi.h | 22 +-
include/linux/lsm_hook_defs.h | 2 +
@ -65,7 +66,7 @@
tools/testing/selftests/bpf/progs/linked_vars2.c | 55 ---
.../selftests/bpf/progs/test_static_linked1.c | 30 --
.../selftests/bpf/progs/test_static_linked2.c | 31 --
67 files changed, 909 insertions(+), 2354 deletions(-)
68 files changed, 917 insertions(+), 2361 deletions(-)
diff --git a/Documentation/admin-guide/kdump/kdump.rst b/Documentation/admin-guide/kdump/kdump.rst
index 75a9dd98e76e..3ff3291551f9 100644
@ -90,7 +91,7 @@ index 75a9dd98e76e..3ff3291551f9 100644
Boot into System Kernel
diff --git a/Makefile b/Makefile
index 975acb16046d..e6b00e6d0094 100644
index 41be12f806e0..f89aa29cd5c2 100644
--- a/Makefile
+++ b/Makefile
@@ -508,6 +508,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
@ -151,19 +152,6 @@ index 2b5f001ff4a6..dcdb3cd75be7 100644
};
&cpu_b0 {
diff --git a/arch/arm64/boot/dts/rockchip/rk3399.dtsi b/arch/arm64/boot/dts/rockchip/rk3399.dtsi
index 634a91af8e83..4b854eb21f72 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399.dtsi
+++ b/arch/arm64/boot/dts/rockchip/rk3399.dtsi
@@ -227,7 +227,7 @@ pcie0: pcie@f8000000 {
<&pcie_phy 2>, <&pcie_phy 3>;
phy-names = "pcie-phy-0", "pcie-phy-1",
"pcie-phy-2", "pcie-phy-3";
- ranges = <0x83000000 0x0 0xfa000000 0x0 0xfa000000 0x0 0x1e00000>,
+ ranges = <0x82000000 0x0 0xfa000000 0x0 0xfa000000 0x0 0x1e00000>,
<0x81000000 0x0 0xfbe00000 0x0 0xfbe00000 0x0 0x100000>;
resets = <&cru SRST_PCIE_CORE>, <&cru SRST_PCIE_MGMT>,
<&cru SRST_PCIE_MGMT_STICKY>, <&cru SRST_PCIE_PIPE>,
diff --git a/arch/arm64/kernel/acpi.c b/arch/arm64/kernel/acpi.c
index cada0b816c8a..0fc840d6b0fb 100644
--- a/arch/arm64/kernel/acpi.c
@ -1404,6 +1392,18 @@ index 75dbe77b0b4b..4bd6dd722f44 100644
ret = wg_allowedips_slab_init();
if (ret < 0)
goto err_allowedips;
diff --git a/drivers/net/wireless/intel/iwlwifi/pcie/drv.c b/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
index d94bd8d732e9..7775395bef6f 100644
--- a/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
+++ b/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
@@ -556,6 +556,7 @@ static const struct iwl_dev_info iwl_dev_info_table[] = {
IWL_DEV_INFO(0xA0F0, 0x1652, killer1650i_2ax_cfg_qu_b0_hr_b0, NULL),
IWL_DEV_INFO(0xA0F0, 0x2074, iwl_ax201_cfg_qu_hr, NULL),
IWL_DEV_INFO(0xA0F0, 0x4070, iwl_ax201_cfg_qu_hr, NULL),
+ IWL_DEV_INFO(0xA0F0, 0x6074, iwl_ax201_cfg_qu_hr, NULL),
IWL_DEV_INFO(0x02F0, 0x0070, iwl_ax201_cfg_quz_hr, NULL),
IWL_DEV_INFO(0x02F0, 0x0074, iwl_ax201_cfg_quz_hr, NULL),
IWL_DEV_INFO(0x02F0, 0x6074, iwl_ax201_cfg_quz_hr, NULL),
diff --git a/drivers/nvme/host/pci.c b/drivers/nvme/host/pci.c
index 42ad75ff1348..5a72bdf5ad03 100644
--- a/drivers/nvme/host/pci.c
@ -1934,6 +1934,40 @@ index df8e69e60aaf..fb851c5130e1 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/drivers/usb/host/xhci-pci-renesas.c b/drivers/usb/host/xhci-pci-renesas.c
index 431213cdf9e0..f97ac9f52bf4 100644
--- a/drivers/usb/host/xhci-pci-renesas.c
+++ b/drivers/usb/host/xhci-pci-renesas.c
@@ -207,8 +207,7 @@ static int renesas_check_rom_state(struct pci_dev *pdev)
return 0;
case RENESAS_ROM_STATUS_NO_RESULT: /* No result yet */
- dev_dbg(&pdev->dev, "Unknown ROM status ...\n");
- break;
+ return 0;
case RENESAS_ROM_STATUS_ERROR: /* Error State */
default: /* All other states are marked as "Reserved states" */
@@ -225,12 +224,13 @@ static int renesas_fw_check_running(struct pci_dev *pdev)
u8 fw_state;
int err;
- /*
- * Only if device has ROM and loaded FW we can skip loading and
- * return success. Otherwise (even unknown state), attempt to load FW.
- */
- if (renesas_check_rom(pdev) && !renesas_check_rom_state(pdev))
- return 0;
+ /* Check if device has ROM and loaded, if so skip everything */
+ err = renesas_check_rom(pdev);
+ if (err) { /* we have rom */
+ err = renesas_check_rom_state(pdev);
+ if (!err)
+ return err;
+ }
/*
* Test if the device is actually needing the firmware. As most
diff --git a/include/linux/acpi.h b/include/linux/acpi.h
index c60745f657e9..dd0dafd21e33 100644
--- a/include/linux/acpi.h

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.13.4.tar.xz) = 702e263302f46ce18d169134faac13dd730bb2d24d9b38f24eae028175e3b966f448faaea21f395a73229ffc0260d6bf4c96d4ed38d99bc898005d41db41aa86
SHA512 (kernel-abi-whitelists-5.13.4-100.tar.bz2) = f958eb92b7a32a33bbe683048fa1e3b1740fda2a30d5dc6fc585402129212182814df0969183fa58e21f256ea68904f5c3b5f1d1e6246209b8da3927da812d3c
SHA512 (kernel-kabi-dw-5.13.4-100.tar.bz2) = 45e8649f488ea6cf43df549fce9c50842d3d0e49b51fc01a4d1196bbcc39f2889ebb8b24fe55026de49b0cc20c393d2203c64043a8b1366d5968f8aa8ba4ae4d
SHA512 (linux-5.13.5.tar.xz) = 180fb334f713c8797dfe6c141a1c5709da5d9d31e9e46e8091ceb30e2d0482c662b936c6436d86da9af6c231ee4bca754ce1bb061391c337192909e2aa8b9129
SHA512 (kernel-abi-whitelists-5.13.5-100.tar.bz2) = 2435431214b5c1f7bbc4fe1ebe9bdacf5bbff61cbd674cb2f721f45efe49f21e58d2e28e93a91c08f4929f39b12c4b1327ac223e0fbda9d4d2d5ab92a5ff3199
SHA512 (kernel-kabi-dw-5.13.5-100.tar.bz2) = 1b8308dde95ff38614ca4ee638e4382ab1b66136e8a0b02e84725fda01d7a9cbd399541aba0fbf8a82411abf52d6c962ec2aca07ac8d1add53e25c53d984ef3e

View File

@ -1,64 +0,0 @@
commit 926bb4ece936dcb83421e55f08eb3055628bca2f
Author: Moritz Fischer <mdf@kernel.org>
Date: Sat Jul 17 15:33:32 2021 -0700
usb: renesas-xhci: Fix handling of unknown ROM state
Justin,
On Sat, Jul 17, 2021 at 08:39:19AM -0500, Justin Forbes wrote:
> On Mon, Jul 12, 2021 at 2:31 AM Greg Kroah-Hartman
> <gregkh@linuxfoundation.org> wrote:
> >
> > From: Moritz Fischer <mdf@kernel.org>
> >
> > commit d143825baf15f204dac60acdf95e428182aa3374 upstream.
> >
> > The ROM load sometimes seems to return an unknown status
> > (RENESAS_ROM_STATUS_NO_RESULT) instead of success / fail.
> >
> > If the ROM load indeed failed this leads to failures when trying to
> > communicate with the controller later on.
> >
> > Attempt to load firmware using RAM load in those cases.
> >
> > Fixes: 2478be82de44 ("usb: renesas-xhci: Add ROM loader for uPD720201")
> > Cc: stable@vger.kernel.org
> > Cc: Mathias Nyman <mathias.nyman@intel.com>
> > Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> > Cc: Vinod Koul <vkoul@kernel.org>
> > Tested-by: Vinod Koul <vkoul@kernel.org>
> > Reviewed-by: Vinod Koul <vkoul@kernel.org>
> > Signed-off-by: Moritz Fischer <mdf@kernel.org>
> > Link: https://lore.kernel.org/r/20210615153758.253572-1-mdf@kernel.org
> > Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> >
>
> After sending out 5.12.17 for testing, we had a user complain that all
> of their USB devices disappeared with the error:
>
> Jul 15 23:18:53 kernel: xhci_hcd 0000:04:00.0: Direct firmware load
> for renesas_usb_fw.mem failed with error -2
> Jul 15 23:18:53 kernel: xhci_hcd 0000:04:00.0: request_firmware failed: -2
> Jul 15 23:18:53 kernel: xhci_hcd: probe of 0000:04:00.0 failed with error -2
This looks like it fails finding the actual firmware file (ENOENT). Any
chance you could give this a whirl on top of the original patch?
diff --git a/drivers/usb/host/xhci-pci.c b/drivers/usb/host/xhci-pci.c
index 18c2bbddf080..cde8f6f1ec5d 100644
--- a/drivers/usb/host/xhci-pci.c
+++ b/drivers/usb/host/xhci-pci.c
@@ -379,7 +379,11 @@ static int xhci_pci_probe(struct pci_dev *dev, const struct pci_device_id *id)
driver_data = (struct xhci_driver_data *)id->driver_data;
if (driver_data && driver_data->quirks & XHCI_RENESAS_FW_QUIRK) {
retval = renesas_xhci_check_request_fw(dev, id);
- if (retval)
+ /*
+ * If firmware wasn't found there's still a chance this might work without
+ * loading firmware on some systems, so let's try at least.
+ */
+ if (retval && retval != -ENOENT)
return retval;
}