kernel-6.6.0-0.rc0.20230906git65d6e954e378.8

* Wed Sep 06 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.6.0-0.rc0.65d6e954e378.8]
- Rename pipeline repo branch and DW tree names (Michael Hofmann)
- Adjust comments that refer to ARK in a Rawhide context (Michael Hofmann)
- Rename variable names starting with ark- to rawhide- (Michael Hofmann)
- Rename trigger-ark to trigger-rawhide (Michael Hofmann)
- Fix up config mismatches for Fedora (Justin M. Forbes)
- Linux v6.6.0-0.rc0.65d6e954e378
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2023-09-06 08:10:59 -05:00
parent 48ccca63a1
commit dc0673a1b6
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 20 additions and 15 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
# #
# Use this spot to avoid future merge conflicts. # Use this spot to avoid future merge conflicts.
# Do not trim this comment. # Do not trim this comment.
RHEL_RELEASE = 7 RHEL_RELEASE = 8
# #
# RHEL_REBASE_NUM # RHEL_REBASE_NUM

View File

@ -163,13 +163,13 @@ Summary: The Linux kernel
%define specrpmversion 6.6.0 %define specrpmversion 6.6.0
%define specversion 6.6.0 %define specversion 6.6.0
%define patchversion 6.6 %define patchversion 6.6
%define pkgrelease 0.rc0.20230905git3f86ed6ec0b3.7 %define pkgrelease 0.rc0.20230906git65d6e954e378.8
%define kversion 6 %define kversion 6
%define tarfile_release 6.5-11704-g3f86ed6ec0b3 %define tarfile_release 6.5-11938-g65d6e954e378
# This is needed to do merge window version magic # This is needed to do merge window version magic
%define patchlevel 6 %define patchlevel 6
# This allows pkg_release to have configurable %%{?dist} tag # This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc0.20230905git3f86ed6ec0b3.7%{?buildid}%{?dist} %define specrelease 0.rc0.20230906git65d6e954e378.8%{?buildid}%{?dist}
# This defines the kabi tarball version # This defines the kabi tarball version
%define kabiversion 6.6.0 %define kabiversion 6.6.0
@ -3701,8 +3701,13 @@ fi\
# #
# #
%changelog %changelog
* Tue Sep 05 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.6.0-0.rc0.20230905git3f86ed6ec0b3.7] * Wed Sep 06 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.6.0-0.rc0.65d6e954e378.8]
- Rename pipeline repo branch and DW tree names (Michael Hofmann)
- Adjust comments that refer to ARK in a Rawhide context (Michael Hofmann)
- Rename variable names starting with ark- to rawhide- (Michael Hofmann)
- Rename trigger-ark to trigger-rawhide (Michael Hofmann)
- Fix up config mismatches for Fedora (Justin M. Forbes) - Fix up config mismatches for Fedora (Justin M. Forbes)
- Linux v6.6.0-0.rc0.65d6e954e378
* Tue Sep 05 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.6.0-0.rc0.3f86ed6ec0b3.7] * Tue Sep 05 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.6.0-0.rc0.3f86ed6ec0b3.7]
- redhat/configs: Texas Instruments Inc. K3 multicore SoC architecture (Steve Best) - redhat/configs: Texas Instruments Inc. K3 multicore SoC architecture (Steve Best)

View File

@ -120,7 +120,7 @@ index 000000000000..effb81d04bfd
+ +
+endmenu +endmenu
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index 4f283d915e54..f0355c2e70bf 100644 index 73f23fa0677a..b67872ae6283 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \ @@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -142,7 +142,7 @@ index 4f283d915e54..f0355c2e70bf 100644
# We are using a recursive build, so we need to do a little thinking # We are using a recursive build, so we need to do a little thinking
# to get the ordering right. # to get the ordering right.
# #
@@ -1336,7 +1348,13 @@ define filechk_version.h @@ -1250,7 +1262,13 @@ define filechk_version.h
((c) > 255 ? 255 : (c)))'; \ ((c) > 255 ? 255 : (c)))'; \
echo \#define LINUX_VERSION_MAJOR $(VERSION); \ echo \#define LINUX_VERSION_MAJOR $(VERSION); \
echo \#define LINUX_VERSION_PATCHLEVEL $(PATCHLEVEL); \ echo \#define LINUX_VERSION_PATCHLEVEL $(PATCHLEVEL); \
@ -442,7 +442,7 @@ index 691d4b7686ee..433ff7d8a844 100644
acpi_dev_get_resources(device, &resource_list, acpi_dev_get_resources(device, &resource_list,
acpi_check_serial_bus_slave, acpi_check_serial_bus_slave,
diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
index 06aec35f88f2..50428bd0fa12 100644 index e2bacedf28ef..b55ea894d874 100644
--- a/drivers/ata/libahci.c --- a/drivers/ata/libahci.c
+++ b/drivers/ata/libahci.c +++ b/drivers/ata/libahci.c
@@ -729,6 +729,24 @@ int ahci_stop_engine(struct ata_port *ap) @@ -729,6 +729,24 @@ int ahci_stop_engine(struct ata_port *ap)
@ -3126,7 +3126,7 @@ index 000000000000..616692b1ac11
+ +
+#endif /* __RH_MESSAGES_H */ +#endif /* __RH_MESSAGES_H */
diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
index b29b29707f10..e176487ebf1f 100644 index 34a5386d444a..6d8ea13fc608 100644
--- a/scripts/mod/modpost.c --- a/scripts/mod/modpost.c
+++ b/scripts/mod/modpost.c +++ b/scripts/mod/modpost.c
@@ -23,6 +23,7 @@ @@ -23,6 +23,7 @@
@ -3135,9 +3135,9 @@ index b29b29707f10..e176487ebf1f 100644
#include "../../include/linux/module_symbol.h" #include "../../include/linux/module_symbol.h"
+#include "../../include/generated/uapi/linux/version.h" +#include "../../include/generated/uapi/linux/version.h"
static bool module_enabled;
/* Are we using CONFIG_MODVERSIONS? */ /* Are we using CONFIG_MODVERSIONS? */
static bool modversions; @@ -2068,6 +2069,12 @@ static void write_buf(struct buffer *b, const char *fname)
@@ -2076,6 +2077,12 @@ static void write_buf(struct buffer *b, const char *fname)
} }
} }
@ -3150,7 +3150,7 @@ index b29b29707f10..e176487ebf1f 100644
static void write_if_changed(struct buffer *b, const char *fname) static void write_if_changed(struct buffer *b, const char *fname)
{ {
char *tmp; char *tmp;
@@ -2136,6 +2143,7 @@ static void write_mod_c_file(struct module *mod) @@ -2128,6 +2135,7 @@ static void write_mod_c_file(struct module *mod)
add_depends(&buf, mod); add_depends(&buf, mod);
add_moddevtable(&buf, mod); add_moddevtable(&buf, mod);
add_srcversion(&buf, mod); add_srcversion(&buf, mod);

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.5-11704-g3f86ed6ec0b3.tar.xz) = 0184ff2bc8c75d732fca336ac3a428892640ef850e17af54ee44539b984b6d58356c624ceb2d9e3b6aa1e552e5dc66adf1cd8077594c1551eaa0dffcd2a7f904 SHA512 (linux-6.5-11938-g65d6e954e378.tar.xz) = 84d32dcf2e6ab1ea7d85aa19b696d042fd8b99f6f807b9f8c800b02b1c5d6d4180c1d8948bf211d950322d451899c61cd54ed5c7f94b944a89728792a4b82092
SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 046b74f174d4df78da5d4e26bfcd325a3bf738d955392420a4ac2861156747a7afd47680f8e324b270f59017ecdc4cd17435a19ae27eecaea62f217039775541 SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 83b975e4ffb1d57de684df6b030036b1524638a87355bc55774084d28221c5d18f2d23dda40d1b39aa64d29c188222cfaaee7593161682e7bf98f540738d5fe9
SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = f2bcbfec565e8effe0bc6b7412bd6161df1f312721b4a4d9dfa6fbd971cc2e8dffa5f1f5454d81124d6b2e9b60f324134d05c8219234052ebb187e0a1aa52ffc SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 65aed67d8bc2c28d3430344312272d89b204485cd9a6284eeb6ba439dcf162714bef1f782864dff4523f43550bb493991f6b0600d156452521c623c13eac7969