kernel-5.16.13-0

* Tue Mar 08 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.16.13-0]
- Add config for ARM64_ERRATUM_2077057 (Justin M. Forbes)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2022-03-08 16:25:00 -06:00
parent 15a62740f8
commit db7d8c7f68
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
8 changed files with 111 additions and 68 deletions

View File

@ -1,3 +1,12 @@
https://gitlab.com/cki-project/kernel-ark/-/commit/ce338c425415d1e9623815d79bb88a98818f4157
ce338c425415d1e9623815d79bb88a98818f4157 Revert "PCI/MSI: Mask MSI-X vectors only on success"
https://gitlab.com/cki-project/kernel-ark/-/commit/bb6f217f11225d6c72a4c43601df295b29c5457d
bb6f217f11225d6c72a4c43601df295b29c5457d drm/i915/psr: Set "SF Partial Frame Enable" also on full update
https://gitlab.com/cki-project/kernel-ark/-/commit/88d7b2ee03edb6abba36a7a34011e1c036bb2c62
88d7b2ee03edb6abba36a7a34011e1c036bb2c62 Revert "drm/i915/psr: Disable PSR2 selective fetch for all TGL steps"
https://gitlab.com/cki-project/kernel-ark/-/commit/1c96abf3c7126a2fb24f689b1ffcdd6eda0ffdc6
1c96abf3c7126a2fb24f689b1ffcdd6eda0ffdc6 drm/nouveau/backlight: Fix LVDS backlight detection on some laptops

View File

@ -334,6 +334,7 @@ CONFIG_ARM64_ERRATUM_1542419=y
CONFIG_ARM64_ERRATUM_2051678=y
CONFIG_ARM64_ERRATUM_2054223=y
CONFIG_ARM64_ERRATUM_2067961=y
CONFIG_ARM64_ERRATUM_2077057=y
CONFIG_ARM64_ERRATUM_2119858=y
CONFIG_ARM64_ERRATUM_2139208=y
CONFIG_ARM64_ERRATUM_2224489=y

View File

@ -263,6 +263,7 @@ CONFIG_ARM64_ERRATUM_1542419=y
CONFIG_ARM64_ERRATUM_2051678=y
CONFIG_ARM64_ERRATUM_2054223=y
CONFIG_ARM64_ERRATUM_2067961=y
CONFIG_ARM64_ERRATUM_2077057=y
CONFIG_ARM64_ERRATUM_2119858=y
CONFIG_ARM64_ERRATUM_2139208=y
CONFIG_ARM64_ERRATUM_2224489=y

View File

@ -334,6 +334,7 @@ CONFIG_ARM64_ERRATUM_1542419=y
CONFIG_ARM64_ERRATUM_2051678=y
CONFIG_ARM64_ERRATUM_2054223=y
CONFIG_ARM64_ERRATUM_2067961=y
CONFIG_ARM64_ERRATUM_2077057=y
CONFIG_ARM64_ERRATUM_2119858=y
CONFIG_ARM64_ERRATUM_2139208=y
CONFIG_ARM64_ERRATUM_2224489=y

View File

@ -263,6 +263,7 @@ CONFIG_ARM64_ERRATUM_1542419=y
CONFIG_ARM64_ERRATUM_2051678=y
CONFIG_ARM64_ERRATUM_2054223=y
CONFIG_ARM64_ERRATUM_2067961=y
CONFIG_ARM64_ERRATUM_2077057=y
CONFIG_ARM64_ERRATUM_2119858=y
CONFIG_ARM64_ERRATUM_2139208=y
CONFIG_ARM64_ERRATUM_2224489=y

View File

@ -130,7 +130,7 @@ Summary: The Linux kernel
# The kernel tarball/base version
%define kversion 5.16
%define rpmversion 5.16.12
%define rpmversion 5.16.13
%define patchversion 5.16
%define pkgrelease 200
@ -692,7 +692,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.16.12.tar.xz
Source0: linux-5.16.13.tar.xz
Source1: Makefile.rhelver
@ -1386,8 +1386,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.16.12 -c
mv linux-5.16.12 linux-%{KVERREL}
%setup -q -n kernel-5.16.13 -c
mv linux-5.16.13 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2985,6 +2985,9 @@ fi
#
#
%changelog
* Tue Mar 08 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.16.13-0]
- Add config for ARM64_ERRATUM_2077057 (Justin M. Forbes)
* Wed Mar 02 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.16.12-0]
- drm/nouveau/backlight: Fix LVDS backlight detection on some laptops (Lyude Paul)

View File

@ -16,7 +16,8 @@
drivers/firmware/efi/Makefile | 1 +
drivers/firmware/efi/efi.c | 124 +++++++++++++++------
drivers/firmware/efi/secureboot.c | 38 +++++++
drivers/gpu/drm/i915/display/intel_psr.c | 10 +-
drivers/gpu/drm/i915/display/intel_psr.c | 16 ++-
drivers/gpu/drm/i915/i915_reg.h | 1 +
drivers/gpu/drm/nouveau/nouveau_backlight.c | 3 +-
drivers/hid/hid-rmi.c | 64 -----------
drivers/hwtracing/coresight/coresight-etm4x-core.c | 19 ++++
@ -29,9 +30,9 @@
drivers/nvme/host/core.c | 22 +++-
drivers/nvme/host/multipath.c | 19 ++--
drivers/nvme/host/nvme.h | 4 +
drivers/pci/msi.c | 13 +--
drivers/pci/quirks.c | 24 ++++
drivers/usb/core/hub.c | 7 ++
drivers/usb/gadget/legacy/inode.c | 10 +-
include/linux/efi.h | 22 ++--
include/linux/lsm_hook_defs.h | 2 +
include/linux/lsm_hooks.h | 6 +
@ -48,10 +49,10 @@
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
tools/testing/selftests/netfilter/nft_nat.sh | 5 +-
50 files changed, 807 insertions(+), 199 deletions(-)
51 files changed, 811 insertions(+), 205 deletions(-)
diff --git a/Makefile b/Makefile
index 09a9bb824afa..02a849fa625b 100644
index 6702e44821eb..9e7e71b0abbb 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -82,10 +83,10 @@ index c2724d986fa0..8063dcef65f7 100644
The VM uses one page of physical memory for each page table.
For systems with a lot of processes, this can use a lot of
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
index ae0e93871ee5..7d5274349536 100644
index 651bf217465e..874ef87c9585 100644
--- a/arch/arm64/Kconfig
+++ b/arch/arm64/Kconfig
@@ -1093,7 +1093,7 @@ endchoice
@@ -1109,7 +1109,7 @@ endchoice
config ARM64_FORCE_52BIT
bool "Force 52-bit virtual addresses for userspace"
@ -94,7 +95,7 @@ index ae0e93871ee5..7d5274349536 100644
help
For systems with 52-bit userspace VAs enabled, the kernel will attempt
to maintain compatibility with older software by providing 48-bit VAs
@@ -1347,6 +1347,7 @@ config XEN
@@ -1363,6 +1363,7 @@ config XEN
config FORCE_MAX_ZONEORDER
int
default "14" if ARM64_64K_PAGES
@ -128,7 +129,7 @@ index 5ad1dde23dc5..b6192d58eed3 100644
+ return !!ipl_secure_flag;
+}
diff --git a/arch/s390/kernel/setup.c b/arch/s390/kernel/setup.c
index 225ab2d0a4c6..6a06cde25ca2 100644
index 65a31cb0611f..5d059341f02b 100644
--- a/arch/s390/kernel/setup.c
+++ b/arch/s390/kernel/setup.c
@@ -49,6 +49,7 @@
@ -139,7 +140,7 @@ index 225ab2d0a4c6..6a06cde25ca2 100644
#include <linux/hugetlb.h>
#include <linux/kmemleak.h>
@@ -963,6 +964,9 @@ void __init setup_arch(char **cmdline_p)
@@ -965,6 +966,9 @@ void __init setup_arch(char **cmdline_p)
log_component_list();
@ -850,26 +851,57 @@ index 000000000000..de0a3714a5d4
+ }
+}
diff --git a/drivers/gpu/drm/i915/display/intel_psr.c b/drivers/gpu/drm/i915/display/intel_psr.c
index 7a205fd5023b..42d57ebd9061 100644
index 7a205fd5023b..3ba8b717e176 100644
--- a/drivers/gpu/drm/i915/display/intel_psr.c
+++ b/drivers/gpu/drm/i915/display/intel_psr.c
@@ -735,10 +735,14 @@ static bool intel_psr2_sel_fetch_config_valid(struct intel_dp *intel_dp,
return false;
}
@@ -1400,6 +1400,13 @@ static inline u32 man_trk_ctl_single_full_frame_bit_get(struct drm_i915_private
PSR2_MAN_TRK_CTL_SF_SINGLE_FULL_FRAME;
}
- /* Wa_14010254185 Wa_14010103792 */
- if (IS_TGL_DISPLAY_STEP(dev_priv, STEP_A0, STEP_C0)) {
+ /*
+ * There's two things stopping this from being enabled on TGL:
+ * For steps A0-C0: workarounds Wa_14010254185 Wa_14010103792 are missing
+ * For all steps: PSR2 selective fetch causes screen flickering
+ */
+ if (IS_TIGERLAKE(dev_priv)) {
drm_dbg_kms(&dev_priv->drm,
- "PSR2 sel fetch not enabled, missing the implementation of WAs\n");
+ "PSR2 sel fetch not enabled, currently broken on TGL\n");
return false;
+static inline u32 man_trk_ctl_partial_frame_bit_get(struct drm_i915_private *dev_priv)
+{
+ return IS_ALDERLAKE_P(dev_priv) ?
+ ADLP_PSR2_MAN_TRK_CTL_SF_PARTIAL_FRAME_UPDATE :
+ PSR2_MAN_TRK_CTL_SF_PARTIAL_FRAME_UPDATE;
+}
+
static void psr_force_hw_tracking_exit(struct intel_dp *intel_dp)
{
struct drm_i915_private *dev_priv = dp_to_i915(intel_dp);
@@ -1495,7 +1502,13 @@ static void psr2_man_trk_ctl_calc(struct intel_crtc_state *crtc_state,
{
struct intel_crtc *crtc = to_intel_crtc(crtc_state->uapi.crtc);
struct drm_i915_private *dev_priv = to_i915(crtc->base.dev);
- u32 val = PSR2_MAN_TRK_CTL_ENABLE;
+ u32 val = 0;
+
+ if (!IS_ALDERLAKE_P(dev_priv))
+ val = PSR2_MAN_TRK_CTL_ENABLE;
+
+ /* SF partial frame enable has to be set even on full update */
+ val |= man_trk_ctl_partial_frame_bit_get(dev_priv);
if (full_update) {
/*
@@ -1515,7 +1528,6 @@ static void psr2_man_trk_ctl_calc(struct intel_crtc_state *crtc_state,
} else {
drm_WARN_ON(crtc_state->uapi.crtc->dev, clip->y1 % 4 || clip->y2 % 4);
- val |= PSR2_MAN_TRK_CTL_SF_PARTIAL_FRAME_UPDATE;
val |= PSR2_MAN_TRK_CTL_SU_REGION_START_ADDR(clip->y1 / 4 + 1);
val |= PSR2_MAN_TRK_CTL_SU_REGION_END_ADDR(clip->y2 / 4 + 1);
}
diff --git a/drivers/gpu/drm/i915/i915_reg.h b/drivers/gpu/drm/i915/i915_reg.h
index 14ce8809efdd..e927776ae183 100644
--- a/drivers/gpu/drm/i915/i915_reg.h
+++ b/drivers/gpu/drm/i915/i915_reg.h
@@ -4738,6 +4738,7 @@ enum {
#define ADLP_PSR2_MAN_TRK_CTL_SU_REGION_START_ADDR(val) REG_FIELD_PREP(ADLP_PSR2_MAN_TRK_CTL_SU_REGION_START_ADDR_MASK, val)
#define ADLP_PSR2_MAN_TRK_CTL_SU_REGION_END_ADDR_MASK REG_GENMASK(12, 0)
#define ADLP_PSR2_MAN_TRK_CTL_SU_REGION_END_ADDR(val) REG_FIELD_PREP(ADLP_PSR2_MAN_TRK_CTL_SU_REGION_END_ADDR_MASK, val)
+#define ADLP_PSR2_MAN_TRK_CTL_SF_PARTIAL_FRAME_UPDATE REG_BIT(31)
#define ADLP_PSR2_MAN_TRK_CTL_SF_SINGLE_FULL_FRAME REG_BIT(14)
#define ADLP_PSR2_MAN_TRK_CTL_SF_CONTINUOS_FULL_FRAME REG_BIT(13)
diff --git a/drivers/gpu/drm/nouveau/nouveau_backlight.c b/drivers/gpu/drm/nouveau/nouveau_backlight.c
index 1cbd71abc80a..9d2513de959b 100644
@ -1526,6 +1558,37 @@ index 9b095ee01364..bf25ef206cd2 100644
static inline void nvme_kick_requeue_lists(struct nvme_ctrl *ctrl)
{
}
diff --git a/drivers/pci/msi.c b/drivers/pci/msi.c
index 8465221be6d2..64f37ad8227d 100644
--- a/drivers/pci/msi.c
+++ b/drivers/pci/msi.c
@@ -722,6 +722,9 @@ static int msix_capability_init(struct pci_dev *dev, struct msix_entry *entries,
goto out_disable;
}
+ /* Ensure that all table entries are masked. */
+ msix_mask_all(base, tsize);
+
ret = msix_setup_entries(dev, base, entries, nvec, affd);
if (ret)
goto out_disable;
@@ -748,16 +751,6 @@ static int msix_capability_init(struct pci_dev *dev, struct msix_entry *entries,
/* Set MSI-X enabled bits and unmask the function */
pci_intx_for_msi(dev, 0);
dev->msix_enabled = 1;
-
- /*
- * Ensure that all table entries are masked to prevent
- * stale entries from firing in a crash kernel.
- *
- * Done late to deal with a broken Marvell NVME device
- * which takes the MSI-X mask bits into account even
- * when MSI-X is disabled, which prevents MSI delivery.
- */
- msix_mask_all(base, tsize);
pci_msix_clear_and_set_ctrl(dev, PCI_MSIX_FLAGS_MASKALL, 0);
pcibios_free_irq(dev);
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
index 20a932690738..494cee3aec7b 100644
--- a/drivers/pci/quirks.c
@ -1579,42 +1642,6 @@ index ac6c5ccfe1cb..ec784479eece 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/drivers/usb/gadget/legacy/inode.c b/drivers/usb/gadget/legacy/inode.c
index 3b58f4fc0a80..25c8809e0a38 100644
--- a/drivers/usb/gadget/legacy/inode.c
+++ b/drivers/usb/gadget/legacy/inode.c
@@ -1826,8 +1826,9 @@ dev_config (struct file *fd, const char __user *buf, size_t len, loff_t *ptr)
spin_lock_irq (&dev->lock);
value = -EINVAL;
if (dev->buf) {
+ spin_unlock_irq(&dev->lock);
kfree(kbuf);
- goto fail;
+ return value;
}
dev->buf = kbuf;
@@ -1874,8 +1875,8 @@ dev_config (struct file *fd, const char __user *buf, size_t len, loff_t *ptr)
value = usb_gadget_probe_driver(&gadgetfs_driver);
if (value != 0) {
- kfree (dev->buf);
- dev->buf = NULL;
+ spin_lock_irq(&dev->lock);
+ goto fail;
} else {
/* at this point "good" hardware has for the first time
* let the USB the host see us. alternatively, if users
@@ -1892,6 +1893,9 @@ dev_config (struct file *fd, const char __user *buf, size_t len, loff_t *ptr)
return value;
fail:
+ dev->config = NULL;
+ dev->hs_config = NULL;
+ dev->dev = NULL;
spin_unlock_irq (&dev->lock);
pr_debug ("%s: %s fail %zd, %p\n", shortname, __func__, value, dev);
kfree (dev->buf);
diff --git a/include/linux/efi.h b/include/linux/efi.h
index ef8dbc0a1522..836a5dfc6156 100644
--- a/include/linux/efi.h

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.16.12.tar.xz) = 88856cd67fa447c88bf476d2f1a1aa6bb91a9329e44e0223fed6465170353782a7254e005cc95a977172312bc4d69fe3a6dfb81b05a360434f83ef32eef76785
SHA512 (kernel-abi-stablelists-5.16.12-200.tar.bz2) = f0b4dd2f49337cb445aa3ca9b193afc1ed5a7cd6a0949284285486ab0feb5e7d7a38b94bbf46f99ec1e895a597c2eeee1dc7ab2dedf45201f69d34b4aa8dd598
SHA512 (kernel-kabi-dw-5.16.12-200.tar.bz2) = 41641a3637003028ce711aa9b186e8f97d54676417da18197f453d2afa448c5808f53735b1ba4ca15c21c6a584731df643ccdd153a5aa0da0d89e95c7bc72127
SHA512 (linux-5.16.13.tar.xz) = 074d278fe9603de01b8feebefbbfb1d620f89fafab1fc898d3b5eede00cf46d62c7f994f904a088d6f4bb613abd5cf5f88a0a1232284f5af330a8e88fcd49f38
SHA512 (kernel-abi-stablelists-5.16.13-200.tar.bz2) = 6c63ade767efb7fb103004ffb461c99688310cb18d709bc01a69fbec33788f6f1163ad6e2996216dae09d6d0481e792c3fd4ba5c12676c89db8295c9abaeec38
SHA512 (kernel-kabi-dw-5.16.13-200.tar.bz2) = a257b5cb940038396f7a1e0961647648454197833f92908621a7b5fe2a0806d27da4783c5042177a9ebcc283058bdd8cec7e6ce207307d0efe2ce0e8143e1269