Linux 3.1.1-rc1
Comment out merged patches, will drop when release is final: ums-realtek-driver-uses-stack-memory-for-DMA.patch epoll-fix-spurious-lockdep-warnings.patch crypto-register-cryptd-first.patch add-macbookair41-keyboard.patch powerpc-Fix-deadlock-in-icswx-code.patch iwlagn-fix-ht_params-NULL-pointer-dereference.patch mmc-Always-check-for-lower-base-frequency-quirk-for-.patch media-DiBcom-protect-the-I2C-bufer-access.patch media-dib0700-protect-the-dib0700-buffer-access.patch WMI-properly-cleanup-devices-to-avoid-crashes.patch mac80211-fix-remain_off_channel-regression.patch mac80211-config-hw-when-going-back-on-channel.patch
This commit is contained in:
parent
f8e6300ee7
commit
dabe57bb09
@ -3105,6 +3105,7 @@ CONFIG_USB_STORAGE_ONETOUCH=m
|
|||||||
CONFIG_USB_STORAGE_ALAUDA=m
|
CONFIG_USB_STORAGE_ALAUDA=m
|
||||||
CONFIG_USB_STORAGE_KARMA=m
|
CONFIG_USB_STORAGE_KARMA=m
|
||||||
CONFIG_USB_STORAGE_REALTEK=m
|
CONFIG_USB_STORAGE_REALTEK=m
|
||||||
|
CONFIG_REALTEK_AUTOPM=y
|
||||||
CONFIG_USB_STORAGE_ENE_UB6250=m
|
CONFIG_USB_STORAGE_ENE_UB6250=m
|
||||||
# CONFIG_USB_LIBUSUAL is not set
|
# CONFIG_USB_LIBUSUAL is not set
|
||||||
CONFIG_USB_UAS=m
|
CONFIG_USB_UAS=m
|
||||||
@ -3158,7 +3159,6 @@ CONFIG_HID_TOPSEED=m
|
|||||||
CONFIG_HID_THRUSTMASTER=m
|
CONFIG_HID_THRUSTMASTER=m
|
||||||
CONFIG_HID_ZEROPLUS=m
|
CONFIG_HID_ZEROPLUS=m
|
||||||
CONFIG_HID_ZYDACRON=m
|
CONFIG_HID_ZYDACRON=m
|
||||||
CONFIG_HID_ACRUX_FF=m
|
|
||||||
CONFIG_HID_EMS_FF=m
|
CONFIG_HID_EMS_FF=m
|
||||||
CONFIG_HID_ELECOM=m
|
CONFIG_HID_ELECOM=m
|
||||||
CONFIG_HID_UCLOGIC=m
|
CONFIG_HID_UCLOGIC=m
|
||||||
@ -3166,6 +3166,7 @@ CONFIG_HID_WALTOP=m
|
|||||||
CONFIG_HID_ROCCAT_PYRA=m
|
CONFIG_HID_ROCCAT_PYRA=m
|
||||||
CONFIG_HID_ROCCAT_KONEPLUS=m
|
CONFIG_HID_ROCCAT_KONEPLUS=m
|
||||||
CONFIG_HID_ACRUX=m
|
CONFIG_HID_ACRUX=m
|
||||||
|
CONFIG_HID_ACRUX_FF=y
|
||||||
CONFIG_HID_KEYTOUCH=m
|
CONFIG_HID_KEYTOUCH=m
|
||||||
CONFIG_HID_LCPOWER=m
|
CONFIG_HID_LCPOWER=m
|
||||||
CONFIG_HID_ROCCAT_ARVO=m
|
CONFIG_HID_ROCCAT_ARVO=m
|
||||||
|
46
kernel.spec
46
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 10
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -63,9 +63,9 @@ Summary: The Linux kernel
|
|||||||
%if 0%{?released_kernel}
|
%if 0%{?released_kernel}
|
||||||
|
|
||||||
# Do we have a -stable update to apply?
|
# Do we have a -stable update to apply?
|
||||||
%define stable_update 0
|
%define stable_update 1
|
||||||
# Is it a -stable RC?
|
# Is it a -stable RC?
|
||||||
%define stable_rc 0
|
%define stable_rc 1
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%if 0%{?stable_update}
|
%if 0%{?stable_update}
|
||||||
%define stablerev %{stable_update}
|
%define stablerev %{stable_update}
|
||||||
@ -1384,14 +1384,14 @@ ApplyPatch disable-i8042-check-on-apple-mac.patch
|
|||||||
ApplyPatch add-appleir-usb-driver.patch
|
ApplyPatch add-appleir-usb-driver.patch
|
||||||
|
|
||||||
ApplyPatch udlfb-bind-framebuffer-to-interface.patch
|
ApplyPatch udlfb-bind-framebuffer-to-interface.patch
|
||||||
ApplyPatch ums-realtek-driver-uses-stack-memory-for-DMA.patch
|
#ApplyPatch ums-realtek-driver-uses-stack-memory-for-DMA.patch
|
||||||
ApplyPatch epoll-fix-spurious-lockdep-warnings.patch
|
#ApplyPatch epoll-fix-spurious-lockdep-warnings.patch
|
||||||
ApplyPatch epoll-limit-paths.patch
|
ApplyPatch epoll-limit-paths.patch
|
||||||
ApplyPatch rcu-avoid-just-onlined-cpu-resched.patch
|
ApplyPatch rcu-avoid-just-onlined-cpu-resched.patch
|
||||||
ApplyPatch block-stray-block-put-after-teardown.patch
|
ApplyPatch block-stray-block-put-after-teardown.patch
|
||||||
ApplyPatch usb-add-quirk-for-logitech-webcams.patch
|
ApplyPatch usb-add-quirk-for-logitech-webcams.patch
|
||||||
|
|
||||||
ApplyPatch crypto-register-cryptd-first.patch
|
#ApplyPatch crypto-register-cryptd-first.patch
|
||||||
|
|
||||||
# rhbz#605888
|
# rhbz#605888
|
||||||
ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
||||||
@ -1399,19 +1399,19 @@ ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
|||||||
ApplyPatch revert-efi-rtclock.patch
|
ApplyPatch revert-efi-rtclock.patch
|
||||||
ApplyPatch efi-dont-map-boot-services-on-32bit.patch
|
ApplyPatch efi-dont-map-boot-services-on-32bit.patch
|
||||||
|
|
||||||
ApplyPatch add-macbookair41-keyboard.patch
|
#ApplyPatch add-macbookair41-keyboard.patch
|
||||||
|
|
||||||
ApplyPatch hvcs_pi_buf_alloc.patch
|
ApplyPatch hvcs_pi_buf_alloc.patch
|
||||||
|
|
||||||
ApplyPatch powerpc-Fix-deadlock-in-icswx-code.patch
|
#ApplyPatch powerpc-Fix-deadlock-in-icswx-code.patch
|
||||||
|
|
||||||
ApplyPatch iwlagn-fix-ht_params-NULL-pointer-dereference.patch
|
#ApplyPatch iwlagn-fix-ht_params-NULL-pointer-dereference.patch
|
||||||
|
|
||||||
#rhbz #722509
|
#rhbz #722509
|
||||||
ApplyPatch mmc-Always-check-for-lower-base-frequency-quirk-for-.patch
|
#ApplyPatch mmc-Always-check-for-lower-base-frequency-quirk-for-.patch
|
||||||
|
|
||||||
ApplyPatch media-DiBcom-protect-the-I2C-bufer-access.patch
|
#ApplyPatch media-DiBcom-protect-the-I2C-bufer-access.patch
|
||||||
ApplyPatch media-dib0700-protect-the-dib0700-buffer-access.patch
|
#ApplyPatch media-dib0700-protect-the-dib0700-buffer-access.patch
|
||||||
ApplyPatch media-dib0700-correct-error-message.patch
|
ApplyPatch media-dib0700-correct-error-message.patch
|
||||||
|
|
||||||
# utrace.
|
# utrace.
|
||||||
@ -1429,7 +1429,7 @@ ApplyPatch benet-remove-bogus-unlikely-on-vlan-check.patch
|
|||||||
ApplyPatch oom-fix-integer-overflow-of-points.patch
|
ApplyPatch oom-fix-integer-overflow-of-points.patch
|
||||||
|
|
||||||
#rhbz 706574
|
#rhbz 706574
|
||||||
ApplyPatch WMI-properly-cleanup-devices-to-avoid-crashes.patch
|
#ApplyPatch WMI-properly-cleanup-devices-to-avoid-crashes.patch
|
||||||
|
|
||||||
#rhbz 728607
|
#rhbz 728607
|
||||||
ApplyPatch elantech.patch
|
ApplyPatch elantech.patch
|
||||||
@ -1438,8 +1438,8 @@ ApplyPatch elantech.patch
|
|||||||
ApplyPatch ideapad-Check-if-acpi-already-handle-backlight.patch
|
ApplyPatch ideapad-Check-if-acpi-already-handle-backlight.patch
|
||||||
|
|
||||||
#rhbz 731365
|
#rhbz 731365
|
||||||
ApplyPatch mac80211-fix-remain_off_channel-regression.patch
|
#ApplyPatch mac80211-fix-remain_off_channel-regression.patch
|
||||||
ApplyPatch mac80211-config-hw-when-going-back-on-channel.patch
|
#ApplyPatch mac80211-config-hw-when-going-back-on-channel.patch
|
||||||
|
|
||||||
#rhbz 752176
|
#rhbz 752176
|
||||||
ApplyPatch sysfs-msi-irq-per-device.patch
|
ApplyPatch sysfs-msi-irq-per-device.patch
|
||||||
@ -2148,6 +2148,22 @@ fi
|
|||||||
# and build.
|
# and build.
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 09 2011 Chuck Ebbert <cebbert@redhat.com> 3.1.1-1.rc1
|
||||||
|
- Linux 3.1.1-rc1
|
||||||
|
- Comment out merged patches, will drop when release is final:
|
||||||
|
ums-realtek-driver-uses-stack-memory-for-DMA.patch
|
||||||
|
epoll-fix-spurious-lockdep-warnings.patch
|
||||||
|
crypto-register-cryptd-first.patch
|
||||||
|
add-macbookair41-keyboard.patch
|
||||||
|
powerpc-Fix-deadlock-in-icswx-code.patch
|
||||||
|
iwlagn-fix-ht_params-NULL-pointer-dereference.patch
|
||||||
|
mmc-Always-check-for-lower-base-frequency-quirk-for-.patch
|
||||||
|
media-DiBcom-protect-the-I2C-bufer-access.patch
|
||||||
|
media-dib0700-protect-the-dib0700-buffer-access.patch
|
||||||
|
WMI-properly-cleanup-devices-to-avoid-crashes.patch
|
||||||
|
mac80211-fix-remain_off_channel-regression.patch
|
||||||
|
mac80211-config-hw-when-going-back-on-channel.patch
|
||||||
|
|
||||||
* Wed Nov 09 2011 John W. Linville <linville@redhat.com>
|
* Wed Nov 09 2011 John W. Linville <linville@redhat.com>
|
||||||
- Backport brcm80211 from 3.2-rc1
|
- Backport brcm80211 from 3.2-rc1
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
|||||||
8d43453f8159b2332ad410b19d86a931 linux-3.1.tar.bz2
|
8d43453f8159b2332ad410b19d86a931 linux-3.1.tar.bz2
|
||||||
|
0582554c78b9979dc91223e3f4e4ec22 patch-3.1.1-rc1.bz2
|
||||||
|
@ -1,75 +1,14 @@
|
|||||||
From d5446509abd85b6845d91a319a033c5bd17e494d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Oliver Neukum <oneukum-l3A5Bk7waGM@public.gmane.org>
|
|
||||||
Date: Tue, 13 Sep 2011 08:42:21 +0200
|
|
||||||
Subject: [PATCH] USB:add RESET_RESUME for webcams shown to be quirky
|
|
||||||
|
|
||||||
From 6f673c5ef819548b2cbaf7bb607779af6fdbe731 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Oliver Neukum <oliver-GvhC2dPhHPQdnm+yROfE0A@public.gmane.org>
|
|
||||||
Date: Tue, 30 Aug 2011 15:34:32 +0200
|
|
||||||
Subject: [PATCH] USB:add RESET_RESUME for webcams shown to be quirky
|
|
||||||
|
|
||||||
The new runtime PM code has shown that many webcams suffer
|
|
||||||
from a race condition that may crash them upon resume.
|
|
||||||
Runtime PM is especially prone to show the problem because
|
|
||||||
it retains power to the cameras at all times. However
|
|
||||||
system suspension may also crash the devices and retain
|
|
||||||
power to the devices.
|
|
||||||
The only way to solve this problem without races is in
|
|
||||||
usbcore with the RESET_RESUME quirk.
|
|
||||||
|
|
||||||
Signed-off-by: Oliver Neukum <oneukum-l3A5Bk7waGM@public.gmane.org>
|
|
||||||
|
|
||||||
Add C300 ID from patch in rhbz #742010
|
|
||||||
Add C600 ID from rhbz #742010
|
Add C600 ID from rhbz #742010
|
||||||
---
|
---
|
||||||
drivers/usb/core/quirks.c | 27 +++++++++++++++++++++++++++
|
|
||||||
1 files changed, 27 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/usb/core/quirks.c b/drivers/usb/core/quirks.c
|
|
||||||
index 81ce6a8..caa1991 100644
|
|
||||||
--- a/drivers/usb/core/quirks.c
|
--- a/drivers/usb/core/quirks.c
|
||||||
+++ b/drivers/usb/core/quirks.c
|
+++ b/drivers/usb/core/quirks.c
|
||||||
@@ -38,6 +38,30 @@ static const struct usb_device_id usb_quirk_list[] = {
|
@@ -38,6 +38,9 @@ static const struct usb_device_id usb_quirk_list[] = {
|
||||||
/* Creative SB Audigy 2 NX */
|
/* Logitech Webcam B/C500 */
|
||||||
{ USB_DEVICE(0x041e, 0x3020), .driver_info = USB_QUIRK_RESET_RESUME },
|
{ USB_DEVICE(0x046d, 0x0807), .driver_info = USB_QUIRK_RESET_RESUME },
|
||||||
|
|
||||||
+ /* Logitech Webcam C200 */
|
|
||||||
+ { USB_DEVICE(0x046d, 0x0802), .driver_info = USB_QUIRK_RESET_RESUME },
|
|
||||||
+
|
|
||||||
+ /* Logitech Webcam C250 */
|
|
||||||
+ { USB_DEVICE(0x046d, 0x0804), .driver_info = USB_QUIRK_RESET_RESUME },
|
|
||||||
+
|
|
||||||
+ /* Logitech Webcam C300 */
|
|
||||||
+ { USB_DEVICE(0x046d, 0x0805), .driver_info = USB_QUIRK_RESET_RESUME },
|
|
||||||
+
|
|
||||||
+ /* Logitech Webcam B/C500 */
|
|
||||||
+ { USB_DEVICE(0x046d, 0x0807), .driver_info = USB_QUIRK_RESET_RESUME },
|
|
||||||
+
|
|
||||||
+ /* Logitech Webcam C600 */
|
+ /* Logitech Webcam C600 */
|
||||||
+ { USB_DEVICE(0x046d, 0x0808), .driver_info = USB_QUIRK_RESET_RESUME },
|
+ { USB_DEVICE(0x046d, 0x0808), .driver_info = USB_QUIRK_RESET_RESUME },
|
||||||
+
|
+
|
||||||
+ /* Logitech Webcam Pro 9000 */
|
/* Logitech Webcam Pro 9000 */
|
||||||
+ { USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },
|
{ USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },
|
||||||
+
|
|
||||||
+ /* Logitech Webcam C310 */
|
|
||||||
+ { USB_DEVICE(0x046d, 0x081b), .driver_info = USB_QUIRK_RESET_RESUME },
|
|
||||||
+
|
|
||||||
+ /* Logitech Webcam C270 */
|
|
||||||
+ { USB_DEVICE(0x046d, 0x0825), .driver_info = USB_QUIRK_RESET_RESUME },
|
|
||||||
+
|
|
||||||
/* Logitech Harmony 700-series */
|
|
||||||
{ USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },
|
|
||||||
|
|
||||||
@@ -69,6 +93,9 @@ static const struct usb_device_id usb_quirk_list[] = {
|
|
||||||
{ USB_DEVICE(0x06a3, 0x0006), .driver_info =
|
|
||||||
USB_QUIRK_CONFIG_INTF_STRINGS },
|
|
||||||
|
|
||||||
+ /* Guillemot Webcam Hercules Dualpix Exchange*/
|
|
||||||
+ { USB_DEVICE(0x06f8, 0x0804), .driver_info = USB_QUIRK_RESET_RESUME },
|
|
||||||
+
|
|
||||||
/* M-Systems Flash Disk Pioneers */
|
|
||||||
{ USB_DEVICE(0x08ec, 0x1000), .driver_info = USB_QUIRK_RESET_RESUME },
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.6.4
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user