kernel-5.13.11-100

* Tue Aug 17 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.11-100]
- kernel-5.13.11-0 (Justin M. Forbes)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-08-17 10:19:48 -05:00
parent cb6a6ba4e1
commit d7687b4cdb
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
3 changed files with 36 additions and 16 deletions

View File

@ -116,7 +116,7 @@ Summary: The Linux kernel
# The kernel tarball/base version
%define kversion 5.13
%define rpmversion 5.13.10
%define rpmversion 5.13.11
%define stableversion 5.13
%define pkgrelease 100
@ -646,7 +646,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.13.10.tar.xz
Source0: linux-5.13.11.tar.xz
Source1: Makefile.rhelver
@ -1315,8 +1315,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.13.10 -c
mv linux-5.13.10 linux-%{KVERREL}
%setup -q -n kernel-5.13.11 -c
mv linux-5.13.11 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2886,14 +2886,34 @@ fi
#
#
%changelog
* Thu Aug 12 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.10-100]
- bpf: Fix integer overflow involving bucket_size (Tatsuhiko Yasumatsu)
- kernel-5.13.10-0 (Justin M. Forbes)
* Tue Aug 17 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.11-100]
- kernel-5.13.11-0 (Justin M. Forbes)
* Thu Aug 12 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.10-0]
- Fix up backport of Dell XPS 9710 quirk (Justin M. Forbes)
- ASoC: Intel: sof_sdw_max98373: remove useless inits (Pierre-Louis Bossart)
- ASoC: Intel: update sof_pcm512x quirks (Pierre-Louis Bossart)
- ASoC: SOF: Intel: Use DMI string to search for adl_mx98373_rt5682 variant (jairaj arava)
- ASoC: Intel: sof_sdw: add quirk for Dell XPS 9710 (Pierre-Louis Bossart)
- kernel-5.13.9-0 (Justin M. Forbes)
- drm/i915/dp: Use max params for older panels (Kai-Heng Feng)
- pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko)
- kernel-5.13.8-0 (Justin M. Forbes)
- Re-enable sermouse for x86 (rhbz 1974002) (Justin M. Forbes)
- Revert CRYPTO_ECDH and CRYPTO_ECDA from builtin to module to fix fips (Justin M. Forbes)
- drm/rockchip: remove existing generic drivers to take over the device (Javier Martinez Canillas)
- powerpc/pseries: Fix regression while building external modules (Srikar Dronamraju)
- kernel-5.13.7-0 (Justin M. Forbes)
- kernel-5.13.6-0 (Justin M. Forbes)
- kernel-5.13.5-0 (Justin M. Forbes)
- iwlwifi Add support for ax201 in Samsung Galaxy Book Flex2 Alpha (Justin M. Forbes)
- Revert "usb: renesas-xhci: Fix handling of unknown ROM state" (Justin M. Forbes)
- RHEL configs need this too (Justin M. Forbes)
- kernel-5.13.4-0 (Justin M. Forbes)
- Config update for 5.13.4 (Justin M. Forbes)
- kernel-5.13.3-0 (Justin M. Forbes)
- Don't tag a release as [redhat] (Justin M. Forbes)
- platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd() (Yang Yingliang)
* Sun Aug 08 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.9-0]
- drm/i915/dp: Use max params for older panels (Kai-Heng Feng)

View File

@ -99,7 +99,7 @@ index 75a9dd98e76e..3ff3291551f9 100644
Boot into System Kernel
diff --git a/Makefile b/Makefile
index 4e9f877f513f..6123e12d63e2 100644
index eaf1df54ad12..96c289777a99 100644
--- a/Makefile
+++ b/Makefile
@@ -508,6 +508,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
@ -2126,10 +2126,10 @@ index ab7eea01ab42..fff7c5f737fc 100644
int rmi_register_transport_device(struct rmi_transport_dev *xport);
diff --git a/include/linux/security.h b/include/linux/security.h
index 06f7c50ce77f..09ed686ac5e6 100644
index 0acd1b68bf30..a02717d46d6d 100644
--- a/include/linux/security.h
+++ b/include/linux/security.h
@@ -471,6 +471,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
@@ -472,6 +472,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
int security_inode_setsecctx(struct dentry *dentry, void *ctx, u32 ctxlen);
int security_inode_getsecctx(struct inode *inode, void **ctx, u32 *ctxlen);
int security_locked_down(enum lockdown_reason what);
@ -2137,7 +2137,7 @@ index 06f7c50ce77f..09ed686ac5e6 100644
#else /* CONFIG_SECURITY */
static inline int call_blocking_lsm_notifier(enum lsm_event event, void *data)
@@ -1347,6 +1348,10 @@ static inline int security_locked_down(enum lockdown_reason what)
@@ -1348,6 +1349,10 @@ static inline int security_locked_down(enum lockdown_reason what)
{
return 0;
}
@ -2323,10 +2323,10 @@ index 87cbdc64d272..18555cf18da7 100644
static int __init lockdown_lsm_init(void)
diff --git a/security/security.c b/security/security.c
index b38155b2de83..b0a6711b4825 100644
index 0d626c0dafcc..61696b1f5d3f 100644
--- a/security/security.c
+++ b/security/security.c
@@ -2598,6 +2598,12 @@ int security_locked_down(enum lockdown_reason what)
@@ -2599,6 +2599,12 @@ int security_locked_down(enum lockdown_reason what)
}
EXPORT_SYMBOL(security_locked_down);

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.13.10.tar.xz) = 54dff92c44f689996568b1a0e73489592340dda4ca1e4ec2113ecce53d09ac92db39db033641ee57268d893091bfc839fc7ba6df05f8adee53604fbc4423833f
SHA512 (kernel-abi-whitelists-5.13.10-100.tar.bz2) = ced11566a6f68979a46346520c8c38689892a8e8a6a987e61f4f56d8303e67c02829c3c3b35296df4e2097cd26bc8de8f8ee0b1b1bf74c6f976b8318abea357b
SHA512 (kernel-kabi-dw-5.13.10-100.tar.bz2) = 3b629d300a3a346f29d9de17e89b1b4cf30d968e26071e8cdb84f0c7c6ce8a80a25f3665ddd0e844afe4bfc08ece86c93b3044c83494c2b4d1b5505105973164
SHA512 (linux-5.13.11.tar.xz) = 9dcf29f211806e4967d5de948eeb3b6750cd8ca86d08f5c79dd56921a5896e04d3e9ebba3f281810e7180833b92939e78047bb21c3327dbdcadd3a0df24084e3
SHA512 (kernel-abi-whitelists-5.13.11-100.tar.bz2) = ce49bc158f9d8d5519dcd9c2072716270663a5a582212f8f40377a9869e96ca6d050334d6d2b44bee040a1a592139cd7c4ba98134c250c0566bf3e8804aefd6e
SHA512 (kernel-kabi-dw-5.13.11-100.tar.bz2) = ff2c0fc2ea35f347c6b0c2456305b415255332c3fa60d61c700cc6e02823cf12f9bfca1698b0d4700e7423869ff3653891f42c22097a489381ca0367599e7f57