Add perf build fix back, changed to work with upstream

This commit is contained in:
Justin M. Forbes 2012-10-12 15:39:29 -05:00
parent ad58b20867
commit d5a57ddec9
2 changed files with 71 additions and 0 deletions

View File

@ -753,6 +753,9 @@ Patch22066: virtio-scsi-Initialize-scatterlist-structure.patch
#rhbz 846037
Patch22067: selinux-Fix-sel_netnode_insert-suspicious-rcu-dereference.patch
#Perf build fix, should go away soon
Patch22070: perf-build-fix.patch
# END OF PATCH DEFINITIONS
%endif
@ -1454,6 +1457,9 @@ ApplyPatch virtio-scsi-Initialize-scatterlist-structure.patch
#rhbz 846037
ApplyPatch selinux-Fix-sel_netnode_insert-suspicious-rcu-dereference.patch
#Perf build fix, should go away soon
ApplyPatch perf-build-fix.patch
# END OF PATCH APPLICATIONS
%endif
@ -2307,6 +2313,9 @@ fi
# ||----w |
# || ||
%changelog
* Fri Oct 12 2012 Justin M. Forbes <jforbes@redhat.com>
- Add perf build fix back, changed to work with upstream
* Fri Oct 12 2012 Justin M. Forbes <jforbes@redhat.com>
- v3.6-10630-gccff9b1

62
perf-build-fix.patch Normal file
View File

@ -0,0 +1,62 @@
Perf build fails with the new rbtree implementation:
../../lib/rbtree.c:24:36: fatal error: linux/rbtree_augmented.h: No such
file or
directory
compilation terminated.
make[2]: *** [util/rbtree.o] Error 1
make[1]: *** [perf_install] Error 2
make: *** [tools/perf_install] Error 2
Fix by updating the Makefile and adding a btree_augmented.h wrapper.
Reported-by: Borislav Petkov <borislav.petkov@amd.com>
Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
---
tools/perf/Makefile | 3 ++-
tools/perf/util/include/linux/rbtree.h | 1 -
tools/perf/util/include/linux/rbtree_augmented.h | 2 ++
tools/perf/util/scripting-engines/trace-event-perl.c | 2 +-
4 files changed, 5 insertions(+), 3 deletions(-)
create mode 100644 tools/perf/util/include/linux/rbtree_augmented.h
diff --git a/tools/perf/Makefile b/tools/perf/Makefile
index 86258c2..9546ff5 100644
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -268,6 +268,7 @@ LIB_H += util/include/linux/magic.h
LIB_H += util/include/linux/poison.h
LIB_H += util/include/linux/prefetch.h
LIB_H += util/include/linux/rbtree.h
+LIB_H += util/include/linux/rbtree_augmented.h
LIB_H += util/include/linux/string.h
LIB_H += util/include/linux/types.h
LIB_H += util/include/linux/linkage.h
@@ -906,7 +907,7 @@ $(OUTPUT)ui/browsers/map.o: ui/browsers/map.c $(OUTPUT)PERF-CFLAGS
$(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -DENABLE_SLFUTURE_CONST $<
$(OUTPUT)util/rbtree.o: ../../lib/rbtree.c $(OUTPUT)PERF-CFLAGS
- $(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -DETC_PERFCONFIG='"$(ETC_PERFCONFIG_SQ)"' $<
+ $(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -Wno-unused-parameter -DETC_PERFCONFIG='"$(ETC_PERFCONFIG_SQ)"' $<
$(OUTPUT)util/parse-events.o: util/parse-events.c $(OUTPUT)PERF-CFLAGS
$(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -Wno-redundant-decls $<
diff --git a/tools/perf/util/include/linux/rbtree.h b/tools/perf/util/include/linux/rbtree.h
index 9bcdc84..2a030c5 100644
diff --git a/tools/perf/util/include/linux/rbtree_augmented.h b/tools/perf/util/include/linux/rbtree_augmented.h
new file mode 100644
index 0000000..9d6fcdf
--- /dev/null
+++ b/tools/perf/util/include/linux/rbtree_augmented.h
@@ -0,0 +1,2 @@
+#include <stdbool.h>
+#include "../../../../include/linux/rbtree_augmented.h"
diff --git a/tools/perf/util/scripting-engines/trace-event-perl.c b/tools/perf/util/scripting-engines/trace-event-perl.c
index f80605e..f53889d 100644
--
Markus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/