3.1-rc3.
Add patch to fix duplicate backlight registration on i915
This commit is contained in:
parent
0b3ccf1fa5
commit
d20ff5e932
44
fix-intel-duplicate-backlight.patch
Normal file
44
fix-intel-duplicate-backlight.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From: Kamal Mostafa <kamal@canonical.com>
|
||||
To: Linux Kernel <linux-kernel@vger.kernel.org>,
|
||||
intel-gfx@lists.freedesktop.org
|
||||
Cc: Matthew Garrett <mjg@redhat.com>,
|
||||
Keith Packard <keithp@keithp.com>,
|
||||
Kamal Mostafa <kamal@canonical.com>
|
||||
Subject: [PATCH] i915: do not setup intel_backlight twice
|
||||
Date: Mon, 22 Aug 2011 12:39:10 -0700
|
||||
Message-Id: <1314041950-12433-1-git-send-email-kamal@canonical.com>
|
||||
X-Mailer: git-send-email 1.7.4.1
|
||||
In-Reply-To: <20110817141010.GA21479@redhat.com>
|
||||
References: <20110817141010.GA21479@redhat.com>
|
||||
Sender: linux-kernel-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <linux-kernel.vger.kernel.org>
|
||||
X-Mailing-List: linux-kernel@vger.kernel.org
|
||||
|
||||
The commit "Not all systems expose a firmware or platform mechanism for
|
||||
changing the backlight intensity on i915, so add native driver support"
|
||||
adds calls to intel_panel_setup_backlight() from intel_{lvds,dp}_init
|
||||
so do not call it again from intel_setup_outputs().
|
||||
|
||||
BugLink: http://bugs.launchpad.net/bugs/831542
|
||||
|
||||
Signed-off-by: Kamal Mostafa <kamal@canonical.com>
|
||||
---
|
||||
drivers/gpu/drm/i915/intel_display.c | 2 --
|
||||
1 files changed, 0 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
|
||||
index ee1d701..5a1ae9f 100644
|
||||
--- a/drivers/gpu/drm/i915/intel_display.c
|
||||
+++ b/drivers/gpu/drm/i915/intel_display.c
|
||||
@@ -7238,8 +7238,6 @@ static void intel_setup_outputs(struct drm_device *dev)
|
||||
intel_encoder_clones(dev, encoder->clone_mask);
|
||||
}
|
||||
|
||||
- intel_panel_setup_backlight(dev);
|
||||
-
|
||||
/* disable all the possible outputs/crtcs before entering KMS mode */
|
||||
drm_helper_disable_unused_functions(dev);
|
||||
}
|
||||
--
|
||||
1.7.4.1
|
@ -1,35 +0,0 @@
|
||||
From 602d6a279939ec30fc7f3ae9d10e3640854f77b2 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Boyer <jwboyer@redhat.com>
|
||||
Date: Thu, 18 Aug 2011 07:24:25 -0400
|
||||
Subject: [PATCH] Fix perf build against newer glibc
|
||||
|
||||
Upstream glibc commit 295e904 added a definition for __attribute_const__ to
|
||||
cdefs.h. This causes the following error when building perf:
|
||||
|
||||
util/include/linux/compiler.h:8:0: error: "__attribute_const__" redefined [-Werror]
|
||||
/usr/include/sys/cdefs.h:226:0: note: this is the location of the previous definition
|
||||
|
||||
Wrap __attribute_const__ in #ifndef as we do for __always_inline.
|
||||
|
||||
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
||||
---
|
||||
tools/perf/util/include/linux/compiler.h | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/tools/perf/util/include/linux/compiler.h b/tools/perf/util/include/linux/compiler.h
|
||||
index 791f9dd..547628e 100644
|
||||
--- a/tools/perf/util/include/linux/compiler.h
|
||||
+++ b/tools/perf/util/include/linux/compiler.h
|
||||
@@ -5,7 +5,9 @@
|
||||
#define __always_inline inline
|
||||
#endif
|
||||
#define __user
|
||||
+#ifndef __attribute_const__
|
||||
#define __attribute_const__
|
||||
+#endif
|
||||
|
||||
#define __used __attribute__((__unused__))
|
||||
|
||||
--
|
||||
1.7.6
|
||||
|
12
kernel.spec
12
kernel.spec
@ -82,9 +82,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%define rcrev 2
|
||||
%define rcrev 3
|
||||
# The git snapshot level
|
||||
%define gitrev 9
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -717,8 +717,8 @@ Patch12024: epoll-fix-spurious-lockdep-warnings.patch
|
||||
Patch12025: rcu-avoid-just-onlined-cpu-resched.patch
|
||||
Patch12026: block-stray-block-put-after-teardown.patch
|
||||
Patch12027: usb-add-quirk-for-logitech-webcams.patch
|
||||
Patch12028: fix-perf-build.patch
|
||||
Patch12029: crypto-register-cryptd-first.patch
|
||||
Patch12030: fix-intel-duplicate-backlight.patch
|
||||
|
||||
|
||||
# Runtime power management
|
||||
@ -1345,8 +1345,8 @@ ApplyPatch rcu-avoid-just-onlined-cpu-resched.patch
|
||||
ApplyPatch block-stray-block-put-after-teardown.patch
|
||||
ApplyPatch usb-add-quirk-for-logitech-webcams.patch
|
||||
|
||||
ApplyPatch fix-perf-build.patch
|
||||
ApplyPatch crypto-register-cryptd-first.patch
|
||||
ApplyPatch fix-intel-duplicate-backlight.patch
|
||||
|
||||
# Runtime PM
|
||||
#ApplyPatch linux-2.6-usb-pci-autosuspend.patch
|
||||
@ -2072,6 +2072,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Aug 22 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Linux 3.1-rc3
|
||||
- Add patch to fix duplicate backlight registration (rhbz 732202)
|
||||
|
||||
* Mon Aug 22 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Linux 3.1-rc2-git9
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user