Fix autoload of atl1c driver for latest hardware (#607499)
This commit is contained in:
parent
6dc8e998dc
commit
d12d7e80c2
17
atl1c-add-missing-pci-id.patch
Normal file
17
atl1c-add-missing-pci-id.patch
Normal file
@ -0,0 +1,17 @@
|
||||
atl1c: Add missing PCI device ID
|
||||
|
||||
Commit 8f574b35f22fbb9b5e5f1d11ad6b55b6f35f4533 added support for a new
|
||||
adapter but failed to add it to the PCI device table.
|
||||
|
||||
Signed-Off-By: Chuck Ebbert <cebbert@redhat.com>
|
||||
|
||||
--- vanilla-2.6.38-rc3.orig/drivers/net/atl1c/atl1c_main.c
|
||||
+++ vanilla-2.6.38-rc3/drivers/net/atl1c/atl1c_main.c
|
||||
@@ -48,6 +48,7 @@ static DEFINE_PCI_DEVICE_TABLE(atl1c_pci
|
||||
{PCI_DEVICE(PCI_VENDOR_ID_ATTANSIC, PCI_DEVICE_ID_ATHEROS_L2C_B)},
|
||||
{PCI_DEVICE(PCI_VENDOR_ID_ATTANSIC, PCI_DEVICE_ID_ATHEROS_L2C_B2)},
|
||||
{PCI_DEVICE(PCI_VENDOR_ID_ATTANSIC, PCI_DEVICE_ID_ATHEROS_L1D)},
|
||||
+ {PCI_DEVICE(PCI_VENDOR_ID_ATTANSIC, PCI_DEVICE_ID_ATHEROS_L1D_2_0)},
|
||||
/* required last entry */
|
||||
{ 0 }
|
||||
};
|
11
kernel.spec
11
kernel.spec
@ -738,6 +738,9 @@ Patch12432: hfsplus-01-dont-leak-buffer.patch
|
||||
Patch12434: hfsplus-03-zero-vhdr-on-free.patch
|
||||
Patch12436: hfsplus-05-fix-failed-mount.patch
|
||||
|
||||
# rhbz#607499
|
||||
Patch12437: atl1c-add-missing-pci-id.patch
|
||||
|
||||
%endif
|
||||
|
||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||
@ -1359,6 +1362,9 @@ ApplyPatch hfsplus-01-dont-leak-buffer.patch
|
||||
ApplyPatch hfsplus-03-zero-vhdr-on-free.patch
|
||||
ApplyPatch hfsplus-05-fix-failed-mount.patch
|
||||
|
||||
# rhbz#607499
|
||||
ApplyPatch atl1c-add-missing-pci-id.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -1971,7 +1977,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Feb 01 2011 Chuck Ebbert <cebbert@redhat.com> 2.6.38-0.rc3.git0.1
|
||||
* Wed Feb 02 2011 Chuck Ebbert <cebbert@redhat.com>
|
||||
- Fix autoload of atl1c driver for latest hardware (#607499)
|
||||
|
||||
* Tue Feb 01 2011 Chuck Ebbert <cebbert@redhat.com> 2.6.38-0.rc3.git0.1
|
||||
- Linux 2.6.38-rc3
|
||||
- Try to fix some obvious bugs in hfsplus mount failure handling (#673857)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user