Linux v4.1-rc2

- Disable debugging options.
This commit is contained in:
Josh Boyer 2015-05-04 10:12:29 -04:00
parent 147ecfb6e4
commit d0e1dabbc9
59 changed files with 123 additions and 221 deletions

View File

@ -26,5 +26,5 @@ index c68e72414a67..4277938af700 100644
/* parse the table header to get the table length */
if (count <= sizeof(struct acpi_table_header))
--
2.1.0
2.3.6

View File

@ -27,5 +27,5 @@ index 3b7151687776..4b19e7e5bc01 100644
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
--
2.1.0
2.3.6

View File

@ -52,5 +52,5 @@ index aa4ee20ec8bb..958d1d9a5af8 100644
* All runtime access to EFI goes through this structure:
*/
--
2.1.0
2.3.6

View File

@ -174,5 +174,5 @@ index 958d1d9a5af8..3dd6f4a51b9b 100644
* efi_range_is_wc - check the WC bit on an address range
* @start: starting kvirt address
--
2.1.0
2.3.6

View File

@ -181,5 +181,5 @@ index f43cbdd52546..feb6736fec91 100644
{
#ifdef CONFIG_MODULE_SIG
--
2.1.0
2.3.6

View File

@ -59,5 +59,5 @@ index 42a1d2afb217..f43cbdd52546 100644
+}
+EXPORT_SYMBOL(secure_modules);
--
2.1.0
2.3.6

View File

@ -244,5 +244,5 @@ index feb6736fec91..5ea645737f23 100644
static int param_set_bool_enable_only(const char *val,
const struct kernel_param *kp)
--
2.1.0
2.3.6

View File

@ -46,5 +46,5 @@ index 630af73e98c4..c69b308beb3f 100644
/* Don't use active slot count to generate BTN_TOOL events. */
--
2.1.0
2.3.6

View File

@ -107,5 +107,5 @@ index 875f64e8935b..c15e93f5a418 100644
}
--
2.1.0
2.3.6

View File

@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 7ff1239f9cd2..eaffb6f8ed36 100644
index 2da553fd7fc3..32f118807d2a 100644
--- a/Makefile
+++ b/Makefile
@@ -704,7 +704,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
@ -88,5 +88,5 @@ index 17670573dda8..d23b7c975eb5 100644
config GDB_SCRIPTS
bool "Provide GDB scripts for kernel debugging"
--
2.1.0
2.3.6

View File

@ -181,5 +181,5 @@ index 000000000000..94b0eb38a284
+}
+late_initcall(load_uefi_certs);
--
2.1.0
2.3.6

View File

@ -79,5 +79,5 @@ index 94b0eb38a284..ae28b974d49a 100644
mok = get_cert_list(L"MokListRT", &mok_var, &moksize);
--
2.1.0
2.3.6

View File

@ -112,5 +112,5 @@ index b91c4da68365..98f5637304d1 100644
dev = pci_get_bus_and_slot(bus, dfn);
--
2.1.0
2.3.6

View File

@ -37,5 +37,5 @@ index 53fe675f9bd7..b52c88860532 100644
unsigned long to_write = min_t(unsigned long, count,
(unsigned long)high_memory - p);
--
2.1.0
2.3.6

View File

@ -41,5 +41,5 @@ index cc79d3fedfb2..d9bf8ba7d848 100644
/*
--
2.1.0
2.3.6

View File

@ -1,95 +0,0 @@
From: Mike Christie <michaelc@cs.wisc.edu>
Date: Tue, 21 Apr 2015 03:42:24 -0400
Subject: [PATCH] SCSI: add 1024 max sectors black list flag
This works around a issue with qnap iscsi targets not handling large IOs
very well.
The target returns:
VPD INQUIRY: Block limits page (SBC)
Maximum compare and write length: 1 blocks
Optimal transfer length granularity: 1 blocks
Maximum transfer length: 4294967295 blocks
Optimal transfer length: 4294967295 blocks
Maximum prefetch, xdread, xdwrite transfer length: 0 blocks
Maximum unmap LBA count: 8388607
Maximum unmap block descriptor count: 1
Optimal unmap granularity: 16383
Unmap granularity alignment valid: 0
Unmap granularity alignment: 0
Maximum write same length: 0xffffffff blocks
Maximum atomic transfer length: 0
Atomic alignment: 0
Atomic transfer length granularity: 0
and it is *sometimes* able to handle at least one IO of size up to 8 MB. We
have seen in traces where it will sometimes work, but other times it
looks like it fails and it looks like it returns failures if we send
multiple large IOs sometimes. Also it looks like it can return 2 different
errors. It will sometimes send iscsi reject errors indicating out of
resources or it will send invalid cdb illegal requests check conditions.
And then when it sends iscsi rejects it does not seem to handle retries
when there are command sequence holes, so I could not just add code to
try and gracefully handle that error code.
The problem is that we do not have a good contact for the company,
so we are not able to determine under what conditions it returns
which error and why it sometimes works.
So, this patch just adds a new black list flag to set targets like this to
the old max safe sectors of 1024. The max_hw_sectors changes added in 3.19
caused this regression, so I also ccing stable.
Reported-by: Christian Hesse <list@eworm.de>
Signed-off-by: Mike Christie <michaelc@cs.wisc.edu>
Cc: stable@vger.kernel.org
---
drivers/scsi/scsi_devinfo.c | 1 +
drivers/scsi/scsi_scan.c | 6 ++++++
include/scsi/scsi_devinfo.h | 1 +
3 files changed, 8 insertions(+)
diff --git a/drivers/scsi/scsi_devinfo.c b/drivers/scsi/scsi_devinfo.c
index 262ab837a704..9f77d23239a2 100644
--- a/drivers/scsi/scsi_devinfo.c
+++ b/drivers/scsi/scsi_devinfo.c
@@ -226,6 +226,7 @@ static struct {
{"PIONEER", "CD-ROM DRM-624X", NULL, BLIST_FORCELUN | BLIST_SINGLELUN},
{"Promise", "VTrak E610f", NULL, BLIST_SPARSELUN | BLIST_NO_RSOC},
{"Promise", "", NULL, BLIST_SPARSELUN},
+ {"QNAP", "iSCSI Storage", NULL, BLIST_MAX_1024},
{"QUANTUM", "XP34301", "1071", BLIST_NOTQ},
{"REGAL", "CDC-4X", NULL, BLIST_MAX5LUN | BLIST_SINGLELUN},
{"SanDisk", "ImageMate CF-SD1", NULL, BLIST_FORCELUN},
diff --git a/drivers/scsi/scsi_scan.c b/drivers/scsi/scsi_scan.c
index 60aae01caa89..6efab1c455e1 100644
--- a/drivers/scsi/scsi_scan.c
+++ b/drivers/scsi/scsi_scan.c
@@ -897,6 +897,12 @@ static int scsi_add_lun(struct scsi_device *sdev, unsigned char *inq_result,
*/
if (*bflags & BLIST_MAX_512)
blk_queue_max_hw_sectors(sdev->request_queue, 512);
+ /*
+ * Max 1024 sector transfer length for targets that report incorrect
+ * max/optimal lengths and relied on the old block layer safe default
+ */
+ else if (*bflags & BLIST_MAX_1024)
+ blk_queue_max_hw_sectors(sdev->request_queue, 1024);
/*
* Some devices may not want to have a start command automatically
diff --git a/include/scsi/scsi_devinfo.h b/include/scsi/scsi_devinfo.h
index 183eaab7c380..96e3f56519e7 100644
--- a/include/scsi/scsi_devinfo.h
+++ b/include/scsi/scsi_devinfo.h
@@ -36,5 +36,6 @@
for sequential scan */
#define BLIST_TRY_VPD_PAGES 0x10000000 /* Attempt to read VPD pages */
#define BLIST_NO_RSOC 0x20000000 /* don't try to issue RSOC */
+#define BLIST_MAX_1024 0x40000000 /* maximum 1024 sector cdb length */
#endif
--
2.1.0

View File

@ -34,5 +34,5 @@ index 39748bb3a543..72edfeedb326 100644
#endif
--
2.1.0
2.3.6

View File

@ -10410,5 +10410,5 @@ index 000000000000..04c00d236c49
+
+#endif
--
2.1.0
2.3.6

View File

@ -1842,5 +1842,5 @@ index 000000000000..c352d5c2989b
+};
+MODULE_DEVICE_TABLE(mdio, amd_xgbe_phy_a0_ids);
--
2.1.0
2.3.6

View File

@ -41,5 +41,5 @@ index 9688dda39e7a..8e3e77f3121f 100644
pinctrl-single,pins = <
0x1b4 (PIN_OUTPUT_PULLDOWN | MUX_MODE3) /* xdma_event_intr1.clkout2 */
--
2.1.0
2.3.6

View File

@ -65,5 +65,5 @@ index c3255e0c90aa..1fd496fe1a68 100644
/include/ "tps65217.dtsi"
--
2.1.0
2.3.6

View File

@ -268,5 +268,5 @@ index 1fd496fe1a68..9688dda39e7a 100644
+ };
};
--
2.1.0
2.3.6

View File

@ -37,5 +37,5 @@ index 0fd89c38cf02..20660917a06f 100644
compatible = "ti,tilcdc,slave";
i2c = <&i2c0>;
--
2.1.0
2.3.6

View File

@ -35,5 +35,5 @@ index 5c42d259fa68..0fd89c38cf02 100644
};
--
2.1.0
2.3.6

View File

@ -56,5 +56,5 @@ index 231fba0d03e5..0de5a6ddd5eb 100644
.init_machine = highbank_init,
.dt_compat = highbank_match,
--
2.1.0
2.3.6

View File

@ -61,5 +61,5 @@ index 99b46f8030ad..8b6ddd16dcc5 100644
+ status = "okay";
+};
--
2.1.0
2.3.6

View File

@ -41,5 +41,5 @@ index 74753132c3ac..3cc99d7c2361 100644
+}
+early_initcall(arm64_console_setup);
--
2.1.0
2.3.6

View File

@ -49,5 +49,5 @@ index 7543a56e0f45..93b5a6998371 100644
1, asus->debug.method_id,
&input, &output);
--
2.1.0
2.3.6

View File

@ -37,5 +37,5 @@ index bba85d1a6cd1..ebbee8f17130 100644
"DMA failed to stop in %d ms AR_CR=0x%08x AR_DIAG_SW=0x%08x DMADBG_7=0x%08x\n",
AH_RX_STOP_DMA_TIMEOUT / 1000,
--
2.1.0
2.3.6

View File

@ -1723,13 +1723,13 @@ CONFIG_B43_PCMCIA=y
CONFIG_B43_SDIO=y
CONFIG_B43_BCMA=y
CONFIG_B43_BCMA_PIO=y
CONFIG_B43_DEBUG=y
# CONFIG_B43_DEBUG is not set
CONFIG_B43_PHY_LP=y
CONFIG_B43_PHY_N=y
CONFIG_B43_PHY_HT=y
CONFIG_B43_PHY_G=y
CONFIG_B43LEGACY=m
CONFIG_B43LEGACY_DEBUG=y
# CONFIG_B43LEGACY_DEBUG is not set
CONFIG_B43LEGACY_DMA=y
CONFIG_B43LEGACY_PIO=y
CONFIG_B43LEGACY_DMA_AND_PIO_MODE=y
@ -4177,7 +4177,7 @@ CONFIG_EXT4_FS=y
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXT4_FS_POSIX_ACL=y
CONFIG_EXT4_FS_SECURITY=y
# CONFIG_EXT4_FS_ENCRYPTION is not set
# CONFIG_EXT4_ENCRYPTION is not set
CONFIG_JBD2=y
CONFIG_FS_MBCACHE=y
CONFIG_REISERFS_FS=m
@ -4820,7 +4820,7 @@ CONFIG_PM_DEBUG=y
# CONFIG_DPM_WATCHDOG is not set # revisit this in debug
CONFIG_PM_TRACE=y
CONFIG_PM_TRACE_RTC=y
CONFIG_PM_TEST_SUSPEND=y
# CONFIG_PM_TEST_SUSPEND is not set
# CONFIG_PM_OPP is not set
# CONFIG_PM_AUTOSLEEP is not set
# CONFIG_PM_WAKELOCKS is not set

View File

@ -2,100 +2,100 @@ CONFIG_SND_VERBOSE_PRINTK=y
CONFIG_SND_DEBUG=y
CONFIG_SND_PCM_XRUN_DEBUG=y
CONFIG_DEBUG_ATOMIC_SLEEP=y
# CONFIG_DEBUG_ATOMIC_SLEEP is not set
CONFIG_DEBUG_MUTEXES=y
CONFIG_DEBUG_RT_MUTEXES=y
CONFIG_DEBUG_LOCK_ALLOC=y
CONFIG_LOCK_TORTURE_TEST=m
CONFIG_PROVE_LOCKING=y
CONFIG_DEBUG_SPINLOCK=y
CONFIG_PROVE_RCU=y
# CONFIG_DEBUG_MUTEXES is not set
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_DEBUG_LOCK_ALLOC is not set
# CONFIG_LOCK_TORTURE_TEST is not set
# CONFIG_PROVE_LOCKING is not set
# CONFIG_DEBUG_SPINLOCK is not set
# CONFIG_PROVE_RCU is not set
# CONFIG_PROVE_RCU_REPEATEDLY is not set
CONFIG_DEBUG_PER_CPU_MAPS=y
# CONFIG_DEBUG_PER_CPU_MAPS is not set
CONFIG_CPUMASK_OFFSTACK=y
CONFIG_CPU_NOTIFIER_ERROR_INJECT=m
# CONFIG_CPU_NOTIFIER_ERROR_INJECT is not set
CONFIG_FAULT_INJECTION=y
CONFIG_FAILSLAB=y
CONFIG_FAIL_PAGE_ALLOC=y
CONFIG_FAIL_MAKE_REQUEST=y
CONFIG_FAULT_INJECTION_DEBUG_FS=y
CONFIG_FAULT_INJECTION_STACKTRACE_FILTER=y
CONFIG_FAIL_IO_TIMEOUT=y
CONFIG_FAIL_MMC_REQUEST=y
# CONFIG_FAULT_INJECTION is not set
# CONFIG_FAILSLAB is not set
# CONFIG_FAIL_PAGE_ALLOC is not set
# CONFIG_FAIL_MAKE_REQUEST is not set
# CONFIG_FAULT_INJECTION_DEBUG_FS is not set
# CONFIG_FAULT_INJECTION_STACKTRACE_FILTER is not set
# CONFIG_FAIL_IO_TIMEOUT is not set
# CONFIG_FAIL_MMC_REQUEST is not set
CONFIG_LOCK_STAT=y
# CONFIG_LOCK_STAT is not set
CONFIG_DEBUG_STACK_USAGE=y
# CONFIG_DEBUG_STACK_USAGE is not set
CONFIG_ACPI_DEBUG=y
# CONFIG_ACPI_DEBUG is not set
CONFIG_DEBUG_SG=y
CONFIG_DEBUG_PI_LIST=y
# CONFIG_DEBUG_SG is not set
# CONFIG_DEBUG_PI_LIST is not set
# CONFIG_PAGE_EXTENSION is not set
# CONFIG_PAGE_OWNER is not set
# CONFIG_DEBUG_PAGEALLOC is not set
CONFIG_DEBUG_OBJECTS=y
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
CONFIG_DEBUG_OBJECTS_FREE=y
CONFIG_DEBUG_OBJECTS_TIMERS=y
CONFIG_DEBUG_OBJECTS_RCU_HEAD=y
# CONFIG_DEBUG_OBJECTS_FREE is not set
# CONFIG_DEBUG_OBJECTS_TIMERS is not set
# CONFIG_DEBUG_OBJECTS_RCU_HEAD is not set
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
CONFIG_X86_PTDUMP=y
CONFIG_ARM64_PTDUMP=y
CONFIG_EFI_PGT_DUMP=y
# CONFIG_ARM64_PTDUMP is not set
# CONFIG_EFI_PGT_DUMP is not set
CONFIG_CAN_DEBUG_DEVICES=y
# CONFIG_CAN_DEBUG_DEVICES is not set
CONFIG_MODULE_FORCE_UNLOAD=y
# CONFIG_MODULE_FORCE_UNLOAD is not set
CONFIG_DEBUG_NOTIFIERS=y
# CONFIG_DEBUG_NOTIFIERS is not set
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMA_API_DEBUG is not set
CONFIG_MMIOTRACE=y
# CONFIG_MMIOTRACE is not set
CONFIG_DEBUG_CREDENTIALS=y
# CONFIG_DEBUG_CREDENTIALS is not set
# off in both production debug and nodebug builds,
# on in rawhide nodebug builds
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
CONFIG_EXT4_DEBUG=y
# CONFIG_EXT4_DEBUG is not set
# CONFIG_XFS_WARN is not set
CONFIG_DEBUG_PERF_USE_VMALLOC=y
# CONFIG_DEBUG_PERF_USE_VMALLOC is not set
CONFIG_JBD2_DEBUG=y
# CONFIG_JBD2_DEBUG is not set
CONFIG_NFSD_FAULT_INJECTION=y
# CONFIG_NFSD_FAULT_INJECTION is not set
CONFIG_DEBUG_BLK_CGROUP=y
# CONFIG_DEBUG_BLK_CGROUP is not set
CONFIG_DRBD_FAULT_INJECTION=y
# CONFIG_DRBD_FAULT_INJECTION is not set
CONFIG_ATH_DEBUG=y
CONFIG_CARL9170_DEBUGFS=y
CONFIG_IWLWIFI_DEVICE_TRACING=y
# CONFIG_ATH_DEBUG is not set
# CONFIG_CARL9170_DEBUGFS is not set
# CONFIG_IWLWIFI_DEVICE_TRACING is not set
# CONFIG_RTLWIFI_DEBUG is not set
CONFIG_DEBUG_OBJECTS_WORK=y
# CONFIG_DEBUG_OBJECTS_WORK is not set
CONFIG_DMADEVICES_DEBUG=y
CONFIG_DMADEVICES_VDEBUG=y
# CONFIG_DMADEVICES_DEBUG is not set
# CONFIG_DMADEVICES_VDEBUG is not set
CONFIG_PM_ADVANCED_DEBUG=y
CONFIG_CEPH_LIB_PRETTYDEBUG=y
CONFIG_QUOTA_DEBUG=y
# CONFIG_CEPH_LIB_PRETTYDEBUG is not set
# CONFIG_QUOTA_DEBUG is not set
CONFIG_KGDB_KDB=y
@ -103,18 +103,18 @@ CONFIG_KDB_DEFAULT_ENABLE=0x0
CONFIG_KDB_KEYBOARD=y
CONFIG_KDB_CONTINUE_CATASTROPHIC=0
CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
# CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER is not set
# CONFIG_PERCPU_TEST is not set
CONFIG_TEST_LIST_SORT=y
# CONFIG_TEST_LIST_SORT is not set
# CONFIG_TEST_STRING_HELPERS is not set
CONFIG_DETECT_HUNG_TASK=y
# CONFIG_DETECT_HUNG_TASK is not set
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK=y
# CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK is not set
CONFIG_DEBUG_KMEMLEAK=y
# CONFIG_DEBUG_KMEMLEAK is not set
CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=1024
# CONFIG_DEBUG_KMEMLEAK_TEST is not set
CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
@ -125,7 +125,7 @@ CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
# CONFIG_SPI_DEBUG is not set
CONFIG_X86_DEBUG_STATIC_CPU_HAS=y
# CONFIG_X86_DEBUG_STATIC_CPU_HAS is not set
# CONFIG_SCHEDSTATS is not set
# CONFIG_LATENCYTOP is not set

View File

@ -345,7 +345,7 @@ CONFIG_SP5100_TCO=m
# CONFIG_MEMTEST is not set
# CONFIG_DEBUG_TLBFLUSH is not set
CONFIG_MAXSMP=y
# CONFIG_MAXSMP is not set
CONFIG_HP_ILO=m

View File

@ -505,5 +505,5 @@ index 000000000000..25ab9869d566
+
+#endif /* __CRASH_H__ */
--
2.1.0
2.3.6

View File

@ -31,5 +31,5 @@ index 1c9c8e500a48..6d00970e220e 100644
default !EXPERT
help
--
2.1.0
2.3.6

View File

@ -28,5 +28,5 @@ index a08cda955285..e320e1e679cf 100644
#else
--
2.1.0
2.3.6

View File

@ -57,5 +57,5 @@ index 4022b75eaad7..1aaf06aa7b0f 100644
if (err)
return err;
--
2.1.0
2.3.6

View File

@ -27,5 +27,5 @@ index d547d9c8dda2..f523ee679987 100644
"[hw state]");
intel_dump_pipe_config(crtc, crtc->config,
--
2.1.0
2.3.6

View File

@ -38,5 +38,5 @@ index af5be0368dec..aa4ee20ec8bb 100644
#ifdef CONFIG_EFI
/*
--
2.1.0
2.3.6

View File

@ -779,5 +779,5 @@ index 9cc069579351..fa3546989ab0 100644
extern int efi_reboot_quirk_mode;
extern bool efi_poweroff_required(void);
--
2.1.0
2.3.6

View File

@ -53,5 +53,5 @@ index 105e7360d747..83fc4e9888ee 100644
}
--
2.1.0
2.3.6

View File

@ -25,5 +25,5 @@ index 6a8f880e213f..d3c21e9d267c 100644
---help---
UEFI Secure Boot provides a mechanism for ensuring that the
--
2.1.0
2.3.6

View File

@ -34,5 +34,5 @@ index 2329daae5255..48a8e82c7e2e 100644
/**
--
2.1.0
2.3.6

View File

@ -29,5 +29,5 @@ index ec876b5b1382..9d5216e23a09 100644
case ATKBD_RET_ERR:
atkbd->err_count++;
--
2.1.0
2.3.6

View File

@ -61,5 +61,5 @@ index 32d710eaf1fc..af4a20b86ee7 100644
cp = can_get_proto(protocol);
}
--
2.1.0
2.3.6

View File

@ -121,5 +121,5 @@ index 86a4fe75f453..161637ed5611 100755
--
2.1.0
2.3.6

View File

@ -65,9 +65,9 @@ Summary: The Linux kernel
# The next upstream release sublevel (base_sublevel+1)
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
# The rc snapshot level
%define rcrev 1
%define rcrev 2
# The git snapshot level
%define gitrev 1
%define gitrev 0
# Set rpm version accordingly
%define rpmversion 4.%{upstream_sublevel}.0
%endif
@ -122,7 +122,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
%define debugbuildsenabled 0
%define debugbuildsenabled 1
# Want to build a vanilla kernel build without any non-upstream patches?
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
@ -612,9 +612,6 @@ Patch26175: xen-pciback-Don-t-disable-PCI_COMMAND-on-PCI-device-.patch
#rhbz 1212230
Patch26176: Input-synaptics-pin-3-touches-when-the-firmware-repo.patch
#rhbz 1208999
Patch26177: SCSI-add-1024-max-sectors-black-list-flag.patch
#rhbz 1210857
Patch26192: blk-loop-avoid-too-many-pending-per-work-IO.patch
@ -1345,9 +1342,6 @@ ApplyPatch xen-pciback-Don-t-disable-PCI_COMMAND-on-PCI-device-.patch
#rhbz 1212230
ApplyPatch Input-synaptics-pin-3-touches-when-the-firmware-repo.patch
#rhbz 1208999
ApplyPatch SCSI-add-1024-max-sectors-black-list-flag.patch
#rhbz 1210857
ApplyPatch blk-loop-avoid-too-many-pending-per-work-IO.patch
@ -2201,6 +2195,10 @@ fi
#
#
%changelog
* Mon May 04 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc2.git0.1
- Linux v4.1-rc2
- Disable debugging options.
* Sun May 3 2015 Peter Robinson <pbrobinson@fedoraproject.org>
- Enable ACPI on aarch64
- General ARMv7 updates

View File

@ -39,5 +39,5 @@ index 7a36fdcca5bf..22d30d7a12b8 100644
* This leaves us room for future extensions.
*/
--
2.1.0
2.3.6

View File

@ -33,5 +33,5 @@ index 601965a948e8..028213cf0e4d 100644
Use dynamic allocation for cpumask_var_t, instead of putting
them on the stack. This is a bit more expensive, but avoids
--
2.1.0
2.3.6

View File

@ -74,5 +74,5 @@ index 4739689d23ad..d713074200f3 100644
return err;
--
2.1.0
2.3.6

View File

@ -21,5 +21,5 @@ index 72b1fc3ab910..86907eaa4883 100644
static int pcspkr_event(struct input_dev *dev, unsigned int type, unsigned int code, int value)
{
--
2.1.0
2.3.6

View File

@ -33,5 +33,5 @@ index 13b45f297727..f84ce0135c38 100644
MODULE_AUTHOR("Tony Lindgren <tony@atomide.com>");
MODULE_DESCRIPTION("One-register-per-pin type device tree based pinctrl driver");
--
2.1.0
2.3.6

View File

@ -33,5 +33,5 @@ index 79beebf53302..eca0b7e0944f 100644
* If the device is offline, don't try and read capacity or any
* of the other niceties.
--
2.1.0
2.3.6

View File

@ -51,5 +51,5 @@ index b97210671a81..2d12ad82fe75 100644
#ifdef MODULE
--
2.1.0
2.3.6

View File

@ -1,4 +1,3 @@
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
7178b5adbaac914f1aa81757295f32c0 patch-4.1-rc1.xz
826da18f0d008ed07d49a93ba90154e3 patch-4.1-rc1-git1.xz
1af1ca2f20db7ebc2a94a786fb6f8e86 patch-4.1-rc2.xz

View File

@ -39,5 +39,5 @@ index 783e819139a7..4f93ef6942d8 100644
hcd = usb_create_hcd(driver, &pdev->dev, dev_name(&pdev->dev));
if (!hcd)
--
2.1.0
2.3.6

View File

@ -74,5 +74,5 @@ index 2316f50b07a4..da39c565a03e 100644
if (watchdog_enabled)
--
2.1.0
2.3.6

View File

@ -66,5 +66,5 @@ index 6b1721f978c2..53fe675f9bd7 100644
return -EFAULT;
while (count-- > 0 && i < 65536) {
--
2.1.0
2.3.6

View File

@ -38,5 +38,5 @@ index 113e70784854..26c2f83fc470 100644
err = -EFAULT;
break;
--
2.1.0
2.3.6

View File

@ -47,5 +47,5 @@ index c4a0666de6f5..26e651336787 100644
} else {
pci_read_config_word(dev, PCI_COMMAND, &cmd);
--
2.1.0
2.3.6