kernel-6.4.14-200
* Sat Sep 02 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.4.14-0] - Add bug fixed by 6.4.14 (Justin M. Forbes) - erofs: ensure that the post-EOF tails are all zeroed (Gao Xiang) - Linux v6.4.14 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
ba5ce7a448
commit
cf410ae425
@ -1,3 +1,6 @@
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/96a82a41ac7aafd328375d3391873f0c3b2cb7e8
|
||||
96a82a41ac7aafd328375d3391873f0c3b2cb7e8 erofs: ensure that the post-EOF tails are all zeroed
|
||||
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/3646d21c389ec7834fc09907787bf597342b7678
|
||||
3646d21c389ec7834fc09907787bf597342b7678 ASoC: SOF: intel: hda: Clean up link DMA for IPC3 during stop
|
||||
|
||||
|
13
kernel.spec
13
kernel.spec
@ -171,18 +171,18 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specrpmversion 6.4.13
|
||||
%define specversion 6.4.13
|
||||
%define specrpmversion 6.4.14
|
||||
%define specversion 6.4.14
|
||||
%define patchversion 6.4
|
||||
%define pkgrelease 200
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.4.13
|
||||
%define tarfile_release 6.4.14
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 4
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 200%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.4.13
|
||||
%define kabiversion 6.4.14
|
||||
|
||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||
# fatal kernel package build error
|
||||
@ -3817,6 +3817,11 @@ fi\
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Sat Sep 02 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.4.14-0]
|
||||
- Add bug fixed by 6.4.14 (Justin M. Forbes)
|
||||
- erofs: ensure that the post-EOF tails are all zeroed (Gao Xiang)
|
||||
- Linux v6.4.14
|
||||
|
||||
* Wed Aug 30 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.4.13-0]
|
||||
- Add CVE-2023-4563 bugs to BugsFixed (Justin M. Forbes)
|
||||
- Linux v6.4.13
|
||||
|
@ -22,6 +22,7 @@
|
||||
drivers/iommu/iommu.c | 22 ++++
|
||||
drivers/pci/quirks.c | 24 ++++
|
||||
drivers/usb/core/hub.c | 7 ++
|
||||
fs/erofs/zdata.c | 2 +
|
||||
include/linux/efi.h | 22 ++--
|
||||
include/linux/lsm_hook_defs.h | 2 +
|
||||
include/linux/module.h | 1 +
|
||||
@ -37,10 +38,10 @@
|
||||
security/lockdown/Kconfig | 13 +++
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 12 ++
|
||||
39 files changed, 518 insertions(+), 191 deletions(-)
|
||||
40 files changed, 520 insertions(+), 191 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 900e515b87cf..5da008e699ef 100644
|
||||
index 97611fe99c8f..d10c062e632d 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -1104,6 +1105,19 @@ index 97a0f8faea6e..d837548d2024 100644
|
||||
/* Lock the device, then check to see if we were
|
||||
* disconnected while waiting for the lock to succeed. */
|
||||
usb_lock_device(hdev);
|
||||
diff --git a/fs/erofs/zdata.c b/fs/erofs/zdata.c
|
||||
index 470988bb7867..9a7c8bb0590f 100644
|
||||
--- a/fs/erofs/zdata.c
|
||||
+++ b/fs/erofs/zdata.c
|
||||
@@ -993,6 +993,8 @@ static int z_erofs_do_read_page(struct z_erofs_decompress_frontend *fe,
|
||||
cur = end - min_t(erofs_off_t, offset + end - map->m_la, end);
|
||||
if (!(map->m_flags & EROFS_MAP_MAPPED)) {
|
||||
zero_user_segment(page, cur, end);
|
||||
+ ++spiltted;
|
||||
+ tight = false;
|
||||
goto next_part;
|
||||
}
|
||||
if (map->m_flags & EROFS_MAP_FRAGMENT) {
|
||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||
index 571d1a6e1b74..8f786e38de3f 100644
|
||||
--- a/include/linux/efi.h
|
||||
@ -1250,7 +1264,7 @@ index 8103ffd217e9..00bc9fa0828b 100644
|
||||
uprobe_dup_mmap(oldmm, mm);
|
||||
/*
|
||||
diff --git a/kernel/module/main.c b/kernel/module/main.c
|
||||
index 4e2cf784cf8c..66782bc8bc65 100644
|
||||
index f1facc898a64..e1b9c2f1a3bd 100644
|
||||
--- a/kernel/module/main.c
|
||||
+++ b/kernel/module/main.c
|
||||
@@ -528,6 +528,7 @@ static struct module_attribute modinfo_##field = { \
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.4.13.tar.xz) = c2aeaddc3c0fb56753e30349b28874b130e206057456d062623febfa29772645f8b5fa3cc794d211d2868a88b6f2a443e27f63b2157572db38c3084df6bc9f06
|
||||
SHA512 (kernel-abi-stablelists-6.4.13.tar.bz2) = 7fa2101a6fcea4c88851b3573a32aae14a7ae571e4abb51f3f138d6c9a937a52174f5723cf4bd13c89ebbe441bae499181bf6cda9acd5ad9cbfee0bbadb77160
|
||||
SHA512 (kernel-kabi-dw-6.4.13.tar.bz2) = dfc7ccf8a507f96c122f0f389a02106db17630ba436c8b466146816c190a8143cd551b6a4d17ab5e3dc55c39a5a6403d37f5bfc1c928780d648b69c333bcb91c
|
||||
SHA512 (linux-6.4.14.tar.xz) = 3b10213aee9dc21740e4ad935b8eaaf950419fa5666a4b41afdecaf1e3edd96a278f069d0378f63a4caec85750d33b77eb7f47296f498a496600c38e6a432c0c
|
||||
SHA512 (kernel-abi-stablelists-6.4.14.tar.bz2) = f2f7ea14ae40df25e997c33d7f23600021caf7ff9ab6633fded0dbb42772dd67d39de04371248cbe9ad384bcd48acc3544f80573a2826e73e3fd53b37f10efe8
|
||||
SHA512 (kernel-kabi-dw-6.4.14.tar.bz2) = 41bd38fb7555f325409db757ed124ec51e1ebaf3aaf6500f944e242e52bfc026398d0316bdbde523bdb4d525b51d1631fc97038e228152459aee384a5e80a81e
|
||||
|
Loading…
Reference in New Issue
Block a user