remove pointless linux-2.6.29-sparc-IOC_TYPECHECK.patch
This is the same definition as the one in asm-generic
This commit is contained in:
parent
d9244d0441
commit
ce55283388
3
TODO
3
TODO
@ -23,9 +23,6 @@
|
|||||||
Rolandware that is used by the debuginfo generation.
|
Rolandware that is used by the debuginfo generation.
|
||||||
Possibly upstreamable ?
|
Possibly upstreamable ?
|
||||||
|
|
||||||
* linux-2.6.29-sparc-IOC_TYPECHECK.patch
|
|
||||||
Responsible: Spot/Dennis.
|
|
||||||
|
|
||||||
* linux-2.6-v4l-dvb-uvcvideo-update.patch
|
* linux-2.6-v4l-dvb-uvcvideo-update.patch
|
||||||
Responsible: Hans.
|
Responsible: Hans.
|
||||||
|
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -645,8 +645,6 @@ Patch09: linux-2.6-upstream-reverts.patch
|
|||||||
|
|
||||||
# Standalone patches
|
# Standalone patches
|
||||||
|
|
||||||
Patch150: linux-2.6.29-sparc-IOC_TYPECHECK.patch
|
|
||||||
|
|
||||||
Patch160: linux-2.6-32bit-mmap-exec-randomization.patch
|
Patch160: linux-2.6-32bit-mmap-exec-randomization.patch
|
||||||
Patch161: linux-2.6-i386-nx-emulation.patch
|
Patch161: linux-2.6-i386-nx-emulation.patch
|
||||||
|
|
||||||
@ -1207,15 +1205,6 @@ ApplyOptionalPatch linux-2.6-upstream-reverts.patch -R
|
|||||||
# Intel IOMMU
|
# Intel IOMMU
|
||||||
#
|
#
|
||||||
|
|
||||||
#
|
|
||||||
# PowerPC
|
|
||||||
#
|
|
||||||
|
|
||||||
#
|
|
||||||
# SPARC64
|
|
||||||
#
|
|
||||||
ApplyPatch linux-2.6.29-sparc-IOC_TYPECHECK.patch
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# ARM
|
# ARM
|
||||||
#
|
#
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
diff -up vanilla-2.6.29-rc7-git2/arch/sparc/include/asm/ioctl.h.BAD vanilla-2.6.29-rc7-git2/arch/sparc/include/asm/ioctl.h
|
|
||||||
--- vanilla-2.6.29-rc7-git2/arch/sparc/include/asm/ioctl.h.BAD 2009-03-09 17:01:32.000000000 -0400
|
|
||||||
+++ vanilla-2.6.29-rc7-git2/arch/sparc/include/asm/ioctl.h 2009-03-09 16:52:27.000000000 -0400
|
|
||||||
@@ -41,6 +41,17 @@
|
|
||||||
((nr) << _IOC_NRSHIFT) | \
|
|
||||||
((size) << _IOC_SIZESHIFT))
|
|
||||||
|
|
||||||
+#ifdef __KERNEL__
|
|
||||||
+/* provoke compile error for invalid uses of size argument */
|
|
||||||
+extern unsigned int __invalid_size_argument_for_IOC;
|
|
||||||
+#define _IOC_TYPECHECK(t) \
|
|
||||||
+ ((sizeof(t) == sizeof(t[1]) && \
|
|
||||||
+ sizeof(t) < (1 << _IOC_SIZEBITS)) ? \
|
|
||||||
+ sizeof(t) : __invalid_size_argument_for_IOC)
|
|
||||||
+#else
|
|
||||||
+#define _IOC_TYPECHECK(t) (sizeof(t))
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
#define _IO(type,nr) _IOC(_IOC_NONE,(type),(nr),0)
|
|
||||||
#define _IOR(type,nr,size) _IOC(_IOC_READ,(type),(nr),sizeof(size))
|
|
||||||
#define _IOW(type,nr,size) _IOC(_IOC_WRITE,(type),(nr),sizeof(size))
|
|
Loading…
Reference in New Issue
Block a user