kernel-6.9.0-0.rc4.20240416git96fca68c4fbf7.38
* Tue Apr 16 2024 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.9.0-0.rc4.96fca68c4fbf.38] - Linux v6.9.0-0.rc4.96fca68c4fbf Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
9fb38402ef
commit
cacde1e103
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 37
|
||||
RHEL_RELEASE = 38
|
||||
|
||||
#
|
||||
# RHEL_REBASE_NUM
|
||||
|
@ -1,3 +1,6 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/2a740e17e8b448f7189bc35eba53784ffd1344e4
|
||||
2a740e17e8b448f7189bc35eba53784ffd1344e4 [redhat] rh_messages.h: initial driver and device lists
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/e178d550963b1ae5f80cf21e7ebb0ea4a8371ec5
|
||||
e178d550963b1ae5f80cf21e7ebb0ea4a8371ec5 arch/x86: Fix XSAVE check for x86_64-v2 check
|
||||
|
||||
|
@ -1,3 +1,7 @@
|
||||
* Tue Apr 16 2024 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.9.0-0.rc4.96fca68c4fbf.38]
|
||||
- Linux v6.9.0-0.rc4.96fca68c4fbf
|
||||
Resolves:
|
||||
|
||||
* Mon Apr 15 2024 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.9.0-0.rc4.37]
|
||||
- Linux v6.9.0-0.rc4
|
||||
Resolves:
|
||||
|
12
kernel.spec
12
kernel.spec
@ -163,13 +163,13 @@ Summary: The Linux kernel
|
||||
%define specrpmversion 6.9.0
|
||||
%define specversion 6.9.0
|
||||
%define patchversion 6.9
|
||||
%define pkgrelease 0.rc4.37
|
||||
%define pkgrelease 0.rc4.20240416git96fca68c4fbf7.38
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.9-rc4
|
||||
%define tarfile_release 6.9-rc4-31-g96fca68c4fbf7
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 9
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc4.37%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc4.20240416git96fca68c4fbf7.38%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.9.0
|
||||
|
||||
@ -3935,6 +3935,12 @@ fi\
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Tue Apr 16 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.9.0-0.rc4.20240416git96fca68c4fbf7.38]
|
||||
- Linux v6.9.0-0.rc4.20240416git96fca68c4fbf7
|
||||
|
||||
* Tue Apr 16 2024 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.9.0-0.rc4.96fca68c4fbf.38]
|
||||
- Linux v6.9.0-0.rc4.96fca68c4fbf
|
||||
|
||||
* Mon Apr 15 2024 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.9.0-0.rc4.37]
|
||||
- Linux v6.9.0-0.rc4
|
||||
|
||||
|
@ -64,14 +64,14 @@
|
||||
kernel/module/signing.c | 9 +-
|
||||
kernel/panic.c | 13 +
|
||||
kernel/rh_messages.c | 414 ++++++++++++++++
|
||||
kernel/rh_messages.h | 109 +++++
|
||||
kernel/rh_messages.h | 319 ++++++++++++
|
||||
scripts/mod/modpost.c | 8 +
|
||||
scripts/tags.sh | 2 +
|
||||
security/integrity/platform_certs/load_uefi.c | 6 +-
|
||||
security/lockdown/Kconfig | 13 +
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 12 +
|
||||
73 files changed, 2147 insertions(+), 207 deletions(-)
|
||||
73 files changed, 2357 insertions(+), 207 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||
index 902ecd92a29fb..23bd65b59904d 100644
|
||||
@ -3646,13 +3646,14 @@ index 0000000000000..bb69e8965748b
|
||||
+}
|
||||
diff --git a/kernel/rh_messages.h b/kernel/rh_messages.h
|
||||
new file mode 100644
|
||||
index 0000000000000..616692b1ac114
|
||||
index 0000000000000..053aeb047617b
|
||||
--- /dev/null
|
||||
+++ b/kernel/rh_messages.h
|
||||
@@ -0,0 +1,109 @@
|
||||
@@ -0,0 +1,319 @@
|
||||
+/*
|
||||
+ * WARNING: This file is auto-generated by an internal Red Hat script and,
|
||||
+ * in general, should not be modified by hand.
|
||||
+ * See: https://gitlab.com/redhat/rhel/src/kernel/hardware-removal-support
|
||||
+ */
|
||||
+
|
||||
+/*
|
||||
@ -3697,8 +3698,6 @@ index 0000000000000..616692b1ac114
|
||||
+#define RH_PARTNER_SUPPORTED "Warning: %s is a Partner supported GPL " \
|
||||
+ "module and not supported directly by Red Hat.\n"
|
||||
+
|
||||
+#if RHEL_MAJOR == 9
|
||||
+
|
||||
+static const char *rh_deprecated_drivers[] = {
|
||||
+ 0 /* Terminating entry */
|
||||
+};
|
||||
@ -3708,10 +3707,60 @@ index 0000000000000..616692b1ac114
|
||||
+};
|
||||
+
|
||||
+static const char *rh_unmaintained_drivers[] = {
|
||||
+ "aacraid",
|
||||
+ "af_key",
|
||||
+ "arp_tables",
|
||||
+ "bnx2",
|
||||
+ "dl2k",
|
||||
+ "e1000",
|
||||
+ "ebtables",
|
||||
+ "hdlc_fr",
|
||||
+ "hpsa",
|
||||
+ "ip6_tables",
|
||||
+ "ip_set",
|
||||
+ "ip_tables",
|
||||
+ "mptbase",
|
||||
+ "mptsas",
|
||||
+ "mptscsih",
|
||||
+ "mptspi",
|
||||
+ "myri10ge",
|
||||
+ "netxen_nic",
|
||||
+ "nft_compat",
|
||||
+ "nicpf",
|
||||
+ "nicvf",
|
||||
+ "nvmet-fc",
|
||||
+ "nvmet-tcp",
|
||||
+ "qla3xxx",
|
||||
+ "team",
|
||||
+ 0 /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+static const char *rh_unmaintained_init_fns[] = {
|
||||
+ "bnx2_pci_driver_init",
|
||||
+ "e1000_init_module",
|
||||
+ "rio_driver_init",
|
||||
+ "hpsa_init",
|
||||
+ "fusion_init",
|
||||
+ "mptsas_init",
|
||||
+ "fusion_init",
|
||||
+ "mptspi_init",
|
||||
+ "myri10ge_init_module",
|
||||
+ "netxen_init_module",
|
||||
+ "ql3xxx_driver_init",
|
||||
+ "hdlc_fr_init",
|
||||
+ "nvmet_fc_init_module",
|
||||
+ "nvmet_tcp_init",
|
||||
+ "team_module_init",
|
||||
+ "ebtables_init",
|
||||
+ "arp_tables_init",
|
||||
+ "ip_tables_init",
|
||||
+ "ip6_tables_init",
|
||||
+ "ip_set_init",
|
||||
+ "nft_compat_module_init",
|
||||
+ "nicvf_init_module",
|
||||
+ "nic_init_module",
|
||||
+ "ipsec_pfkey_init",
|
||||
+ "aac_init",
|
||||
+ 0 /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
@ -3720,44 +3769,205 @@ index 0000000000000..616692b1ac114
|
||||
+};
|
||||
+
|
||||
+static const struct pci_device_id rh_disabled_pci_devices[] = {
|
||||
+ { 0x1011, 0x0046, 0x103c, 0x10c2 },
|
||||
+ { 0x1011, 0x0046, 0x9005, 0x0364 },
|
||||
+ { 0x1011, 0x0046, 0x9005, 0x0365 },
|
||||
+ { 0x1011, 0x0046, 0x9005, 0x1364 },
|
||||
+ { 0x1028, 0x0001, 0x1028, 0x0001 },
|
||||
+ { 0x1028, 0x0002, 0x1028, 0x0002 },
|
||||
+ { 0x1028, 0x0002, 0x1028, 0x00d1 },
|
||||
+ { 0x1028, 0x0002, 0x1028, 0x00d9 },
|
||||
+ { 0x1028, 0x0003, 0x1028, 0x0003 },
|
||||
+ { 0x1028, 0x0004, 0x1028, 0x00d0 },
|
||||
+ { 0x1028, 0x000a, 0x1028, 0x0106 },
|
||||
+ { 0x1028, 0x000a, 0x1028, 0x011b },
|
||||
+ { 0x1028, 0x000a, 0x1028, 0x0121 },
|
||||
+ { 0x9005, 0x0200, 0x9005, 0x0200 },
|
||||
+ { 0x9005, 0x0283, 0x9005, 0x0283 },
|
||||
+ { 0x9005, 0x0284, 0x9005, 0x0284 },
|
||||
+ { 0x9005, 0x0285, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x9005, 0x0285, 0x1014, 0x02F2 },
|
||||
+ { 0x9005, 0x0285, 0x1014, 0x0312 },
|
||||
+ { 0x9005, 0x0285, 0x1028, PCI_ANY_ID },
|
||||
+ { 0x9005, 0x0285, 0x1028, 0x0287 },
|
||||
+ { 0x9005, 0x0285, 0x103C, 0x3227 },
|
||||
+ { 0x9005, 0x0285, 0x17aa, PCI_ANY_ID },
|
||||
+ { 0x9005, 0x0285, 0x17aa, 0x0286 },
|
||||
+ { 0x9005, 0x0285, 0x17aa, 0x0287 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0285 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0286 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0287 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0288 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0289 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x028a },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x028b },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x028e },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x028f },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0290 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0291 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0292 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0293 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0294 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0296 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0297 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0298 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x0299 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x029a },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x02a4 },
|
||||
+ { 0x9005, 0x0285, 0x9005, 0x02a5 },
|
||||
+ { 0x9005, 0x0286, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x9005, 0x0286, 0x1014, 0x9540 },
|
||||
+ { 0x9005, 0x0286, 0x1014, 0x9580 },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x028c },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x028d },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x029b },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x029c },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x029d },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x029e },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x029f },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x02a0 },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x02a1 },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x02a2 },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x02a3 },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x02a6 },
|
||||
+ { 0x9005, 0x0286, 0x9005, 0x0800 },
|
||||
+ { 0x9005, 0x0287, 0x9005, 0x0800 },
|
||||
+ { 0x9005, 0x0288, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x0222, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x0712, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x212, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x702, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x703, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x0700, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x0211, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x0710, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x0221, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0xe220, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0x1ae5, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xe100, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xe131, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xe180, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xe260, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf095, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf098, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0a1, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0a5, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0d1, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0d5, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0e1, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0e5, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0f5, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0f6, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf0f7, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf180, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf700, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf800, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf900, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf980, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfa00, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfb00, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfc00, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfc10, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfc20, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfc50, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfd00, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfd11, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfd12, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfe00, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfe05, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfe11, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfe12, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x0704, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x19a2, 0x0714, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0060, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0078, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x007C, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0411, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0413, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1028, 0x0015, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1002, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x6340, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x634A, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x6354, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x6368, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x6372, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x6732, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x673C, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x6746, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x6750, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x675A, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x6764, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x676E, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1003, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1004, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1005, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1006, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1007, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1008, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1009, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x100a, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x100b, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x100c, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x100d, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x100e, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x100f, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0x1010, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x15B3, 0xA2DC, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0064, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0065, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0070, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0072, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0074, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0076, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0077, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x007E, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x2422, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x2432, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x5422, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x5432, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x8001, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x8021, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x8044, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x8432, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0xF000, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x8022, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x8032, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x8042, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ {0} /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+static const struct pci_device_id rh_unmaintained_pci_devices[] = {
|
||||
+ { 0x10df, 0xe220, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0x0724, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xe200, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf011, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf015, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xf100, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x10df, 0xfc40, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x005b, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0071, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0073, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0079, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x006E, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0080, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0081, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0082, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0083, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0084, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0085, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0086, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1000, 0x0087, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x177d, 0xa01e, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x177d, 0xa034, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x177d, 0x0011, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x2031, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x2532, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1077, 0x8031, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1924, 0x0803, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ { 0x1924, 0x0813, PCI_ANY_ID, PCI_ANY_ID },
|
||||
+ {0} /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+#else /* RHEL-10 */
|
||||
+
|
||||
+static const char *rh_deprecated_drivers[] = {
|
||||
+ 0 /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+static const char *rh_deprecated_init_fns[] = {
|
||||
+ 0 /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+static const char *rh_unmaintained_drivers[] = {
|
||||
+ 0 /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+static const char *rh_unmaintained_init_fns[] = {
|
||||
+ 0 /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+static const struct pci_device_id rh_deprecated_pci_devices[] = {
|
||||
+ {0} /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+static const struct pci_device_id rh_disabled_pci_devices[] = {
|
||||
+ {0} /* Terminating entry */
|
||||
+};
|
||||
+
|
||||
+static const struct pci_device_id rh_unmaintained_pci_devices[] = {
|
||||
+ {0} /* Terminating entry */
|
||||
+};
|
||||
+#endif /* RHEL_MAJOR */
|
||||
+
|
||||
+#endif /* __RH_MESSAGES_H */
|
||||
diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
|
||||
index 2f5b91da5afa9..040cecc777783 100644
|
||||
|
6
sources
6
sources
@ -1,5 +1,5 @@
|
||||
SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 4f917598056dee5e23814621ec96ff2e4a411c8c4ba9d56ecb01b23cb96431825bedbecfcbaac9338efbf5cb21694d85497fa0bf43e7c80d9cd10bc6dd144dbd
|
||||
SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 19308cd976031d05e18ef7f5d093218acdb89446418bab0cd956ff12cf66369915b9e64bb66fa9f20939428a60e81884fec5be3529c6c7461738d6540d3cc5c6
|
||||
SHA512 (linux-6.9-rc4.tar.xz) = eee328913fc3c32e69e10ddecfd81d283f46b403c254a7a31727575188e8d5ae74d2b15d18d97874241a6f995b55ed5b220f6eea0f231b6676e182c096c51f7d
|
||||
SHA512 (kernel-abi-stablelists-6.9.0.tar.xz) = 5144c764ba2d2b3bf272bfb80f237a413fc6b2862654091ca385af31879bbe37a48f9e03a1f92b015c42260f53b132ad3020f005604ecbe1b2cce6c5a569f852
|
||||
SHA512 (kernel-kabi-dw-6.9.0.tar.xz) = ebe8c59c82faf7952ef513b2531f55986c9c6e4722b16bd9914c6e565742c3522c55722394c5c74b63f0c29c83e8082636cfe9f400be25c4220c9325a6308f46
|
||||
SHA512 (linux-6.9-rc4-31-g96fca68c4fbf7.tar.xz) = bac9247b13c2a4faf26dba9794bd197d81b0b321c462a1e9568a0f7c12ffd1b702a33a187c766aff97bf1b32352bec5c21693085286d0486448077fe05f07520
|
||||
SHA512 (kernel-abi-stablelists-6.9.0.tar.xz) = d4dbfad3600a719c47c6bdeb4c01714b2953ecf0cbe5aaebfb5ada3d18658f04b59e60ef31f8e81c3aa1a2bb6b6ca215de4dd12e9331215bdfe9fa0e2032f876
|
||||
SHA512 (kernel-kabi-dw-6.9.0.tar.xz) = 27f3f29950357dcf2361224dc9cb135d52bb5c1b08c908c4318124e954e5ab3380318e88a4684e3f0cb6de63e3184b0c681a58a00111ebdbf26efb1567d8a15c
|
||||
|
Loading…
Reference in New Issue
Block a user