|
|
|
@ -39,7 +39,7 @@
|
|
|
|
|
38 files changed, 762 insertions(+), 192 deletions(-)
|
|
|
|
|
|
|
|
|
|
diff --git a/Kconfig b/Kconfig
|
|
|
|
|
index 745bc773f5670..f57ff40109d71 100644
|
|
|
|
|
index 745bc773f567..f57ff40109d7 100644
|
|
|
|
|
--- a/Kconfig
|
|
|
|
|
+++ b/Kconfig
|
|
|
|
|
@@ -30,3 +30,5 @@ source "lib/Kconfig"
|
|
|
|
@ -50,7 +50,7 @@ index 745bc773f5670..f57ff40109d71 100644
|
|
|
|
|
+source "Kconfig.redhat"
|
|
|
|
|
diff --git a/Kconfig.redhat b/Kconfig.redhat
|
|
|
|
|
new file mode 100644
|
|
|
|
|
index 0000000000000..733a26bd887a2
|
|
|
|
|
index 000000000000..733a26bd887a
|
|
|
|
|
--- /dev/null
|
|
|
|
|
+++ b/Kconfig.redhat
|
|
|
|
|
@@ -0,0 +1,17 @@
|
|
|
|
@ -72,7 +72,7 @@ index 0000000000000..733a26bd887a2
|
|
|
|
|
+
|
|
|
|
|
+endmenu
|
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
|
|
|
index 17dc3e55323e7..205a0114f9351 100644
|
|
|
|
|
index 060e20dba35e..58478aa0cc73 100644
|
|
|
|
|
--- a/Makefile
|
|
|
|
|
+++ b/Makefile
|
|
|
|
|
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
|
|
|
@ -95,7 +95,7 @@ index 17dc3e55323e7..205a0114f9351 100644
|
|
|
|
|
# to get the ordering right.
|
|
|
|
|
#
|
|
|
|
|
diff --git a/arch/s390/include/asm/ipl.h b/arch/s390/include/asm/ipl.h
|
|
|
|
|
index b0d00032479d6..afb9544fb0074 100644
|
|
|
|
|
index b0d00032479d..afb9544fb007 100644
|
|
|
|
|
--- a/arch/s390/include/asm/ipl.h
|
|
|
|
|
+++ b/arch/s390/include/asm/ipl.h
|
|
|
|
|
@@ -139,6 +139,7 @@ int ipl_report_add_component(struct ipl_report *report, struct kexec_buf *kbuf,
|
|
|
|
@ -107,7 +107,7 @@ index b0d00032479d6..afb9544fb0074 100644
|
|
|
|
|
/*
|
|
|
|
|
* DIAG 308 support
|
|
|
|
|
diff --git a/arch/s390/kernel/ipl.c b/arch/s390/kernel/ipl.c
|
|
|
|
|
index 469e8d3fbfbf3..3ce742cd61c3b 100644
|
|
|
|
|
index 469e8d3fbfbf..3ce742cd61c3 100644
|
|
|
|
|
--- a/arch/s390/kernel/ipl.c
|
|
|
|
|
+++ b/arch/s390/kernel/ipl.c
|
|
|
|
|
@@ -2519,3 +2519,8 @@ int ipl_report_free(struct ipl_report *report)
|
|
|
|
@ -120,7 +120,7 @@ index 469e8d3fbfbf3..3ce742cd61c3b 100644
|
|
|
|
|
+ return !!ipl_secure_flag;
|
|
|
|
|
+}
|
|
|
|
|
diff --git a/arch/s390/kernel/setup.c b/arch/s390/kernel/setup.c
|
|
|
|
|
index 7ecd27c62d564..cad68dfba646c 100644
|
|
|
|
|
index 7ecd27c62d56..cad68dfba646 100644
|
|
|
|
|
--- a/arch/s390/kernel/setup.c
|
|
|
|
|
+++ b/arch/s390/kernel/setup.c
|
|
|
|
|
@@ -49,6 +49,7 @@
|
|
|
|
@ -142,7 +142,7 @@ index 7ecd27c62d564..cad68dfba646c 100644
|
|
|
|
|
/* boot_command_line has been already set up in early.c */
|
|
|
|
|
*cmdline_p = boot_command_line;
|
|
|
|
|
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
|
|
|
|
index e125e059e2c45..9cfd28e580e0a 100644
|
|
|
|
|
index e125e059e2c4..9cfd28e580e0 100644
|
|
|
|
|
--- a/arch/x86/kernel/setup.c
|
|
|
|
|
+++ b/arch/x86/kernel/setup.c
|
|
|
|
|
@@ -20,6 +20,7 @@
|
|
|
|
@ -189,7 +189,7 @@ index e125e059e2c45..9cfd28e580e0a 100644
|
|
|
|
|
reserve_initrd();
|
|
|
|
|
|
|
|
|
|
diff --git a/crypto/drbg.c b/crypto/drbg.c
|
|
|
|
|
index 3addce90930c3..730b03de596a3 100644
|
|
|
|
|
index 3addce90930c..730b03de596a 100644
|
|
|
|
|
--- a/crypto/drbg.c
|
|
|
|
|
+++ b/crypto/drbg.c
|
|
|
|
|
@@ -1494,13 +1494,14 @@ static int drbg_generate(struct drbg_state *drbg,
|
|
|
|
@ -244,7 +244,7 @@ index 3addce90930c3..730b03de596a3 100644
|
|
|
|
|
|
|
|
|
|
/*
|
|
|
|
|
diff --git a/crypto/rng.c b/crypto/rng.c
|
|
|
|
|
index 279dffdebf598..d24dd37205cd7 100644
|
|
|
|
|
index 279dffdebf59..d24dd37205cd 100644
|
|
|
|
|
--- a/crypto/rng.c
|
|
|
|
|
+++ b/crypto/rng.c
|
|
|
|
|
@@ -12,10 +12,13 @@
|
|
|
|
@ -463,7 +463,7 @@ index 279dffdebf598..d24dd37205cd7 100644
|
|
|
|
|
MODULE_LICENSE("GPL");
|
|
|
|
|
MODULE_DESCRIPTION("Random Number Generator");
|
|
|
|
|
diff --git a/drivers/acpi/apei/hest.c b/drivers/acpi/apei/hest.c
|
|
|
|
|
index 20d757687e3d9..90a13f20f052b 100644
|
|
|
|
|
index 20d757687e3d..90a13f20f052 100644
|
|
|
|
|
--- a/drivers/acpi/apei/hest.c
|
|
|
|
|
+++ b/drivers/acpi/apei/hest.c
|
|
|
|
|
@@ -142,6 +142,14 @@ static int apei_hest_parse(apei_hest_func_t func, void *data)
|
|
|
|
@ -482,7 +482,7 @@ index 20d757687e3d9..90a13f20f052b 100644
|
|
|
|
|
for (i = 0; i < hest_tab->error_source_count; i++) {
|
|
|
|
|
len = hest_esrc_len(hest_hdr);
|
|
|
|
|
diff --git a/drivers/acpi/irq.c b/drivers/acpi/irq.c
|
|
|
|
|
index 1687483ff319e..390b67f19181a 100644
|
|
|
|
|
index 1687483ff319..390b67f19181 100644
|
|
|
|
|
--- a/drivers/acpi/irq.c
|
|
|
|
|
+++ b/drivers/acpi/irq.c
|
|
|
|
|
@@ -143,6 +143,7 @@ struct acpi_irq_parse_one_ctx {
|
|
|
|
@ -525,7 +525,7 @@ index 1687483ff319e..390b67f19181a 100644
|
|
|
|
|
return ctx.rc;
|
|
|
|
|
}
|
|
|
|
|
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
|
|
|
|
|
index d1464324de951..a3b2f99a2d785 100644
|
|
|
|
|
index d1464324de95..a3b2f99a2d78 100644
|
|
|
|
|
--- a/drivers/acpi/scan.c
|
|
|
|
|
+++ b/drivers/acpi/scan.c
|
|
|
|
|
@@ -1798,6 +1798,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device)
|
|
|
|
@ -545,7 +545,7 @@ index d1464324de951..a3b2f99a2d785 100644
|
|
|
|
|
acpi_dev_get_resources(device, &resource_list,
|
|
|
|
|
acpi_check_serial_bus_slave,
|
|
|
|
|
diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
|
|
|
|
|
index 83431aae74d8b..f2a9c0d644af2 100644
|
|
|
|
|
index 83431aae74d8..f2a9c0d644af 100644
|
|
|
|
|
--- a/drivers/ata/libahci.c
|
|
|
|
|
+++ b/drivers/ata/libahci.c
|
|
|
|
|
@@ -729,6 +729,24 @@ int ahci_stop_engine(struct ata_port *ap)
|
|
|
|
@ -574,7 +574,7 @@ index 83431aae74d8b..f2a9c0d644af2 100644
|
|
|
|
|
tmp = ata_wait_register(ap, port_mmio + PORT_CMD,
|
|
|
|
|
PORT_CMD_LIST_ON, PORT_CMD_LIST_ON, 1, 500);
|
|
|
|
|
diff --git a/drivers/char/ipmi/ipmi_dmi.c b/drivers/char/ipmi/ipmi_dmi.c
|
|
|
|
|
index bbf7029e224be..cf7faa970dd65 100644
|
|
|
|
|
index bbf7029e224b..cf7faa970dd6 100644
|
|
|
|
|
--- a/drivers/char/ipmi/ipmi_dmi.c
|
|
|
|
|
+++ b/drivers/char/ipmi/ipmi_dmi.c
|
|
|
|
|
@@ -215,6 +215,21 @@ static int __init scan_for_dmi_ipmi(void)
|
|
|
|
@ -600,7 +600,7 @@ index bbf7029e224be..cf7faa970dd65 100644
|
|
|
|
|
dmi_decode_ipmi((const struct dmi_header *) dev->device_data);
|
|
|
|
|
|
|
|
|
|
diff --git a/drivers/char/ipmi/ipmi_msghandler.c b/drivers/char/ipmi/ipmi_msghandler.c
|
|
|
|
|
index b0eedc4595b37..a9024c1dd68ab 100644
|
|
|
|
|
index b0eedc4595b3..a9024c1dd68a 100644
|
|
|
|
|
--- a/drivers/char/ipmi/ipmi_msghandler.c
|
|
|
|
|
+++ b/drivers/char/ipmi/ipmi_msghandler.c
|
|
|
|
|
@@ -35,6 +35,7 @@
|
|
|
|
@ -635,7 +635,7 @@ index b0eedc4595b37..a9024c1dd68ab 100644
|
|
|
|
|
rv = ipmi_register_driver();
|
|
|
|
|
mutex_unlock(&ipmi_interfaces_mutex);
|
|
|
|
|
diff --git a/drivers/char/random.c b/drivers/char/random.c
|
|
|
|
|
index 2597cb43f4387..d860f4f6ba2c7 100644
|
|
|
|
|
index 2597cb43f438..d860f4f6ba2c 100644
|
|
|
|
|
--- a/drivers/char/random.c
|
|
|
|
|
+++ b/drivers/char/random.c
|
|
|
|
|
@@ -51,6 +51,7 @@
|
|
|
|
@ -832,7 +832,7 @@ index 2597cb43f4387..d860f4f6ba2c7 100644
|
|
|
|
|
/********************************************************************
|
|
|
|
|
*
|
|
|
|
|
diff --git a/drivers/firmware/efi/Makefile b/drivers/firmware/efi/Makefile
|
|
|
|
|
index a2d0009560d0f..4f3486e6a84b2 100644
|
|
|
|
|
index a2d0009560d0..4f3486e6a84b 100644
|
|
|
|
|
--- a/drivers/firmware/efi/Makefile
|
|
|
|
|
+++ b/drivers/firmware/efi/Makefile
|
|
|
|
|
@@ -25,6 +25,7 @@ subdir-$(CONFIG_EFI_STUB) += libstub
|
|
|
|
@ -844,7 +844,7 @@ index a2d0009560d0f..4f3486e6a84b2 100644
|
|
|
|
|
obj-$(CONFIG_EFI_RCI2_TABLE) += rci2-table.o
|
|
|
|
|
obj-$(CONFIG_EFI_EMBEDDED_FIRMWARE) += embedded-firmware.o
|
|
|
|
|
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
|
|
|
|
|
index fdf07dd6f4591..cfd2b58a34940 100644
|
|
|
|
|
index fdf07dd6f459..cfd2b58a3494 100644
|
|
|
|
|
--- a/drivers/firmware/efi/efi.c
|
|
|
|
|
+++ b/drivers/firmware/efi/efi.c
|
|
|
|
|
@@ -33,6 +33,7 @@
|
|
|
|
@ -990,7 +990,7 @@ index fdf07dd6f4591..cfd2b58a34940 100644
|
|
|
|
|
|
|
|
|
|
diff --git a/drivers/firmware/efi/secureboot.c b/drivers/firmware/efi/secureboot.c
|
|
|
|
|
new file mode 100644
|
|
|
|
|
index 0000000000000..de0a3714a5d44
|
|
|
|
|
index 000000000000..de0a3714a5d4
|
|
|
|
|
--- /dev/null
|
|
|
|
|
+++ b/drivers/firmware/efi/secureboot.c
|
|
|
|
|
@@ -0,0 +1,38 @@
|
|
|
|
@ -1033,7 +1033,7 @@ index 0000000000000..de0a3714a5d44
|
|
|
|
|
+ }
|
|
|
|
|
+}
|
|
|
|
|
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
|
|
|
|
|
index d4af17fdba467..154f0403cbf4c 100644
|
|
|
|
|
index d4af17fdba46..154f0403cbf4 100644
|
|
|
|
|
--- a/drivers/hid/hid-rmi.c
|
|
|
|
|
+++ b/drivers/hid/hid-rmi.c
|
|
|
|
|
@@ -321,21 +321,12 @@ static int rmi_input_event(struct hid_device *hdev, u8 *data, int size)
|
|
|
|
@ -1135,7 +1135,7 @@ index d4af17fdba467..154f0403cbf4c 100644
|
|
|
|
|
data->xport.ops = &hid_rmi_ops;
|
|
|
|
|
|
|
|
|
|
diff --git a/drivers/hwtracing/coresight/coresight-etm4x-core.c b/drivers/hwtracing/coresight/coresight-etm4x-core.c
|
|
|
|
|
index a0bdfabddbc68..cd824ceebd0fe 100644
|
|
|
|
|
index a0bdfabddbc6..cd824ceebd0f 100644
|
|
|
|
|
--- a/drivers/hwtracing/coresight/coresight-etm4x-core.c
|
|
|
|
|
+++ b/drivers/hwtracing/coresight/coresight-etm4x-core.c
|
|
|
|
|
@@ -10,6 +10,7 @@
|
|
|
|
@ -1186,7 +1186,7 @@ index a0bdfabddbc68..cd824ceebd0fe 100644
|
|
|
|
|
platform_driver_unregister(&etm4_platform_driver);
|
|
|
|
|
etm4_pm_clear();
|
|
|
|
|
diff --git a/drivers/input/rmi4/rmi_driver.c b/drivers/input/rmi4/rmi_driver.c
|
|
|
|
|
index ef9ea295f9e03..0103334e8f32c 100644
|
|
|
|
|
index ef9ea295f9e0..0103334e8f32 100644
|
|
|
|
|
--- a/drivers/input/rmi4/rmi_driver.c
|
|
|
|
|
+++ b/drivers/input/rmi4/rmi_driver.c
|
|
|
|
|
@@ -182,34 +182,47 @@ void rmi_set_attn_data(struct rmi_device *rmi_dev, unsigned long irq_status,
|
|
|
|
@ -1378,7 +1378,7 @@ index ef9ea295f9e03..0103334e8f32c 100644
|
|
|
|
|
if (data->f01_container->dev.driver) {
|
|
|
|
|
/* Driver already bound, so enable ATTN now. */
|
|
|
|
|
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
|
|
|
|
|
index 659a77f7bb833..e8dc1fd50e21d 100644
|
|
|
|
|
index 659a77f7bb83..e8dc1fd50e21 100644
|
|
|
|
|
--- a/drivers/iommu/iommu.c
|
|
|
|
|
+++ b/drivers/iommu/iommu.c
|
|
|
|
|
@@ -8,6 +8,7 @@
|
|
|
|
@ -1418,7 +1418,7 @@ index 659a77f7bb833..e8dc1fd50e21d 100644
|
|
|
|
|
* iommu_setup_default_domain - Set the default_domain for the group
|
|
|
|
|
* @group: Group to change
|
|
|
|
|
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
|
|
|
|
|
index eff7f5df08e27..b58145ce7775c 100644
|
|
|
|
|
index eff7f5df08e2..b58145ce7775 100644
|
|
|
|
|
--- a/drivers/pci/quirks.c
|
|
|
|
|
+++ b/drivers/pci/quirks.c
|
|
|
|
|
@@ -4433,6 +4433,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
|
|
|
|
@ -1453,7 +1453,7 @@ index eff7f5df08e27..b58145ce7775c 100644
|
|
|
|
|
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
|
|
|
|
|
* class code. Fix it.
|
|
|
|
|
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
|
|
|
|
|
index a4638ea92571d..aff13cdce0156 100644
|
|
|
|
|
index a4638ea92571..aff13cdce015 100644
|
|
|
|
|
--- a/drivers/scsi/sd.c
|
|
|
|
|
+++ b/drivers/scsi/sd.c
|
|
|
|
|
@@ -120,6 +120,14 @@ static const char *sd_cache_types[] = {
|
|
|
|
@ -1481,7 +1481,7 @@ index a4638ea92571d..aff13cdce0156 100644
|
|
|
|
|
if (err)
|
|
|
|
|
goto err_out_driver;
|
|
|
|
|
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
|
|
|
|
|
index 008053039875a..f948a5c96006b 100644
|
|
|
|
|
index 008053039875..f948a5c96006 100644
|
|
|
|
|
--- a/drivers/usb/core/hub.c
|
|
|
|
|
+++ b/drivers/usb/core/hub.c
|
|
|
|
|
@@ -5845,6 +5845,13 @@ static void hub_event(struct work_struct *work)
|
|
|
|
@ -1499,7 +1499,7 @@ index 008053039875a..f948a5c96006b 100644
|
|
|
|
|
* disconnected while waiting for the lock to succeed. */
|
|
|
|
|
usb_lock_device(hdev);
|
|
|
|
|
diff --git a/include/linux/crypto.h b/include/linux/crypto.h
|
|
|
|
|
index b164da5e129e8..59021b8609a70 100644
|
|
|
|
|
index b164da5e129e..59021b8609a7 100644
|
|
|
|
|
--- a/include/linux/crypto.h
|
|
|
|
|
+++ b/include/linux/crypto.h
|
|
|
|
|
@@ -133,6 +133,7 @@
|
|
|
|
@ -1511,7 +1511,7 @@ index b164da5e129e8..59021b8609a70 100644
|
|
|
|
|
/*
|
|
|
|
|
* Miscellaneous stuff.
|
|
|
|
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
|
|
|
|
index d59b0947fba08..8b1e2e71d4858 100644
|
|
|
|
|
index d59b0947fba0..8b1e2e71d485 100644
|
|
|
|
|
--- a/include/linux/efi.h
|
|
|
|
|
+++ b/include/linux/efi.h
|
|
|
|
|
@@ -45,6 +45,8 @@ struct screen_info;
|
|
|
|
@ -1579,7 +1579,7 @@ index d59b0947fba08..8b1e2e71d4858 100644
|
|
|
|
|
enum efi_secureboot_mode efi_get_secureboot_mode(efi_get_variable_t *get_var)
|
|
|
|
|
{
|
|
|
|
|
diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
|
|
|
|
|
index 7e539f6f8c674..3c3e56566457a 100644
|
|
|
|
|
index 7e539f6f8c67..3c3e56566457 100644
|
|
|
|
|
--- a/include/linux/lsm_hook_defs.h
|
|
|
|
|
+++ b/include/linux/lsm_hook_defs.h
|
|
|
|
|
@@ -436,6 +436,8 @@ LSM_HOOK(int, 0, bpf_token_capable, const struct bpf_token *token, int cap)
|
|
|
|
@ -1592,7 +1592,7 @@ index 7e539f6f8c674..3c3e56566457a 100644
|
|
|
|
|
#ifdef CONFIG_PERF_EVENTS
|
|
|
|
|
LSM_HOOK(int, 0, perf_event_open, struct perf_event_attr *attr, int type)
|
|
|
|
|
diff --git a/include/linux/random.h b/include/linux/random.h
|
|
|
|
|
index b0a940af4fff5..8a52424fd0d50 100644
|
|
|
|
|
index b0a940af4fff..8a52424fd0d5 100644
|
|
|
|
|
--- a/include/linux/random.h
|
|
|
|
|
+++ b/include/linux/random.h
|
|
|
|
|
@@ -9,6 +9,13 @@
|
|
|
|
@ -1620,7 +1620,7 @@ index b0a940af4fff5..8a52424fd0d50 100644
|
|
|
|
|
extern const struct file_operations random_fops, urandom_fops;
|
|
|
|
|
#endif
|
|
|
|
|
diff --git a/include/linux/rmi.h b/include/linux/rmi.h
|
|
|
|
|
index ab7eea01ab427..fff7c5f737fc8 100644
|
|
|
|
|
index ab7eea01ab42..fff7c5f737fc 100644
|
|
|
|
|
--- a/include/linux/rmi.h
|
|
|
|
|
+++ b/include/linux/rmi.h
|
|
|
|
|
@@ -364,6 +364,7 @@ struct rmi_driver_data {
|
|
|
|
@ -1632,7 +1632,7 @@ index ab7eea01ab427..fff7c5f737fc8 100644
|
|
|
|
|
|
|
|
|
|
int rmi_register_transport_device(struct rmi_transport_dev *xport);
|
|
|
|
|
diff --git a/include/linux/security.h b/include/linux/security.h
|
|
|
|
|
index 5122e3ad83b19..b5f0081bc894d 100644
|
|
|
|
|
index 5122e3ad83b1..b5f0081bc894 100644
|
|
|
|
|
--- a/include/linux/security.h
|
|
|
|
|
+++ b/include/linux/security.h
|
|
|
|
|
@@ -507,6 +507,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
|
|
|
|
@ -1655,7 +1655,7 @@ index 5122e3ad83b19..b5f0081bc894d 100644
|
|
|
|
|
u32 *uctx_len, void *val, size_t val_len,
|
|
|
|
|
u64 id, u64 flags)
|
|
|
|
|
diff --git a/kernel/module/signing.c b/kernel/module/signing.c
|
|
|
|
|
index a2ff4242e623d..f0d2be1ee4f1c 100644
|
|
|
|
|
index a2ff4242e623..f0d2be1ee4f1 100644
|
|
|
|
|
--- a/kernel/module/signing.c
|
|
|
|
|
+++ b/kernel/module/signing.c
|
|
|
|
|
@@ -61,10 +61,17 @@ int mod_verify_sig(const void *mod, struct load_info *info)
|
|
|
|
@ -1678,7 +1678,7 @@ index a2ff4242e623d..f0d2be1ee4f1c 100644
|
|
|
|
|
|
|
|
|
|
int module_sig_check(struct load_info *info, int flags)
|
|
|
|
|
diff --git a/scripts/tags.sh b/scripts/tags.sh
|
|
|
|
|
index 191e0461d6d5b..e6f418b3e948b 100755
|
|
|
|
|
index 191e0461d6d5..e6f418b3e948 100755
|
|
|
|
|
--- a/scripts/tags.sh
|
|
|
|
|
+++ b/scripts/tags.sh
|
|
|
|
|
@@ -16,6 +16,8 @@ fi
|
|
|
|
@ -1691,7 +1691,7 @@ index 191e0461d6d5b..e6f418b3e948b 100755
|
|
|
|
|
# ignore arbitrary directories
|
|
|
|
|
if [ -n "${IGNORE_DIRS}" ]; then
|
|
|
|
|
diff --git a/security/integrity/platform_certs/load_uefi.c b/security/integrity/platform_certs/load_uefi.c
|
|
|
|
|
index d1fdd113450a6..182e8090cfe85 100644
|
|
|
|
|
index d1fdd113450a..182e8090cfe8 100644
|
|
|
|
|
--- a/security/integrity/platform_certs/load_uefi.c
|
|
|
|
|
+++ b/security/integrity/platform_certs/load_uefi.c
|
|
|
|
|
@@ -74,7 +74,8 @@ static __init void *get_cert_list(efi_char16_t *name, efi_guid_t *guid,
|
|
|
|
@ -1715,7 +1715,7 @@ index d1fdd113450a6..182e8090cfe85 100644
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
diff --git a/security/lockdown/Kconfig b/security/lockdown/Kconfig
|
|
|
|
|
index e84ddf4840101..d0501353a4b95 100644
|
|
|
|
|
index e84ddf484010..d0501353a4b9 100644
|
|
|
|
|
--- a/security/lockdown/Kconfig
|
|
|
|
|
+++ b/security/lockdown/Kconfig
|
|
|
|
|
@@ -16,6 +16,19 @@ config SECURITY_LOCKDOWN_LSM_EARLY
|
|
|
|
@ -1739,7 +1739,7 @@ index e84ddf4840101..d0501353a4b95 100644
|
|
|
|
|
prompt "Kernel default lockdown mode"
|
|
|
|
|
default LOCK_DOWN_KERNEL_FORCE_NONE
|
|
|
|
|
diff --git a/security/lockdown/lockdown.c b/security/lockdown/lockdown.c
|
|
|
|
|
index cd84d8ea1dfbf..e4c70a0312bc8 100644
|
|
|
|
|
index cd84d8ea1dfb..e4c70a0312bc 100644
|
|
|
|
|
--- a/security/lockdown/lockdown.c
|
|
|
|
|
+++ b/security/lockdown/lockdown.c
|
|
|
|
|
@@ -74,6 +74,7 @@ static int lockdown_is_locked_down(enum lockdown_reason what)
|
|
|
|
@ -1751,7 +1751,7 @@ index cd84d8ea1dfbf..e4c70a0312bc8 100644
|
|
|
|
|
|
|
|
|
|
const struct lsm_id lockdown_lsmid = {
|
|
|
|
|
diff --git a/security/security.c b/security/security.c
|
|
|
|
|
index 4fd3c839353ec..d52cb3bb720dd 100644
|
|
|
|
|
index 4fd3c839353e..d52cb3bb720d 100644
|
|
|
|
|
--- a/security/security.c
|
|
|
|
|
+++ b/security/security.c
|
|
|
|
|
@@ -5569,6 +5569,18 @@ int security_locked_down(enum lockdown_reason what)
|
|
|
|
|