Build fixes for big-endian arches

This commit is contained in:
Justin M. Forbes 2015-01-15 15:48:11 -06:00
parent eb4ef34063
commit c392ecaab5
2 changed files with 37 additions and 1 deletions

View File

@ -655,6 +655,9 @@ Patch26132: x86_64-vdso-Fix-the-vdso-address-randomization-algor.patch
# git clone ssh://git.fedorahosted.org/git/kernel-arm64.git, git diff master...devel
Patch30000: kernel-arm64.patch
# Fix for big-endian arches, already upstream
Patch30001: mpssd-x86-only.patch
# END OF PATCH DEFINITIONS
%endif
@ -1415,6 +1418,9 @@ ApplyPatch acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
#CVE-2014-9585 rhbz 1181054 1181056
ApplyPatch x86_64-vdso-Fix-the-vdso-address-randomization-algor.patch
# Fix for big-endian arches, already upstream
ApplyPatch mpssd-x86-only.patch
%if 0%{?aarch64patches}
ApplyPatch kernel-arm64.patch
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
@ -1954,7 +1960,7 @@ find $RPM_BUILD_ROOT/usr/include \
%if %{with_perf}
# perf tool binary and supporting scripts/binaries
%{perf_make} DESTDIR=$RPM_BUILD_ROOT MULTILIBDIR=%{_lib} install-bin install-traceevent-plugins
%{perf_make} DESTDIR=$RPM_BUILD_ROOT lib=%{_lib} install-bin install-traceevent-plugins
# remove the 'trace' symlink.
rm -f %{buildroot}%{_bindir}/trace
@ -2285,6 +2291,9 @@ fi
# ||----w |
# || ||
%changelog
* Thu Jan 15 2015 Justin M. Forbes <jforbes@fedoraproject.org>
- Build fixes for big-endian arches
* Tue Jan 13 2015 Justin M. Forbes <jforbes@fedoraproject.org> - 3.18.2-200
- Linux v3.18.2

27
mpssd-x86-only.patch Normal file
View File

@ -0,0 +1,27 @@
commit d47fb4ec7e101a63754939fa49d75fd7e81e94f8
Author: Ashutosh Dixit <ashutosh.dixit@intel.com>
Date: Thu Dec 4 13:27:29 2014 -0800
Documentation: Build mic/mpssd only for x86_64
mic/mpssd along with MIC drivers are currently only usable on
x86_64. So build mic/mpssd only for x86_64 to avoid build breaks on
big-endian systems.
Reported-by: Daniel Borkmann <dborkman@redhat.com>
Reported-by: Dan Streetman <ddstreet@gmail.com>
Suggested-by: Peter Foley <pefoley2@pefoley.com>
Signed-off-by: Ashutosh Dixit <ashutosh.dixit@intel.com>
Signed-off-by: Jonathan Corbet <corbet@lwn.net>
diff --git a/Documentation/mic/mpssd/Makefile b/Documentation/mic/mpssd/Makefile
index 0f31568..f47fe6b 100644
--- a/Documentation/mic/mpssd/Makefile
+++ b/Documentation/mic/mpssd/Makefile
@@ -1,5 +1,5 @@
# List of programs to build
-hostprogs-y := mpssd
+hostprogs-$(CONFIG_X86_64) := mpssd
mpssd-objs := mpssd.o sysfs.o