kernel-5.8.0-0.rc0.20200612gitb791d1bdf921.1

* Fri Jun 12 2020 Justin M. Forbes <jforbes@fedoraproject.org> [5.8.0-0.rc0.20200612gitb791d1bdf921.1]
- Fedora config updates ("Justin M. Forbes")
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2020-06-12 10:00:25 -05:00
parent e9f1331084
commit c0b2feb7cc
31 changed files with 112 additions and 49 deletions

View File

@ -124,7 +124,7 @@ index 82d91547d122..b82db0c0caec 100644
+
#endif
diff --git a/kernel/Makefile b/kernel/Makefile
index c332eb9d4841..281e1abbe3b2 100644
index ce8716a04d0e..54c00c4719ab 100644
--- a/kernel/Makefile
+++ b/kernel/Makefile
@@ -12,6 +12,8 @@ obj-y = fork.o exec_domain.o panic.o \

View File

@ -16,7 +16,7 @@ Signed-off-by: Jeremy Cline <jcline@redhat.com>
1 file changed, 1 insertion(+)
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
index 2fba78e84d53..47f5f3c8c7aa 100644
index cb73d398a2fe..2c2b7760c13c 100644
--- a/arch/arm64/Kconfig
+++ b/arch/arm64/Kconfig
@@ -1133,6 +1133,7 @@ config XEN

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index d4d2a5c5d003..24ad272d3197 100644
index 07e96d9ab020..e9d06886f99c 100644
--- a/Makefile
+++ b/Makefile
@@ -510,7 +510,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE

View File

@ -64,7 +64,7 @@ index 0a0081b10edb..cfaaa6a234d4 100644
void mark_hardware_deprecated(const char *msg);
void mark_tech_preview(const char *msg, struct module *mod);
diff --git a/kernel/Makefile b/kernel/Makefile
index 281e1abbe3b2..8da4dd1bafe0 100644
index 54c00c4719ab..d4e404913f2e 100644
--- a/kernel/Makefile
+++ b/kernel/Makefile
@@ -12,7 +12,7 @@ obj-y = fork.o exec_domain.o panic.o \

View File

@ -21,7 +21,7 @@ Signed-off-by: Jeremy Cline <jcline@redhat.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
index 7f9d38444d6d..2fba78e84d53 100644
index 8a46ed3ab429..cb73d398a2fe 100644
--- a/arch/arm64/Kconfig
+++ b/arch/arm64/Kconfig
@@ -861,7 +861,7 @@ endchoice

View File

@ -59,10 +59,10 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 839f9fee22cb..d4d2a5c5d003 100644
index f0c1a3a8d9e4..07e96d9ab020 100644
--- a/Makefile
+++ b/Makefile
@@ -1230,7 +1230,13 @@ endef
@@ -1231,7 +1231,13 @@ endef
define filechk_version.h
echo \#define LINUX_VERSION_CODE $(shell \
expr $(VERSION) \* 65536 + 0$(PATCHLEVEL) \* 256 + 0$(SUBLEVEL)); \

View File

@ -1471,7 +1471,9 @@ CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_API_DEBUG=y
CONFIG_DMA_BCM2835=m
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -3825,7 +3827,7 @@ CONFIG_MSDOS_FS=m
CONFIG_MSDOS_PARTITION=y
CONFIG_MSM_GCC_8660=y
CONFIG_MSM_GCC_8916=y
# CONFIG_MSM_GCC_8939 is not set
CONFIG_MSM_GCC_8939=m
CONFIG_MSM_GCC_8960=y
CONFIG_MSM_GCC_8974=y
# CONFIG_MSM_GCC_8994 is not set
@ -5085,6 +5087,7 @@ CONFIG_QCOM_HIDMA=m
CONFIG_QCOM_HIDMA_MGMT=m
CONFIG_QCOM_IOMMU=y
CONFIG_QCOM_IPA=m
# CONFIG_QCOM_IPCC is not set
CONFIG_QCOM_IRQ_COMBINER=y
CONFIG_QCOM_L2_PMU=y
CONFIG_QCOM_L3_PMU=y

View File

@ -1133,7 +1133,8 @@ CONFIG_DLCI_MAX=8
# CONFIG_DLM is not set
CONFIG_DMA_API_DEBUG_SG=y
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -4102,6 +4103,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_E1041=y
CONFIG_QCOM_HIDMA=m
CONFIG_QCOM_HIDMA_MGMT=m
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
CONFIG_QCOM_L2_PMU=y
CONFIG_QCOM_L3_PMU=y
# CONFIG_QCOM_LLCC is not set

View File

@ -1464,7 +1464,9 @@ CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_BCM2835=m
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -3806,7 +3808,7 @@ CONFIG_MSDOS_FS=m
CONFIG_MSDOS_PARTITION=y
CONFIG_MSM_GCC_8660=y
CONFIG_MSM_GCC_8916=y
# CONFIG_MSM_GCC_8939 is not set
CONFIG_MSM_GCC_8939=m
CONFIG_MSM_GCC_8960=y
CONFIG_MSM_GCC_8974=y
# CONFIG_MSM_GCC_8994 is not set
@ -5066,6 +5068,7 @@ CONFIG_QCOM_HIDMA=m
CONFIG_QCOM_HIDMA_MGMT=m
CONFIG_QCOM_IOMMU=y
CONFIG_QCOM_IPA=m
# CONFIG_QCOM_IPCC is not set
CONFIG_QCOM_IRQ_COMBINER=y
CONFIG_QCOM_L2_PMU=y
CONFIG_QCOM_L3_PMU=y

View File

@ -1125,7 +1125,8 @@ CONFIG_DLCI_MAX=8
# CONFIG_DLM is not set
# CONFIG_DMA_API_DEBUG is not set
CONFIG_DMA_API_DEBUG_SG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -4084,6 +4085,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_E1041=y
CONFIG_QCOM_HIDMA=m
CONFIG_QCOM_HIDMA_MGMT=m
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
CONFIG_QCOM_L2_PMU=y
CONFIG_QCOM_L3_PMU=y
# CONFIG_QCOM_LLCC is not set

View File

@ -1474,7 +1474,9 @@ CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_API_DEBUG=y
CONFIG_DMA_BCM2835=m
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -3901,7 +3903,7 @@ CONFIG_MSDOS_FS=m
CONFIG_MSDOS_PARTITION=y
CONFIG_MSM_GCC_8660=y
# CONFIG_MSM_GCC_8916 is not set
# CONFIG_MSM_GCC_8939 is not set
CONFIG_MSM_GCC_8939=m
CONFIG_MSM_GCC_8960=y
CONFIG_MSM_GCC_8974=y
# CONFIG_MSM_GCC_8994 is not set
@ -5196,6 +5198,7 @@ CONFIG_QCOM_HFPLL=m
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
CONFIG_QCOM_IOMMU=y
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_LLCC is not set
CONFIG_QCOM_OCMEM=m
CONFIG_QCOM_PDC=y

View File

@ -1467,7 +1467,9 @@ CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_BCM2835=m
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -3883,7 +3885,7 @@ CONFIG_MSDOS_FS=m
CONFIG_MSDOS_PARTITION=y
CONFIG_MSM_GCC_8660=y
# CONFIG_MSM_GCC_8916 is not set
# CONFIG_MSM_GCC_8939 is not set
CONFIG_MSM_GCC_8939=m
CONFIG_MSM_GCC_8960=y
CONFIG_MSM_GCC_8974=y
# CONFIG_MSM_GCC_8994 is not set
@ -5178,6 +5180,7 @@ CONFIG_QCOM_HFPLL=m
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
CONFIG_QCOM_IOMMU=y
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_LLCC is not set
CONFIG_QCOM_OCMEM=m
CONFIG_QCOM_PDC=y

View File

@ -1442,7 +1442,9 @@ CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_API_DEBUG=y
CONFIG_DMA_BCM2835=m
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -3810,7 +3812,7 @@ CONFIG_MQ_IOSCHED_KYBER=y
# CONFIG_MS_BLOCK is not set
CONFIG_MSDOS_FS=m
CONFIG_MSDOS_PARTITION=y
# CONFIG_MSM_GCC_8939 is not set
CONFIG_MSM_GCC_8939=m
# CONFIG_MSM_GCC_8994 is not set
# CONFIG_MSM_GCC_8998 is not set
# CONFIG_MSM_GPUCC_8998 is not set
@ -5054,6 +5056,7 @@ CONFIG_QCOM_FASTRPC=m
CONFIG_QCOM_HFPLL=m
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_LLCC is not set
CONFIG_QCOM_OCMEM=m
CONFIG_QCOM_PDC=y

View File

@ -1435,7 +1435,9 @@ CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_BCM2835=m
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -3792,7 +3794,7 @@ CONFIG_MQ_IOSCHED_KYBER=y
# CONFIG_MS_BLOCK is not set
CONFIG_MSDOS_FS=m
CONFIG_MSDOS_PARTITION=y
# CONFIG_MSM_GCC_8939 is not set
CONFIG_MSM_GCC_8939=m
# CONFIG_MSM_GCC_8994 is not set
# CONFIG_MSM_GCC_8998 is not set
# CONFIG_MSM_GPUCC_8998 is not set
@ -5036,6 +5038,7 @@ CONFIG_QCOM_FASTRPC=m
CONFIG_QCOM_HFPLL=m
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_LLCC is not set
CONFIG_QCOM_OCMEM=m
CONFIG_QCOM_PDC=y

View File

@ -1231,7 +1231,9 @@ CONFIG_DLM=m
CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -4636,6 +4638,7 @@ CONFIG_PWRSEQ_SIMPLE=m
# CONFIG_QCOM_EMAC is not set
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_SCM_DOWNLOAD_MODE_DEFAULT is not set
# CONFIG_QCS_TURING_404 is not set

View File

@ -1223,7 +1223,9 @@ CONFIG_DLM=m
CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMA_API_DEBUG_SG is not set
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -4617,6 +4619,7 @@ CONFIG_PWRSEQ_SIMPLE=m
# CONFIG_QCOM_EMAC is not set
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_SCM_DOWNLOAD_MODE_DEFAULT is not set
# CONFIG_QCS_TURING_404 is not set

View File

@ -1138,7 +1138,9 @@ CONFIG_DLM=m
CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -4313,6 +4315,7 @@ CONFIG_PWRSEQ_SIMPLE=m
# CONFIG_QCOM_EMAC is not set
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_SCM_DOWNLOAD_MODE_DEFAULT is not set
# CONFIG_QCS_TURING_404 is not set

View File

@ -1015,7 +1015,8 @@ CONFIG_DLM_DEBUG=y
CONFIG_DLM=m
CONFIG_DMA_API_DEBUG_SG=y
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -3956,6 +3957,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_1009=y
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_PDC is not set
CONFIG_QCOM_QDF2400_ERRATUM_0065=y

View File

@ -1130,7 +1130,9 @@ CONFIG_DLM=m
CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMA_API_DEBUG_SG is not set
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -4293,6 +4295,7 @@ CONFIG_PWRSEQ_SIMPLE=m
# CONFIG_QCOM_EMAC is not set
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_SCM_DOWNLOAD_MODE_DEFAULT is not set
# CONFIG_QCS_TURING_404 is not set

View File

@ -1007,7 +1007,8 @@ CONFIG_DLM_DEBUG=y
CONFIG_DLM=m
# CONFIG_DMA_API_DEBUG is not set
CONFIG_DMA_API_DEBUG_SG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -3940,6 +3941,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_1009=y
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_PDC is not set
CONFIG_QCOM_QDF2400_ERRATUM_0065=y

View File

@ -1145,7 +1145,9 @@ CONFIG_DLM=m
CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -4241,6 +4243,7 @@ CONFIG_PWRSEQ_SIMPLE=m
# CONFIG_QCOM_EMAC is not set
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_SCM_DOWNLOAD_MODE_DEFAULT is not set
# CONFIG_QCS_TURING_404 is not set

View File

@ -1020,7 +1020,8 @@ CONFIG_DLM_DEBUG=y
CONFIG_DLM=m
CONFIG_DMA_API_DEBUG_SG=y
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -3887,6 +3888,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_1009=y
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_PDC is not set
CONFIG_QCOM_QDF2400_ERRATUM_0065=y

View File

@ -1137,7 +1137,9 @@ CONFIG_DLM=m
CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMA_API_DEBUG_SG is not set
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -4221,6 +4223,7 @@ CONFIG_PWRSEQ_SIMPLE=m
# CONFIG_QCOM_EMAC is not set
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_SCM_DOWNLOAD_MODE_DEFAULT is not set
# CONFIG_QCS_TURING_404 is not set

View File

@ -1012,7 +1012,8 @@ CONFIG_DLM_DEBUG=y
CONFIG_DLM=m
# CONFIG_DMA_API_DEBUG is not set
CONFIG_DMA_API_DEBUG_SG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -3871,6 +3872,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_1009=y
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_PDC is not set
CONFIG_QCOM_QDF2400_ERRATUM_0065=y

View File

@ -1022,7 +1022,8 @@ CONFIG_DLM_DEBUG=y
CONFIG_DLM=m
# CONFIG_DMA_API_DEBUG is not set
CONFIG_DMA_API_DEBUG_SG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -3895,6 +3896,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_1009=y
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_PDC is not set
CONFIG_QCOM_QDF2400_ERRATUM_0065=y

View File

@ -1267,7 +1267,9 @@ CONFIG_DLM=m
CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG_SG is not set
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -4675,6 +4677,7 @@ CONFIG_PWRSEQ_SIMPLE=m
# CONFIG_QCOM_EMAC is not set
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_SCM_DOWNLOAD_MODE_DEFAULT is not set
# CONFIG_QCS_TURING_404 is not set

View File

@ -1087,7 +1087,8 @@ CONFIG_DLM_DEBUG=y
CONFIG_DLM=m
CONFIG_DMA_API_DEBUG_SG=y
CONFIG_DMA_API_DEBUG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -4118,6 +4119,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_1009=y
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_PDC is not set
CONFIG_QCOM_QDF2400_ERRATUM_0065=y

View File

@ -1259,7 +1259,9 @@ CONFIG_DLM=m
CONFIG_DM9102=m
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMA_API_DEBUG_SG is not set
# CONFIG_DMABUF_HEAPS is not set
CONFIG_DMABUF_HEAPS_CMA=y
CONFIG_DMABUF_HEAPS_SYSTEM=y
CONFIG_DMABUF_HEAPS=y
# CONFIG_DMABUF_MOVE_NOTIFY is not set
# CONFIG_DMABUF_SELFTESTS is not set
CONFIG_DMA_CMA=y
@ -4656,6 +4658,7 @@ CONFIG_PWRSEQ_SIMPLE=m
# CONFIG_QCOM_EMAC is not set
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_SCM_DOWNLOAD_MODE_DEFAULT is not set
# CONFIG_QCS_TURING_404 is not set

View File

@ -1079,7 +1079,8 @@ CONFIG_DLM_DEBUG=y
CONFIG_DLM=m
# CONFIG_DMA_API_DEBUG is not set
CONFIG_DMA_API_DEBUG_SG=y
# CONFIG_DMABUF_HEAPS is not set
# CONFIG_DMABUF_HEAPS_SYSTEM is not set
CONFIG_DMABUF_HEAPS=y
CONFIG_DMABUF_MOVE_NOTIFY=y
# CONFIG_DMABUF_SELFTESTS is not set
# CONFIG_DMA_CMA is not set
@ -4100,6 +4101,7 @@ CONFIG_QCOM_FALKOR_ERRATUM_1009=y
# CONFIG_QCOM_HIDMA is not set
# CONFIG_QCOM_HIDMA_MGMT is not set
# CONFIG_QCOM_IOMMU is not set
# CONFIG_QCOM_IPCC is not set
# CONFIG_QCOM_OCMEM is not set
# CONFIG_QCOM_PDC is not set
CONFIG_QCOM_QDF2400_ERRATUM_0065=y

View File

@ -30,7 +30,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
%global distro_build 0.rc0.20200611gitb29482fde649.1
%global distro_build 0.rc0.20200612gitb791d1bdf921.1
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -69,13 +69,13 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.8.0
%define pkgrelease 0.rc0.20200611gitb29482fde649.1
%define pkgrelease 0.rc0.20200612gitb791d1bdf921.1
# This is needed to do merge window version magic
%define patchlevel 8
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc0.20200611gitb29482fde649.1%{?buildid}%{?dist}
%define specrelease 0.rc0.20200612gitb791d1bdf921.1%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@ -567,7 +567,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-20200611gitb29482fde649.tar.xz
Source0: linux-20200612gitb791d1bdf921.tar.xz
Source1: Makefile.rhelver
@ -1280,8 +1280,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-20200611gitb29482fde649 -c
mv linux-20200611gitb29482fde649 linux-%{KVERREL}
%setup -q -n kernel-20200612gitb791d1bdf921 -c
mv linux-20200612gitb791d1bdf921 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2787,16 +2787,19 @@ fi
#
#
%changelog
* Thu Jun 11 2020 Justin M. Forbes <jforbes@fedoraproject.org> [5.8.0-0.rc0.20200611gitb29482fde649.1]
* Fri Jun 12 2020 Justin M. Forbes <jforbes@fedoraproject.org> [5.8.0-0.rc0.20200612gitb791d1bdf921.1]
- Fedora config updates ("Justin M. Forbes")
* Thu Jun 11 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc0.20200611gitb29482fde649.1]
- b29482fde649 rebase
- Fix PATCHLEVEL for merge window ("Justin M. Forbes")
* Fri Jun 12 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc0.20200612gitb791d1bdf921.1]
- b791d1bdf921 rebase
- PCI: tegra: Revert raw_violation_fixup for tegra124 (Nicolas Chauvet)
- One more Fedora config update ("Justin M. Forbes")
- Change ark CONFIG_COMMON_CLK to yes, it is selected already by other options ("Justin M. Forbes")
- Fix PATCHLEVEL for merge window ("Justin M. Forbes")
- More module filtering for Fedora ("Justin M. Forbes")
- Update filters for rnbd in Fedora ("Justin M. Forbes")
- redhat/Makefile.common: fix RPMKSUBLEVEL condition (Ondrej Mosnacek)
- redhat/Makefile: silence KABI tar output (Ondrej Mosnacek)
- Fix up module filtering for 5.8 ("Justin M. Forbes")
- More Fedora config work ("Justin M. Forbes")
- RTW88BE and CE have been extracted to their own modules ("Justin M. Forbes")

View File

@ -1,3 +1,3 @@
SHA512 (linux-20200611gitb29482fde649.tar.xz) = 865c1607ad71e297d93b0cb7d2614f87237d5d825c009e8dfe2cdcd14e8339d20a5fed3b76a25a7e4dffd389c85454e975d7cca54c78eb9356f617eb4346ab30
SHA512 (kernel-abi-whitelists-5.8.0-0.rc0.20200611gitb29482fde649.1.tar.bz2) = 544594a01ad68c19a1db3a69ca7aa8ddc6dc900eb4a3710fd89d3b84079fc12b57a1877eb4e9a5fc7597ecb400c3571f5c2c8c7cac6b4d7a0ee179306b0ed043
SHA512 (kernel-kabi-dw-5.8.0-0.rc0.20200611gitb29482fde649.1.tar.bz2) = 8891cfa7e740d30076054b6669dcdc241a9d80c0382fd5a72f3c32f324668e4e12ed396b928f9baebe5f40dd6d91c08d352a7d61a10100afb9e866bd354ffc95
SHA512 (linux-20200612gitb791d1bdf921.tar.xz) = 3b57b00ab8352643f761b34f7e7c38398fc31d48b5705980c731606903db0780654914789b5149fab09f6dfe2a918844e31b93de4357bf2ddc4bc5e2aa5bf759
SHA512 (kernel-abi-whitelists-5.8.0-0.rc0.20200612gitb791d1bdf921.1.tar.bz2) = 7151171a0e598a6f5e3cbc400790cfef25789a5a4d10d09aca121d5f28eeb0800a4cbcad0deb8dc34480c6ae816815f30e1e0a8c94c39321a79e186c6fdc5687
SHA512 (kernel-kabi-dw-5.8.0-0.rc0.20200612gitb791d1bdf921.1.tar.bz2) = d989025cf7f50367bc9b7327cef7238f9cf7ecafaa6df4fa623624af23854892aefea754c7fd37523405a37179265d52167e7ae79bc1dc084319cc5f455c8eb2