Merge remote-tracking branch 'up/f38' into f38-riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
commit
c0406186f6
13
kernel.spec
13
kernel.spec
@ -142,18 +142,18 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specrpmversion 6.3.10
|
||||
%define specversion 6.3.10
|
||||
%define specrpmversion 6.3.11
|
||||
%define specversion 6.3.11
|
||||
%define patchversion 6.3
|
||||
%define pkgrelease 200
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.3.10
|
||||
%define tarfile_release 6.3.11
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 3
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 200%{?buildid}.0.riscv64%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.3.10
|
||||
%define kabiversion 6.3.11
|
||||
|
||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||
# fatal kernel package build error
|
||||
@ -3419,9 +3419,12 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed Jun 29 2023 David Abdurachmanov <davidlt@rivosinc.com> [6.3.10.0.riscv64]
|
||||
* Sun Jul 02 2023 David Abdurachmanov <davidlt@rivosinc.com> [6.3.11.0.riscv64]
|
||||
- Add support for riscv64
|
||||
|
||||
* Sun Jul 02 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.11-0]
|
||||
- Linux v6.3.11
|
||||
|
||||
* Wed Jun 28 2023 Augusto Caringi <acaringi@redhat.com> [6.3.10-0]
|
||||
- Linux v6.3.10
|
||||
|
||||
|
@ -40,7 +40,7 @@
|
||||
39 files changed, 512 insertions(+), 187 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 47253ac6c85c..15a31ab19ace 100644
|
||||
index 34349623a76a..6c842f7ce710 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -63,10 +63,10 @@ index 47253ac6c85c..15a31ab19ace 100644
|
||||
# to get the ordering right.
|
||||
#
|
||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||
index e24a9820e12f..c39629f18c95 100644
|
||||
index a04bb151a902..292f324bf1ff 100644
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -1306,9 +1306,9 @@ config HIGHMEM
|
||||
@@ -1307,9 +1307,9 @@ config HIGHMEM
|
||||
If unsure, say n.
|
||||
|
||||
config HIGHPTE
|
||||
@ -79,10 +79,10 @@ index e24a9820e12f..c39629f18c95 100644
|
||||
The VM uses one page of physical memory for each page table.
|
||||
For systems with a lot of processes, this can use a lot of
|
||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||
index 1023e896d46b..a5bb8dc90d68 100644
|
||||
index 15e097206e1a..8eefb7a011f0 100644
|
||||
--- a/arch/arm64/Kconfig
|
||||
+++ b/arch/arm64/Kconfig
|
||||
@@ -1238,7 +1238,7 @@ endchoice
|
||||
@@ -1239,7 +1239,7 @@ endchoice
|
||||
|
||||
config ARM64_FORCE_52BIT
|
||||
bool "Force 52-bit virtual addresses for userspace"
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.3.10.tar.xz) = e1bee6ab13c2447d795c97daae52bc68b7dcd17f5055976e89ae733c58acc5de28cd51393942010f64957102f84870032e63392b24322a25798375fa96d8b25f
|
||||
SHA512 (kernel-abi-stablelists-6.3.10.tar.bz2) = cb036e3facdb78170a0b0047139398ca5b5425f482f3a63072ae9c141a7d126a218f0bdec56c823b9bd0e972ce9061db2af250ffce16231906c0e81337ec8331
|
||||
SHA512 (kernel-kabi-dw-6.3.10.tar.bz2) = 20ef9d7eca2ea19f1ef28d9f50becd8cfc583f2225c744f22dffa1de6dadc6811f4aef1b2a4314fa8108f931166f8850236e575169ba0d78260670932ebe3585
|
||||
SHA512 (linux-6.3.11.tar.xz) = c5aa15813dfa8e166b55100ec94a71fb64e2ce272ab812f708fcc29e5c0d79998720a7c122473f198cec1caef8292e78ff62ff7c0b398b9565de80122464d0e6
|
||||
SHA512 (kernel-abi-stablelists-6.3.11.tar.bz2) = 3d112e66e4ba8cc0430ef9c1c7e0220c6855636decb1cf03a1ea71ca1e32fb7416b2203bdbc2bc1b46b8d6d790fdcc4f8e5e2ef7e20676bb0d84377878daf576
|
||||
SHA512 (kernel-kabi-dw-6.3.11.tar.bz2) = 2f0cb361d48bae530f6e6c549bfeb0ced1e7ee8f1231389f6fb8c6cfcce31379916b20b7ee086a6814771c96429f04855225f9b023f91f7a04675379195ab7b6
|
||||
|
Loading…
x
Reference in New Issue
Block a user