kernel-5.13.17-100
* Wed Sep 15 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.17-100] - kernel-5.13.17-0 (Justin M. Forbes) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
cb50491e43
commit
be77a85299
45
kernel.spec
45
kernel.spec
@ -116,7 +116,7 @@ Summary: The Linux kernel
|
||||
# The kernel tarball/base version
|
||||
%define kversion 5.13
|
||||
|
||||
%define rpmversion 5.13.16
|
||||
%define rpmversion 5.13.17
|
||||
%define stableversion 5.13
|
||||
%define pkgrelease 100
|
||||
|
||||
@ -646,7 +646,7 @@ BuildRequires: clang
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.13.16.tar.xz
|
||||
Source0: linux-5.13.17.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1315,8 +1315,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.13.16 -c
|
||||
mv linux-5.13.16 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.13.17 -c
|
||||
mv linux-5.13.17 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -2886,8 +2886,41 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Sep 13 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.16-100]
|
||||
- kernel-5.13.16-0 (Justin M. Forbes)
|
||||
* Wed Sep 15 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.17-100]
|
||||
- kernel-5.13.17-0 (Justin M. Forbes)
|
||||
|
||||
* Mon Sep 13 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.16-0]
|
||||
- kernel-5.13.15-0 (Justin M. Forbes)
|
||||
- kernel-5.13.14-0 (Justin M. Forbes)
|
||||
- kernel-5.13.13-0 (Justin M. Forbes)
|
||||
- kernel-5.13.12-0 (Justin M. Forbes)
|
||||
- kernel-5.13.11-0 (Justin M. Forbes)
|
||||
- bpf: Fix integer overflow involving bucket_size (Tatsuhiko Yasumatsu)
|
||||
- kernel-5.13.10-0 (Justin M. Forbes)
|
||||
- Fix up backport of Dell XPS 9710 quirk (Justin M. Forbes)
|
||||
- ASoC: Intel: sof_sdw_max98373: remove useless inits (Pierre-Louis Bossart)
|
||||
- ASoC: Intel: update sof_pcm512x quirks (Pierre-Louis Bossart)
|
||||
- ASoC: SOF: Intel: Use DMI string to search for adl_mx98373_rt5682 variant (jairaj arava)
|
||||
- ASoC: Intel: sof_sdw: add quirk for Dell XPS 9710 (Pierre-Louis Bossart)
|
||||
- kernel-5.13.9-0 (Justin M. Forbes)
|
||||
- drm/i915/dp: Use max params for older panels (Kai-Heng Feng)
|
||||
- pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko)
|
||||
- kernel-5.13.8-0 (Justin M. Forbes)
|
||||
- Re-enable sermouse for x86 (rhbz 1974002) (Justin M. Forbes)
|
||||
- Revert CRYPTO_ECDH and CRYPTO_ECDA from builtin to module to fix fips (Justin M. Forbes)
|
||||
- drm/rockchip: remove existing generic drivers to take over the device (Javier Martinez Canillas)
|
||||
- powerpc/pseries: Fix regression while building external modules (Srikar Dronamraju)
|
||||
- kernel-5.13.7-0 (Justin M. Forbes)
|
||||
- kernel-5.13.6-0 (Justin M. Forbes)
|
||||
- kernel-5.13.5-0 (Justin M. Forbes)
|
||||
- iwlwifi Add support for ax201 in Samsung Galaxy Book Flex2 Alpha (Justin M. Forbes)
|
||||
- Revert "usb: renesas-xhci: Fix handling of unknown ROM state" (Justin M. Forbes)
|
||||
- RHEL configs need this too (Justin M. Forbes)
|
||||
- kernel-5.13.4-0 (Justin M. Forbes)
|
||||
- Config update for 5.13.4 (Justin M. Forbes)
|
||||
- kernel-5.13.3-0 (Justin M. Forbes)
|
||||
- Don't tag a release as [redhat] (Justin M. Forbes)
|
||||
- platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd() (Yang Yingliang)
|
||||
|
||||
* Wed Sep 08 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.15-0]
|
||||
- kernel-5.13.14-0 (Justin M. Forbes)
|
||||
|
@ -28,7 +28,6 @@
|
||||
drivers/input/rmi4/rmi_driver.c | 124 +++--
|
||||
drivers/iommu/iommu.c | 22 +
|
||||
drivers/net/wireguard/main.c | 6 +
|
||||
drivers/net/wireless/intel/iwlwifi/pcie/drv.c | 1 +
|
||||
drivers/nvme/host/pci.c | 28 +-
|
||||
drivers/pci/quirks.c | 24 +
|
||||
drivers/platform/x86/amd-pmc.c | 204 +++++++-
|
||||
@ -72,7 +71,7 @@
|
||||
tools/testing/selftests/bpf/progs/linked_vars2.c | 55 ---
|
||||
.../selftests/bpf/progs/test_static_linked1.c | 30 --
|
||||
.../selftests/bpf/progs/test_static_linked2.c | 31 --
|
||||
74 files changed, 942 insertions(+), 2351 deletions(-)
|
||||
73 files changed, 941 insertions(+), 2351 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kdump/kdump.rst b/Documentation/admin-guide/kdump/kdump.rst
|
||||
index 75a9dd98e76e..3ff3291551f9 100644
|
||||
@ -97,7 +96,7 @@ index 75a9dd98e76e..3ff3291551f9 100644
|
||||
|
||||
Boot into System Kernel
|
||||
diff --git a/Makefile b/Makefile
|
||||
index cbb2f35baedb..d3dc4ecbc462 100644
|
||||
index c79a2c70a22b..5e3e32edbd4b 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -508,6 +508,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
||||
@ -1446,18 +1445,6 @@ index 75dbe77b0b4b..4bd6dd722f44 100644
|
||||
ret = wg_allowedips_slab_init();
|
||||
if (ret < 0)
|
||||
goto err_allowedips;
|
||||
diff --git a/drivers/net/wireless/intel/iwlwifi/pcie/drv.c b/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
|
||||
index 9f11a1d5d034..81e881da7f15 100644
|
||||
--- a/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
|
||||
+++ b/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
|
||||
@@ -556,6 +556,7 @@ static const struct iwl_dev_info iwl_dev_info_table[] = {
|
||||
IWL_DEV_INFO(0xA0F0, 0x1652, killer1650i_2ax_cfg_qu_b0_hr_b0, NULL),
|
||||
IWL_DEV_INFO(0xA0F0, 0x2074, iwl_ax201_cfg_qu_hr, NULL),
|
||||
IWL_DEV_INFO(0xA0F0, 0x4070, iwl_ax201_cfg_qu_hr, NULL),
|
||||
+ IWL_DEV_INFO(0xA0F0, 0x6074, iwl_ax201_cfg_qu_hr, NULL),
|
||||
IWL_DEV_INFO(0x02F0, 0x0070, iwl_ax201_cfg_quz_hr, NULL),
|
||||
IWL_DEV_INFO(0x02F0, 0x0074, iwl_ax201_cfg_quz_hr, NULL),
|
||||
IWL_DEV_INFO(0x02F0, 0x6074, iwl_ax201_cfg_quz_hr, NULL),
|
||||
diff --git a/drivers/nvme/host/pci.c b/drivers/nvme/host/pci.c
|
||||
index d963f25fc7ae..66455e2261d0 100644
|
||||
--- a/drivers/nvme/host/pci.c
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.13.16.tar.xz) = c711a58ce088fad9af8629077b40ecbb316e429b0cce008bc1bc51a8c31d71d093013fd151f67badf2131d86d20c1e113db8a091567b6ba39e1c17edf1e08116
|
||||
SHA512 (kernel-abi-whitelists-5.13.16-100.tar.bz2) = 98afe32c6a5243a20282d05dc7af31f889a7b8cf5075e35ee0235ebdf61a8635ea5ce6eca9e2fe1f729067081dd446e881da08c4ae2a0fd52a01b2da520a8367
|
||||
SHA512 (kernel-kabi-dw-5.13.16-100.tar.bz2) = 67d502788941af827dd2880ca7a99cc6449c12c4274ba02cbf4cb405049b62e06897ef394341630119a25f89d2205d89bc130f572882ecb70ae8b1cba1611f22
|
||||
SHA512 (linux-5.13.17.tar.xz) = 29bca41aa55a210b33f1510a5c192f6df00debb2e087d859ce137aef4bbb121328a6017839384287c3ed23713b22de303b7eadaf0dd4f73fba9e14a27c1053f5
|
||||
SHA512 (kernel-abi-whitelists-5.13.17-100.tar.bz2) = 131a03c21df153933250f9de78ff7ffd23b798d09b192f4533909d876025441f03cc942635ac22f0001c88c403b9354f8c748f3c4c2643b4c1b33795e9b5d992
|
||||
SHA512 (kernel-kabi-dw-5.13.17-100.tar.bz2) = 5de6959f753acbafe11a904e0c10cfa9b1ec790db640025d483acc205ca3421688a7df4bce332c7e6b74819e2ba042f995eb78ae3e8e81b9ecf0ede8bada3f5b
|
||||
|
Loading…
Reference in New Issue
Block a user