Linux v3.4-8261-ga01ee16
Need to revisit the linux-2.6-makefile-after_link.patch rework. Upstream moved linking vmlinux into a shell script, so we have to call debugedit from there, but we do it in a somewhat hacky way at the moment.
This commit is contained in:
parent
01a543076e
commit
be64ba5ea6
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 8
|
%define gitrev 9
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -2298,6 +2298,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 29 2012 Josh Boyer <jwboyer@redhat.com> - 3.5.0-0.rc0.git9.1
|
||||||
|
- Linux v3.4-8261-ga01ee16
|
||||||
|
|
||||||
* Sun May 27 2012 Josh Boyer <jwboyer@redhat.com> - 3.5.0-0.rc0.git8.1
|
* Sun May 27 2012 Josh Boyer <jwboyer@redhat.com> - 3.5.0-0.rc0.git8.1
|
||||||
- Linux v3.4-8215-g1e2aec8
|
- Linux v3.4-8215-g1e2aec8
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From f072f7db2194c8255c003d985b61ad2f97ebbee0 Mon Sep 17 00:00:00 2001
|
From b707aea6a4947c3806ced2c23e889943a0f36876 Mon Sep 17 00:00:00 2001
|
||||||
From: Roland McGrath <roland@redhat.com>
|
From: Roland McGrath <roland@redhat.com>
|
||||||
Date: Mon, 6 Oct 2008 23:03:03 -0700
|
Date: Mon, 6 Oct 2008 23:03:03 -0700
|
||||||
Subject: [PATCH] kbuild: AFTER_LINK
|
Subject: [PATCH] kbuild: AFTER_LINK
|
||||||
@ -7,24 +7,9 @@ If the make variable AFTER_LINK is set, it is a command line to run
|
|||||||
after each final link. This includes vmlinux itself and vDSO images.
|
after each final link. This includes vmlinux itself and vDSO images.
|
||||||
|
|
||||||
Signed-off-by: Roland McGrath <roland@redhat.com>
|
Signed-off-by: Roland McGrath <roland@redhat.com>
|
||||||
---
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index f908acc..960ff6f 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -746,6 +746,10 @@ quiet_cmd_vmlinux__ ?= LD $@
|
|
||||||
--start-group $(vmlinux-main) --end-group \
|
|
||||||
$(filter-out $(vmlinux-lds) $(vmlinux-init) $(vmlinux-main) vmlinux.o FORCE ,$^)
|
|
||||||
|
|
||||||
+ifdef AFTER_LINK
|
|
||||||
+cmd_vmlinux__ += ; $(AFTER_LINK)
|
|
||||||
+endif
|
|
||||||
+
|
|
||||||
# Generate new vmlinux version
|
|
||||||
quiet_cmd_vmlinux_version = GEN .version
|
|
||||||
cmd_vmlinux_version = set -e; \
|
|
||||||
diff --git a/arch/powerpc/kernel/vdso32/Makefile b/arch/powerpc/kernel/vdso32/Makefile
|
diff --git a/arch/powerpc/kernel/vdso32/Makefile b/arch/powerpc/kernel/vdso32/Makefile
|
||||||
index 51ead52..ad21273 100644
|
index 9a7946c..28d6765 100644
|
||||||
--- a/arch/powerpc/kernel/vdso32/Makefile
|
--- a/arch/powerpc/kernel/vdso32/Makefile
|
||||||
+++ b/arch/powerpc/kernel/vdso32/Makefile
|
+++ b/arch/powerpc/kernel/vdso32/Makefile
|
||||||
@@ -41,7 +41,8 @@ $(obj-vdso32): %.o: %.S
|
@@ -41,7 +41,8 @@ $(obj-vdso32): %.o: %.S
|
||||||
@ -38,7 +23,7 @@ index 51ead52..ad21273 100644
|
|||||||
cmd_vdso32as = $(CROSS32CC) $(a_flags) -c -o $@ $<
|
cmd_vdso32as = $(CROSS32CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
diff --git a/arch/powerpc/kernel/vdso64/Makefile b/arch/powerpc/kernel/vdso64/Makefile
|
diff --git a/arch/powerpc/kernel/vdso64/Makefile b/arch/powerpc/kernel/vdso64/Makefile
|
||||||
index 79da65d..f11c21b 100644
|
index 8c500d8..d27737b 100644
|
||||||
--- a/arch/powerpc/kernel/vdso64/Makefile
|
--- a/arch/powerpc/kernel/vdso64/Makefile
|
||||||
+++ b/arch/powerpc/kernel/vdso64/Makefile
|
+++ b/arch/powerpc/kernel/vdso64/Makefile
|
||||||
@@ -36,7 +36,8 @@ $(obj-vdso64): %.o: %.S
|
@@ -36,7 +36,8 @@ $(obj-vdso64): %.o: %.S
|
||||||
@ -51,11 +36,39 @@ index 79da65d..f11c21b 100644
|
|||||||
quiet_cmd_vdso64as = VDSO64A $@
|
quiet_cmd_vdso64as = VDSO64A $@
|
||||||
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
|
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
|
diff --git a/arch/s390/kernel/vdso32/Makefile b/arch/s390/kernel/vdso32/Makefile
|
||||||
|
index 8ad2b34..e153572 100644
|
||||||
|
--- a/arch/s390/kernel/vdso32/Makefile
|
||||||
|
+++ b/arch/s390/kernel/vdso32/Makefile
|
||||||
|
@@ -43,7 +43,8 @@ $(obj-vdso32): %.o: %.S
|
||||||
|
|
||||||
|
# actual build commands
|
||||||
|
quiet_cmd_vdso32ld = VDSO32L $@
|
||||||
|
- cmd_vdso32ld = $(CC) $(c_flags) -Wl,-T $^ -o $@
|
||||||
|
+ cmd_vdso32ld = $(CC) $(c_flags) -Wl,-T $^ -o $@ \
|
||||||
|
+ $(if $(AFTER_LINK),; $(AFTER_LINK))
|
||||||
|
quiet_cmd_vdso32as = VDSO32A $@
|
||||||
|
cmd_vdso32as = $(CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
|
diff --git a/arch/s390/kernel/vdso64/Makefile b/arch/s390/kernel/vdso64/Makefile
|
||||||
|
index 2a8ddfd..452ca53 100644
|
||||||
|
--- a/arch/s390/kernel/vdso64/Makefile
|
||||||
|
+++ b/arch/s390/kernel/vdso64/Makefile
|
||||||
|
@@ -43,7 +43,8 @@ $(obj-vdso64): %.o: %.S
|
||||||
|
|
||||||
|
# actual build commands
|
||||||
|
quiet_cmd_vdso64ld = VDSO64L $@
|
||||||
|
- cmd_vdso64ld = $(CC) $(c_flags) -Wl,-T $^ -o $@
|
||||||
|
+ cmd_vdso64ld = $(CC) $(c_flags) -Wl,-T $^ -o $@ \
|
||||||
|
+ $(if $(AFTER_LINK),; $(AFTER_LINK))
|
||||||
|
quiet_cmd_vdso64as = VDSO64A $@
|
||||||
|
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
diff --git a/arch/x86/vdso/Makefile b/arch/x86/vdso/Makefile
|
diff --git a/arch/x86/vdso/Makefile b/arch/x86/vdso/Makefile
|
||||||
index 4a2afa1..12ad9f7 100644
|
index fd14be1..1f3eb19 100644
|
||||||
--- a/arch/x86/vdso/Makefile
|
--- a/arch/x86/vdso/Makefile
|
||||||
+++ b/arch/x86/vdso/Makefile
|
+++ b/arch/x86/vdso/Makefile
|
||||||
@@ -120,8 +120,9 @@ $(obj)/vdso32-syms.lds: $(vdso32.so-y:%=$(obj)/vdso32-%-syms.lds) FORCE
|
@@ -178,8 +178,9 @@ $(obj)/vdso32-syms.lds: $(vdso32.so-y:%=$(obj)/vdso32-%-syms.lds) FORCE
|
||||||
quiet_cmd_vdso = VDSO $@
|
quiet_cmd_vdso = VDSO $@
|
||||||
cmd_vdso = $(CC) -nostdlib -o $@ \
|
cmd_vdso = $(CC) -nostdlib -o $@ \
|
||||||
$(VDSO_LDFLAGS) $(VDSO_LDFLAGS_$(filter %.lds,$(^F))) \
|
$(VDSO_LDFLAGS) $(VDSO_LDFLAGS_$(filter %.lds,$(^F))) \
|
||||||
@ -67,32 +80,21 @@ index 4a2afa1..12ad9f7 100644
|
|||||||
|
|
||||||
VDSO_LDFLAGS = -fPIC -shared $(call cc-ldoption, -Wl$(comma)--hash-style=sysv)
|
VDSO_LDFLAGS = -fPIC -shared $(call cc-ldoption, -Wl$(comma)--hash-style=sysv)
|
||||||
GCOV_PROFILE := n
|
GCOV_PROFILE := n
|
||||||
|
diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
|
||||||
|
index cd9c6c6..3edf048 100644
|
||||||
|
--- a/scripts/link-vmlinux.sh
|
||||||
|
+++ b/scripts/link-vmlinux.sh
|
||||||
|
@@ -65,6 +65,10 @@ vmlinux_link()
|
||||||
|
-lutil ${1}
|
||||||
|
rm -f linux
|
||||||
|
fi
|
||||||
|
+ if [ -n "${AFTER_LINK}" ]; then
|
||||||
|
+ /usr/lib/rpm/debugedit -b ${RPM_BUILD_DIR} -d /usr/src/debug -i ${2} \
|
||||||
|
+ > ${2}.id
|
||||||
|
+ fi
|
||||||
|
}
|
||||||
|
|
||||||
diff --git a/arch/s390/kernel/vdso32/Makefile b/arch/s390/kernel/vdso32/Makefile
|
|
||||||
index d13e875..28a3e1ad 100644
|
|
||||||
--- a/arch/s390/kernel/vdso32/Makefile
|
|
||||||
+++ b/arch/s390/kernel/vdso32/Makefile
|
|
||||||
@@ -40,7 +40,8 @@ $(obj-vdso32): %.o: %.S
|
|
||||||
|
|
||||||
# actual build commands
|
--
|
||||||
quiet_cmd_vdso32ld = VDSO32L $@
|
1.7.7.6
|
||||||
- cmd_vdso32ld = $(CC) $(c_flags) -Wl,-T $^ -o $@
|
|
||||||
+ cmd_vdso32ld = $(CC) $(c_flags) -Wl,-T $^ -o $@ \
|
|
||||||
+ $(if $(AFTER_LINK),; $(AFTER_LINK))
|
|
||||||
quiet_cmd_vdso32as = VDSO32A $@
|
|
||||||
cmd_vdso32as = $(CC) $(a_flags) -c -o $@ $<
|
|
||||||
|
|
||||||
diff --git a/arch/s390/kernel/vdso64/Makefile b/arch/s390/kernel/vdso64/Makefile
|
|
||||||
index 449352d..e90e656 100644
|
|
||||||
--- a/arch/s390/kernel/vdso64/Makefile
|
|
||||||
+++ b/arch/s390/kernel/vdso64/Makefile
|
|
||||||
@@ -40,7 +40,8 @@ $(obj-vdso64): %.o: %.S
|
|
||||||
|
|
||||||
# actual build commands
|
|
||||||
quiet_cmd_vdso64ld = VDSO64L $@
|
|
||||||
- cmd_vdso64ld = $(CC) $(c_flags) -Wl,-T $^ -o $@
|
|
||||||
+ cmd_vdso64ld = $(CC) $(c_flags) -Wl,-T $^ -o $@ \
|
|
||||||
+ $(if $(AFTER_LINK),; $(AFTER_LINK))
|
|
||||||
quiet_cmd_vdso64as = VDSO64A $@
|
|
||||||
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user