Linux v4.18-rc3
This commit is contained in:
parent
1126e4c975
commit
bdb5b2d8f8
@ -1,35 +0,0 @@
|
||||
From fbeaf6c71be2273fde980395974e70eb8e1f4a80 Mon Sep 17 00:00:00 2001
|
||||
From: Jerry James <loganjerry@gmail.com>
|
||||
Date: Sat, 23 Jun 2018 22:49:04 +0200
|
||||
Subject: [PATCH] kconfig: loop boundary condition fix
|
||||
|
||||
If buf[-1] just happens to hold the byte 0x0A, then nread can wrap around
|
||||
to (size_t)-1, leading to invalid memory accesses.
|
||||
|
||||
This has caused segmentation faults when trying to build the latest
|
||||
kernel snapshots for i686 in Fedora:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1592374
|
||||
|
||||
Signed-off-by: Jerry James <loganjerry@gmail.com>
|
||||
[alexpl@fedoraproject.org: reformatted patch for submission]
|
||||
Signed-off-by: Alexander Ploumistos <alexpl@fedoraproject.org>
|
||||
---
|
||||
scripts/kconfig/preprocess.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scripts/kconfig/preprocess.c b/scripts/kconfig/preprocess.c
|
||||
index 65da87fce907..5ca2df790d3c 100644
|
||||
--- a/scripts/kconfig/preprocess.c
|
||||
+++ b/scripts/kconfig/preprocess.c
|
||||
@@ -156,7 +156,7 @@ static char *do_shell(int argc, char *argv[])
|
||||
nread--;
|
||||
|
||||
/* remove trailing new lines */
|
||||
- while (buf[nread - 1] == '\n')
|
||||
+ while (nread > 0 && buf[nread - 1] == '\n')
|
||||
nread--;
|
||||
|
||||
buf[nread] = 0;
|
||||
--
|
||||
2.17.1
|
||||
|
10
kernel.spec
10
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%global rcrev 2
|
||||
%global rcrev 3
|
||||
# The git snapshot level
|
||||
%define gitrev 4
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 4.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -603,9 +603,6 @@ Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
|
||||
# rhbz 1470995
|
||||
Patch504: kexec-bzimage-verify-pe-signature-fix.patch
|
||||
|
||||
# i686 fix
|
||||
Patch505: 0001-kconfig-loop-boundary-condition-fix.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1841,6 +1838,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Jul 02 2018 Laura Abbott <labbott@redhat.com> - 4.18.0-0.rc3.git0.1
|
||||
- Linux v4.18-rc3
|
||||
|
||||
* Mon Jul 02 2018 Laura Abbott <labbott@redhat.com>
|
||||
- Disable debugging options.
|
||||
|
||||
|
3
sources
3
sources
@ -1,3 +1,2 @@
|
||||
SHA512 (linux-4.17.tar.xz) = 4d9de340a26155a89ea8773131c76220cc2057f2b5d031b467b60e8b14c1842518e2d60a863d8c695f0f7640f3f18d43826201984a238dade857b6cef79837db
|
||||
SHA512 (patch-4.18-rc2.xz) = d9723a202e43f3e68895fc8463e15b0723f6ecff947805ca501fdf12aa74e87915bc42d1c021d14168814c2178574f3f6f0c2bd770af9653c9e0867ebfaaebe0
|
||||
SHA512 (patch-4.18-rc2-git4.xz) = dd588965f2cc4d2ce89077f4857d9a4f30705a1a65738e169a471ce70b80087827aaf54f1d93012ef191229b147c50e810331300f8cccc8443bac06883de42bf
|
||||
SHA512 (patch-4.18-rc3.xz) = 9c6cb28585e1fa9e7b41a83314040c6b74fdb20c9a69041de9879412c92926f71aaac2c76f4f59c0ad25f06a2431ffa2fd2bd44c6413e7bb6ab078b90fa87f9d
|
||||
|
Loading…
Reference in New Issue
Block a user