Linux v3.11-rc2-93-gb3a3a9c
This commit is contained in:
parent
faf25207dc
commit
bd472195d6
13
kernel.spec
13
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 2
|
||||
%global baserelease 1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 2
|
||||
# The git snapshot level
|
||||
%define gitrev 0
|
||||
%define gitrev 1
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -729,9 +729,6 @@ Patch22001: selinux-apply-different-permission-to-ptrace-child.patch
|
||||
#rhbz 927469
|
||||
Patch23006: fix-child-thread-introspection.patch
|
||||
|
||||
#CVE-2013-2140 rhbz 971146 971148
|
||||
Patch25031: xen-blkback-Check-device-permissions-before-allowing.patch
|
||||
|
||||
#CVE-2013-2147 rhbz 971242 971249
|
||||
Patch25032: cve-2013-2147-ciss-info-leak.patch
|
||||
|
||||
@ -1429,9 +1426,6 @@ ApplyPatch ath9k_rx_dma_stop_check.patch
|
||||
#rhbz 927469
|
||||
ApplyPatch fix-child-thread-introspection.patch
|
||||
|
||||
#CVE-2013-2140 rhbz 971146 971148
|
||||
ApplyPatch xen-blkback-Check-device-permissions-before-allowing.patch
|
||||
|
||||
#CVE-2013-2147 rhbz 971242 971249
|
||||
ApplyPatch cve-2013-2147-ciss-info-leak.patch
|
||||
|
||||
@ -2246,6 +2240,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Jul 23 2013 Justin M. Forbes <jforbes@redhat.com> - 3.11.0-0.rc2.git1.1
|
||||
- Linux v3.11-rc2-93-gb3a3a9c
|
||||
|
||||
* Mon Jul 22 2013 Justin M. Forbes <jforbes@redhat.com> - 3.11.0-0.rc2.git0.2
|
||||
- let flavors/variants end with "+$flavor" in the uname patch from harald@redhat.com
|
||||
- Reenable debugging options.
|
||||
|
3
sources
3
sources
@ -1,4 +1,3 @@
|
||||
4f25cd5bec5f8d5a7d935b3f2ccb8481 linux-3.10.tar.xz
|
||||
d790b034867145dd9c5828ed58eaac45 patch-3.11-rc1.xz
|
||||
dad3e43d9c55a913b9d68c488396722d patch-3.11-rc1-git4.xz
|
||||
fe39310c0f1b58e78632c3976ff80289 patch-3.11-rc2.xz
|
||||
05ead9ed5c2932ad5e9d1ac478be62f4 patch-3.11-rc2-git1.xz
|
||||
|
@ -1,54 +0,0 @@
|
||||
From e029d62efa5eb46831a9e1414468e582379b743f Mon Sep 17 00:00:00 2001
|
||||
From: Konrad Rzeszutek Wilk <konrad.wilk () oracle com>
|
||||
Date: Wed, 16 Jan 2013 11:33:52 -0500
|
||||
Subject: [PATCH] xen/blkback: Check device permissions before allowing
|
||||
OP_DISCARD
|
||||
|
||||
We need to make sure that the device is not RO or that
|
||||
the request is not past the number of sectors we want to
|
||||
issue the DISCARD operation for.
|
||||
|
||||
Cc: stable () vger kernel org
|
||||
Acked-by: Jan Beulich <JBeulich () suse com>
|
||||
Acked-by: Ian Campbell <Ian.Campbell () citrix com>
|
||||
[v1: Made it pr_warn instead of pr_debug]
|
||||
Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk () oracle com>
|
||||
---
|
||||
drivers/block/xen-blkback/blkback.c | 13 ++++++++++++-
|
||||
1 file changed, 12 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/block/xen-blkback/blkback.c b/drivers/block/xen-blkback/blkback.c
|
||||
index e79ab45..4119bcd 100644
|
||||
--- a/drivers/block/xen-blkback/blkback.c
|
||||
+++ b/drivers/block/xen-blkback/blkback.c
|
||||
@@ -876,7 +876,18 @@ static int dispatch_discard_io(struct xen_blkif *blkif,
|
||||
int status = BLKIF_RSP_OKAY;
|
||||
struct block_device *bdev = blkif->vbd.bdev;
|
||||
unsigned long secure;
|
||||
+ struct phys_req preq;
|
||||
+
|
||||
+ preq.sector_number = req->u.discard.sector_number;
|
||||
+ preq.nr_sects = req->u.discard.nr_sectors;
|
||||
|
||||
+ err = xen_vbd_translate(&preq, blkif, WRITE);
|
||||
+ if (err) {
|
||||
+ pr_warn(DRV_PFX "access denied: DISCARD [%llu->%llu] on dev=%04x\n",
|
||||
+ preq.sector_number,
|
||||
+ preq.sector_number + preq.nr_sects, blkif->vbd.pdevice);
|
||||
+ goto fail_response;
|
||||
+ }
|
||||
blkif->st_ds_req++;
|
||||
|
||||
xen_blkif_get(blkif);
|
||||
@@ -887,7 +898,7 @@ static int dispatch_discard_io(struct xen_blkif *blkif,
|
||||
err = blkdev_issue_discard(bdev, req->u.discard.sector_number,
|
||||
req->u.discard.nr_sectors,
|
||||
GFP_KERNEL, secure);
|
||||
-
|
||||
+fail_response:
|
||||
if (err == -EOPNOTSUPP) {
|
||||
pr_debug(DRV_PFX "discard op failed, not supported\n");
|
||||
status = BLKIF_RSP_EOPNOTSUPP;
|
||||
--
|
||||
1.8.1.4
|
||||
|
Loading…
Reference in New Issue
Block a user