perf: install trace-event plugins
perf hardcodes $libdir to be lib for all but x86_64, so kludge around it until upstream gets their act together. --kyle
This commit is contained in:
parent
f5cb86548f
commit
bb584dd537
11
kernel.spec
11
kernel.spec
@ -641,6 +641,8 @@ Patch25071: s390-appldata-add-slab.h-for-kzalloc-kfree.patch
|
||||
# CVE-2014-3917 rhbz 1102571 1102715
|
||||
Patch25093: auditsc-audit_krule-mask-accesses-need-bounds-checking.patch
|
||||
|
||||
Patch26000: perf-lib64.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -723,7 +725,7 @@ This package provides debug information for the perf package.
|
||||
# symlinks because of the trailing nonmatching alternation and
|
||||
# the leading .*, because of find-debuginfo.sh's buggy handling
|
||||
# of matching the pattern against the symlinks file.
|
||||
%{expand:%%global debuginfo_args %{?debuginfo_args} -p '.*%%{_bindir}/perf(\.debug)?|.*%%{_libexecdir}/perf-core/.*|XXX' -o perf-debuginfo.list}
|
||||
%{expand:%%global debuginfo_args %{?debuginfo_args} -p '.*%%{_bindir}/perf(\.debug)?|.*%%{_libexecdir}/perf-core/.*|.*%%{_libdir}/traceevent/plugins/.*|XXX' -o perf-debuginfo.list}
|
||||
|
||||
%package -n python-perf
|
||||
Summary: Python bindings for apps which will manipulate perf events
|
||||
@ -1358,6 +1360,8 @@ ApplyPatch s390-appldata-add-slab.h-for-kzalloc-kfree.patch
|
||||
# CVE-2014-3917 rhbz 1102571 1102715
|
||||
ApplyPatch auditsc-audit_krule-mask-accesses-need-bounds-checking.patch
|
||||
|
||||
ApplyPatch perf-lib64.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -1893,7 +1897,7 @@ find $RPM_BUILD_ROOT/usr/include \
|
||||
|
||||
%if %{with_perf}
|
||||
# perf tool binary and supporting scripts/binaries
|
||||
%{perf_make} DESTDIR=$RPM_BUILD_ROOT install-bin
|
||||
%{perf_make} DESTDIR=$RPM_BUILD_ROOT MULTILIBDIR=%{_lib} install-bin install-traceevent-plugins
|
||||
# remove the 'trace' symlink.
|
||||
rm -f %{buildroot}%{_bindir}/trace
|
||||
|
||||
@ -2092,6 +2096,8 @@ fi
|
||||
%files -n perf
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/perf
|
||||
%dir %{_libdir}/traceevent/plugins
|
||||
%{_libdir}/traceevent/plugins/*
|
||||
%dir %{_libexecdir}/perf-core
|
||||
%{_libexecdir}/perf-core/*
|
||||
%{_mandir}/man[1-8]/perf*
|
||||
@ -2229,6 +2235,7 @@ fi
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Jun 03 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc8.git1.1
|
||||
- Add patch to install libtraceevent plugins from Kyle McMartin
|
||||
- Linux v3.15-rc8-53-gcae61ba37b4c
|
||||
- Reenable debugging options.
|
||||
|
||||
|
17
perf-lib64.patch
Normal file
17
perf-lib64.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff --git a/tools/perf/config/Makefile b/tools/perf/config/Makefile
|
||||
index 802cf54..7f30bfa 100644
|
||||
--- a/tools/perf/config/Makefile
|
||||
+++ b/tools/perf/config/Makefile
|
||||
@@ -621,8 +621,12 @@ endif
|
||||
ifeq ($(IS_X86_64),1)
|
||||
lib = lib64
|
||||
else
|
||||
+ifdef MULTILIBDIR
|
||||
+lib = $(MULTILIBDIR)
|
||||
+else
|
||||
lib = lib
|
||||
endif
|
||||
+endif
|
||||
libdir = $(prefix)/$(lib)
|
||||
|
||||
# Shell quote (do not use $(call) to accommodate ancient setups);
|
Loading…
Reference in New Issue
Block a user