Don't clear efi_info in boot_params (rhbz 918408)
This commit is contained in:
parent
d77d603f14
commit
bb07d251d0
13
kernel.spec
13
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 3
|
%global baserelease 4
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -739,6 +739,9 @@ Patch21264: intel_pstate-Fix-intel_pstate_init-error-path.patch
|
|||||||
#rhbz 917984
|
#rhbz 917984
|
||||||
Patch21265: efi-fixes.patch
|
Patch21265: efi-fixes.patch
|
||||||
|
|
||||||
|
#rhbz 918408
|
||||||
|
Patch21266: x86-bootparams-dont-clear-efi_info.patch
|
||||||
|
|
||||||
Patch22000: weird-root-dentry-name-debug.patch
|
Patch22000: weird-root-dentry-name-debug.patch
|
||||||
|
|
||||||
#selinux ptrace child permissions
|
#selinux ptrace child permissions
|
||||||
@ -1435,6 +1438,9 @@ ApplyPatch intel_pstate-Fix-intel_pstate_init-error-path.patch
|
|||||||
#rhbz 917984
|
#rhbz 917984
|
||||||
ApplyPatch efi-fixes.patch
|
ApplyPatch efi-fixes.patch
|
||||||
|
|
||||||
|
#rhbz 918408
|
||||||
|
ApplyPatch x86-bootparams-dont-clear-efi_info.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2276,7 +2282,10 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Mar 5 2013 Peter Robinson <pbrobinson@fedoraproject.org>
|
* Wed Mar 06 2013 Josh Boyer <jwboyer@redhat.com>
|
||||||
|
- Don't clear efi_info in boot_params (rhbz 918408)
|
||||||
|
|
||||||
|
* Wed Mar 06 2013 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||||
- Update ARM mvebu config
|
- Update ARM mvebu config
|
||||||
|
|
||||||
* Wed Mar 06 2013 Dave Jones <davej@redhat.com>
|
* Wed Mar 06 2013 Dave Jones <davej@redhat.com>
|
||||||
|
13
x86-bootparams-dont-clear-efi_info.patch
Normal file
13
x86-bootparams-dont-clear-efi_info.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/arch/x86/include/asm/bootparam_utils.h b/arch/x86/include/asm/bootparam_utils.h
|
||||||
|
index 5b5e9cb..ae93f72 100644
|
||||||
|
--- a/arch/x86/include/asm/bootparam_utils.h
|
||||||
|
+++ b/arch/x86/include/asm/bootparam_utils.h
|
||||||
|
@@ -20,7 +20,7 @@ static void sanitize_boot_params(struct boot_params *boot_params)
|
||||||
|
if (boot_params->sentinel) {
|
||||||
|
/*fields in boot_params are not valid, clear them */
|
||||||
|
memset(&boot_params->olpc_ofw_header, 0,
|
||||||
|
- (char *)&boot_params->alt_mem_k -
|
||||||
|
+ (char *)&boot_params->efi_info -
|
||||||
|
(char *)&boot_params->olpc_ofw_header);
|
||||||
|
memset(&boot_params->kbd_status, 0,
|
||||||
|
(char *)&boot_params->hdr -
|
Loading…
x
Reference in New Issue
Block a user