Fix oops from incorrect rfkill set in hp-wmi (rhbz 964367)
This commit is contained in:
parent
bb35785ad6
commit
ba455ab11f
13
hp-wmi-fix-incorrect-rfkill-set-hw-state.patch
Normal file
13
hp-wmi-fix-incorrect-rfkill-set-hw-state.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/drivers/platform/x86/hp-wmi.c b/drivers/platform/x86/hp-wmi.c
|
||||||
|
index 8df0c5a..d111c86 100644
|
||||||
|
--- a/drivers/platform/x86/hp-wmi.c
|
||||||
|
+++ b/drivers/platform/x86/hp-wmi.c
|
||||||
|
@@ -703,7 +703,7 @@ static int hp_wmi_rfkill_setup(struct platform_device *device)
|
||||||
|
}
|
||||||
|
rfkill_init_sw_state(gps_rfkill,
|
||||||
|
hp_wmi_get_sw_state(HPWMI_GPS));
|
||||||
|
- rfkill_set_hw_state(bluetooth_rfkill,
|
||||||
|
+ rfkill_set_hw_state(gps_rfkill,
|
||||||
|
hp_wmi_get_hw_state(HPWMI_GPS));
|
||||||
|
err = rfkill_register(gps_rfkill);
|
||||||
|
if (err)
|
11
kernel.spec
11
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 1
|
%global baserelease 2
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -731,6 +731,9 @@ Patch23006: fix-child-thread-introspection.patch
|
|||||||
#rhbz 961527
|
#rhbz 961527
|
||||||
Patch25021: radeon-use-max_bus-speed-to-activate-gen2-speeds.patch
|
Patch25021: radeon-use-max_bus-speed-to-activate-gen2-speeds.patch
|
||||||
|
|
||||||
|
#rhbz 964367
|
||||||
|
Patch25023: hp-wmi-fix-incorrect-rfkill-set-hw-state.patch
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1409,6 +1412,9 @@ ApplyPatch fix-child-thread-introspection.patch
|
|||||||
#rhbz 961527
|
#rhbz 961527
|
||||||
ApplyPatch radeon-use-max_bus-speed-to-activate-gen2-speeds.patch
|
ApplyPatch radeon-use-max_bus-speed-to-activate-gen2-speeds.patch
|
||||||
|
|
||||||
|
#rhbz 964367
|
||||||
|
ApplyPatch hp-wmi-fix-incorrect-rfkill-set-hw-state.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2212,6 +2218,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 23 2013 Josh Boyer <jwboyer@redhat.com>
|
||||||
|
- Fix oops from incorrect rfkill set in hp-wmi (rhbz 964367)
|
||||||
|
|
||||||
* Wed May 22 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc2.git1.1
|
* Wed May 22 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc2.git1.1
|
||||||
- Linux v3.10-rc2-68-gbb3ec6b
|
- Linux v3.10-rc2-68-gbb3ec6b
|
||||||
- Reenable debugging options.
|
- Reenable debugging options.
|
||||||
|
Loading…
Reference in New Issue
Block a user