Add patch to fix ACPICA null pointer exception regression (rhbz 834318)
This commit is contained in:
parent
a9a4422683
commit
b24ad922a5
@ -0,0 +1,44 @@
|
|||||||
|
From: Bob Moore <robert.moore@intel.com>
|
||||||
|
|
||||||
|
Fixes a problem that can occur when a lone package object is
|
||||||
|
wrapped with an outer package object in order to conform to
|
||||||
|
the ACPI specification. Can affect these predefined names:
|
||||||
|
_ALR,_MLS,_PSS,_TRT,_TSS,_PRT,_HPX,_DLM,_CSD,_PSD,_TSD
|
||||||
|
|
||||||
|
https://bugzilla.kernel.org/show_bug.cgi?id=44171
|
||||||
|
|
||||||
|
Reported-by: Vlastimil Babka <caster@gentoo.org>
|
||||||
|
Signed-off-by: Bob Moore <robert.moore@intel.com>
|
||||||
|
Signed-off-by: Lin Ming <ming.m.lin@intel.com>
|
||||||
|
---
|
||||||
|
|
||||||
|
Len,
|
||||||
|
|
||||||
|
This is an important bug fix.
|
||||||
|
Could you merge it?
|
||||||
|
|
||||||
|
drivers/acpi/acpica/nspredef.c | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/acpi/acpica/nspredef.c b/drivers/acpi/acpica/nspredef.c
|
||||||
|
index 23ce096..fe66260 100644
|
||||||
|
--- a/drivers/acpi/acpica/nspredef.c
|
||||||
|
+++ b/drivers/acpi/acpica/nspredef.c
|
||||||
|
@@ -638,7 +638,7 @@ acpi_ns_check_package(struct acpi_predefined_data *data,
|
||||||
|
/* Create the new outer package and populate it */
|
||||||
|
|
||||||
|
status =
|
||||||
|
- acpi_ns_wrap_with_package(data, *elements,
|
||||||
|
+ acpi_ns_wrap_with_package(data, return_object,
|
||||||
|
return_object_ptr);
|
||||||
|
if (ACPI_FAILURE(status)) {
|
||||||
|
return (status);
|
||||||
|
--
|
||||||
|
1.7.2.5
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
--
|
||||||
|
To unsubscribe from this list: send the line "unsubscribe linux-acpi" in
|
||||||
|
the body of a message to majordomo@vger.kernel.org
|
||||||
|
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
11
kernel.spec
11
kernel.spec
@ -54,7 +54,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 5
|
%global baserelease 6
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -817,6 +817,9 @@ Patch22051: xen-blkback-Copy-id-field-when-doing-BLKIF_DISCARD.patch
|
|||||||
Patch22055: crypto-testmgr-allow-aesni-intel-and-ghash_clmulni-intel.patch
|
Patch22055: crypto-testmgr-allow-aesni-intel-and-ghash_clmulni-intel.patch
|
||||||
Patch22056: crypto-aesni-intel-fix-wrong-kfree-pointer.patch
|
Patch22056: crypto-aesni-intel-fix-wrong-kfree-pointer.patch
|
||||||
|
|
||||||
|
#rhbz 834318
|
||||||
|
Patch22057: ACPICA-Fix-possible-fault-in-return-package-object-repair-code.patch
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1520,6 +1523,9 @@ ApplyPatch xen-blkback-Copy-id-field-when-doing-BLKIF_DISCARD.patch
|
|||||||
ApplyPatch crypto-testmgr-allow-aesni-intel-and-ghash_clmulni-intel.patch
|
ApplyPatch crypto-testmgr-allow-aesni-intel-and-ghash_clmulni-intel.patch
|
||||||
ApplyPatch crypto-aesni-intel-fix-wrong-kfree-pointer.patch
|
ApplyPatch crypto-aesni-intel-fix-wrong-kfree-pointer.patch
|
||||||
|
|
||||||
|
#rhbz 834318
|
||||||
|
ApplyPatch ACPICA-Fix-possible-fault-in-return-package-object-repair-code.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2258,6 +2264,9 @@ fi
|
|||||||
# and build.
|
# and build.
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 12 2012 Josh Boyer <jwboyer@redhat.com>
|
||||||
|
- Add patch to fix ACPICA null pointer exception regression (rhbz 834318)
|
||||||
|
|
||||||
* Wed Jul 11 2012 Justin M. Forbes <jforbes@redhat.com>
|
* Wed Jul 11 2012 Justin M. Forbes <jforbes@redhat.com>
|
||||||
- Fix FIPS for aesni hardware (rhbz 839239)
|
- Fix FIPS for aesni hardware (rhbz 839239)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user