Linux v4.0-2620-gb79013b2449c

This commit is contained in:
Josh Boyer 2015-04-14 09:54:01 -04:00
parent 85afd6960d
commit b18e6e7536
23 changed files with 124 additions and 104 deletions

View File

@ -9,7 +9,7 @@ Patch for disconnect issues with storage attached to a
1 file changed, 7 insertions(+) 1 file changed, 7 insertions(+)
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index d7c3d5a35946..a1121fc01e8c 100644 index 3b7151687776..4b19e7e5bc01 100644
--- a/drivers/usb/core/hub.c --- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c +++ b/drivers/usb/core/hub.c
@@ -5006,6 +5006,13 @@ static void hub_event(struct work_struct *work) @@ -5006,6 +5006,13 @@ static void hub_event(struct work_struct *work)

View File

@ -14,7 +14,7 @@ Signed-off-by: David Howells <dhowells@redhat.com>
1 file changed, 20 insertions(+) 1 file changed, 20 insertions(+)
diff --git a/include/linux/efi.h b/include/linux/efi.h diff --git a/include/linux/efi.h b/include/linux/efi.h
index c74cbd892032..1293d0e0bf90 100644 index aa4ee20ec8bb..958d1d9a5af8 100644
--- a/include/linux/efi.h --- a/include/linux/efi.h
+++ b/include/linux/efi.h +++ b/include/linux/efi.h
@@ -589,6 +589,12 @@ void efi_native_runtime_setup(void); @@ -589,6 +589,12 @@ void efi_native_runtime_setup(void);

View File

@ -159,7 +159,7 @@ index 000000000000..424896a0b169
+ return 0; + return 0;
+} +}
diff --git a/include/linux/efi.h b/include/linux/efi.h diff --git a/include/linux/efi.h b/include/linux/efi.h
index 1293d0e0bf90..706b16fa6de8 100644 index 958d1d9a5af8..3dd6f4a51b9b 100644
--- a/include/linux/efi.h --- a/include/linux/efi.h
+++ b/include/linux/efi.h +++ b/include/linux/efi.h
@@ -925,6 +925,10 @@ extern bool efi_poweroff_required(void); @@ -925,6 +925,10 @@ extern bool efi_poweroff_required(void);

View File

@ -33,10 +33,10 @@ index 82fbdbc1e0b0..a811210ad486 100644
290/040 ALL edd_mbr_sig_buffer EDD MBR signatures 290/040 ALL edd_mbr_sig_buffer EDD MBR signatures
2D0/A00 ALL e820_map E820 memory map table 2D0/A00 ALL e820_map E820 memory map table
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
index b7d31ca55187..ab403a636357 100644 index faff6934c05a..4accc52523b4 100644
--- a/arch/x86/Kconfig --- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig +++ b/arch/x86/Kconfig
@@ -1695,6 +1695,16 @@ config EFI_MIXED @@ -1690,6 +1690,16 @@ config EFI_MIXED
If unsure, say N. If unsure, say N.
@ -115,10 +115,10 @@ index ef17683484e9..105e7360d747 100644
setup_efi_pci(boot_params); setup_efi_pci(boot_params);
diff --git a/arch/x86/include/uapi/asm/bootparam.h b/arch/x86/include/uapi/asm/bootparam.h diff --git a/arch/x86/include/uapi/asm/bootparam.h b/arch/x86/include/uapi/asm/bootparam.h
index 225b0988043a..90dbfb73e11f 100644 index ab456dc233b5..74ba4083e7ce 100644
--- a/arch/x86/include/uapi/asm/bootparam.h --- a/arch/x86/include/uapi/asm/bootparam.h
+++ b/arch/x86/include/uapi/asm/bootparam.h +++ b/arch/x86/include/uapi/asm/bootparam.h
@@ -133,7 +133,8 @@ struct boot_params { @@ -134,7 +134,8 @@ struct boot_params {
__u8 eddbuf_entries; /* 0x1e9 */ __u8 eddbuf_entries; /* 0x1e9 */
__u8 edd_mbr_sig_buf_entries; /* 0x1ea */ __u8 edd_mbr_sig_buf_entries; /* 0x1ea */
__u8 kbd_status; /* 0x1eb */ __u8 kbd_status; /* 0x1eb */
@ -129,10 +129,10 @@ index 225b0988043a..90dbfb73e11f 100644
* The sentinel is set to a nonzero value (0xff) in header.S. * The sentinel is set to a nonzero value (0xff) in header.S.
* *
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
index 0a2421cca01f..a3d8174dedf9 100644 index d74ac33290ae..88dad730e858 100644
--- a/arch/x86/kernel/setup.c --- a/arch/x86/kernel/setup.c
+++ b/arch/x86/kernel/setup.c +++ b/arch/x86/kernel/setup.c
@@ -1151,6 +1151,12 @@ void __init setup_arch(char **cmdline_p) @@ -1156,6 +1156,12 @@ void __init setup_arch(char **cmdline_p)
io_delay_init(); io_delay_init();

View File

@ -15,7 +15,7 @@ Upstream-status: Fedora mustard
7 files changed, 65 insertions(+), 10 deletions(-) 7 files changed, 65 insertions(+), 10 deletions(-)
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
index 26c5d54124c1..dab298f03a9c 100644 index d99c8c38914f..bfb77c4faae6 100644
--- a/arch/x86/kernel/setup.c --- a/arch/x86/kernel/setup.c
+++ b/arch/x86/kernel/setup.c +++ b/arch/x86/kernel/setup.c
@@ -70,6 +70,11 @@ @@ -70,6 +70,11 @@
@ -30,7 +30,7 @@ index 26c5d54124c1..dab298f03a9c 100644
#include <video/edid.h> #include <video/edid.h>
#include <asm/mtrr.h> #include <asm/mtrr.h>
@@ -1278,6 +1283,37 @@ void __init i386_reserve_resources(void) @@ -1283,6 +1288,37 @@ void __init i386_reserve_resources(void)
#endif /* CONFIG_X86_32 */ #endif /* CONFIG_X86_32 */
@ -81,10 +81,10 @@ index 421e29e4cd81..61c1eb97806c 100644
input_set_drvdata(udev->dev, udev); input_set_drvdata(udev->dev, udev);
diff --git a/drivers/tty/sysrq.c b/drivers/tty/sysrq.c diff --git a/drivers/tty/sysrq.c b/drivers/tty/sysrq.c
index 259a4d5a4e8f..512c21dcb86f 100644 index 843f2cdc280b..13a5a3843d4c 100644
--- a/drivers/tty/sysrq.c --- a/drivers/tty/sysrq.c
+++ b/drivers/tty/sysrq.c +++ b/drivers/tty/sysrq.c
@@ -464,6 +464,7 @@ static struct sysrq_key_op *sysrq_key_table[36] = { @@ -465,6 +465,7 @@ static struct sysrq_key_op *sysrq_key_table[36] = {
&sysrq_showstate_blocked_op, /* w */ &sysrq_showstate_blocked_op, /* w */
/* x: May be registered on ppc/powerpc for xmon */ /* x: May be registered on ppc/powerpc for xmon */
/* x: May be registered on sparc64 for global PMU dump */ /* x: May be registered on sparc64 for global PMU dump */
@ -92,7 +92,7 @@ index 259a4d5a4e8f..512c21dcb86f 100644
NULL, /* x */ NULL, /* x */
/* y: May be registered on sparc64 for global register dump */ /* y: May be registered on sparc64 for global register dump */
NULL, /* y */ NULL, /* y */
@@ -507,7 +508,7 @@ static void __sysrq_put_key_op(int key, struct sysrq_key_op *op_p) @@ -508,7 +509,7 @@ static void __sysrq_put_key_op(int key, struct sysrq_key_op *op_p)
sysrq_key_table[i] = op_p; sysrq_key_table[i] = op_p;
} }
@ -101,7 +101,7 @@ index 259a4d5a4e8f..512c21dcb86f 100644
{ {
struct sysrq_key_op *op_p; struct sysrq_key_op *op_p;
int orig_log_level; int orig_log_level;
@@ -527,11 +528,15 @@ void __handle_sysrq(int key, bool check_mask) @@ -528,11 +529,15 @@ void __handle_sysrq(int key, bool check_mask)
op_p = __sysrq_get_key_op(key); op_p = __sysrq_get_key_op(key);
if (op_p) { if (op_p) {
@ -118,7 +118,7 @@ index 259a4d5a4e8f..512c21dcb86f 100644
pr_cont("%s\n", op_p->action_msg); pr_cont("%s\n", op_p->action_msg);
console_loglevel = orig_log_level; console_loglevel = orig_log_level;
op_p->handler(key); op_p->handler(key);
@@ -563,7 +568,7 @@ void __handle_sysrq(int key, bool check_mask) @@ -564,7 +569,7 @@ void __handle_sysrq(int key, bool check_mask)
void handle_sysrq(int key) void handle_sysrq(int key)
{ {
if (sysrq_on()) if (sysrq_on())
@ -127,7 +127,7 @@ index 259a4d5a4e8f..512c21dcb86f 100644
} }
EXPORT_SYMBOL(handle_sysrq); EXPORT_SYMBOL(handle_sysrq);
@@ -643,7 +648,7 @@ static void sysrq_do_reset(unsigned long _state) @@ -644,7 +649,7 @@ static void sysrq_do_reset(unsigned long _state)
static void sysrq_handle_reset_request(struct sysrq_state *state) static void sysrq_handle_reset_request(struct sysrq_state *state)
{ {
if (state->reset_requested) if (state->reset_requested)
@ -136,7 +136,7 @@ index 259a4d5a4e8f..512c21dcb86f 100644
if (sysrq_reset_downtime_ms) if (sysrq_reset_downtime_ms)
mod_timer(&state->keyreset_timer, mod_timer(&state->keyreset_timer,
@@ -794,8 +799,10 @@ static bool sysrq_handle_keypress(struct sysrq_state *sysrq, @@ -795,8 +800,10 @@ static bool sysrq_handle_keypress(struct sysrq_state *sysrq,
default: default:
if (sysrq->active && value && value != 2) { if (sysrq->active && value && value != 2) {
@ -148,7 +148,7 @@ index 259a4d5a4e8f..512c21dcb86f 100644
} }
break; break;
} }
@@ -1090,7 +1097,7 @@ static ssize_t write_sysrq_trigger(struct file *file, const char __user *buf, @@ -1091,7 +1098,7 @@ static ssize_t write_sysrq_trigger(struct file *file, const char __user *buf,
if (get_user(c, buf)) if (get_user(c, buf))
return -EFAULT; return -EFAULT;

View File

@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
2 files changed, 21 insertions(+), 1 deletion(-) 2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index fbd43bfe4445..4bc89d2a3508 100644 index 9b76ce1e08bb..710c857e6450 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer @@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
@ -59,7 +59,7 @@ index fbd43bfe4445..4bc89d2a3508 100644
ifdef CONFIG_DEBUG_INFO ifdef CONFIG_DEBUG_INFO
ifdef CONFIG_DEBUG_INFO_SPLIT ifdef CONFIG_DEBUG_INFO_SPLIT
diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
index c5cefb3c009c..b663e8e211b0 100644 index 36b6fa88ce5b..74cbed113c24 100644
--- a/lib/Kconfig.debug --- a/lib/Kconfig.debug
+++ b/lib/Kconfig.debug +++ b/lib/Kconfig.debug
@@ -165,7 +165,23 @@ config DEBUG_INFO_DWARF4 @@ -165,7 +165,23 @@ config DEBUG_INFO_DWARF4

View File

@ -25,7 +25,7 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
create mode 100644 kernel/modsign_uefi.c create mode 100644 kernel/modsign_uefi.c
diff --git a/include/linux/efi.h b/include/linux/efi.h diff --git a/include/linux/efi.h b/include/linux/efi.h
index 706b16fa6de8..470e8dfcb517 100644 index 3dd6f4a51b9b..9cc069579351 100644
--- a/include/linux/efi.h --- a/include/linux/efi.h
+++ b/include/linux/efi.h +++ b/include/linux/efi.h
@@ -595,6 +595,12 @@ void efi_native_runtime_setup(void); @@ -595,6 +595,12 @@ void efi_native_runtime_setup(void);

View File

@ -15,10 +15,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
2 files changed, 2 insertions(+), 2 deletions(-) 2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
index bfcb1a62a7b4..a1d62e9ed29b 100644 index 01aa47d3b6ab..e9b48474301b 100644
--- a/Documentation/kernel-parameters.txt --- a/Documentation/kernel-parameters.txt
+++ b/Documentation/kernel-parameters.txt +++ b/Documentation/kernel-parameters.txt
@@ -3822,7 +3822,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted. @@ -3823,7 +3823,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
the allocated input device; If set to 0, video driver the allocated input device; If set to 0, video driver
will only send out the event without touching backlight will only send out the event without touching backlight
brightness level. brightness level.

View File

@ -121,6 +121,7 @@ CONFIG_MMC_DW_PLTFM=m
CONFIG_MMC_DW_PCI=m CONFIG_MMC_DW_PCI=m
CONFIG_SPI_DW_MMIO=m CONFIG_SPI_DW_MMIO=m
CONFIG_SPI_DW_PCI=m CONFIG_SPI_DW_PCI=m
# CONFIG_SPI_DW_MID_DMA is not set
# CONFIG_MMC_DW_IDMAC is not set # CONFIG_MMC_DW_IDMAC is not set
# CONFIG_MMC_DW_K3 is not set # CONFIG_MMC_DW_K3 is not set
# CONFIG_MMC_QCOM_DML is not set # CONFIG_MMC_QCOM_DML is not set

View File

@ -167,3 +167,5 @@ CONFIG_SATA_AHCI_PLATFORM=y
CONFIG_DEBUG_SECTION_MISMATCH=y CONFIG_DEBUG_SECTION_MISMATCH=y
CONFIG_EDAC_XGENE=y CONFIG_EDAC_XGENE=y
# CONFIG_FSL_MC_BUS is not set

View File

@ -102,6 +102,7 @@ CONFIG_DMA_OMAP=m
CONFIG_OMAP_IOMMU=y CONFIG_OMAP_IOMMU=y
CONFIG_HWSPINLOCK_OMAP=m CONFIG_HWSPINLOCK_OMAP=m
# CONFIG_OMAP3_SDRC_AC_TIMING is not set # CONFIG_OMAP3_SDRC_AC_TIMING is not set
CONFIG_PHY_DM816X_USB=m
CONFIG_SERIAL_OMAP=y CONFIG_SERIAL_OMAP=y
CONFIG_SERIAL_OMAP_CONSOLE=y CONFIG_SERIAL_OMAP_CONSOLE=y

View File

@ -143,6 +143,7 @@ CONFIG_UACCESS_WITH_MEMCPY=y
CONFIG_PCI_HOST_GENERIC=y CONFIG_PCI_HOST_GENERIC=y
# CONFIG_PCI_LAYERSCAPE is not set # CONFIG_PCI_LAYERSCAPE is not set
# CONFIG_PCIE_IPROC is not set
CONFIG_LBDAF=y CONFIG_LBDAF=y
@ -192,6 +193,7 @@ CONFIG_STMMAC_PLATFORM=m
CONFIG_EEPROM_SUNXI_SID=m CONFIG_EEPROM_SUNXI_SID=m
CONFIG_RTC_DRV_SUNXI=m CONFIG_RTC_DRV_SUNXI=m
CONFIG_PHY_SUN4I_USB=m CONFIG_PHY_SUN4I_USB=m
# CONFIG_PHY_SUN9I_USB is not set
CONFIG_AHCI_SUNXI=m CONFIG_AHCI_SUNXI=m
CONFIG_SPI_SUN4I=m CONFIG_SPI_SUN4I=m
CONFIG_SPI_SUN6I=m CONFIG_SPI_SUN6I=m
@ -201,6 +203,7 @@ CONFIG_GPIO_PCA953X=m
CONFIG_TOUCHSCREEN_SUN4I=m CONFIG_TOUCHSCREEN_SUN4I=m
CONFIG_MFD_AXP20X=y CONFIG_MFD_AXP20X=y
CONFIG_REGULATOR_AXP20X=m CONFIG_REGULATOR_AXP20X=m
CONFIG_AXP288_FUEL_GAUGE=m
CONFIG_IR_SUNXI=m CONFIG_IR_SUNXI=m
CONFIG_MDIO_SUN4I=m CONFIG_MDIO_SUN4I=m
CONFIG_SUN4I_EMAC=m CONFIG_SUN4I_EMAC=m
@ -445,6 +448,7 @@ CONFIG_USB_CONFIGFS_SERIAL=y
# CONFIG_USB_CONFIGFS_F_MIDI is not set # CONFIG_USB_CONFIGFS_F_MIDI is not set
# CONFIG_USB_CONFIGFS_F_HID is not set # CONFIG_USB_CONFIGFS_F_HID is not set
# CONFIG_USB_CONFIGFS_F_UVC is not set # CONFIG_USB_CONFIGFS_F_UVC is not set
# CONFIG_USB_CONFIGFS_F_PRINTER is not set
# CONFIG_USB_GADGET_DEBUG is not set # CONFIG_USB_GADGET_DEBUG is not set
# CONFIG_USB_GADGET_DEBUG_FILES is not set # CONFIG_USB_GADGET_DEBUG_FILES is not set

View File

@ -1714,13 +1714,13 @@ CONFIG_B43_PCMCIA=y
CONFIG_B43_SDIO=y CONFIG_B43_SDIO=y
CONFIG_B43_BCMA=y CONFIG_B43_BCMA=y
CONFIG_B43_BCMA_PIO=y CONFIG_B43_BCMA_PIO=y
# CONFIG_B43_DEBUG is not set CONFIG_B43_DEBUG=y
CONFIG_B43_PHY_LP=y CONFIG_B43_PHY_LP=y
CONFIG_B43_PHY_N=y CONFIG_B43_PHY_N=y
CONFIG_B43_PHY_HT=y CONFIG_B43_PHY_HT=y
CONFIG_B43_PHY_G=y CONFIG_B43_PHY_G=y
CONFIG_B43LEGACY=m CONFIG_B43LEGACY=m
# CONFIG_B43LEGACY_DEBUG is not set CONFIG_B43LEGACY_DEBUG=y
CONFIG_B43LEGACY_DMA=y CONFIG_B43LEGACY_DMA=y
CONFIG_B43LEGACY_PIO=y CONFIG_B43LEGACY_PIO=y
CONFIG_B43LEGACY_DMA_AND_PIO_MODE=y CONFIG_B43LEGACY_DMA_AND_PIO_MODE=y
@ -2573,6 +2573,7 @@ CONFIG_SENSORS_MCP3021=m
CONFIG_SENSORS_NCT6775=m CONFIG_SENSORS_NCT6775=m
CONFIG_SENSORS_NCT6683=m CONFIG_SENSORS_NCT6683=m
CONFIG_SENSORS_NCT7802=m CONFIG_SENSORS_NCT7802=m
CONFIG_SENSORS_NCT7904=m
CONFIG_SENSORS_NTC_THERMISTOR=m CONFIG_SENSORS_NTC_THERMISTOR=m
CONFIG_SENSORS_PC87360=m CONFIG_SENSORS_PC87360=m
CONFIG_SENSORS_PC87427=m CONFIG_SENSORS_PC87427=m
@ -2688,6 +2689,7 @@ CONFIG_HID_SENSOR_IIO_TRIGGER=m
# CONFIG_APDS9300 is not set # CONFIG_APDS9300 is not set
CONFIG_CM32181=m CONFIG_CM32181=m
# CONFIG_CM3232 is not set # CONFIG_CM3232 is not set
# CONFIG_CM3323 is not set
# CONFIG_CM36651 is not set # CONFIG_CM36651 is not set
# CONFIG_GP2AP020A00F is not set # CONFIG_GP2AP020A00F is not set
# CONFIG_TSL2583 is not set # CONFIG_TSL2583 is not set
@ -2756,6 +2758,7 @@ CONFIG_HID_SENSOR_DEVICE_ROTATION=m
# CONFIG_ADIS16480 is not set # CONFIG_ADIS16480 is not set
# CONFIG_DHT11 is not set # CONFIG_DHT11 is not set
# CONFIG_MPL3115 is not set # CONFIG_MPL3115 is not set
# CONFIG_MS5611 is not set
# CONFIG_MPL115 is not set # CONFIG_MPL115 is not set
# CONFIG_SI7005 is not set # CONFIG_SI7005 is not set
# CONFIG_SI7020 is not set # CONFIG_SI7020 is not set
@ -3992,6 +3995,7 @@ CONFIG_USB_YUREX=m
CONFIG_USB_EZUSB_FX2=m CONFIG_USB_EZUSB_FX2=m
CONFIG_USB_HSIC_USB3503=m CONFIG_USB_HSIC_USB3503=m
# CONFIG_USB_LINK_LAYER_TEST is not set # CONFIG_USB_LINK_LAYER_TEST is not set
CONFIG_USB_CHAOSKEY=m
CONFIG_USB_LCD=m CONFIG_USB_LCD=m
CONFIG_USB_LD=m CONFIG_USB_LD=m
CONFIG_USB_LEGOTOWER=m CONFIG_USB_LEGOTOWER=m
@ -4767,7 +4771,7 @@ CONFIG_PM_DEBUG=y
# CONFIG_DPM_WATCHDOG is not set # revisit this in debug # CONFIG_DPM_WATCHDOG is not set # revisit this in debug
CONFIG_PM_TRACE=y CONFIG_PM_TRACE=y
CONFIG_PM_TRACE_RTC=y CONFIG_PM_TRACE_RTC=y
# CONFIG_PM_TEST_SUSPEND is not set CONFIG_PM_TEST_SUSPEND=y
# CONFIG_PM_OPP is not set # CONFIG_PM_OPP is not set
# CONFIG_PM_AUTOSLEEP is not set # CONFIG_PM_AUTOSLEEP is not set
# CONFIG_PM_WAKELOCKS is not set # CONFIG_PM_WAKELOCKS is not set
@ -4991,6 +4995,7 @@ CONFIG_HZ_1000=y
CONFIG_NO_HZ=y CONFIG_NO_HZ=y
# CONFIG_SCHED_STACK_END_CHECK is not set # CONFIG_SCHED_STACK_END_CHECK is not set
# CONFIG_DEBUG_TIMEKEEPING is not set
CONFIG_TIMER_STATS=y CONFIG_TIMER_STATS=y
CONFIG_HIGH_RES_TIMERS=y CONFIG_HIGH_RES_TIMERS=y
CONFIG_PERF_EVENTS=y CONFIG_PERF_EVENTS=y
@ -5033,6 +5038,7 @@ CONFIG_APM_POWER=m
CONFIG_POWER_RESET=y CONFIG_POWER_RESET=y
# CONFIG_POWER_RESET_LTC2952 is not set # CONFIG_POWER_RESET_LTC2952 is not set
# CONFIG_POWER_RESET_SYSCON is not set # CONFIG_POWER_RESET_SYSCON is not set
# CONFIG_POWER_RESET_SYSCON_POWEROFF is not set
# CONFIG_BATTERY_GAUGE_LTC2941 is not set # CONFIG_BATTERY_GAUGE_LTC2941 is not set
# CONFIG_POWER_RESET_RESTART is not set # CONFIG_POWER_RESET_RESTART is not set
@ -5213,6 +5219,7 @@ CONFIG_USBIP_HOST=m
# CONFIG_DVB_MN88473 is not set # CONFIG_DVB_MN88473 is not set
# CONFIG_FB_SM7XX is not set # CONFIG_FB_SM7XX is not set
# CONFIG_FB_TFT is not set # CONFIG_FB_TFT is not set
# CONFIG_FB_SM750 is not set
# END OF STAGING # END OF STAGING
# #

View File

@ -2,100 +2,100 @@ CONFIG_SND_VERBOSE_PRINTK=y
CONFIG_SND_DEBUG=y CONFIG_SND_DEBUG=y
CONFIG_SND_PCM_XRUN_DEBUG=y CONFIG_SND_PCM_XRUN_DEBUG=y
# CONFIG_DEBUG_ATOMIC_SLEEP is not set CONFIG_DEBUG_ATOMIC_SLEEP=y
# CONFIG_DEBUG_MUTEXES is not set CONFIG_DEBUG_MUTEXES=y
# CONFIG_DEBUG_RT_MUTEXES is not set CONFIG_DEBUG_RT_MUTEXES=y
# CONFIG_DEBUG_LOCK_ALLOC is not set CONFIG_DEBUG_LOCK_ALLOC=y
# CONFIG_LOCK_TORTURE_TEST is not set CONFIG_LOCK_TORTURE_TEST=m
# CONFIG_PROVE_LOCKING is not set CONFIG_PROVE_LOCKING=y
# CONFIG_DEBUG_SPINLOCK is not set CONFIG_DEBUG_SPINLOCK=y
# CONFIG_PROVE_RCU is not set CONFIG_PROVE_RCU=y
# CONFIG_PROVE_RCU_REPEATEDLY is not set # CONFIG_PROVE_RCU_REPEATEDLY is not set
# CONFIG_DEBUG_PER_CPU_MAPS is not set CONFIG_DEBUG_PER_CPU_MAPS=y
CONFIG_CPUMASK_OFFSTACK=y CONFIG_CPUMASK_OFFSTACK=y
# CONFIG_CPU_NOTIFIER_ERROR_INJECT is not set CONFIG_CPU_NOTIFIER_ERROR_INJECT=m
# CONFIG_FAULT_INJECTION is not set CONFIG_FAULT_INJECTION=y
# CONFIG_FAILSLAB is not set CONFIG_FAILSLAB=y
# CONFIG_FAIL_PAGE_ALLOC is not set CONFIG_FAIL_PAGE_ALLOC=y
# CONFIG_FAIL_MAKE_REQUEST is not set CONFIG_FAIL_MAKE_REQUEST=y
# CONFIG_FAULT_INJECTION_DEBUG_FS is not set CONFIG_FAULT_INJECTION_DEBUG_FS=y
# CONFIG_FAULT_INJECTION_STACKTRACE_FILTER is not set CONFIG_FAULT_INJECTION_STACKTRACE_FILTER=y
# CONFIG_FAIL_IO_TIMEOUT is not set CONFIG_FAIL_IO_TIMEOUT=y
# CONFIG_FAIL_MMC_REQUEST is not set CONFIG_FAIL_MMC_REQUEST=y
# CONFIG_LOCK_STAT is not set CONFIG_LOCK_STAT=y
# CONFIG_DEBUG_STACK_USAGE is not set CONFIG_DEBUG_STACK_USAGE=y
# CONFIG_ACPI_DEBUG is not set CONFIG_ACPI_DEBUG=y
# CONFIG_DEBUG_SG is not set CONFIG_DEBUG_SG=y
# CONFIG_DEBUG_PI_LIST is not set CONFIG_DEBUG_PI_LIST=y
# CONFIG_PAGE_EXTENSION is not set # CONFIG_PAGE_EXTENSION is not set
# CONFIG_PAGE_OWNER is not set # CONFIG_PAGE_OWNER is not set
# CONFIG_DEBUG_PAGEALLOC is not set # CONFIG_DEBUG_PAGEALLOC is not set
# CONFIG_DEBUG_OBJECTS is not set CONFIG_DEBUG_OBJECTS=y
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set # CONFIG_DEBUG_OBJECTS_SELFTEST is not set
# CONFIG_DEBUG_OBJECTS_FREE is not set CONFIG_DEBUG_OBJECTS_FREE=y
# CONFIG_DEBUG_OBJECTS_TIMERS is not set CONFIG_DEBUG_OBJECTS_TIMERS=y
# CONFIG_DEBUG_OBJECTS_RCU_HEAD is not set CONFIG_DEBUG_OBJECTS_RCU_HEAD=y
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1 CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
CONFIG_X86_PTDUMP=y CONFIG_X86_PTDUMP=y
# CONFIG_ARM64_PTDUMP is not set CONFIG_ARM64_PTDUMP=y
# CONFIG_EFI_PGT_DUMP is not set CONFIG_EFI_PGT_DUMP=y
# CONFIG_CAN_DEBUG_DEVICES is not set CONFIG_CAN_DEBUG_DEVICES=y
# CONFIG_MODULE_FORCE_UNLOAD is not set CONFIG_MODULE_FORCE_UNLOAD=y
# CONFIG_DEBUG_NOTIFIERS is not set CONFIG_DEBUG_NOTIFIERS=y
# CONFIG_DMA_API_DEBUG is not set CONFIG_DMA_API_DEBUG=y
# CONFIG_MMIOTRACE is not set CONFIG_MMIOTRACE=y
# CONFIG_DEBUG_CREDENTIALS is not set CONFIG_DEBUG_CREDENTIALS=y
# off in both production debug and nodebug builds, # off in both production debug and nodebug builds,
# on in rawhide nodebug builds # on in rawhide nodebug builds
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
# CONFIG_EXT4_DEBUG is not set CONFIG_EXT4_DEBUG=y
# CONFIG_XFS_WARN is not set # CONFIG_XFS_WARN is not set
# CONFIG_DEBUG_PERF_USE_VMALLOC is not set CONFIG_DEBUG_PERF_USE_VMALLOC=y
# CONFIG_JBD2_DEBUG is not set CONFIG_JBD2_DEBUG=y
# CONFIG_NFSD_FAULT_INJECTION is not set CONFIG_NFSD_FAULT_INJECTION=y
# CONFIG_DEBUG_BLK_CGROUP is not set CONFIG_DEBUG_BLK_CGROUP=y
# CONFIG_DRBD_FAULT_INJECTION is not set CONFIG_DRBD_FAULT_INJECTION=y
# CONFIG_ATH_DEBUG is not set CONFIG_ATH_DEBUG=y
# CONFIG_CARL9170_DEBUGFS is not set CONFIG_CARL9170_DEBUGFS=y
# CONFIG_IWLWIFI_DEVICE_TRACING is not set CONFIG_IWLWIFI_DEVICE_TRACING=y
# CONFIG_RTLWIFI_DEBUG is not set # CONFIG_RTLWIFI_DEBUG is not set
# CONFIG_DEBUG_OBJECTS_WORK is not set CONFIG_DEBUG_OBJECTS_WORK=y
# CONFIG_DMADEVICES_DEBUG is not set CONFIG_DMADEVICES_DEBUG=y
# CONFIG_DMADEVICES_VDEBUG is not set CONFIG_DMADEVICES_VDEBUG=y
CONFIG_PM_ADVANCED_DEBUG=y CONFIG_PM_ADVANCED_DEBUG=y
# CONFIG_CEPH_LIB_PRETTYDEBUG is not set CONFIG_CEPH_LIB_PRETTYDEBUG=y
# CONFIG_QUOTA_DEBUG is not set CONFIG_QUOTA_DEBUG=y
CONFIG_KGDB_KDB=y CONFIG_KGDB_KDB=y
@ -103,18 +103,18 @@ CONFIG_KDB_DEFAULT_ENABLE=0x0
CONFIG_KDB_KEYBOARD=y CONFIG_KDB_KEYBOARD=y
CONFIG_KDB_CONTINUE_CATASTROPHIC=0 CONFIG_KDB_CONTINUE_CATASTROPHIC=0
# CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER is not set CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
# CONFIG_PERCPU_TEST is not set # CONFIG_PERCPU_TEST is not set
# CONFIG_TEST_LIST_SORT is not set CONFIG_TEST_LIST_SORT=y
# CONFIG_TEST_STRING_HELPERS is not set # CONFIG_TEST_STRING_HELPERS is not set
# CONFIG_DETECT_HUNG_TASK is not set CONFIG_DETECT_HUNG_TASK=y
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120 CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set # CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
# CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK is not set CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK=y
# CONFIG_DEBUG_KMEMLEAK is not set CONFIG_DEBUG_KMEMLEAK=y
CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=1024 CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=1024
# CONFIG_DEBUG_KMEMLEAK_TEST is not set # CONFIG_DEBUG_KMEMLEAK_TEST is not set
CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
@ -125,7 +125,7 @@ CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
# CONFIG_SPI_DEBUG is not set # CONFIG_SPI_DEBUG is not set
# CONFIG_X86_DEBUG_STATIC_CPU_HAS is not set CONFIG_X86_DEBUG_STATIC_CPU_HAS=y
# CONFIG_SCHEDSTATS is not set # CONFIG_SCHEDSTATS is not set
# CONFIG_LATENCYTOP is not set # CONFIG_LATENCYTOP is not set

View File

@ -346,7 +346,7 @@ CONFIG_SP5100_TCO=m
# CONFIG_MEMTEST is not set # CONFIG_MEMTEST is not set
# CONFIG_DEBUG_TLBFLUSH is not set # CONFIG_DEBUG_TLBFLUSH is not set
# CONFIG_MAXSMP is not set CONFIG_MAXSMP=y
CONFIG_HP_ILO=m CONFIG_HP_ILO=m

View File

@ -12,10 +12,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
2 files changed, 3 insertions(+) 2 files changed, 3 insertions(+)
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
index a3d8174dedf9..26c5d54124c1 100644 index 88dad730e858..d99c8c38914f 100644
--- a/arch/x86/kernel/setup.c --- a/arch/x86/kernel/setup.c
+++ b/arch/x86/kernel/setup.c +++ b/arch/x86/kernel/setup.c
@@ -1153,7 +1153,9 @@ void __init setup_arch(char **cmdline_p) @@ -1158,7 +1158,9 @@ void __init setup_arch(char **cmdline_p)
#ifdef CONFIG_EFI_SECURE_BOOT_SIG_ENFORCE #ifdef CONFIG_EFI_SECURE_BOOT_SIG_ENFORCE
if (boot_params.secure_boot) { if (boot_params.secure_boot) {
@ -26,14 +26,14 @@ index a3d8174dedf9..26c5d54124c1 100644
#endif #endif
diff --git a/include/linux/efi.h b/include/linux/efi.h diff --git a/include/linux/efi.h b/include/linux/efi.h
index cf7e431cbc73..c74cbd892032 100644 index af5be0368dec..aa4ee20ec8bb 100644
--- a/include/linux/efi.h --- a/include/linux/efi.h
+++ b/include/linux/efi.h +++ b/include/linux/efi.h
@@ -942,6 +942,7 @@ extern int __init efi_setup_pcdp_console(char *); @@ -943,6 +943,7 @@ extern int __init efi_setup_pcdp_console(char *);
#define EFI_64BIT 5 /* Is the firmware 64-bit? */
#define EFI_PARAVIRT 6 /* Access is via a paravirt interface */ #define EFI_PARAVIRT 6 /* Access is via a paravirt interface */
#define EFI_ARCH_1 7 /* First arch-specific bit */ #define EFI_ARCH_1 7 /* First arch-specific bit */
+#define EFI_SECURE_BOOT 8 /* Are we in Secure Boot mode? */ #define EFI_DBG 8 /* Print additional debug info at runtime */
+#define EFI_SECURE_BOOT 9 /* Are we in Secure Boot mode? */
#ifdef CONFIG_EFI #ifdef CONFIG_EFI
/* /*

View File

@ -123,13 +123,13 @@ index 000000000000..6e431d1a4e79
+ 6 - Battery power event + 6 - Battery power event
+ +
diff --git a/arch/x86/platform/efi/efi.c b/arch/x86/platform/efi/efi.c diff --git a/arch/x86/platform/efi/efi.c b/arch/x86/platform/efi/efi.c
index dbc8627a5cdf..b4c9fbbc9270 100644 index 02744df576d5..3b984c3aa1b0 100644
--- a/arch/x86/platform/efi/efi.c --- a/arch/x86/platform/efi/efi.c
+++ b/arch/x86/platform/efi/efi.c +++ b/arch/x86/platform/efi/efi.c
@@ -492,6 +492,8 @@ void __init efi_init(void) @@ -501,6 +501,8 @@ void __init efi_init(void)
return;
print_efi_memmap(); if (efi_enabled(EFI_DBG))
print_efi_memmap();
+ +
+ efi_esrt_init(); + efi_esrt_init();
} }
@ -733,7 +733,7 @@ index 000000000000..20c0cbdb1c60
+MODULE_DESCRIPTION("EFI System Resource Table support"); +MODULE_DESCRIPTION("EFI System Resource Table support");
+MODULE_LICENSE("GPL"); +MODULE_LICENSE("GPL");
diff --git a/include/linux/efi.h b/include/linux/efi.h diff --git a/include/linux/efi.h b/include/linux/efi.h
index 470e8dfcb517..c15e1de5273c 100644 index 9cc069579351..fa3546989ab0 100644
--- a/include/linux/efi.h --- a/include/linux/efi.h
+++ b/include/linux/efi.h +++ b/include/linux/efi.h
@@ -583,6 +583,9 @@ void efi_native_runtime_setup(void); @@ -583,6 +583,9 @@ void efi_native_runtime_setup(void);

View File

@ -11,10 +11,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
1 file changed, 2 insertions(+), 1 deletion(-) 1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
index ab403a636357..5dac78119fa7 100644 index 4accc52523b4..7d852306b245 100644
--- a/arch/x86/Kconfig --- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig +++ b/arch/x86/Kconfig
@@ -1696,7 +1696,8 @@ config EFI_MIXED @@ -1691,7 +1691,8 @@ config EFI_MIXED
If unsure, say N. If unsure, say N.
config EFI_SECURE_BOOT_SIG_ENFORCE config EFI_SECURE_BOOT_SIG_ENFORCE

View File

@ -90,7 +90,7 @@ index 2a8ddfd12a5b..452ca53561fe 100644
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $< cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
diff --git a/arch/x86/vdso/Makefile b/arch/x86/vdso/Makefile diff --git a/arch/x86/vdso/Makefile b/arch/x86/vdso/Makefile
index 7b9be9822724..c4c5d4ae3dad 100644 index 275a3a8b78af..a4430446630c 100644
--- a/arch/x86/vdso/Makefile --- a/arch/x86/vdso/Makefile
+++ b/arch/x86/vdso/Makefile +++ b/arch/x86/vdso/Makefile
@@ -172,8 +172,9 @@ $(vdso32-images:%=$(obj)/%.dbg): $(obj)/vdso32-%.so.dbg: FORCE \ @@ -172,8 +172,9 @@ $(vdso32-images:%=$(obj)/%.dbg): $(obj)/vdso32-%.so.dbg: FORCE \

View File

@ -6,7 +6,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1. For rawhide # For a stable, released kernel, released_kernel should be 1. For rawhide
# and/or a kernel built from an rc or git snapshot, released_kernel should # and/or a kernel built from an rc or git snapshot, released_kernel should
# be 0. # be 0.
%global released_kernel 1 %global released_kernel 0
# Sign modules on x86. Make sure the config files match this setting if more # Sign modules on x86. Make sure the config files match this setting if more
# architectures are added. # architectures are added.
@ -67,7 +67,7 @@ Summary: The Linux kernel
# The rc snapshot level # The rc snapshot level
%define rcrev 0 %define rcrev 0
# The git snapshot level # The git snapshot level
%define gitrev 0 %define gitrev 1
# Set rpm version accordingly # Set rpm version accordingly
%define rpmversion 4.%{upstream_sublevel}.0 %define rpmversion 4.%{upstream_sublevel}.0
%endif %endif
@ -122,7 +122,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels) # Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels). # and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'. # See also 'make debug' and 'make release'.
%define debugbuildsenabled 1 %define debugbuildsenabled 0
# Want to build a vanilla kernel build without any non-upstream patches? # Want to build a vanilla kernel build without any non-upstream patches?
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0} %define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
@ -2213,6 +2213,10 @@ fi
# #
# #
%changelog %changelog
* Tue Apr 14 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc0.git1.1
- Linux v4.0-2620-gb79013b2449c
- Reenable debugging options.
* Sun Apr 12 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.0.0-1 * Sun Apr 12 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.0.0-1
- Linux v4.0 - Linux v4.0

View File

@ -1,2 +1,3 @@
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
0f72b6741e011d55ce7c9ff8207da113 patch-4.0-git1.xz

View File

@ -13,10 +13,10 @@ Signed-off-by: Mark Langsdorf <mlangsdo@redhat.com>
1 file changed, 7 insertions(+), 8 deletions(-) 1 file changed, 7 insertions(+), 8 deletions(-)
diff --git a/drivers/usb/host/xhci-plat.c b/drivers/usb/host/xhci-plat.c diff --git a/drivers/usb/host/xhci-plat.c b/drivers/usb/host/xhci-plat.c
index 0e11d61408ff..cc5ca2cac706 100644 index 783e819139a7..4f93ef6942d8 100644
--- a/drivers/usb/host/xhci-plat.c --- a/drivers/usb/host/xhci-plat.c
+++ b/drivers/usb/host/xhci-plat.c +++ b/drivers/usb/host/xhci-plat.c
@@ -83,14 +83,13 @@ static int xhci_plat_probe(struct platform_device *pdev) @@ -84,14 +84,13 @@ static int xhci_plat_probe(struct platform_device *pdev)
if (irq < 0) if (irq < 0)
return -ENODEV; return -ENODEV;

View File

@ -14,7 +14,7 @@ Signed-off-by: Matthew Garrett <matthew.garrett@nebula.com>
2 files changed, 7 insertions(+), 2 deletions(-) 2 files changed, 7 insertions(+), 2 deletions(-)
diff --git a/arch/x86/kernel/ioport.c b/arch/x86/kernel/ioport.c diff --git a/arch/x86/kernel/ioport.c b/arch/x86/kernel/ioport.c
index 4ddaf66ea35f..00b440307419 100644 index 37dae792dbbe..1ecc03ca3c15 100644
--- a/arch/x86/kernel/ioport.c --- a/arch/x86/kernel/ioport.c
+++ b/arch/x86/kernel/ioport.c +++ b/arch/x86/kernel/ioport.c
@@ -15,6 +15,7 @@ @@ -15,6 +15,7 @@