Merge remote-tracking branch 'up/f38' into f38-riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
commit
b1430c9d82
19
kernel.spec
19
kernel.spec
@ -160,18 +160,18 @@ Summary: The Linux kernel
|
|||||||
# the --with-release option overrides this setting.)
|
# the --with-release option overrides this setting.)
|
||||||
%define debugbuildsenabled 1
|
%define debugbuildsenabled 1
|
||||||
# define buildid .local
|
# define buildid .local
|
||||||
%define specrpmversion 6.6.3
|
%define specrpmversion 6.6.4
|
||||||
%define specversion 6.6.3
|
%define specversion 6.6.4
|
||||||
%define patchversion 6.6
|
%define patchversion 6.6
|
||||||
%define pkgrelease 100
|
%define pkgrelease 100
|
||||||
%define kversion 6
|
%define kversion 6
|
||||||
%define tarfile_release 6.6.3
|
%define tarfile_release 6.6.4
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 6
|
%define patchlevel 6
|
||||||
# This allows pkg_release to have configurable %%{?dist} tag
|
# This allows pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 100%{?buildid}.0.riscv64%{?dist}
|
%define specrelease 100%{?buildid}.0.riscv64%{?dist}
|
||||||
# This defines the kabi tarball version
|
# This defines the kabi tarball version
|
||||||
%define kabiversion 6.6.3
|
%define kabiversion 6.6.4
|
||||||
|
|
||||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||||
# fatal kernel package build error
|
# fatal kernel package build error
|
||||||
@ -792,7 +792,7 @@ BuildRequires: binutils
|
|||||||
BuildRequires: lvm2
|
BuildRequires: lvm2
|
||||||
BuildRequires: systemd-boot-unsigned
|
BuildRequires: systemd-boot-unsigned
|
||||||
# For systemd-stub and systemd-pcrphase
|
# For systemd-stub and systemd-pcrphase
|
||||||
BuildRequires: systemd-udev >= 252-1
|
BuildRequires: systemd-udev
|
||||||
# For TPM operations in UKI initramfs
|
# For TPM operations in UKI initramfs
|
||||||
BuildRequires: tpm2-tools
|
BuildRequires: tpm2-tools
|
||||||
%endif
|
%endif
|
||||||
@ -1521,7 +1521,7 @@ Provides: installonlypkg(kernel)\
|
|||||||
Provides: kernel-%{?1:%{1}-}uname-r = %{KVERREL}%{uname_suffix %{?1:+%{1}}}\
|
Provides: kernel-%{?1:%{1}-}uname-r = %{KVERREL}%{uname_suffix %{?1:+%{1}}}\
|
||||||
Requires: kernel%{?1:-%{1}}-modules-core-uname-r = %{KVERREL}%{uname_suffix %{?1:+%{1}}}\
|
Requires: kernel%{?1:-%{1}}-modules-core-uname-r = %{KVERREL}%{uname_suffix %{?1:+%{1}}}\
|
||||||
Requires(pre): %{kernel_prereq}\
|
Requires(pre): %{kernel_prereq}\
|
||||||
Requires(pre): systemd >= 254-1\
|
Requires(pre): systemd\
|
||||||
%endif\
|
%endif\
|
||||||
%endif\
|
%endif\
|
||||||
%if %{with_gcov}\
|
%if %{with_gcov}\
|
||||||
@ -3722,9 +3722,14 @@ fi\
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Nov 29 2023 David Abdurachmanov <davidlt@rivosinc.com> [6.6.3-0.0.riscv64]
|
* Sun Dec 03 2023 David Abdurachmanov <davidlt@rivosinc.com> [6.6.4-0.0.riscv64]
|
||||||
- Add support for riscv64
|
- Add support for riscv64
|
||||||
|
|
||||||
|
* Sun Dec 03 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.6.4-0]
|
||||||
|
- redhat: Fix macro for kernel-uki-virt flavor (Neal Gompa)
|
||||||
|
- Change the uki reqs for Fedora (Justin M. Forbes)
|
||||||
|
- Linux v6.6.4
|
||||||
|
|
||||||
* Tue Nov 28 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.6.3-0]
|
* Tue Nov 28 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.6.3-0]
|
||||||
- Add BugsFixed for 6.6.3 (Justin M. Forbes)
|
- Add BugsFixed for 6.6.3 (Justin M. Forbes)
|
||||||
- Update BugsFixed (Justin M. Forbes)
|
- Update BugsFixed (Justin M. Forbes)
|
||||||
|
@ -3,9 +3,7 @@
|
|||||||
arch/s390/kernel/ipl.c | 5 +
|
arch/s390/kernel/ipl.c | 5 +
|
||||||
arch/s390/kernel/setup.c | 4 +
|
arch/s390/kernel/setup.c | 4 +
|
||||||
arch/x86/kernel/setup.c | 22 ++-
|
arch/x86/kernel/setup.c | 22 ++-
|
||||||
drivers/acpi/acpi_video.c | 2 +-
|
|
||||||
drivers/acpi/apei/hest.c | 8 +
|
drivers/acpi/apei/hest.c | 8 +
|
||||||
drivers/acpi/device_pm.c | 13 ++
|
|
||||||
drivers/acpi/irq.c | 17 +-
|
drivers/acpi/irq.c | 17 +-
|
||||||
drivers/acpi/scan.c | 9 ++
|
drivers/acpi/scan.c | 9 ++
|
||||||
drivers/ata/libahci.c | 18 +++
|
drivers/ata/libahci.c | 18 +++
|
||||||
@ -23,7 +21,6 @@
|
|||||||
drivers/rtc/rtc-cmos.c | 18 ++-
|
drivers/rtc/rtc-cmos.c | 18 ++-
|
||||||
drivers/scsi/sd.c | 10 ++
|
drivers/scsi/sd.c | 10 ++
|
||||||
drivers/usb/core/hub.c | 7 +
|
drivers/usb/core/hub.c | 7 +
|
||||||
include/acpi/acpi_bus.h | 1 +
|
|
||||||
include/linux/efi.h | 22 ++-
|
include/linux/efi.h | 22 ++-
|
||||||
include/linux/lsm_hook_defs.h | 2 +
|
include/linux/lsm_hook_defs.h | 2 +
|
||||||
include/linux/module.h | 1 +
|
include/linux/module.h | 1 +
|
||||||
@ -38,10 +35,10 @@
|
|||||||
security/lockdown/Kconfig | 13 ++
|
security/lockdown/Kconfig | 13 ++
|
||||||
security/lockdown/lockdown.c | 1 +
|
security/lockdown/lockdown.c | 1 +
|
||||||
security/security.c | 12 ++
|
security/security.c | 12 ++
|
||||||
40 files changed, 696 insertions(+), 182 deletions(-)
|
37 files changed, 681 insertions(+), 181 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 8ecebeb5642c..d2ae44a64210 100644
|
index cbe63ba9126e..07635f242c3d 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||||
@ -91,10 +88,10 @@ index b0d00032479d..afb9544fb007 100644
|
|||||||
/*
|
/*
|
||||||
* DIAG 308 support
|
* DIAG 308 support
|
||||||
diff --git a/arch/s390/kernel/ipl.c b/arch/s390/kernel/ipl.c
|
diff --git a/arch/s390/kernel/ipl.c b/arch/s390/kernel/ipl.c
|
||||||
index 05e51666db03..454a33b77878 100644
|
index 8d0b95c17312..118ae555a179 100644
|
||||||
--- a/arch/s390/kernel/ipl.c
|
--- a/arch/s390/kernel/ipl.c
|
||||||
+++ b/arch/s390/kernel/ipl.c
|
+++ b/arch/s390/kernel/ipl.c
|
||||||
@@ -2519,3 +2519,8 @@ int ipl_report_free(struct ipl_report *report)
|
@@ -2520,3 +2520,8 @@ int ipl_report_free(struct ipl_report *report)
|
||||||
}
|
}
|
||||||
|
|
||||||
#endif
|
#endif
|
||||||
@ -172,19 +169,6 @@ index b098b1fa2470..a159419e60df 100644
|
|||||||
|
|
||||||
reserve_initrd();
|
reserve_initrd();
|
||||||
|
|
||||||
diff --git a/drivers/acpi/acpi_video.c b/drivers/acpi/acpi_video.c
|
|
||||||
index b411948594ff..4e868454b38d 100644
|
|
||||||
--- a/drivers/acpi/acpi_video.c
|
|
||||||
+++ b/drivers/acpi/acpi_video.c
|
|
||||||
@@ -2031,7 +2031,7 @@ static int acpi_video_bus_add(struct acpi_device *device)
|
|
||||||
* HP ZBook Fury 16 G10 requires ACPI video's child devices have _PS0
|
|
||||||
* evaluated to have functional panel brightness control.
|
|
||||||
*/
|
|
||||||
- acpi_device_fix_up_power_extended(device);
|
|
||||||
+ acpi_device_fix_up_power_children(device);
|
|
||||||
|
|
||||||
pr_info("%s [%s] (multi-head: %s rom: %s post: %s)\n",
|
|
||||||
ACPI_VIDEO_DEVICE_NAME, acpi_device_bid(device),
|
|
||||||
diff --git a/drivers/acpi/apei/hest.c b/drivers/acpi/apei/hest.c
|
diff --git a/drivers/acpi/apei/hest.c b/drivers/acpi/apei/hest.c
|
||||||
index 6aef1ee5e1bd..8f146b1b4972 100644
|
index 6aef1ee5e1bd..8f146b1b4972 100644
|
||||||
--- a/drivers/acpi/apei/hest.c
|
--- a/drivers/acpi/apei/hest.c
|
||||||
@ -204,30 +188,6 @@ index 6aef1ee5e1bd..8f146b1b4972 100644
|
|||||||
hest_hdr = (struct acpi_hest_header *)(hest_tab + 1);
|
hest_hdr = (struct acpi_hest_header *)(hest_tab + 1);
|
||||||
for (i = 0; i < hest_tab->error_source_count; i++) {
|
for (i = 0; i < hest_tab->error_source_count; i++) {
|
||||||
len = hest_esrc_len(hest_hdr);
|
len = hest_esrc_len(hest_hdr);
|
||||||
diff --git a/drivers/acpi/device_pm.c b/drivers/acpi/device_pm.c
|
|
||||||
index f007116a8427..3b4d048c4941 100644
|
|
||||||
--- a/drivers/acpi/device_pm.c
|
|
||||||
+++ b/drivers/acpi/device_pm.c
|
|
||||||
@@ -397,6 +397,19 @@ void acpi_device_fix_up_power_extended(struct acpi_device *adev)
|
|
||||||
}
|
|
||||||
EXPORT_SYMBOL_GPL(acpi_device_fix_up_power_extended);
|
|
||||||
|
|
||||||
+/**
|
|
||||||
+ * acpi_device_fix_up_power_children - Force a device's children into D0.
|
|
||||||
+ * @adev: Parent device object whose children's power state is to be fixed up.
|
|
||||||
+ *
|
|
||||||
+ * Call acpi_device_fix_up_power() for @adev's children so long as they
|
|
||||||
+ * are reported as present and enabled.
|
|
||||||
+ */
|
|
||||||
+void acpi_device_fix_up_power_children(struct acpi_device *adev)
|
|
||||||
+{
|
|
||||||
+ acpi_dev_for_each_child(adev, fix_up_power_if_applicable, NULL);
|
|
||||||
+}
|
|
||||||
+EXPORT_SYMBOL_GPL(acpi_device_fix_up_power_children);
|
|
||||||
+
|
|
||||||
int acpi_device_update_power(struct acpi_device *device, int *state_p)
|
|
||||||
{
|
|
||||||
int state;
|
|
||||||
diff --git a/drivers/acpi/irq.c b/drivers/acpi/irq.c
|
diff --git a/drivers/acpi/irq.c b/drivers/acpi/irq.c
|
||||||
index 1687483ff319..390b67f19181 100644
|
index 1687483ff319..390b67f19181 100644
|
||||||
--- a/drivers/acpi/irq.c
|
--- a/drivers/acpi/irq.c
|
||||||
@ -1102,10 +1062,10 @@ index 6effa13039f3..fbfbd542b858 100644
|
|||||||
if (err)
|
if (err)
|
||||||
goto err_out_driver;
|
goto err_out_driver;
|
||||||
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
|
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
|
||||||
index 0ff47eeffb49..005b8c595c60 100644
|
index dfc30cebd4c4..ce1e2cf26478 100644
|
||||||
--- a/drivers/usb/core/hub.c
|
--- a/drivers/usb/core/hub.c
|
||||||
+++ b/drivers/usb/core/hub.c
|
+++ b/drivers/usb/core/hub.c
|
||||||
@@ -5782,6 +5782,13 @@ static void hub_event(struct work_struct *work)
|
@@ -5759,6 +5759,13 @@ static void hub_event(struct work_struct *work)
|
||||||
(u16) hub->change_bits[0],
|
(u16) hub->change_bits[0],
|
||||||
(u16) hub->event_bits[0]);
|
(u16) hub->event_bits[0]);
|
||||||
|
|
||||||
@ -1119,18 +1079,6 @@ index 0ff47eeffb49..005b8c595c60 100644
|
|||||||
/* Lock the device, then check to see if we were
|
/* Lock the device, then check to see if we were
|
||||||
* disconnected while waiting for the lock to succeed. */
|
* disconnected while waiting for the lock to succeed. */
|
||||||
usb_lock_device(hdev);
|
usb_lock_device(hdev);
|
||||||
diff --git a/include/acpi/acpi_bus.h b/include/acpi/acpi_bus.h
|
|
||||||
index 254685085c82..0b7eab0ef7d7 100644
|
|
||||||
--- a/include/acpi/acpi_bus.h
|
|
||||||
+++ b/include/acpi/acpi_bus.h
|
|
||||||
@@ -539,6 +539,7 @@ int acpi_device_set_power(struct acpi_device *device, int state);
|
|
||||||
int acpi_bus_init_power(struct acpi_device *device);
|
|
||||||
int acpi_device_fix_up_power(struct acpi_device *device);
|
|
||||||
void acpi_device_fix_up_power_extended(struct acpi_device *adev);
|
|
||||||
+void acpi_device_fix_up_power_children(struct acpi_device *adev);
|
|
||||||
int acpi_bus_update_power(acpi_handle handle, int *state_p);
|
|
||||||
int acpi_device_update_power(struct acpi_device *device, int *state_p);
|
|
||||||
bool acpi_bus_power_manageable(acpi_handle handle);
|
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index 80b21d1c6eaf..b66c0683f2fc 100644
|
index 80b21d1c6eaf..b66c0683f2fc 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
|
6
sources
6
sources
@ -1,5 +1,5 @@
|
|||||||
SHA512 (kernel-abi-stablelists-6.5.12.tar.bz2) = ea72bdfb5065f430c0b7076ba49f8fbc1b16f861dc4182f1ee5bc8a809f8f3103d97766e5719354f8163a77235a759a65cc7d4efc66e314dcc658ceda6a77016
|
SHA512 (kernel-abi-stablelists-6.5.12.tar.bz2) = ea72bdfb5065f430c0b7076ba49f8fbc1b16f861dc4182f1ee5bc8a809f8f3103d97766e5719354f8163a77235a759a65cc7d4efc66e314dcc658ceda6a77016
|
||||||
SHA512 (kernel-kabi-dw-6.5.12.tar.bz2) = 7fc7372de576d1f3602abe70483edf30cf635a6d4175261bb44e1b7d4b413bc045b1e2affc0dbe6bf710a7c10b4a5c26c7fd47d8b8e7fe4bee2a25e2fd80b13a
|
SHA512 (kernel-kabi-dw-6.5.12.tar.bz2) = 7fc7372de576d1f3602abe70483edf30cf635a6d4175261bb44e1b7d4b413bc045b1e2affc0dbe6bf710a7c10b4a5c26c7fd47d8b8e7fe4bee2a25e2fd80b13a
|
||||||
SHA512 (linux-6.6.3.tar.xz) = b384138ec19390340c4099fc9d545626aa644b8e5f71616df9d15456f04a878c0c49333023e6b711aac75182de5b6b8cc8b3f8d2451b6ff02c7fd6f102c77137
|
SHA512 (linux-6.6.4.tar.xz) = a1f82a91560b042be2ebb00b62cf6ba4628d9b8486269b562d524c89919e3a6820115ea553e0af42b3114c4df5a528660984aa840422e8586cb538295dff0983
|
||||||
SHA512 (kernel-abi-stablelists-6.6.3.tar.xz) = 3fe74342ebf8d3fc165d2a6f282ce2fba4fa8cdd642cec9760dfd28d31984917621cfc25be5a21982fff1dbc9a926324eadf79eca9c11ca1c292ef07d0baa3d4
|
SHA512 (kernel-abi-stablelists-6.6.4.tar.xz) = 7adc271705fa5e6f79c502c823bf760b219ea7f14aa7be8d58db072f91ee7e343ca49da3c0067f1d2be3e81d3527bfd2aceff2163473f7b46929611e8c0ac18b
|
||||||
SHA512 (kernel-kabi-dw-6.6.3.tar.xz) = e77f7c62bc3b5b8057b705d1c820459cae15cb2c243829ced12cc096b2364fd6b481689421073f32cf1dd02115616924a7b72c0a7dafcbe402ea840f05e2e008
|
SHA512 (kernel-kabi-dw-6.6.4.tar.xz) = e9826b2343276be74b21a01a5fb9b174edd3c96d1ba5508d1c01bf5714eff0058b000373f2cb25e0e1db197219b3df89977ed2c89dcf0260152b50ad3a454487
|
||||||
|
Loading…
Reference in New Issue
Block a user