kernel-5.12.7-0

* Wed May 26 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.12.7-0]
- Fix up merge issue resulting in dual entries for ALC295_FIXUP_ASUS_DACS (Justin M. Forbes)
- powerpc/64s/syscall: Fix ptrace syscall info with scv syscalls (Nicholas Piggin)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-05-26 07:52:18 -05:00
parent 20f434ce5f
commit af1b203d79
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 19 additions and 60 deletions

View File

@ -1,3 +1,9 @@
https://gitlab.com/cki-project/kernel-ark/-/commit/b8c43c4d0bdf8d9f4210e9f3263771c9f76d12bc
b8c43c4d0bdf8d9f4210e9f3263771c9f76d12bc Fix up merge issue resulting in dual entries for ALC295_FIXUP_ASUS_DACS
https://gitlab.com/cki-project/kernel-ark/-/commit/640004f918263da53d6f657817cc06089a3c2f93
640004f918263da53d6f657817cc06089a3c2f93 powerpc/64s/syscall: Fix ptrace syscall info with scv syscalls
https://gitlab.com/cki-project/kernel-ark/-/commit/00f96bf907caf6f5bd6ff876958aa9a1bb45f969
00f96bf907caf6f5bd6ff876958aa9a1bb45f969 bus: mhi: core: Download AMSS image from appropriate function

View File

@ -106,7 +106,7 @@ Summary: The Linux kernel
%define primary_target rhel
%endif
%define rpmversion 5.12.6
%define rpmversion 5.12.7
%define stableversion 5.12
%define pkgrelease 200
@ -623,7 +623,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.12.6.tar.xz
Source0: linux-5.12.7.tar.xz
Source1: Makefile.rhelver
@ -1277,8 +1277,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.12.6 -c
mv linux-5.12.6 linux-%{KVERREL}
%setup -q -n kernel-5.12.7 -c
mv linux-5.12.7 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2792,6 +2792,10 @@ fi
#
#
%changelog
* Wed May 26 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.12.7-0]
- Fix up merge issue resulting in dual entries for ALC295_FIXUP_ASUS_DACS (Justin M. Forbes)
- powerpc/64s/syscall: Fix ptrace syscall info with scv syscalls (Nicholas Piggin)
* Sat May 22 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.12.6-0]
- bus: mhi: core: Download AMSS image from appropriate function (Bhaumik Bhatt)

View File

@ -40,8 +40,7 @@
security/lockdown/Kconfig | 13 +++
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
sound/pci/hda/patch_realtek.c | 18 +++
43 files changed, 670 insertions(+), 193 deletions(-)
42 files changed, 652 insertions(+), 193 deletions(-)
diff --git a/Documentation/admin-guide/kdump/kdump.rst b/Documentation/admin-guide/kdump/kdump.rst
index 75a9dd98e76e..3ff3291551f9 100644
@ -66,7 +65,7 @@ index 75a9dd98e76e..3ff3291551f9 100644
Boot into System Kernel
diff --git a/Makefile b/Makefile
index dd021135838b..834afa29b14c 100644
index 6a73dee7c221..585dfe88d94c 100644
--- a/Makefile
+++ b/Makefile
@@ -495,6 +495,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
@ -1635,53 +1634,3 @@ index 5ac96b16f8fa..fc47d6de57ee 100644
#ifdef CONFIG_PERF_EVENTS
int security_perf_event_open(struct perf_event_attr *attr, int type)
{
diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 1fe70f2fe4fe..af80edb21bbb 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -5717,6 +5717,18 @@ static void alc_fixup_tpt470_dacs(struct hda_codec *codec,
spec->gen.preferred_dacs = preferred_pairs;
}
+static void alc295_fixup_asus_dacs(struct hda_codec *codec,
+ const struct hda_fixup *fix, int action)
+{
+ static const hda_nid_t preferred_pairs[] = {
+ 0x17, 0x02, 0x21, 0x03, 0
+ };
+ struct alc_spec *spec = codec->spec;
+
+ if (action == HDA_FIXUP_ACT_PRE_PROBE)
+ spec->gen.preferred_dacs = preferred_pairs;
+}
+
static void alc_shutup_dell_xps13(struct hda_codec *codec)
{
struct alc_spec *spec = codec->spec;
@@ -6484,6 +6496,7 @@ enum {
ALC282_FIXUP_ACER_DISABLE_LINEOUT,
ALC255_FIXUP_ACER_LIMIT_INT_MIC_BOOST,
ALC256_FIXUP_ACER_HEADSET_MIC,
+ ALC295_FIXUP_ASUS_DACS,
ALC285_FIXUP_IDEAPAD_S740_COEF,
};
@@ -7977,6 +7990,10 @@ static const struct hda_fixup alc269_fixups[] = {
.chained = true,
.chain_id = ALC269_FIXUP_HEADSET_MODE_NO_HP_MIC
},
+ [ALC295_FIXUP_ASUS_DACS] = {
+ .type = HDA_FIXUP_FUNC,
+ .v.func = alc295_fixup_asus_dacs,
+ },
[ALC285_FIXUP_IDEAPAD_S740_COEF] = {
.type = HDA_FIXUP_FUNC,
.v.func = alc285_fixup_ideapad_s740_coef,
@@ -8181,6 +8198,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
SND_PCI_QUIRK(0x1043, 0x1427, "Asus Zenbook UX31E", ALC269VB_FIXUP_ASUS_ZENBOOK),
SND_PCI_QUIRK(0x1043, 0x1517, "Asus Zenbook UX31A", ALC269VB_FIXUP_ASUS_ZENBOOK_UX31A),
SND_PCI_QUIRK(0x1043, 0x16e3, "ASUS UX50", ALC269_FIXUP_STEREO_DMIC),
+ SND_PCI_QUIRK(0x1043, 0x1740, "ASUS UX430UA", ALC295_FIXUP_ASUS_DACS),
SND_PCI_QUIRK(0x1043, 0x17d1, "ASUS UX431FL", ALC294_FIXUP_ASUS_DUAL_SPK),
SND_PCI_QUIRK(0x1043, 0x1881, "ASUS Zephyrus S/M", ALC294_FIXUP_ASUS_GX502_PINS),
SND_PCI_QUIRK(0x1043, 0x18b1, "Asus MJ401TA", ALC256_FIXUP_ASUS_HEADSET_MIC),

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.12.6.tar.xz) = d32118c20439e68b00c5a57ace70049272753263e3d6e9a48483995f42cf7b2256fb3c4017525d32281151d68a0d8e79192b209f200e42e60bce99f07ed13398
SHA512 (kernel-abi-whitelists-5.12.6-200.tar.bz2) = afa188339895680fad94f05e2b533927b6ece83d85a23fa6e0bdad86c9e3e8827b782fe3b492601e2172a2031f004e32f519c06b69e1d2a81181076296ebb062
SHA512 (kernel-kabi-dw-5.12.6-200.tar.bz2) = 99eb304cae38c04da82273e0897a239e39c7b4c50f1ededfff49f19867b263d1b5fb7d792ff68a5f14c5206410196c44b129f510f38b0d2065aa685bd23ee41c
SHA512 (linux-5.12.7.tar.xz) = 90c056c36a64f10a9ceb64a98b93c3fe59bcad3e00650d349a759224c83cdcba49921a53dee3b51186abfaddf06db4eb84aae17b486c8caddcaee4fb1529d339
SHA512 (kernel-abi-whitelists-5.12.7-200.tar.bz2) = 59f288bd151c3bd1e6e7e8049be373f7e3b0a38def25c953337fb1b46c57988abf21eb9b858f4bc0154e6a8faab6b7c4c0b12bbf77d1bacbb10c4f5f64d13318
SHA512 (kernel-kabi-dw-5.12.7-200.tar.bz2) = 3aeeafb1005f279600a3e2e4b88f28e629fce1baa1207b46e410268aa5ee70a5eedd65986e573aad538cdb18764b30a6b10ec856c2a352c02a484cba198b0149