- Revise compat-wireless configuration

- Update compat-wireless snapshot
- Enable with-backports by default
This commit is contained in:
John W. Linville 2011-11-22 16:16:30 -05:00
parent 9f33e8dbe2
commit aeaaac5e9a
3 changed files with 128 additions and 6 deletions

View File

@ -0,0 +1,64 @@
diff -up compat-wireless-3.2-rc1-1/config.mk.orig compat-wireless-3.2-rc1-1/config.mk
--- compat-wireless-3.2-rc1-1/config.mk.orig 2011-11-22 13:09:50.422879313 -0500
+++ compat-wireless-3.2-rc1-1/config.mk 2011-11-22 13:10:28.870398679 -0500
@@ -14,6 +14,9 @@ else
include $(KLIB_BUILD)/.config
endif
+# Enable SSB module (needs to be visible in compat_autoconf.h)
+CONFIG_SSB=m
+
ifneq ($(wildcard $(KLIB_BUILD)/Makefile),)
COMPAT_LATEST_VERSION = 1
diff -up compat-wireless-3.2-rc1-1/drivers/misc/eeprom/Makefile.orig compat-wireless-3.2-rc1-1/drivers/misc/eeprom/Makefile
--- compat-wireless-3.2-rc1-1/drivers/misc/eeprom/Makefile.orig 2011-11-22 13:09:50.423879301 -0500
+++ compat-wireless-3.2-rc1-1/drivers/misc/eeprom/Makefile 2011-11-22 13:10:28.871398662 -0500
@@ -1,3 +1,3 @@
-obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
+#obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
obj-$(CONFIG_EEPROM_93XX46) += eeprom_93xx46.o
obj-$(CONFIG_EEPROM_DIGSY_MTC_CFG) += digsy_mtc_eeprom.o
diff -up compat-wireless-3.2-rc1-1/drivers/net/ethernet/atheros/Makefile.orig compat-wireless-3.2-rc1-1/drivers/net/ethernet/atheros/Makefile
--- compat-wireless-3.2-rc1-1/drivers/net/ethernet/atheros/Makefile.orig 2011-11-22 13:09:50.423879301 -0500
+++ compat-wireless-3.2-rc1-1/drivers/net/ethernet/atheros/Makefile 2011-11-22 13:10:28.871398662 -0500
@@ -2,7 +2,7 @@
# Makefile for the Atheros network device drivers.
#
-obj-$(CONFIG_ATL1) += atlx/
-obj-$(CONFIG_ATL2) += atlx/
-obj-$(CONFIG_ATL1E) += atl1e/
-obj-$(CONFIG_ATL1C) += atl1c/
+#obj-$(CONFIG_ATL1) += atlx/
+#obj-$(CONFIG_ATL2) += atlx/
+#obj-$(CONFIG_ATL1E) += atl1e/
+#obj-$(CONFIG_ATL1C) += atl1c/
diff -up compat-wireless-3.2-rc1-1/drivers/net/usb/Makefile.orig compat-wireless-3.2-rc1-1/drivers/net/usb/Makefile
--- compat-wireless-3.2-rc1-1/drivers/net/usb/Makefile.orig 2011-11-22 13:09:50.424879289 -0500
+++ compat-wireless-3.2-rc1-1/drivers/net/usb/Makefile 2011-11-22 13:10:28.872398646 -0500
@@ -2,7 +2,7 @@
# Makefile for USB Network drivers
#
-obj-$(CONFIG_USB_NET_COMPAT_CDCETHER) += cdc_ether.o
-obj-$(CONFIG_USB_NET_COMPAT_RNDIS_HOST) += rndis_host.o
-obj-$(CONFIG_USB_COMPAT_USBNET) += usbnet.o
+#obj-$(CONFIG_USB_NET_COMPAT_CDCETHER) += cdc_ether.o
+#obj-$(CONFIG_USB_NET_COMPAT_RNDIS_HOST) += rndis_host.o
+#obj-$(CONFIG_USB_COMPAT_USBNET) += usbnet.o
diff -up compat-wireless-3.2-rc1-1/Makefile.orig compat-wireless-3.2-rc1-1/Makefile
--- compat-wireless-3.2-rc1-1/Makefile.orig 2011-11-22 13:10:37.165294951 -0500
+++ compat-wireless-3.2-rc1-1/Makefile 2011-11-22 13:10:47.335167758 -0500
@@ -41,8 +41,8 @@ endif
endif
-obj-$(CONFIG_COMPAT_BLUETOOTH) += net/bluetooth/
-obj-$(CONFIG_COMPAT_BLUETOOTH_MODULES) += drivers/bluetooth/
+#obj-$(CONFIG_COMPAT_BLUETOOTH) += net/bluetooth/
+#obj-$(CONFIG_COMPAT_BLUETOOTH_MODULES) += drivers/bluetooth/
else

19
config-backports Normal file
View File

@ -0,0 +1,19 @@
# CONFIG_CFG80211 is not set
# CONFIG_LIB80211 is not set
# CONFIG_MAC80211 is not set
# CONFIG_BCMA is not set
#
# ssb and b44 share infrastructure with b43
#
# CONFIG_SSB is not set
# CONFIG_B44 is not set
#
# These have to be turned-on again since compat-wireless does not
# provide them...
#
CONFIG_CRC7=m
CONFIG_AVERAGE=y

View File

@ -147,7 +147,7 @@ Summary: The Linux kernel
%define with_release %{?_with_release: 1} %{?!_with_release: 0}
# Include driver backports (e.g. compat-wireless) in the kernel build.
%define with_backports %{?_with_backports: 1} %{?!_with_backports: 0}
%define with_backports %{?_without_backports: 0} %{?!_without_backports: 1}
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
@ -202,9 +202,18 @@ Summary: The Linux kernel
%define kversion 3.%{base_sublevel}
# The compat-wireless version
# (If this is less than kversion, make sure with_backports is turned-off.)
# (For rawhide, use a snapshot version anyway...)
%define cwversion 2011-11-15
%define cwversion 2011-12-01
#######################################################################
# If cwversion is less than kversion, make sure with_backports is
# turned-off.
#
# For rawhide, disable with_backports immediately after a rebase...
#
# (Uncomment the '#' and both spaces below to disable with_backports.)
#
# % define with_backports 0
#######################################################################
%define make_target bzImage
@ -472,7 +481,7 @@ Summary: The Linux kernel
# Packages that need to be installed before the kernel is, because the %%post
# scripts use them.
#
%define kernel_prereq fileutils, module-init-tools >= 3.16-2, initscripts >= 8.11.1-1, grubby >= 8.3-1
%define kernel_prereq fileutils, module-init-tools >= 3.16-4, initscripts >= 8.11.1-1, grubby >= 8.3-1
%define initrd_prereq dracut >= 001-7
#
@ -573,6 +582,8 @@ Source100: config-arm-generic
Source110: config-arm-omap-generic
Source111: config-arm-tegra
Source200: config-backports
# This file is intentionally left empty in the stock kernel. Its a nicety
# added for those wanting to do custom rebuilds with altered config opts.
Source1000: config-local
@ -717,6 +728,9 @@ Patch21029: nfsv4-include-bitmap-in-nfsv4_get_acl_data.patch
#rhbz 590880
Patch21030: alps.patch
# compat-wireless patches
Patch50000: compat-wireless-config-fixups.patch
%endif
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
@ -1215,6 +1229,16 @@ make -f %{SOURCE19} config-release
# Dynamically generate kernel .config files from config-* files
make -f %{SOURCE20} VERSION=%{version} configs
%if %{with_backports}
# Turn-off bits provided by compat-wireless
for i in %{all_arch_configs}
do
mv $i $i.tmp
./merge.pl %{SOURCE200} $i.tmp > $i
rm $i.tmp
done
%endif
# Merge in any user-provided local config option changes
%if %{?all_arch_configs:1}%{!?all_arch_configs:0}
for i in %{all_arch_configs}
@ -1367,8 +1391,10 @@ ApplyPatch oom-fix-integer-overflow-of-points.patch
# Add msi irq ennumeration in sysfs for devices
ApplyPatch sysfs-msi-irq-per-device.patch
%if !%{with_backports}
# Remove overlap between bcma/b43 and brcmsmac and reenable bcm4331
ApplyPatch bcma-brcmsmac-compat.patch
%endif
ApplyPatch pci-Rework-ASPM-disable-code.patch
@ -1438,6 +1464,15 @@ cd ..
# Extract the compat-wireless bits
%setup -q -n kernel-%{kversion}%{?dist} -T -D -a 1
cd compat-wireless-%{cwversion}
ApplyPatch compat-wireless-config-fixups.patch
# Remove overlap between bcma/b43 and brcmsmac and reenable bcm4331
ApplyPatch bcma-brcmsmac-compat.patch
cd ..
%endif
###
@ -1722,7 +1757,6 @@ BuildKernel() {
%if %{with_backports}
cd ../compat-wireless-%{cwversion}/
make clean
make KLIB_BUILD=../linux-%{kversion}.%{_target_cpu} \
KMODPATH_ARG="INSTALL_MOD_PATH=$RPM_BUILD_ROOT" \
@ -2177,6 +2211,11 @@ fi
# ||----w |
# || ||
%changelog
* Fri Dec 02 2011 John W. Linville <linville@redhat.com>
- Revise compat-wireless configuration
- Update compat-wireless snapshot
- Enable with-backports by default
* Fri Dec 02 2011 Josh Boyer <jwboyer@redhat.com> 3.2.0-0.rc4.git1.4.fc17
- Backport ALPS touchpad patches from input/next branch (rhbz #590880)
- Apply patch from John Linville to reverse modules-extra dependency order