Add iwlwifi fix for connection issue (rhbz 885407)
This commit is contained in:
parent
9c63d892b7
commit
ae1356ac9f
@ -0,0 +1,32 @@
|
||||
From 7b29fdb8cd8f92e31f550611a8c031986dba2e8f Mon Sep 17 00:00:00 2001
|
||||
From: Johannes Berg <johannes.berg@intel.com>
|
||||
Date: Fri, 03 May 2013 16:58:16 +0000
|
||||
Subject: iwlwifi: dvm: don't send BT_CONFIG on devices w/o Bluetooth
|
||||
|
||||
The BT_CONFIG command that is sent to the device during
|
||||
startup will enable BT coex unless the module parameter
|
||||
turns it off, but on devices without Bluetooth this may
|
||||
cause problems, as reported in Redhat BZ 885407.
|
||||
|
||||
Fix this by sending the BT_CONFIG command only when the
|
||||
device has Bluetooth.
|
||||
|
||||
Cc: stable@vger.kernel.org
|
||||
Reviewed-by: Emmanuel Grumbach <emmanuel.grumbach@intel.com>
|
||||
Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
|
||||
---
|
||||
diff --git a/drivers/net/wireless/iwlwifi/dvm/main.c b/drivers/net/wireless/iwlwifi/dvm/main.c
|
||||
index 3952ddf..1531a4f 100644
|
||||
--- a/drivers/net/wireless/iwlwifi/dvm/main.c
|
||||
+++ b/drivers/net/wireless/iwlwifi/dvm/main.c
|
||||
@@ -758,7 +758,7 @@ int iwl_alive_start(struct iwl_priv *priv)
|
||||
BT_COEX_PRIO_TBL_EVT_INIT_CALIB2);
|
||||
if (ret)
|
||||
return ret;
|
||||
- } else {
|
||||
+ } else if (priv->lib->bt_params) {
|
||||
/*
|
||||
* default is 2-wire BT coexexistence support
|
||||
*/
|
||||
--
|
||||
cgit v0.9.2
|
11
kernel.spec
11
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -768,6 +768,9 @@ Patch25055: ath3k-dont-use-stack-memory-for-DMA.patch
|
||||
Patch25056: iwl3945-better-skb-management-in-rx-path.patch
|
||||
Patch25057: iwl4965-better-skb-management-in-rx-path.patch
|
||||
|
||||
#rhbz 885407
|
||||
Patch25064: iwlwifi-dvm-dont-send-BT_CONFIG-on-devices-wo-Bluetooth.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1462,6 +1465,9 @@ ApplyPatch ath3k-dont-use-stack-memory-for-DMA.patch
|
||||
ApplyPatch iwl3945-better-skb-management-in-rx-path.patch
|
||||
ApplyPatch iwl4965-better-skb-management-in-rx-path.patch
|
||||
|
||||
#rhbz 885407
|
||||
ApplyPatch iwlwifi-dvm-dont-send-BT_CONFIG-on-devices-wo-Bluetooth.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2258,6 +2264,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Jul 12 2013 Josh Boyer <jwboyer@redhat.com>
|
||||
- Add iwlwifi fix for connection issue (rhbz 885407)
|
||||
|
||||
* Thu Jul 11 2013 Justin M. Forbes <jforbes@redhat.com> - 3.11.0-0.rc0.git6.1
|
||||
- Linux v3.10-9080-g19d2f8e
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user