kernel-6.3.5-200
* Tue May 30 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.5-0] - Drop rhelver for 6.3.5 (Justin M. Forbes) - Linux v6.3.5 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
7acde4384c
commit
aa733c43ff
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 1
|
||||
RHEL_RELEASE = 0
|
||||
|
||||
#
|
||||
# RHEL_REBASE_NUM
|
||||
|
16
kernel.spec
16
kernel.spec
@ -142,18 +142,18 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specrpmversion 6.3.4
|
||||
%define specversion 6.3.4
|
||||
%define specrpmversion 6.3.5
|
||||
%define specversion 6.3.5
|
||||
%define patchversion 6.3
|
||||
%define pkgrelease 201
|
||||
%define pkgrelease 200
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.3.4
|
||||
%define tarfile_release 6.3.5
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 3
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 201%{?buildid}%{?dist}
|
||||
%define specrelease 200%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.3.4
|
||||
%define kabiversion 6.3.5
|
||||
|
||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||
# fatal kernel package build error
|
||||
@ -3406,6 +3406,10 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Tue May 30 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.5-0]
|
||||
- Drop rhelver for 6.3.5 (Justin M. Forbes)
|
||||
- Linux v6.3.5
|
||||
|
||||
* Sat May 27 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.4-1]
|
||||
- Bump rhelver for build with xfs fix (Justin M. Forbes)
|
||||
- xfs: fix livelock in delayed allocation at ENOSPC (Dave Chinner)
|
||||
|
@ -23,7 +23,6 @@
|
||||
drivers/nvme/host/nvme.h | 4 +
|
||||
drivers/pci/quirks.c | 24 ++++
|
||||
drivers/usb/core/hub.c | 7 ++
|
||||
fs/xfs/libxfs/xfs_bmap.c | 1 -
|
||||
fs/xfs/xfs_buf_item_recover.c | 10 ++
|
||||
include/linux/efi.h | 22 ++--
|
||||
include/linux/lsm_hook_defs.h | 2 +
|
||||
@ -37,10 +36,10 @@
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 6 +
|
||||
sound/pci/hda/patch_realtek.c | 2 +
|
||||
39 files changed, 502 insertions(+), 187 deletions(-)
|
||||
38 files changed, 502 insertions(+), 186 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 3c5b60669018..154ee11110d4 100644
|
||||
index d710ff6a3d56..fafd28dd7b62 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -1132,18 +1131,6 @@ index 97a0f8faea6e..d837548d2024 100644
|
||||
/* Lock the device, then check to see if we were
|
||||
* disconnected while waiting for the lock to succeed. */
|
||||
usb_lock_device(hdev);
|
||||
diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
|
||||
index 34de6e6898c4..3ce43068daa1 100644
|
||||
--- a/fs/xfs/libxfs/xfs_bmap.c
|
||||
+++ b/fs/xfs/libxfs/xfs_bmap.c
|
||||
@@ -3505,7 +3505,6 @@ xfs_bmap_btalloc_at_eof(
|
||||
* original non-aligned state so the caller can proceed on allocation
|
||||
* failure as if this function was never called.
|
||||
*/
|
||||
- args->fsbno = ap->blkno;
|
||||
args->alignment = 1;
|
||||
return 0;
|
||||
}
|
||||
diff --git a/fs/xfs/xfs_buf_item_recover.c b/fs/xfs/xfs_buf_item_recover.c
|
||||
index ffa94102094d..43167f543afc 100644
|
||||
--- a/fs/xfs/xfs_buf_item_recover.c
|
||||
@ -1412,7 +1399,7 @@ index cf6cc576736f..3653a4f35265 100644
|
||||
int security_perf_event_open(struct perf_event_attr *attr, int type)
|
||||
{
|
||||
diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
|
||||
index c75760717736..62366750c261 100644
|
||||
index 379f216158ab..5711a9365a91 100644
|
||||
--- a/sound/pci/hda/patch_realtek.c
|
||||
+++ b/sound/pci/hda/patch_realtek.c
|
||||
@@ -9706,6 +9706,8 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.3.4.tar.xz) = 5bd6379d647b0c578523988015091684f6196989393d3996a02dde14ba0cd6c54ec9d243f0d6161692f8af541efe7a642db248e5621dda51ccaeb0f788e8dc36
|
||||
SHA512 (kernel-abi-stablelists-6.3.4.tar.bz2) = 5b297e8817a2f9ccb388e4c07f3527dcc92a30f54237ced32ddd7ef86a61a963d672f36e87fef65dda6f9a39f20a890bc3a31d97658d6b085193274420f38034
|
||||
SHA512 (kernel-kabi-dw-6.3.4.tar.bz2) = 8d00b14e3474a52a97cb7a2a01ca71ee7fb3eacdd10e6d5495616f2c427989088b87d0892d1c19ae05c1f46e5780f37553d27767bb8f0c6130b02f571e84d9ce
|
||||
SHA512 (linux-6.3.5.tar.xz) = 250ddb5493a770121e87b7fc9fb60235c5d5bf15142759b191ea9a5e1cda90ec78aa3885c8f955c4c7b20e30ae1e5d5f45dae6c95a60d8558af91083303a8bb1
|
||||
SHA512 (kernel-abi-stablelists-6.3.5.tar.bz2) = 0eddb52b7ff500d142971dca8004ec286df13298d93a86449e7c41ca8028b6cdbef1901f308cdf1d4beb4d19c597bd00961277dbb04e1847a3e59866b6337c18
|
||||
SHA512 (kernel-kabi-dw-6.3.5.tar.bz2) = f4fe340f8fd03cf4f008eefd7eee6abcce24c8801941159c86debaf9e5fcbca6a0e18567bbca506c73ff4381fd772b3811dc74bb4c06555964693dc3d8ed7e21
|
||||
|
Loading…
Reference in New Issue
Block a user