kernel-5.7.0-0.rc7.1

* Mon May 25 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc7.1]
- v5.7-rc7 rebase
- Updated changelog for the release based on caffb99b6929 ("CKI@GitLab")
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2020-05-25 12:09:26 -05:00
parent 891d5e1e47
commit a79d8affb7
9 changed files with 32 additions and 24 deletions

View File

@ -15,7 +15,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
2 files changed, 96 insertions(+), 31 deletions(-)
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
index 911a2bd0f6b7..3696e87f19ee 100644
index 4e3055238f31..36ca9e2943ce 100644
--- a/drivers/firmware/efi/efi.c
+++ b/drivers/firmware/efi/efi.c
@@ -31,6 +31,7 @@
@ -26,7 +26,7 @@ index 911a2bd0f6b7..3696e87f19ee 100644
#include <asm/early_ioremap.h>
@@ -831,40 +832,101 @@ int efi_mem_type(unsigned long phys_addr)
@@ -828,40 +829,101 @@ int efi_mem_type(unsigned long phys_addr)
}
#endif
@ -160,7 +160,7 @@ index 911a2bd0f6b7..3696e87f19ee 100644
static DEFINE_SPINLOCK(efi_mem_reserve_persistent_lock);
diff --git a/include/linux/efi.h b/include/linux/efi.h
index 251f1f783cdf..fa8e23680314 100644
index 9430d01c0c3d..51503bf118ab 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -42,6 +42,8 @@

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 266cc438f200..2f4fdf51c7e2 100644
index 2f1f5603cf1c..45ce82a03718 100644
--- a/Makefile
+++ b/Makefile
@@ -479,7 +479,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE

View File

@ -27,10 +27,10 @@ Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
1 file changed, 6 insertions(+)
diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
index 0ef4f2f203fd..b8f8bf3aca50 100644
index 77ecd8b47d70..759670262445 100644
--- a/kernel/bpf/syscall.c
+++ b/kernel/bpf/syscall.c
@@ -3687,11 +3687,17 @@ static int link_update(union bpf_attr *attr)
@@ -3698,11 +3698,17 @@ static int link_update(union bpf_attr *attr)
SYSCALL_DEFINE3(bpf, int, cmd, union bpf_attr __user *, uattr, unsigned int, size)
{
union bpf_attr attr;

View File

@ -66,7 +66,7 @@ index c041d4e950f4..8588bb62e74c 100644
#define TAINT_FLAGS_COUNT 32
diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
index 2843bbba9ca1..0ef4f2f203fd 100644
index 4e6dee19a668..77ecd8b47d70 100644
--- a/kernel/bpf/syscall.c
+++ b/kernel/bpf/syscall.c
@@ -24,6 +24,7 @@

View File

@ -107,7 +107,7 @@ index 000000000000..de0a3714a5d4
+ }
+}
diff --git a/include/linux/efi.h b/include/linux/efi.h
index fa8e23680314..a9a9e7e976e7 100644
index 51503bf118ab..b35e693f20f3 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -778,6 +778,14 @@ extern int __init efi_setup_pcdp_console(char *);

View File

@ -59,7 +59,7 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 04f5662ae61a..266cc438f200 100644
index f0d118b86287..2f1f5603cf1c 100644
--- a/Makefile
+++ b/Makefile
@@ -1190,7 +1190,13 @@ endef

View File

@ -82,10 +82,10 @@ index 5a952617a0eb..61cc3cdc4d25 100644
static int __init lockdown_lsm_init(void)
diff --git a/security/security.c b/security/security.c
index 7fed24b9d57e..37fab5c5d974 100644
index 51de970fbb1e..48d05f8067f2 100644
--- a/security/security.c
+++ b/security/security.c
@@ -2456,6 +2456,12 @@ int security_locked_down(enum lockdown_reason what)
@@ -2468,6 +2468,12 @@ int security_locked_down(enum lockdown_reason what)
}
EXPORT_SYMBOL(security_locked_down);

View File

@ -30,7 +30,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
%global distro_build 0.rc6.20200522git051143e1602d.1
%global distro_build 0.rc7.1
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -69,10 +69,10 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.7.0
%define pkgrelease 0.rc6.20200522git051143e1602d.1
%define pkgrelease 0.rc7.1
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc6.20200522git051143e1602d.1%{?buildid}%{?dist}
%define specrelease 0.rc7.1%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@ -163,7 +163,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
%define debugbuildsenabled 0
%define debugbuildsenabled 1
# The kernel tarball/base version
%define kversion 5.7
@ -564,7 +564,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-20200522git051143e1602d.tar.xz
Source0: linux-5.7-rc7.tar.xz
Source1: Makefile.rhelver
@ -1275,8 +1275,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-20200522git051143e1602d -c
mv linux-20200522git051143e1602d linux-%{KVERREL}
%setup -q -n kernel-5.7-rc7 -c
mv linux-5.7-rc7 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2776,13 +2776,21 @@ fi
#
#
%changelog
* Fri May 22 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc6.20200522git051143e1602d.1]
- 051143e1602d rebase
- Add Documentation back to kernel-devel as it has Kconfig now ("Justin M. Forbes")
* Mon May 25 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc7.1]
- v5.7-rc7 rebase
- Updated changelog for the release based on caffb99b6929 ("CKI@GitLab")
* Sun May 24 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc6.20200524gitcaffb99b6929.1]
- caffb99b6929 rebase
- Updated changelog for the release based on 444565650a5f ("CKI@GitLab")
* Sat May 23 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc6.20200523git444565650a5f.1]
- 444565650a5f rebase
- x86: Fix compile issues with rh_check_supported() (Don Zickus)
- redhat/Makefile: Fix RHEL8 python warning (Prarit Bhargava)
- kernel.spec: fix 'make scripts' for kernel-devel package (Brian Masney)
- Makefile: correct help text for dist-cross-<arch>-rpms (Brian Masney)
- Add Documentation back to kernel-devel as it has Kconfig now ("Justin M. Forbes")
- Updated changelog for the release based on 642b151f45dd ("CKI@GitLab")
- redhat: Change Makefile target names to dist- (Prarit Bhargava)
- configs: Disable Serial IR driver (Prarit Bhargava)

View File

@ -1,3 +1,3 @@
SHA512 (linux-20200522git051143e1602d.tar.xz) = af343113cdd76ed5fc23ca13645d3862b774180056fe7f1fde5fc48ab5f53a2ece81507f145b1c73f50e024285fe5df1079e1a69fbb986d9ecad977c7d0157c5
SHA512 (kernel-abi-whitelists-5.7.0-0.rc6.20200522git051143e1602d.1.tar.bz2) = 26c72256cefa5e519a73d4cd11c35a0afe80b974055a7f4639b24714836afc17807708d0b047dc8256b692cf42eed1abb89552bc57bd04d908072267d8817336
SHA512 (kernel-kabi-dw-5.7.0-0.rc6.20200522git051143e1602d.1.tar.bz2) = a9ccdba526997eb79f6db59522c66c5e363ded05fe330cb65d167ae0850f4b445054c682ec96185006e4198ccc647c88273d41420fc39911fd742f9016a8957a
SHA512 (linux-5.7-rc7.tar.xz) = d2553e8f25f988f796f017c4425ae3c45f6f468785b6ab29f8fe380832da42e9023cf1ed7ff04bcaeea8aea772942a98de301af1fa6b2103c26119c3738a6bb3
SHA512 (kernel-abi-whitelists-5.7.0-0.rc7.1.tar.bz2) = 0354fc494949869eb0414c302b01f6900779a10eabf98e8c5d59f258c1a9217173b81b8e968fa501ee2ae44391e647cf22e19e016c6eb6f756fe89807156e309
SHA512 (kernel-kabi-dw-5.7.0-0.rc7.1.tar.bz2) = b279439b7bdd140df979367fde66b294fc9888bd66f51d850f7520fb9ab20ad4e9449a16ced7dd0893bafed7dad5017997dbf4b6bc2ed4f71574670b7e052126