Refresh from git tree

This commit is contained in:
Josh Boyer 2015-05-07 08:13:46 -04:00
parent 9d8b2619d9
commit a5c6885ba1
69 changed files with 3 additions and 210 deletions

View File

@ -25,6 +25,3 @@ index c68e72414a67..4277938af700 100644
if (!(*ppos)) {
/* parse the table header to get the table length */
if (count <= sizeof(struct acpi_table_header))
--
2.1.0

View File

@ -9,7 +9,7 @@ Patch for disconnect issues with storage attached to a
1 file changed, 7 insertions(+)
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index b4bfa3ac4b12..1753af78b2b2 100644
index 95409aacc076..f33003e59ab3 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -5021,6 +5021,13 @@ static void hub_event(struct work_struct *work)
@ -26,6 +26,3 @@ index b4bfa3ac4b12..1753af78b2b2 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
--
2.1.0

View File

@ -51,6 +51,3 @@ index 16ec1c00919d..b7cb7dc5ebb4 100644
/*
* All runtime access to EFI goes through this structure:
*/
--
2.1.0

View File

@ -173,6 +173,3 @@ index b7cb7dc5ebb4..fb972b96959a 100644
/**
* efi_range_is_wc - check the WC bit on an address range
* @start: starting kvirt address
--
2.1.0

View File

@ -180,6 +180,3 @@ index 98c3d7955a51..6244f24abe27 100644
bool secure_modules(void)
{
#ifdef CONFIG_MODULE_SIG
--
2.1.0

View File

@ -58,6 +58,3 @@ index d856e96a3cce..98c3d7955a51 100644
+#endif
+}
+EXPORT_SYMBOL(secure_modules);
--
2.1.0

View File

@ -243,6 +243,3 @@ index 6244f24abe27..b77554170d76 100644
static int param_set_bool_enable_only(const char *val,
const struct kernel_param *kp)
--
2.1.0

View File

@ -47,6 +47,3 @@ index a93cefe0e522..00304f742eca 100644
if (hidpp->quirks & HIDPP_QUIRK_CLASS_WTP) {
ret = wtp_allocate(hdev, id);
if (ret)
--
2.1.0

View File

@ -45,6 +45,3 @@ index f65e78b46999..ef06dc30b9b1 100644
input_mt_init_slots(input, td->maxcontacts, td->mt_flags);
td->mt_flags = 0;
--
2.1.0

View File

@ -146,6 +146,3 @@ index 8d3761ce8f54..f39539c70219 100644
struct synaptics_mt_state mt_state; /* Current mt finger state */
bool mt_state_lost; /* mt_state may be incorrect */
--
2.1.0

View File

@ -39,6 +39,3 @@ index 8f6a153677b9..9d599eb79f17 100644
__set_bit(INPUT_PROP_TOPBUTTONPAD, dev->propbit);
/* Clickpads report only left button */
__clear_bit(BTN_RIGHT, dev->keybit);
--
2.1.0

View File

@ -30,6 +30,3 @@ index ecc7811cbd46..160def02cde2 100644
"LEN0049",
"LEN2000",
"LEN2001", /* Edge E431 */
--
2.1.0

View File

@ -27,6 +27,3 @@ index 160def02cde2..ca7ca8d4eb33 100644
"LEN0047",
"LEN0049",
"LEN2000",
--
2.1.0

View File

@ -120,6 +120,3 @@ index 1bd01f21783b..8d3761ce8f54 100644
unsigned long int identity; /* Identification */
unsigned int x_res, y_res; /* X/Y resolution in units/mm */
unsigned int x_max, y_max; /* Max coordinates (from FW) */
--
2.1.0

View File

@ -106,6 +106,3 @@ index 875f64e8935b..c15e93f5a418 100644
return 0;
}
--
2.1.0

View File

@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 65c7c8756803..2d81c41a5ba2 100644
index 69952c1404b2..c0aa7af8ee68 100644
--- a/Makefile
+++ b/Makefile
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
@ -87,6 +87,3 @@ index 5f2ce616c046..6525e2a5619a 100644
config ENABLE_WARN_DEPRECATED
bool "Enable __deprecated logic"
--
2.1.0

View File

@ -180,6 +180,3 @@ index 000000000000..94b0eb38a284
+ return rc;
+}
+late_initcall(load_uefi_certs);
--
2.1.0

View File

@ -78,6 +78,3 @@ index 94b0eb38a284..ae28b974d49a 100644
}
mok = get_cert_list(L"MokListRT", &mok_var, &moksize);
--
2.1.0

View File

@ -111,6 +111,3 @@ index b91c4da68365..98f5637304d1 100644
return -EPERM;
dev = pci_get_bus_and_slot(bus, dfn);
--
2.1.0

View File

@ -36,6 +36,3 @@ index fc9637812d78..dde50e5bf527 100644
if (p < (unsigned long) high_memory) {
unsigned long to_write = min_t(unsigned long, count,
(unsigned long)high_memory - p);
--
2.1.0

View File

@ -40,6 +40,3 @@ index 3647ce71154c..9dc8ba086596 100644
module_param(brightness_switch_enabled, bool, 0644);
/*
--
2.1.0

View File

@ -90,6 +90,3 @@ index 183eaab7c380..96e3f56519e7 100644
+#define BLIST_MAX_1024 0x40000000 /* maximum 1024 sector cdb length */
#endif
--
2.1.0

View File

@ -33,6 +33,3 @@ index f9eeae871593..aa1dcf3d0216 100644
return acpi_rsdp;
#endif
--
2.1.0

View File

@ -79,6 +79,3 @@ index 27c43499977a..c42feb2bacd0 100644
{ },
};
--
2.1.0

View File

@ -71,6 +71,3 @@ index 497622ce5c31..2f1f16df460c 100644
return 0;
}
--
2.1.0

View File

@ -40,6 +40,3 @@ index db880bf46135..c931ec7201c0 100644
clkout2_pin: pinmux_clkout2_pin {
pinctrl-single,pins = <
0x1b4 (PIN_OUTPUT_PULLDOWN | MUX_MODE3) /* xdma_event_intr1.clkout2 */
--
2.1.0

View File

@ -64,6 +64,3 @@ index 2c6248d9a9ef..ec755eeb78ee 100644
};
/include/ "tps65217.dtsi"
--
2.1.0

View File

@ -174,6 +174,3 @@ index ec755eeb78ee..db880bf46135 100644
+ };
+ };
+};
--
2.1.0

View File

@ -36,6 +36,3 @@ index 0fd89c38cf02..20660917a06f 100644
hdmi {
compatible = "ti,tilcdc,slave";
i2c = <&i2c0>;
--
2.1.0

View File

@ -34,6 +34,3 @@ index 5c42d259fa68..0fd89c38cf02 100644
};
};
--
2.1.0

View File

@ -55,6 +55,3 @@ index 07a09570175d..5db6d14fcd67 100644
.init_irq = highbank_init_irq,
.init_machine = highbank_init,
.dt_compat = highbank_match,
--
2.1.0

View File

@ -60,6 +60,3 @@ index 99b46f8030ad..8b6ddd16dcc5 100644
+ pinctrl-0 = <&pinctrl_usdhc3>;
+ status = "okay";
+};
--
2.1.0

View File

@ -48,6 +48,3 @@ index 7543a56e0f45..93b5a6998371 100644
status = wmi_evaluate_method(ASUS_WMI_MGMT_GUID,
1, asus->debug.method_id,
&input, &output);
--
2.1.0

View File

@ -36,6 +36,3 @@ index 3e58bfa0c1fd..406eea47256e 100644
ath_err(common,
"DMA failed to stop in %d ms AR_CR=0x%08x AR_DIAG_SW=0x%08x DMADBG_7=0x%08x\n",
AH_RX_STOP_DMA_TIMEOUT / 1000,
--
2.1.0

View File

@ -504,6 +504,3 @@ index 000000000000..25ab9869d566
+#endif /* __KERNEL__ */
+
+#endif /* __CRASH_H__ */
--
2.1.0

View File

@ -30,6 +30,3 @@ index dac9ed0f01f7..31a29fe7c555 100644
default !EXPERT
help
Provides the way to make tasks work with different objects using
--
2.1.0

View File

@ -27,6 +27,3 @@ index 56d46ffb08e1..1c8db250df88 100644
#else
--
2.1.0

View File

@ -56,6 +56,3 @@ index bfb0b2280df0..06b10fe7e65b 100644
err = i8042_platform_init();
if (err)
return err;
--
2.1.0

View File

@ -26,6 +26,3 @@ index db07153b693f..c049fe3fbdff 100644
};
module_param_named(modeset, i915.modeset, int, 0400);
--
2.1.0

View File

@ -26,6 +26,3 @@ index 33d4d37fd614..6865ef2d3476 100644
intel_dump_pipe_config(crtc, &pipe_config,
"[hw state]");
intel_dump_pipe_config(crtc, &crtc->config,
--
2.1.0

View File

@ -556,6 +556,3 @@ index 9f6c8971855c..67adf6437f78 100644
port_name(dp_to_dig_port(intel_dp)->port));
intel_dp->want_panel_vdd = false;
--
2.1.0

View File

@ -37,6 +37,3 @@ index 0238d612750e..16ec1c00919d 100644
#ifdef CONFIG_EFI
/*
--
2.1.0

View File

@ -52,6 +52,3 @@ index 2192da755e34..4b03911a502d 100644
return 1;
}
--
2.1.0

View File

@ -24,6 +24,3 @@ index 58273956750d..e17f88ceaeab 100644
prompt "Force module signing when UEFI Secure Boot is enabled"
---help---
UEFI Secure Boot provides a mechanism for ensuring that the
--
2.1.0

View File

@ -73,6 +73,3 @@ index bed43081720f..aa522429b751 100644
/* Now release the pages and zero block aligned part of pages*/
truncate_pagecache_range(inode, start, end - 1);
--
2.1.0

View File

@ -33,6 +33,3 @@ index 2329daae5255..48a8e82c7e2e 100644
}
/**
--
2.1.0

View File

@ -28,6 +28,3 @@ index e27a25892db4..9ab0a86cc03d 100644
goto out;
case ATKBD_RET_ERR:
atkbd->err_count++;
--
2.1.0

View File

@ -60,6 +60,3 @@ index 32d710eaf1fc..af4a20b86ee7 100644
cp = can_get_proto(protocol);
}
--
2.1.0

View File

@ -44,6 +44,3 @@ index 7ce52737c7a1..dc14fec4ede1 100644
lv2table_kmem_cache = kmem_cache_create("exynos-iommu-lv2table",
LV2TABLE_SIZE, LV2TABLE_SIZE, 0, NULL);
if (!lv2table_kmem_cache) {
--
2.1.0

View File

@ -44,6 +44,3 @@ index bbb7dcef02d3..19db0b684b7f 100644
p = kmem_cache_create("iopte_cache", IOPTE_TABLE_SIZE, align, flags,
iopte_cachep_ctor);
--
2.1.0

View File

@ -47,6 +47,3 @@ index 6a8b1ec4a48a..9f74fddcd304 100644
ret = bus_set_iommu(&platform_bus_type, &rk_iommu_ops);
if (ret)
return ret;
--
2.1.0

View File

@ -26,6 +26,3 @@ index 0ae28f517a9b..c0db43d2e1a6 100644
sock_put(sk);
isk->inet_num = 0;
isk->inet_sport = 0;
--
2.3.6

View File

@ -120,6 +120,3 @@ index 86a4fe75f453..161637ed5611 100755
}
--
2.1.0

View File

@ -38,6 +38,3 @@ index 9a8a01abbaed..9a0ecbf14545 100644
* Verify we have a legal set of flags
* This leaves us room for future extensions.
*/
--
2.1.0

View File

@ -32,6 +32,3 @@ index 54cf309a92a5..64f8bb4882fb 100644
help
Use dynamic allocation for cpumask_var_t, instead of putting
them on the stack. This is a bit more expensive, but avoids
--
2.1.0

View File

@ -34,6 +34,3 @@ index 00f2f740b425..eabee5ec901f 100644
ATA_HORKAGE_ZERO_AFTER_TRIM, },
/*
--
2.3.6

View File

@ -73,6 +73,3 @@ index 3ef4627f9cb1..2b2d2e8e5eeb 100644
if (err)
return err;
--
2.1.0

View File

@ -20,6 +20,3 @@ index 72b1fc3ab910..86907eaa4883 100644
static int pcspkr_event(struct input_dev *dev, unsigned int type, unsigned int code, int value)
{
--
2.1.0

View File

@ -32,6 +32,3 @@ index 69e84427f913..f21cf4291476 100644
MODULE_AUTHOR("Tony Lindgren <tony@atomide.com>");
MODULE_DESCRIPTION("One-register-per-pin type device tree based pinctrl driver");
--
2.1.0

View File

@ -282,6 +282,3 @@ index 7d66ae508e5c..8716524f0b25 100644
extern void tty_buffer_free_all(struct tty_port *port);
extern void tty_buffer_flush(struct tty_struct *tty, struct tty_ldisc *ld);
extern void tty_buffer_init(struct tty_port *port);
--
2.1.0

View File

@ -9,7 +9,7 @@ Upstream-status: Fedora mustard (might be worth dropping...)
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index 05ea0d49a3a3..95f18e07491b 100644
index ad35ccdb92a2..661efea89ded 100644
--- a/drivers/scsi/sd.c
+++ b/drivers/scsi/sd.c
@@ -2750,13 +2750,18 @@ static int sd_try_extended_inquiry(struct scsi_device *sdp)
@ -32,6 +32,3 @@ index 05ea0d49a3a3..95f18e07491b 100644
/*
* If the device is offline, don't try and read capacity or any
* of the other niceties.
--
2.1.0

View File

@ -50,6 +50,3 @@ index ea437245562e..eefa9c45d2e1 100644
fs_initcall(fb_console_init);
#ifdef MODULE
--
2.1.0

View File

@ -88,6 +88,3 @@ index fc34a71866ed..1c5879ae3b53 100644
memset(&props, 0, sizeof(props));
props.type = BACKLIGHT_PLATFORM;
props.max_brightness = HCI_LCD_BRIGHTNESS_LEVELS - 1;
--
2.1.0

View File

@ -48,6 +48,3 @@ index d695b1673ae5..f5c98e6f7b58 100644
return ERR_PTR(-EINVAL);
tpg = kzalloc(sizeof(struct tcm_vhost_tpg), GFP_KERNEL);
--
2.1.0

View File

@ -73,6 +73,3 @@ index 70bf11815f84..4eeb9923472b 100644
set_sample_period();
if (watchdog_user_enabled)
--
2.1.0

View File

@ -65,6 +65,3 @@ index 4c58333b4257..fc9637812d78 100644
if (!access_ok(VERIFY_READ, buf, count))
return -EFAULT;
while (count-- > 0 && i < 65536) {
--
2.1.0

View File

@ -37,6 +37,3 @@ index 113e70784854..26c2f83fc470 100644
if (copy_from_user(&regs, uregs, sizeof regs)) {
err = -EFAULT;
break;
--
2.1.0

View File

@ -30,6 +30,3 @@ index ec9df6f9cd47..5e109a31f62b 100644
mc_header = (struct microcode_header_intel *)ucode_ptr;
mc_size = get_totalsize(mc_header);
--
2.1.0

View File

@ -46,6 +46,3 @@ index c4a0666de6f5..26e651336787 100644
dev->is_busmaster = 0;
} else {
pci_read_config_word(dev, PCI_COMMAND, &cmd);
--
2.1.0