kernel-5.16-0.rc1.20211119git4c388a8e740d.17
* Fri Nov 19 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211119git4c388a8e740d.17] - kasan: test: Silence intentional read overflow warnings (Kees Cook) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
fd9011d43a
commit
a514e7dbf8
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 16
|
RHEL_RELEASE = 17
|
||||||
|
|
||||||
#
|
#
|
||||||
# Early y+1 numbering
|
# Early y+1 numbering
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
https://gitlab.com/cki-project/kernel-ark/-/commit/8677ec5e639ddd6c17e47c34f3d661293a3d4f63
|
https://gitlab.com/cki-project/kernel-ark/-/commit/37c6a888c3a748451024ad31436cf3f4e2ceaa34
|
||||||
8677ec5e639ddd6c17e47c34f3d661293a3d4f63 kasan: test: Silence intentional read overflow warnings
|
37c6a888c3a748451024ad31436cf3f4e2ceaa34 kasan: test: Silence intentional read overflow warnings
|
||||||
|
|
||||||
https://gitlab.com/cki-project/kernel-ark/-/commit/07b3d9b051aa347237b4c637a1984c1915c750b2
|
https://gitlab.com/cki-project/kernel-ark/-/commit/07b3d9b051aa347237b4c637a1984c1915c750b2
|
||||||
07b3d9b051aa347237b4c637a1984c1915c750b2 Enable e1000 in rhel9 as unsupported
|
07b3d9b051aa347237b4c637a1984c1915c750b2 Enable e1000 in rhel9 as unsupported
|
||||||
|
16
kernel.spec
16
kernel.spec
@ -85,7 +85,7 @@ Summary: The Linux kernel
|
|||||||
# the --with-release option overrides this setting.)
|
# the --with-release option overrides this setting.)
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 0
|
||||||
|
|
||||||
%global distro_build 0.rc1.20211118git42eb8fdac2fc.16
|
%global distro_build 0.rc1.20211119git4c388a8e740d.17
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -130,13 +130,13 @@ Summary: The Linux kernel
|
|||||||
|
|
||||||
%define rpmversion 5.16.0
|
%define rpmversion 5.16.0
|
||||||
%define patchversion 5.16
|
%define patchversion 5.16
|
||||||
%define pkgrelease 0.rc1.20211118git42eb8fdac2fc.16
|
%define pkgrelease 0.rc1.20211119git4c388a8e740d.17
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 16
|
%define patchlevel 16
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc1.20211118git42eb8fdac2fc.16%{?buildid}%{?dist}
|
%define specrelease 0.rc1.20211119git4c388a8e740d.17%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -682,7 +682,7 @@ BuildRequires: lld
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-5.16-rc1-21-g42eb8fdac2fc.tar.xz
|
Source0: linux-5.16-rc1-236-g4c388a8e740d.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1374,8 +1374,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-5.16-rc1-21-g42eb8fdac2fc -c
|
%setup -q -n kernel-5.16-rc1-236-g4c388a8e740d -c
|
||||||
mv linux-5.16-rc1-21-g42eb8fdac2fc linux-%{KVERREL}
|
mv linux-5.16-rc1-236-g4c388a8e740d linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -2184,7 +2184,7 @@ InitBuildVars
|
|||||||
%global perf_build_extra_opts CORESIGHT=1
|
%global perf_build_extra_opts CORESIGHT=1
|
||||||
%endif
|
%endif
|
||||||
%global perf_make \
|
%global perf_make \
|
||||||
%{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
|
%{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
|
||||||
%if %{with_perf}
|
%if %{with_perf}
|
||||||
# perf
|
# perf
|
||||||
# make sure check-headers.sh is executable
|
# make sure check-headers.sh is executable
|
||||||
@ -2972,7 +2972,7 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Nov 18 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211118git42eb8fdac2fc.16]
|
* Fri Nov 19 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211119git4c388a8e740d.17]
|
||||||
- kasan: test: Silence intentional read overflow warnings (Kees Cook)
|
- kasan: test: Silence intentional read overflow warnings (Kees Cook)
|
||||||
|
|
||||||
* Thu Nov 18 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211118git42eb8fdac2fc.15]
|
* Thu Nov 18 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211118git42eb8fdac2fc.15]
|
||||||
|
@ -545,7 +545,7 @@ index c68e694fca26..146cba5ae5bc 100644
|
|||||||
return ctx.rc;
|
return ctx.rc;
|
||||||
}
|
}
|
||||||
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
|
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
|
||||||
index a50f1967c73d..faeecb8bc471 100644
|
index 2c80765670bc..5245fad951d8 100644
|
||||||
--- a/drivers/acpi/scan.c
|
--- a/drivers/acpi/scan.c
|
||||||
+++ b/drivers/acpi/scan.c
|
+++ b/drivers/acpi/scan.c
|
||||||
@@ -1725,6 +1725,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device)
|
@@ -1725,6 +1725,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device)
|
||||||
@ -2664,7 +2664,7 @@ index 186c49582f45..7bbf1c3801f9 100644
|
|||||||
obj-$(CONFIG_MODULES) += kmod.o
|
obj-$(CONFIG_MODULES) += kmod.o
|
||||||
obj-$(CONFIG_MULTIUSER) += groups.o
|
obj-$(CONFIG_MULTIUSER) += groups.o
|
||||||
diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
|
diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
|
||||||
index 50f96ea4452a..4f2f992de1aa 100644
|
index 1033ee8c0caf..f2e6d22a5645 100644
|
||||||
--- a/kernel/bpf/syscall.c
|
--- a/kernel/bpf/syscall.c
|
||||||
+++ b/kernel/bpf/syscall.c
|
+++ b/kernel/bpf/syscall.c
|
||||||
@@ -24,6 +24,7 @@
|
@@ -24,6 +24,7 @@
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-5.16-rc1-21-g42eb8fdac2fc.tar.xz) = 16e9525200fa55835f1d7ce7fe4e03a9058ec0b9943ab286cd3ca776709a8f30314e3c3f06748be15cbc0931ce9697511cf4a96e503dfc74e3feb22576d037ff
|
SHA512 (linux-5.16-rc1-236-g4c388a8e740d.tar.xz) = b9d309f2ea385081847b4165cd5b87012f71a8851e351d2c373e7451a25535b62bf36c96f18727d0491aba47e42248ebfde165d2de1715fcaf4ba9ead8498f48
|
||||||
SHA512 (kernel-abi-stablelists-5.16.0-0.rc1.20211118git42eb8fdac2fc.16.tar.bz2) = d1be0805c89447d17515ff7e6b00f063c655ac4fa207d040779d267664ce6b56c174cfd7c186787e9a163451e249239a00d331e69ab3a2a70b0ad19098201c34
|
SHA512 (kernel-abi-stablelists-5.16.0-0.rc1.20211119git4c388a8e740d.17.tar.bz2) = c86abd17f2ce76f92d5ab848b327dfc729843cdd800bbe1eec183ddd8a325868bf9758d4f681b32682fe927161ccb6527ab3a3429c713868d92e87174ea7c34f
|
||||||
SHA512 (kernel-kabi-dw-5.16.0-0.rc1.20211118git42eb8fdac2fc.16.tar.bz2) = 626bffaa3f4f81645d4774ae679a73be049434598fe69f87eda1f66333431dd64da4a70bee1371173d141df714c8ab2f1eb4dd0d05f01becc4ab632b904e5886
|
SHA512 (kernel-kabi-dw-5.16.0-0.rc1.20211119git4c388a8e740d.17.tar.bz2) = 5b2de2f56591cc6f9ecd3a100483a757d1c173b5bba5097b8ca49ddcc3de63117545fbfe5bdf5e7bb25b305838c495cc100687631249f551103b30ff78a504c4
|
||||||
|
Loading…
Reference in New Issue
Block a user