kernel-6.11.2-300
* Fri Oct 04 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.11.2-0] - Linux v6.11.2 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
2d030fba39
commit
a3b6381014
@ -1,3 +1,7 @@
|
||||
* Fri Oct 04 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.11.2-0]
|
||||
- Linux v6.11.2
|
||||
Resolves:
|
||||
|
||||
* Mon Sep 30 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.11.1-0]
|
||||
- media: qcom: camss: Fix ordering of pm_runtime_enable (Bryan O'Donoghue)
|
||||
- media: qcom: camss: Remove use_count guard in stop_streaming (Bryan O'Donoghue)
|
||||
|
11
kernel.spec
11
kernel.spec
@ -160,18 +160,18 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specrpmversion 6.11.1
|
||||
%define specversion 6.11.1
|
||||
%define specrpmversion 6.11.2
|
||||
%define specversion 6.11.2
|
||||
%define patchversion 6.11
|
||||
%define pkgrelease 300
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.11.1
|
||||
%define tarfile_release 6.11.2
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 11
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 300%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.11.1
|
||||
%define kabiversion 6.11.2
|
||||
|
||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||
# fatal kernel package build error
|
||||
@ -4128,6 +4128,9 @@ fi\
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Oct 04 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.11.2-0]
|
||||
- Linux v6.11.2
|
||||
|
||||
* Mon Sep 30 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.11.1-0]
|
||||
- media: qcom: camss: Fix ordering of pm_runtime_enable (Bryan O'Donoghue)
|
||||
- media: qcom: camss: Remove use_count guard in stop_streaming (Bryan O'Donoghue)
|
||||
|
@ -6,7 +6,6 @@
|
||||
arch/arm64/boot/dts/broadcom/bcm2712-rpi-5-b.dts | 64 +++++
|
||||
arch/arm64/boot/dts/broadcom/bcm2712.dtsi | 283 +++++++++++++++++++++
|
||||
.../dts/qcom/sc8280xp-lenovo-thinkpad-x13s.dts | 67 +++++
|
||||
.../boot/dts/rockchip/rk3399-pinebook-pro.dts | 2 +-
|
||||
arch/s390/include/asm/ipl.h | 1 +
|
||||
arch/s390/kernel/ipl.c | 5 +
|
||||
arch/s390/kernel/setup.c | 4 +
|
||||
@ -46,10 +45,10 @@
|
||||
security/lockdown/Kconfig | 13 +
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 12 +
|
||||
48 files changed, 975 insertions(+), 242 deletions(-)
|
||||
47 files changed, 974 insertions(+), 241 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index df9c90cdd1c5..5dc83cc389bf 100644
|
||||
index 7bcf0c32ea5e..f2c0bc57ebaa 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -127,7 +126,7 @@ index 84c08b46519d..c281697142b1 100644
|
||||
reg = <0x40000000 0x100>;
|
||||
interrupt-controller;
|
||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||
index a2f8ff354ca6..e185f3e75a5c 100644
|
||||
index c8cba20a4d11..40a1665236ab 100644
|
||||
--- a/arch/arm64/Kconfig
|
||||
+++ b/arch/arm64/Kconfig
|
||||
@@ -1365,7 +1365,7 @@ endchoice
|
||||
@ -629,19 +628,6 @@ index b27143f81867..320706c88cdd 100644
|
||||
edp_reg_en: edp-reg-en-state {
|
||||
pins = "gpio25";
|
||||
function = "gpio";
|
||||
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts b/arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts
|
||||
index 294eb2de263d..b3f76cc2d6e1 100644
|
||||
--- a/arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts
|
||||
+++ b/arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts
|
||||
@@ -32,7 +32,7 @@ chosen {
|
||||
backlight: edp-backlight {
|
||||
compatible = "pwm-backlight";
|
||||
power-supply = <&vcc_12v>;
|
||||
- pwms = <&pwm0 0 740740 0>;
|
||||
+ pwms = <&pwm0 0 125000 0>;
|
||||
};
|
||||
|
||||
bat: battery {
|
||||
diff --git a/arch/s390/include/asm/ipl.h b/arch/s390/include/asm/ipl.h
|
||||
index b0d00032479d..afb9544fb007 100644
|
||||
--- a/arch/s390/include/asm/ipl.h
|
||||
@ -1707,10 +1693,10 @@ index 51b1d3550421..d64985ca6e88 100644
|
||||
camss_genpd_cleanup(camss);
|
||||
|
||||
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
|
||||
index a2ce4e08edf5..07dd75b1f580 100644
|
||||
index 5d57ea27dbc4..304afc09fc11 100644
|
||||
--- a/drivers/pci/quirks.c
|
||||
+++ b/drivers/pci/quirks.c
|
||||
@@ -4433,6 +4433,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
|
||||
@@ -4446,6 +4446,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9084,
|
||||
quirk_bridge_cavm_thrx2_pcie_root);
|
||||
|
||||
@ -1742,7 +1728,7 @@ index a2ce4e08edf5..07dd75b1f580 100644
|
||||
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
|
||||
* class code. Fix it.
|
||||
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
|
||||
index 9db86943d04c..6e03290a7a07 100644
|
||||
index 53896df7ec2b..98e08f10f60e 100644
|
||||
--- a/drivers/scsi/sd.c
|
||||
+++ b/drivers/scsi/sd.c
|
||||
@@ -122,6 +122,14 @@ static const char *sd_cache_types[] = {
|
||||
@ -1869,10 +1855,10 @@ index 6bf3c4fe8511..67e5400f7644 100644
|
||||
enum efi_secureboot_mode efi_get_secureboot_mode(efi_get_variable_t *get_var)
|
||||
{
|
||||
diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
|
||||
index 855db460e08b..7a8c28cd7510 100644
|
||||
index 19c333fafe11..db33ee7f55d5 100644
|
||||
--- a/include/linux/lsm_hook_defs.h
|
||||
+++ b/include/linux/lsm_hook_defs.h
|
||||
@@ -438,6 +438,8 @@ LSM_HOOK(int, 0, bpf_token_capable, const struct bpf_token *token, int cap)
|
||||
@@ -439,6 +439,8 @@ LSM_HOOK(int, 0, bpf_token_capable, const struct bpf_token *token, int cap)
|
||||
#endif /* CONFIG_BPF_SYSCALL */
|
||||
|
||||
LSM_HOOK(int, 0, locked_down, enum lockdown_reason what)
|
||||
@ -2067,10 +2053,10 @@ index cd84d8ea1dfb..e4c70a0312bc 100644
|
||||
|
||||
const struct lsm_id lockdown_lsmid = {
|
||||
diff --git a/security/security.c b/security/security.c
|
||||
index 8cee5b6c6e6d..489e25946bf9 100644
|
||||
index 43166e341526..b8cf110aeb58 100644
|
||||
--- a/security/security.c
|
||||
+++ b/security/security.c
|
||||
@@ -5596,6 +5596,18 @@ int security_locked_down(enum lockdown_reason what)
|
||||
@@ -5630,6 +5630,18 @@ int security_locked_down(enum lockdown_reason what)
|
||||
}
|
||||
EXPORT_SYMBOL(security_locked_down);
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.11.1.tar.xz) = cfd9fed68178fb3f3869e451513894af90237747f64cf0c68444d38d5ee569585676e4d6ca96c837d2fedc5a1f03e2499397d75e4cc010000e9cbd2f648dfd5b
|
||||
SHA512 (kernel-abi-stablelists-6.11.1.tar.xz) = 47058c04ad42b4092e5e7e33bff84a4ea36ba0310184a3ea4762feca85b5ba3f7d5c6e21b114ace8cbb5ecc2ffa94a03fd0166eb9a51fb5fc6a7c9d7a64cbcef
|
||||
SHA512 (kernel-kabi-dw-6.11.1.tar.xz) = b2ba72216748d9efa2de69484a367c2f9f0d151b7d4810141753f87f4ef35c8f7cdea7099390bccd105cb212a2c8791c346a547f1faeefd55c0c352a19253978
|
||||
SHA512 (linux-6.11.2.tar.xz) = 7ea72c66429c57ef56b283bf7e771af7e49225d4a7402879da9f62260d1ad66416cd864bdff3aa48c10798bf89792dd0b9cd2317a6f091a1d9cbef8d31227c10
|
||||
SHA512 (kernel-abi-stablelists-6.11.2.tar.xz) = 571686172a2a9fd7c8ba4432c853f5f7f24f941d370f5fb403a253671a55128d07591c4b981766e2b81d72b59dbf6e55644af6cd3cdb5e673edcd8efa087b899
|
||||
SHA512 (kernel-kabi-dw-6.11.2.tar.xz) = 14eaa9e69a3f42a02e1be4ccfbb4105a792be38398fb54fc4f3bc77ffb71f9f5bf3eb8d8f31fe27019a853f4c6a8bcd13ff6f2b4e73f938f1eb382b26bfb069f
|
||||
|
Loading…
Reference in New Issue
Block a user