kernel-5.9.0-0.rc4.20200909git34d4ddd359db.5

* Wed Sep 09 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200909git34d4ddd359db.5]
- Merge ark-patches
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2020-09-09 12:27:11 -05:00
parent 45d4c5a623
commit 9f7f1a167a
77 changed files with 116 additions and 88 deletions

View File

@ -67,5 +67,5 @@ index 6e980fe16772..37bc003e7a83 100644
for (i = 0; i < hest_tab->error_source_count; i++) {
len = hest_esrc_len(hest_hdr);
--
2.26.2
2.28.0

View File

@ -71,5 +71,5 @@ index e209081d644b..7484bcf59a1b 100644
return ctx.rc;
}
--
2.26.2
2.28.0

View File

@ -82,5 +82,5 @@ index a13d90206472..6a6aae01755b 100644
#define get_user(x, p) \
--
2.26.2
2.28.0

View File

@ -28,5 +28,5 @@ index 5b768b80d1ee..6929b6b5186b 100644
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
--
2.26.2
2.28.0

View File

@ -235,5 +235,5 @@ index 000000000000..8d1641710ed7
+}
+EXPORT_SYMBOL(mark_driver_unsupported);
--
2.26.2
2.28.0

View File

@ -181,5 +181,5 @@ index 73db1ae04cef..92aa4697f558 100644
/*
* Variable Attributes
--
2.26.2
2.28.0

View File

@ -28,5 +28,5 @@ index 60a89b5e57b3..165d602481fe 100644
default "11"
help
--
2.26.2
2.28.0

View File

@ -299,5 +299,5 @@ index 3511736fbc74..112efbef3414 100644
}
--
2.26.2
2.28.0

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 33c63014f15a..0cc2def5e1c5 100644
index 0b3f5f551acb..eb3329583d82 100644
--- a/Makefile
+++ b/Makefile
@@ -497,7 +497,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
@ -21,5 +21,5 @@ index 33c63014f15a..0cc2def5e1c5 100644
KBUILD_CPPFLAGS := -D__KERNEL__
KBUILD_AFLAGS_KERNEL :=
--
2.26.2
2.28.0

View File

@ -32,5 +32,5 @@ index 2e4ba374ab54..7630e22e1722 100644
static int __init parse_acpi(char *arg)
--
2.26.2
2.28.0

View File

@ -54,5 +54,5 @@ index 907203afbd99..6fbbe2b109d1 100644
err = rxe_cache_init();
if (err) {
--
2.26.2
2.28.0

View File

@ -326,5 +326,5 @@ index 8ed37f93f3c8..d7ad35a15acb 100644
int rmi_register_transport_device(struct rmi_transport_dev *xport);
--
2.26.2
2.28.0

View File

@ -60,5 +60,5 @@ index 000000000000..733a26bd887a
+
+endmenu
--
2.26.2
2.28.0

View File

@ -40,5 +40,5 @@ index 9d9fc678c91d..84ad75a53c83 100644
+ return ret;
}
--
2.26.2
2.28.0

View File

@ -36,5 +36,5 @@ index 253fb9a7fc98..8c95b68d86d4 100644
}
--
2.26.2
2.28.0

View File

@ -39,5 +39,5 @@ index 48a7abae02d2..2d826a14824a 100644
$(version_h): FORCE
--
2.26.2
2.28.0

View File

@ -109,5 +109,5 @@ index d48414e295a0..ba0e384412c9 100644
PCI_ANY_ID, PCI_ANY_ID, },
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_LANCER_G7_FC,
--
2.26.2
2.28.0

View File

@ -76,5 +76,5 @@ index 4fbfd2a0800c..a591962f7906 100644
obj-$(CONFIG_MULTIUSER) += groups.o
--
2.26.2
2.28.0

View File

@ -25,5 +25,5 @@ index c503188880d9..b5b2be8eec22 100644
'maintainers_include', 'sphinx.ext.autosectionlabel' ]
--
2.26.2
2.28.0

View File

@ -71,5 +71,5 @@ index 2a589b6d6ed8..a2b2333e6ab1 100644
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
* class code. Fix it.
--
2.26.2
2.28.0

View File

@ -25,5 +25,5 @@ index 2a660ac1bc3a..fa87ff6a2a71 100644
int i;
--
2.26.2
2.28.0

View File

@ -47,5 +47,5 @@ index a3aee146537b..cf50fa206890 100644
{ 0x9005, 0x028c, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 63 }, /* Adaptec PMC Series 7 (Denali) */
{ 0x9005, 0x028d, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 64 }, /* Adaptec PMC Series 8 */
--
2.26.2
2.28.0

View File

@ -48,5 +48,5 @@ index 2142f1554761..f5fdf6f3650c 100644
acpi_dev_get_resources(device, &resource_list,
acpi_check_serial_bus_slave,
--
2.26.2
2.28.0

View File

@ -52,5 +52,5 @@ index a85174d05473..2e4ba374ab54 100644
static int __init parse_acpi(char *arg)
--
2.26.2
2.28.0

View File

@ -79,5 +79,5 @@ index aef8872ba843..fe1d3decf61c 100644
/**
--
2.26.2
2.28.0

View File

@ -92,5 +92,5 @@ index 835530605c0d..1a5afb3b706f 100644
int pass);
--
2.26.2
2.28.0

View File

@ -85,5 +85,5 @@ index ea5bf5f4cbed..71c55cae27ac 100644
tmp = ata_wait_register(ap, port_mmio + PORT_CMD,
PORT_CMD_LIST_ON, PORT_CMD_LIST_ON, 1, 500);
--
2.26.2
2.28.0

View File

@ -124,5 +124,5 @@ index 66441cb9c1af..6100995124f9 100644
pr_crit("Detected processor %s %s\n",
boot_cpu_data.x86_vendor_id,
--
2.26.2
2.28.0

View File

@ -34,5 +34,5 @@ index 6d232837cbee..60a89b5e57b3 100644
For systems with 52-bit userspace VAs enabled, the kernel will attempt
to maintain compatibility with older software by providing 48-bit VAs
--
2.26.2
2.28.0

View File

@ -27,5 +27,5 @@ index e00d94b16658..4db48405b23a 100644
The VM uses one page of physical memory for each page table.
For systems with a lot of processes, this can use a lot of
--
2.26.2
2.28.0

View File

@ -67,5 +67,5 @@ index 5c3513a4b450..0d59aca2cf58 100644
{ 0 }
};
--
2.26.2
2.28.0

View File

@ -49,5 +49,5 @@ index 5e5ac50d9137..ce77b8dfe47a 100644
if (err)
return err;
--
2.26.2
2.28.0

View File

@ -118,5 +118,5 @@ index fe1d3decf61c..2c483bec82d6 100644
/**
--
2.26.2
2.28.0

View File

@ -419,5 +419,5 @@ index 000000000000..b483f96ee1db
+MODULE_DESCRIPTION("DRM driver for Xingbangda XBD599 MIPI DSI panel");
+MODULE_LICENSE("GPL v2");
--
2.26.2
2.28.0

View File

@ -55,5 +55,5 @@ index 7f13f4d715bf..dd1b426f105c 100644
/*
* And I'm not entirely sure what vblk is about. The driver in
--
2.26.2
2.28.0

View File

@ -70,5 +70,5 @@ index 000000000000..b27bcf11198f
+
+...
--
2.26.2
2.28.0

View File

@ -31,5 +31,5 @@ index b2f2fcfdf732..a9e4c059d402 100644
goto out;
}
--
2.26.2
2.28.0

View File

@ -157,5 +157,5 @@ index 92aa4697f558..1cdc5d8b6ac3 100644
#ifdef CONFIG_RESET_ATTACK_MITIGATION
--
2.26.2
2.28.0

View File

@ -68,5 +68,5 @@ index e84ddf484010..d0501353a4b9 100644
prompt "Kernel default lockdown mode"
default LOCK_DOWN_KERNEL_FORCE_NONE
--
2.26.2
2.28.0

View File

@ -51,5 +51,5 @@ index 48d5da59262b..84d90eedb067 100644
};
--
2.26.2
2.28.0

View File

@ -39,5 +39,5 @@ index 4634b48949bb..e93470340eda 100644
ice_wq = alloc_workqueue("%s", WQ_MEM_RECLAIM, 0, KBUILD_MODNAME);
if (!ice_wq) {
--
2.26.2
2.28.0

View File

@ -39,5 +39,5 @@ index 3e4868a6498b..502f9a9a2806 100644
$(version_h): FORCE
--
2.26.2
2.28.0

View File

@ -94,5 +94,5 @@ index 609bd25bf154..c701912b13ab 100644
+arch_initcall(iommu_quirks);
+#endif
--
2.26.2
2.28.0

View File

@ -119,5 +119,5 @@ index 737c0b6b24ea..7901e780323b 100644
rv = ipmi_register_driver();
mutex_unlock(&ipmi_interfaces_mutex);
--
2.26.2
2.28.0

View File

@ -210,5 +210,5 @@ index 000000000000..e0d3353802bb
+
+#endif /* _LINUX_RH_KABI_H */
--
2.26.2
2.28.0

View File

@ -185,5 +185,5 @@ index 0b3f738178b8..a04650f7f6c2 100644
* if the commandline contains a ':', then that's the extended
* syntax -- if not, it must be the classic syntax
--
2.26.2
2.28.0

View File

@ -39,5 +39,5 @@ index a04650f7f6c2..09a4870fe1fb 100644
/*
--
2.26.2
2.28.0

View File

@ -89,5 +89,5 @@ index 106e4500fd53..0b3f738178b8 100644
break;
}
--
2.26.2
2.28.0

View File

@ -49,5 +49,5 @@ index 2c483bec82d6..e1f2bf843901 100644
[ TAINT_RESERVED29 ] = { '?', '-', false },
[ TAINT_RESERVED30 ] = { '?', '-', false },
--
2.26.2
2.28.0

View File

@ -43,5 +43,5 @@ index 2b7e7b5f38ed..b3bacfdcb727 100644
/* Fusion */
{PCI_DEVICE(PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_PLASMA)},
--
2.26.2
2.28.0

View File

@ -67,5 +67,5 @@ index 5e252d91eb14..c6e1a9443e9e 100644
debugfs_create_file("kmemleak", 0644, NULL, NULL, &kmemleak_fops);
--
2.26.2
2.28.0

View File

@ -147,5 +147,5 @@ index 69341b36f271..dbc63328187c 100644
sprintf(fname, "%s.mod.c", mod->name);
write_if_changed(&buf, fname);
--
2.26.2
2.28.0

View File

@ -67,5 +67,5 @@ index 2e2756d8a49b..a67a47d3fce1 100644
{ MPI2_MFGPAGE_VENDORID_LSI, MPI25_MFGPAGE_DEVID_SAS3004,
PCI_ANY_ID, PCI_ANY_ID },
--
2.26.2
2.28.0

View File

@ -47,5 +47,5 @@ index 18b91ea1a353..38d8b2bb3a37 100644
if (error) {
dprintk(ioc, printk(MYIOC_s_ERR_FMT
--
2.26.2
2.28.0

View File

@ -54,5 +54,5 @@ index 38d8b2bb3a37..b71f77a5799f 100644
};
MODULE_DEVICE_TABLE(pci, mptsas_pci_table);
--
2.26.2
2.28.0

View File

@ -47,5 +47,5 @@ index eabc4de5816c..c028f5944694 100644
out_mptspi_probe:
--
2.26.2
2.28.0

View File

@ -52,5 +52,5 @@ index c028f5944694..1f458e35effb 100644
};
MODULE_DEVICE_TABLE(pci, mptspi_pci_table);
--
2.26.2
2.28.0

View File

@ -59,10 +59,10 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index ec2330ce0fc5..33c63014f15a 100644
index 2b1061ec98ed..0b3f5f551acb 100644
--- a/Makefile
+++ b/Makefile
@@ -1249,7 +1249,13 @@ endef
@@ -1245,7 +1245,13 @@ endef
define filechk_version.h
echo \#define LINUX_VERSION_CODE $(shell \
expr $(VERSION) \* 65536 + 0$(PATCHLEVEL) \* 256 + 0$(SUBLEVEL)); \
@ -78,5 +78,5 @@ index ec2330ce0fc5..33c63014f15a 100644
$(version_h): FORCE
--
2.26.2
2.28.0

View File

@ -75,5 +75,5 @@ index 8da00ba54aec..cf5ccbdd7fbc 100644
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2271) },
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2261) },
--
2.26.2
2.28.0

View File

@ -52,5 +52,5 @@ index 676778cbc550..e41772d11f26 100644
};
MODULE_DEVICE_TABLE(pci, qla4xxx_pci_tbl);
--
2.26.2
2.28.0

View File

@ -46,5 +46,5 @@ index 8d1641710ed7..4050b6dead75 100644
EXPORT_SYMBOL(mark_hardware_unsupported);
--
2.26.2
2.28.0

View File

@ -197,5 +197,5 @@ index 87f2bd530df7..d551df994583 100644
+
#endif /* _LINUX_RH_KABI_H */
--
2.26.2
2.28.0

View File

@ -43,5 +43,5 @@ index d551df994583..9a4fea93ad99 100644
/*
--
2.26.2
2.28.0

View File

@ -46,5 +46,5 @@ index 9a4fea93ad99..cdc636d3013d 100644
/*
* RH_KABI_SET_SIZE calculates and sets the size of the extended struct and
--
2.26.2
2.28.0

View File

@ -63,5 +63,5 @@ index 4debb7aaad48..b90601e8a657 100644
* considered not to be part of the kABI whitelist and may be changed at
* will. Note however that it's the responsibility of the developer
--
2.26.2
2.28.0

View File

@ -61,5 +61,5 @@ index b90601e8a657..ea9c136bf884 100644
})
--
2.26.2
2.28.0

View File

@ -97,5 +97,5 @@ index cdc636d3013d..4debb7aaad48 100644
* RHEL macros to extend structs.
*
--
2.26.2
2.28.0

View File

@ -100,5 +100,5 @@ index e0d3353802bb..87f2bd530df7 100644
+
#endif /* _LINUX_RH_KABI_H */
--
2.26.2
2.28.0

View File

@ -63,5 +63,5 @@ index e600f6953d7c..4264e01824b3 100644
/* boot_command_line has been already set up in early.c */
*cmdline_p = boot_command_line;
--
2.26.2
2.28.0

View File

@ -66,5 +66,5 @@ index ca1e6cf6a38e..af3ce8608ed3 100644
PCI_DEVICE_SUB(PCI_VENDOR_ID_ADAPTEC2, 0x028f,
PCI_VENDOR_ID_DELL, 0x1fe0)
--
2.26.2
2.28.0

View File

@ -99,5 +99,5 @@ index 70a7ad357bc6..23e16e773bc2 100644
int security_perf_event_open(struct perf_event_attr *attr, int type)
{
--
2.26.2
2.28.0

View File

@ -50,5 +50,5 @@ index 32d3f53af10b..52a0138c6920 100755
# Use make KBUILD_ABS_SRCTREE=1 {tags|cscope}
# to force full paths for a non-O= build
--
2.26.2
2.28.0

View File

@ -57,5 +57,5 @@ index b57e6dd6d7ef..66441cb9c1af 100644
unwind_init();
}
--
2.26.2
2.28.0

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 5
RHEL_RELEASE = 6
#
# Early y+1 numbering

View File

@ -30,7 +30,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
%global distro_build 0.rc4.5
%global distro_build 0.rc4.20200909git34d4ddd359db.6
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -69,13 +69,13 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.9.0
%define pkgrelease 0.rc4.5
%define pkgrelease 0.rc4.20200909git34d4ddd359db.6
# This is needed to do merge window version magic
%define patchlevel 9
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc4.5%{?buildid}%{?dist}
%define specrelease 0.rc4.20200909git34d4ddd359db.6%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@ -166,7 +166,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
%define debugbuildsenabled 1
%define debugbuildsenabled 0
# The kernel tarball/base version
%define kversion 5.9
@ -567,7 +567,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.9-rc4.tar.xz
Source0: linux-20200909git34d4ddd359db.tar.xz
Source1: Makefile.rhelver
@ -1284,8 +1284,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.9-rc4 -c
mv linux-5.9-rc4 linux-%{KVERREL}
%setup -q -n kernel-20200909git34d4ddd359db -c
mv linux-20200909git34d4ddd359db linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2793,6 +2793,34 @@ fi
#
#
%changelog
* Wed Sep 09 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200909git34d4ddd359db.5]
- Merge ark-patches
* Wed Sep 09 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200909git34d4ddd359db.4.test]
- 34d4ddd359db rebase
- Revert "drm/i915/gem: Delete unused code" (Dave Airlie)
- Revert "drm/i915/gem: Async GPU relocations only" (Dave Airlie)
- Revert "drm/i915: Remove i915_gem_object_get_dirty_page()" (Dave Airlie)
- Updated changelog for the release based on v5.9-rc4 (Fedora Kernel Team)
- drm/msm: Disable the RPTR shadow (Jordan Crouse)
- drm/msm: Disable preemption on all 5xx targets (Jordan Crouse)
- drm/msm: Enable expanded apriv support for a650 (Jordan Crouse)
- drm/msm: Split the a5xx preemption record (Jordan Crouse)
- Revert "kbuild: use -flive-patching when CONFIG_LIVEPATCH is enabled" (Josh Poimboeuf)
- scsi: mpt3sas: Don't call disable_irq from IRQ poll handler (Tomas Henzl)
- scsi: megaraid_sas: Don't call disable_irq from process IRQ poll (Tomas Henzl)
- scsi: target: iscsi: Fix hang in iscsit_access_np() when getting tpg->np_login_sem (Hou Pu)
- scsi: libsas: Set data_dir as DMA_NONE if libata marks qc as NODATA (Luo Jiaxing)
- scsi: target: iscsi: Fix data digest calculation (Varun Prakash)
- scsi: lpfc: Update lpfc version to 12.8.0.4 (James Smart)
- scsi: lpfc: Extend the RDF FPIN Registration descriptor for additional events (James Smart)
- scsi: lpfc: Fix FLOGI/PLOGI receive race condition in pt2pt discovery (James Smart)
- scsi: lpfc: Fix setting IRQ affinity with an empty CPU mask (James Smart)
- scsi: qla2xxx: Fix regression on sparc64 (=?UTF-8?q?Ren=C3=A9=20Rebe?=)
- scsi: libfc: Fix for double free() (Javed Hasan)
- scsi: pm8001: Fix memleak in pm8001_exec_internal_task_abort (Dinghao Liu)
- selftests/timers: Turn off timeout setting (Po-Hsu Lin)
* Mon Sep 07 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.4]
- Merge ark-patches

View File

@ -23,4 +23,4 @@ test "$procgroup" = 1 && exec xargs -r xz
# xz has some startup cost. If files are really small,
# this cost might be significant. To combat this,
# process several files (in sequence) by each xz process via -n 16:
exec xargs -r -n 16 -P $procgroup xz
exec xargs -r -n 16 -P "$procgroup" xz

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.9-rc4.tar.xz) = 2899fd304d48bfe10cd2915fe9c89dacbc9793e0d2b4a06ae0656afc7170cab895c9da6e81975e999958a1d6ae340a43a3a88306330a7f41383580541e33cb26
SHA512 (kernel-abi-whitelists-5.9.0-0.rc4.5.tar.bz2) = f2f65e66fce2c46243687db29f490120e2a432dfba3ba2eb94eac6ceb310412ccbb0d82792c166bdd085a28c2445185b909e40e5db08a717a4c0e6f8d886a9e6
SHA512 (kernel-kabi-dw-5.9.0-0.rc4.5.tar.bz2) = 12afdba6cfc0a2103072482a2a9d736e57e997f6ea44b727ac005a371df2b7da725ba3cd64f551e885dcd6c0d965d58b2905b99a5ccd659baefd648cd3079d05
SHA512 (linux-20200909git34d4ddd359db.tar.xz) = cbcb42eaf278e2d97e376ddcf2bc88d65a3ef7af4066c1aacb9621612c53cdc3f274263a1e974a5d588f8999bf8e2fbac0161395ed5fd452434b5056f8fd32c1
SHA512 (kernel-abi-whitelists-5.9.0-0.rc4.20200909git34d4ddd359db.6.tar.bz2) = 811199485989af2ff29c0a2120208d0e7180c88a4f6a705be12e20cbab67c7bb602e4ea35e77a73698c8002a07d878cfa371c2182caffa427d096b443768935f
SHA512 (kernel-kabi-dw-5.9.0-0.rc4.20200909git34d4ddd359db.6.tar.bz2) = f91b7c857ca70406d180151642539cf092bb18952caf13426844ad9e0eab34dbc94c703390b9cc4532941179094c241d048f25dd29ab2936e83a80baa43c25f2