kernel-5.16-0.rc0.20211112git5833291ab6de.12
* Fri Nov 12 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc0.20211112git5833291ab6de.12] - drm/virtio: Fix NULL dereference error in virtio_gpu_poll (Vivek Kasireddy) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
f0005b3337
commit
9f3c08456e
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 11
|
||||
RHEL_RELEASE = 12
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
@ -1,8 +1,5 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/08976b7add73a184cbe339aadd9bb83b0c0d6800
|
||||
08976b7add73a184cbe339aadd9bb83b0c0d6800 arm64: cpufeature: Export this_cpu_has_cap helper
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/9263342d48cdaad8a46fa002b7676e9571ce70a9
|
||||
9263342d48cdaad8a46fa002b7676e9571ce70a9 drm/virtio: Fix NULL dereference error in virtio_gpu_poll
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/3da0ae07e0d2d55fb4eb313ec6dc721ceb5439de
|
||||
3da0ae07e0d2d55fb4eb313ec6dc721ceb5439de drm/virtio: Fix NULL dereference error in virtio_gpu_poll
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/07b3d9b051aa347237b4c637a1984c1915c750b2
|
||||
07b3d9b051aa347237b4c637a1984c1915c750b2 Enable e1000 in rhel9 as unsupported
|
||||
|
15
kernel.spec
15
kernel.spec
@ -85,7 +85,7 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 0
|
||||
|
||||
%global distro_build 0.rc0.20211111gitdebe436e77c7.11
|
||||
%global distro_build 0.rc0.20211112git5833291ab6de.12
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -130,13 +130,13 @@ Summary: The Linux kernel
|
||||
|
||||
%define rpmversion 5.16.0
|
||||
%define patchversion 5.16
|
||||
%define pkgrelease 0.rc0.20211111gitdebe436e77c7.11
|
||||
%define pkgrelease 0.rc0.20211112git5833291ab6de.12
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 16
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc0.20211111gitdebe436e77c7.11%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc0.20211112git5833291ab6de.12%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -682,7 +682,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.15-12267-gdebe436e77c7.tar.xz
|
||||
Source0: linux-5.15-12452-g5833291ab6de.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1374,8 +1374,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.15-12267-gdebe436e77c7 -c
|
||||
mv linux-5.15-12267-gdebe436e77c7 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.15-12452-g5833291ab6de -c
|
||||
mv linux-5.15-12452-g5833291ab6de linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -2972,8 +2972,7 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Thu Nov 11 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc0.20211111gitdebe436e77c7.11]
|
||||
- arm64: cpufeature: Export this_cpu_has_cap helper (Arnd Bergmann)
|
||||
* Fri Nov 12 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc0.20211112git5833291ab6de.12]
|
||||
- drm/virtio: Fix NULL dereference error in virtio_gpu_poll (Vivek Kasireddy)
|
||||
|
||||
* Thu Nov 11 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc0.20211111gitdebe436e77c7.10]
|
||||
|
@ -5,7 +5,6 @@
|
||||
arch/arm/Kconfig | 4 +-
|
||||
arch/arm64/Kconfig | 3 +-
|
||||
arch/arm64/kernel/acpi.c | 4 +
|
||||
arch/arm64/kernel/cpufeature.c | 1 +
|
||||
arch/s390/include/asm/ipl.h | 1 +
|
||||
arch/s390/kernel/ipl.c | 5 +
|
||||
arch/s390/kernel/setup.c | 4 +
|
||||
@ -74,7 +73,7 @@
|
||||
security/lockdown/Kconfig | 13 +
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 6 +
|
||||
76 files changed, 1384 insertions(+), 189 deletions(-)
|
||||
75 files changed, 1383 insertions(+), 189 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||
index 9725c546a0d4..4d440bdcf5b9 100644
|
||||
@ -212,18 +211,6 @@ index f3851724fe35..ef69eeab6f2a 100644
|
||||
static bool param_acpi_force __initdata;
|
||||
|
||||
static int __init parse_acpi(char *arg)
|
||||
diff --git a/arch/arm64/kernel/cpufeature.c b/arch/arm64/kernel/cpufeature.c
|
||||
index 7de96196ae14..6f3e677d88f1 100644
|
||||
--- a/arch/arm64/kernel/cpufeature.c
|
||||
+++ b/arch/arm64/kernel/cpufeature.c
|
||||
@@ -2868,6 +2868,7 @@ bool this_cpu_has_cap(unsigned int n)
|
||||
|
||||
return false;
|
||||
}
|
||||
+EXPORT_SYMBOL_GPL(this_cpu_has_cap);
|
||||
|
||||
/*
|
||||
* This helper function is used in a narrow window when,
|
||||
diff --git a/arch/s390/include/asm/ipl.h b/arch/s390/include/asm/ipl.h
|
||||
index 3f8ee257f9aa..3ab92feb6241 100644
|
||||
--- a/arch/s390/include/asm/ipl.h
|
||||
@ -1719,7 +1706,7 @@ index b334af8aa264..b2a0e2fc6d47 100644
|
||||
{
|
||||
}
|
||||
diff --git a/drivers/pci/pci-driver.c b/drivers/pci/pci-driver.c
|
||||
index 1d98c974381c..b442f6927ec0 100644
|
||||
index 588588cfda48..1b90c69b7718 100644
|
||||
--- a/drivers/pci/pci-driver.c
|
||||
+++ b/drivers/pci/pci-driver.c
|
||||
@@ -19,6 +19,7 @@
|
||||
@ -2219,10 +2206,10 @@ index 968b4c4fe65b..4c34135b7fee 100644
|
||||
+
|
||||
#endif
|
||||
diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
|
||||
index a9ac70ae01ab..9bbf62267622 100644
|
||||
index 442a611fa0fb..45b98d102e61 100644
|
||||
--- a/include/linux/lsm_hook_defs.h
|
||||
+++ b/include/linux/lsm_hook_defs.h
|
||||
@@ -395,6 +395,8 @@ LSM_HOOK(void, LSM_RET_VOID, bpf_prog_free_security, struct bpf_prog_aux *aux)
|
||||
@@ -397,6 +397,8 @@ LSM_HOOK(void, LSM_RET_VOID, bpf_prog_free_security, struct bpf_prog_aux *aux)
|
||||
#endif /* CONFIG_BPF_SYSCALL */
|
||||
|
||||
LSM_HOOK(int, 0, locked_down, enum lockdown_reason what)
|
||||
@ -2232,10 +2219,10 @@ index a9ac70ae01ab..9bbf62267622 100644
|
||||
#ifdef CONFIG_PERF_EVENTS
|
||||
LSM_HOOK(int, 0, perf_event_open, struct perf_event_attr *attr, int type)
|
||||
diff --git a/include/linux/lsm_hooks.h b/include/linux/lsm_hooks.h
|
||||
index 0bada4df23fc..3bee971d0b1e 100644
|
||||
index d6823214d5c1..c927853f0732 100644
|
||||
--- a/include/linux/lsm_hooks.h
|
||||
+++ b/include/linux/lsm_hooks.h
|
||||
@@ -1548,6 +1548,12 @@
|
||||
@@ -1553,6 +1553,12 @@
|
||||
*
|
||||
* @what: kernel feature being accessed
|
||||
*
|
||||
@ -2291,10 +2278,10 @@ index f5844908a089..901d51012738 100644
|
||||
|
||||
struct taint_flag {
|
||||
diff --git a/include/linux/pci.h b/include/linux/pci.h
|
||||
index c8afbee5da4b..122c0b5473fe 100644
|
||||
index 138d764c1c35..ab6ba4f105f6 100644
|
||||
--- a/include/linux/pci.h
|
||||
+++ b/include/linux/pci.h
|
||||
@@ -1475,6 +1475,10 @@ int pci_add_dynid(struct pci_driver *drv,
|
||||
@@ -1476,6 +1476,10 @@ int pci_add_dynid(struct pci_driver *drv,
|
||||
unsigned long driver_data);
|
||||
const struct pci_device_id *pci_match_id(const struct pci_device_id *ids,
|
||||
struct pci_dev *dev);
|
||||
@ -2646,7 +2633,7 @@ index ab7eea01ab42..fff7c5f737fc 100644
|
||||
|
||||
int rmi_register_transport_device(struct rmi_transport_dev *xport);
|
||||
diff --git a/include/linux/security.h b/include/linux/security.h
|
||||
index 7e0ba63b5dde..5ab6ceaa2589 100644
|
||||
index 06eac4e61a13..afbb845f8203 100644
|
||||
--- a/include/linux/security.h
|
||||
+++ b/include/linux/security.h
|
||||
@@ -473,6 +473,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
|
||||
@ -2669,7 +2656,7 @@ index 7e0ba63b5dde..5ab6ceaa2589 100644
|
||||
|
||||
#if defined(CONFIG_SECURITY) && defined(CONFIG_WATCH_QUEUE)
|
||||
diff --git a/init/Kconfig b/init/Kconfig
|
||||
index 21b1f4870c80..5e82f7f77abd 100644
|
||||
index 45bcaa8e7481..e0c1399a1a2c 100644
|
||||
--- a/init/Kconfig
|
||||
+++ b/init/Kconfig
|
||||
@@ -1648,7 +1648,7 @@ config AIO
|
||||
@ -3061,10 +3048,10 @@ index 87cbdc64d272..18555cf18da7 100644
|
||||
|
||||
static int __init lockdown_lsm_init(void)
|
||||
diff --git a/security/security.c b/security/security.c
|
||||
index 95e30fadba78..ee2beb206700 100644
|
||||
index 779a9edea0a0..08fd8f49ad3a 100644
|
||||
--- a/security/security.c
|
||||
+++ b/security/security.c
|
||||
@@ -2600,6 +2600,12 @@ int security_locked_down(enum lockdown_reason what)
|
||||
@@ -2607,6 +2607,12 @@ int security_locked_down(enum lockdown_reason what)
|
||||
}
|
||||
EXPORT_SYMBOL(security_locked_down);
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.15-12267-gdebe436e77c7.tar.xz) = aab85f56390077bf1af6c2c67213e0e2e778206844ecb2b73b6c60add240a058573e7157331bfc5ce76dc4a092f287582f70ccb65a1d1a3612b078ef8653f4b6
|
||||
SHA512 (kernel-abi-stablelists-5.16.0-0.rc0.20211111gitdebe436e77c7.11.tar.bz2) = 94017a06d8fa9d90e5bf4cd5236614a3042318a392b793fed7f39c34ca0e5292305c3c543044dd017c512aea75bb8c1e75cd7a7d58d042ada65850324d3f3603
|
||||
SHA512 (kernel-kabi-dw-5.16.0-0.rc0.20211111gitdebe436e77c7.11.tar.bz2) = 3cb0391fd29ae297344c36fd9e1c5030d328a762391c5ed4c5091d5087b406bfbc044ba1d7073b94e81ff4fd653158e160052470b83a5638bf4d36fed89c7420
|
||||
SHA512 (linux-5.15-12452-g5833291ab6de.tar.xz) = 5ea9f6f6692c3c6e36c3b6306621defcc40afea9df718980d372fa7eecdcc1405e488d58962becbd94a45afceeeff1dfb2215d53bdb200251e56ff140426d1ed
|
||||
SHA512 (kernel-abi-stablelists-5.16.0-0.rc0.20211112git5833291ab6de.12.tar.bz2) = 3341442e0035ea3ec49463db2b52287eac9b3cb88c0add2976e30f8d974e570885ba8d06fc3f88e3c6aee01e4725be2cde97f37f222119496464dc3b1b247de0
|
||||
SHA512 (kernel-kabi-dw-5.16.0-0.rc0.20211112git5833291ab6de.12.tar.bz2) = 6459cc1b1c18a4c986d34f96079c1ccaf7b1113733ca36d08123cb45b6c9f8e3b393e5e44d6446ef83e3ccb6e26df2afc116135903079fc4276ae8287def9def
|
||||
|
Loading…
Reference in New Issue
Block a user