kernel-5.15.12-0

* Wed Dec 29 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.15.12-0]
- iwlwifi: mvm: Increase the scan timeout guard to 30 seconds (Ilan Peer)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-12-29 08:40:42 -06:00
parent 8c0f76826f
commit 9daea543cb
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 37 additions and 17 deletions

View File

@ -1,3 +1,6 @@
https://gitlab.com/cki-project/kernel-ark/-/commit/f1cc8d1b733c14b152da07eeab09ae0ffb541ef1
f1cc8d1b733c14b152da07eeab09ae0ffb541ef1 iwlwifi: mvm: Increase the scan timeout guard to 30 seconds
https://gitlab.com/cki-project/kernel-ark/-/commit/0fa86a7082006675caec52bd8bfb003f3481b483
0fa86a7082006675caec52bd8bfb003f3481b483 platform/x86: thinkpad_acpi: Add lid_logo_dot to the list of safe LEDs

View File

@ -128,7 +128,7 @@ Summary: The Linux kernel
# The kernel tarball/base version
%define kversion 5.15
%define rpmversion 5.15.11
%define rpmversion 5.15.12
%define patchversion 5.15
%define pkgrelease 200
@ -682,7 +682,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.15.11.tar.xz
Source0: linux-5.15.12.tar.xz
Source1: Makefile.rhelver
@ -1374,8 +1374,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.15.11 -c
mv linux-5.15.11 linux-%{KVERREL}
%setup -q -n kernel-5.15.12 -c
mv linux-5.15.12 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2972,6 +2972,9 @@ fi
#
#
%changelog
* Wed Dec 29 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.15.12-0]
- iwlwifi: mvm: Increase the scan timeout guard to 30 seconds (Ilan Peer)
* Wed Dec 22 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.15.11-0]
- Fix up Changelog (Justin M. Forbes)

View File

@ -27,6 +27,7 @@
drivers/hwtracing/coresight/coresight-etm4x-core.c | 19 ++++
drivers/input/rmi4/rmi_driver.c | 124 ++++++++++++---------
drivers/iommu/iommu.c | 22 ++++
drivers/net/wireless/intel/iwlwifi/mvm/scan.c | 2 +-
drivers/net/wireless/marvell/mwifiex/usb.c | 3 +-
drivers/nvme/host/core.c | 22 +++-
drivers/nvme/host/multipath.c | 19 ++--
@ -47,13 +48,13 @@
security/lockdown/Kconfig | 13 +++
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
49 files changed, 752 insertions(+), 201 deletions(-)
50 files changed, 753 insertions(+), 202 deletions(-)
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
index 1396fd2d9031..4bc97128cee8 100644
index a454f438bd62..d00009504c94 100644
--- a/Documentation/admin-guide/kernel-parameters.txt
+++ b/Documentation/admin-guide/kernel-parameters.txt
@@ -3949,6 +3949,15 @@
@@ -3953,6 +3953,15 @@
please report a bug.
nocrs [X86] Ignore PCI host bridge windows from ACPI.
If you need to use this, please report a bug.
@ -70,7 +71,7 @@ index 1396fd2d9031..4bc97128cee8 100644
This is normally done in pci_enable_device(),
so this option is a temporary workaround
diff --git a/Makefile b/Makefile
index 37a1144c32df..71ebb01b9baa 100644
index 474b2a2292ca..22cae212633b 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -101,7 +102,7 @@ index 4ebd512043be..6743668b7b33 100644
The VM uses one page of physical memory for each page table.
For systems with a lot of processes, this can use a lot of
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
index fee914c716aa..99bb34aac703 100644
index 0758ea0717f9..fb57b7a992d4 100644
--- a/arch/arm64/Kconfig
+++ b/arch/arm64/Kconfig
@@ -911,7 +911,7 @@ endchoice
@ -249,7 +250,7 @@ index 9b9fb7882c20..e8dc9bc327bd 100644
entry = &e820_table->entries[i];
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
index d71267081153..5f7b1c67ddcc 100644
index 48596f9fddf4..b31d4f581b66 100644
--- a/arch/x86/kernel/setup.c
+++ b/arch/x86/kernel/setup.c
@@ -20,6 +20,7 @@
@ -260,7 +261,7 @@ index d71267081153..5f7b1c67ddcc 100644
#include <linux/usb/xhci-dbgp.h>
#include <linux/static_call.h>
#include <linux/swiotlb.h>
@@ -941,6 +942,13 @@ void __init setup_arch(char **cmdline_p)
@@ -929,6 +930,13 @@ void __init setup_arch(char **cmdline_p)
if (efi_enabled(EFI_BOOT))
efi_init();
@ -274,7 +275,7 @@ index d71267081153..5f7b1c67ddcc 100644
dmi_setup();
/*
@@ -1106,19 +1114,7 @@ void __init setup_arch(char **cmdline_p)
@@ -1094,19 +1102,7 @@ void __init setup_arch(char **cmdline_p)
/* Allocate bigger log buffer */
setup_log_buf(1);
@ -647,7 +648,7 @@ index bbf7029e224b..cf7faa970dd6 100644
dmi_decode_ipmi((const struct dmi_header *) dev->device_data);
diff --git a/drivers/char/ipmi/ipmi_msghandler.c b/drivers/char/ipmi/ipmi_msghandler.c
index b404cc46cbda..c74d611bcb79 100644
index fe91090e04a4..f00bc6886913 100644
--- a/drivers/char/ipmi/ipmi_msghandler.c
+++ b/drivers/char/ipmi/ipmi_msghandler.c
@@ -35,6 +35,7 @@
@ -658,7 +659,7 @@ index b404cc46cbda..c74d611bcb79 100644
#include <linux/delay.h>
#define IPMI_DRIVER_VERSION "39.2"
@@ -5173,8 +5174,21 @@ static int __init ipmi_init_msghandler_mod(void)
@@ -5178,8 +5179,21 @@ static int __init ipmi_init_msghandler_mod(void)
{
int rv;
@ -1448,6 +1449,19 @@ index 3303d707bab4..372edaaafaa1 100644
/*
* Changes the default domain of an iommu group that has *only* one device
*
diff --git a/drivers/net/wireless/intel/iwlwifi/mvm/scan.c b/drivers/net/wireless/intel/iwlwifi/mvm/scan.c
index d78e436fa8b5..b064d3137e46 100644
--- a/drivers/net/wireless/intel/iwlwifi/mvm/scan.c
+++ b/drivers/net/wireless/intel/iwlwifi/mvm/scan.c
@@ -2490,7 +2490,7 @@ static int iwl_mvm_check_running_scans(struct iwl_mvm *mvm, int type)
return -EIO;
}
-#define SCAN_TIMEOUT 20000
+#define SCAN_TIMEOUT 30000
void iwl_mvm_scan_timeout_wk(struct work_struct *work)
{
diff --git a/drivers/net/wireless/marvell/mwifiex/usb.c b/drivers/net/wireless/marvell/mwifiex/usb.c
index 9736aa0ab7fd..8f01fcbe9396 100644
--- a/drivers/net/wireless/marvell/mwifiex/usb.c

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.15.11.tar.xz) = c78502919e8394f935a837a8e92917df1703b350348aef51dfc51aae5bbe66083d128af5b4455d6cc70a1d7ee465227099e93ea7ecd3e67831e6bb6faa2188f8
SHA512 (kernel-abi-stablelists-5.15.11-200.tar.bz2) = 706ea8ac606ddc12413349c1c3c8c1d90e4953e11c41bd83021889ddb0e3525642614015e081c8c3b78e546d91e9844f0d85037b732c5efea43bec243048d876
SHA512 (kernel-kabi-dw-5.15.11-200.tar.bz2) = 79dc6427d310318d731f161a24474ed9bfbc165fbd792882e13ece590bf8e5dcf0e6d46686a29959f0688f227fded0254c9bf8ba2e350ba6472d1fa9cfcb9b2a
SHA512 (linux-5.15.12.tar.xz) = c227f0d22128fac855f97d5bc8a48bfe7d7756a1176eb595372b5a073f2077a242514da41667ec4fb7f3b96b32e324611fabba6f3acad8646e8349462ce76363
SHA512 (kernel-abi-stablelists-5.15.12-200.tar.bz2) = 0d6bb650ac22ec56622c17c65ed6ecce30309e47f8ab482b4348767e9939236838203ed4fb1d0db1013473ba89969adcf07f9a42cbff1150e14340ff9dca5e1f
SHA512 (kernel-kabi-dw-5.15.12-200.tar.bz2) = e370b48397aadcfcb93304dad8494a832c78aa2b35dbe72f8ddf91cae3430001b767fb8e5f0d176c6ab40766a97afcaee89a0a9400a970aa92592b0b692b7a8e