Fix for arm64 compilation issue

The short answer is that it looks like Fedora binutils doesn't quite
work with this patch. The long answer might be more complicated but this
gets things compiling.
This commit is contained in:
Laura Abbott 2018-07-09 16:01:27 -07:00
parent e71fe62528
commit 9caee771b5
2 changed files with 57 additions and 0 deletions

View File

@ -0,0 +1,54 @@
From 4cf95d8ea33f6b4704229e64f8a215bc44bf2403 Mon Sep 17 00:00:00 2001
From: Laura Abbott <labbott@redhat.com>
Date: Mon, 9 Jul 2018 12:55:30 -0700
Subject: [PATCH] Revert "arm64: Use aarch64elf and aarch64elfb emulation mode
variants"
To: Will Deacon <will.deacon@arm.com>
To: Paul Kocialkowski <contact@paulk.fr>
To: Catalin Marinas <catalin.marinas@arm.com>
Cc: linux-arm-kernel@lists.infradead.org
Cc: linux-kernel@vger.kernel.org
This reverts commit 38fc4248677552ce35efc09902fdcb06b61d7ef9.
This breaks compilation with Fedora gcc-8 tool chains:
CHK include/generated/compile.h
LD [M] arch/arm64/crypto/sha512-ce.o
aarch64-linux-gnu-ld: cannot open linker script file ldscripts/aarch64elf.xr: No such file or directory
make[1]: *** [scripts/Makefile.build:530: arch/arm64/crypto/sha512-ce.o] Error 1
make: *** [Makefile:1029: arch/arm64/crypto] Error 2
Fixes: 38fc42486775 ("arm64: Use aarch64elf and aarch64elfb emulation mode variants")
Signed-off-by: Laura Abbott <labbott@redhat.com>
---
A bit rushed and I'm still debugging but I wanted to send this out
before anyone else gets hit since it is -rc4. Seeing this on both native
and cross compiles.
---
arch/arm64/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm64/Makefile b/arch/arm64/Makefile
index 7976d2d242fa..f476d52ad8d6 100644
--- a/arch/arm64/Makefile
+++ b/arch/arm64/Makefile
@@ -60,13 +60,13 @@ ifeq ($(CONFIG_CPU_BIG_ENDIAN), y)
KBUILD_CPPFLAGS += -mbig-endian
CHECKFLAGS += -D__AARCH64EB__
AS += -EB
-LDFLAGS += -EB -maarch64elfb
+LDFLAGS += -EB -maarch64linuxb
UTS_MACHINE := aarch64_be
else
KBUILD_CPPFLAGS += -mlittle-endian
CHECKFLAGS += -D__AARCH64EL__
AS += -EL
-LDFLAGS += -EL -maarch64elf
+LDFLAGS += -EL -maarch64linux
UTS_MACHINE := aarch64
endif
--
2.17.1

View File

@ -607,6 +607,9 @@ Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
# rhbz 1470995
Patch504: kexec-bzimage-verify-pe-signature-fix.patch
# arm64 compile fix
Patch505: 0001-Revert-arm64-Use-aarch64elf-and-aarch64elfb-emulatio.patch
# END OF PATCH DEFINITIONS
%endif