kernel-5.15-0.rc3.20211001git4de593fb965f.30

* Fri Oct 01 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc3.20211001git4de593fb965f.30]
- Fix BPF selftests build on ppc64 (Justin M. Forbes)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-10-01 11:42:31 -05:00
parent 91e7add6fe
commit 9c83d24601
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
8 changed files with 102 additions and 78 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 28
RHEL_RELEASE = 30
#
# Early y+1 numbering

View File

@ -1080,8 +1080,8 @@ CONFIG_CRYPTO_SHA1_S390=m
CONFIG_CRYPTO_SHA1=y
CONFIG_CRYPTO_SHA256_S390=m
CONFIG_CRYPTO_SHA256=y
CONFIG_CRYPTO_SHA3_256_S390=y
CONFIG_CRYPTO_SHA3_512_S390=y
CONFIG_CRYPTO_SHA3_256_S390=m
CONFIG_CRYPTO_SHA3_512_S390=m
CONFIG_CRYPTO_SHA3=y
CONFIG_CRYPTO_SHA512_S390=m
CONFIG_CRYPTO_SHA512=y

View File

@ -914,8 +914,8 @@ CONFIG_CRYPTO_SHA1=y
CONFIG_CRYPTO_SHA256_ARM64=m
CONFIG_CRYPTO_SHA256_S390=y
CONFIG_CRYPTO_SHA256=y
CONFIG_CRYPTO_SHA3_256_S390=y
CONFIG_CRYPTO_SHA3_512_S390=y
CONFIG_CRYPTO_SHA3_256_S390=m
CONFIG_CRYPTO_SHA3_512_S390=m
# CONFIG_CRYPTO_SHA3_ARM64 is not set
CONFIG_CRYPTO_SHA3=y
CONFIG_CRYPTO_SHA512_ARM64_CE=m

View File

@ -1079,8 +1079,8 @@ CONFIG_CRYPTO_SHA1_S390=m
CONFIG_CRYPTO_SHA1=y
CONFIG_CRYPTO_SHA256_S390=m
CONFIG_CRYPTO_SHA256=y
CONFIG_CRYPTO_SHA3_256_S390=y
CONFIG_CRYPTO_SHA3_512_S390=y
CONFIG_CRYPTO_SHA3_256_S390=m
CONFIG_CRYPTO_SHA3_512_S390=m
CONFIG_CRYPTO_SHA3=y
CONFIG_CRYPTO_SHA512_S390=m
CONFIG_CRYPTO_SHA512=y

View File

@ -914,8 +914,8 @@ CONFIG_CRYPTO_SHA1=y
CONFIG_CRYPTO_SHA256_ARM64=m
CONFIG_CRYPTO_SHA256_S390=y
CONFIG_CRYPTO_SHA256=y
CONFIG_CRYPTO_SHA3_256_S390=y
CONFIG_CRYPTO_SHA3_512_S390=y
CONFIG_CRYPTO_SHA3_256_S390=m
CONFIG_CRYPTO_SHA3_512_S390=m
# CONFIG_CRYPTO_SHA3_ARM64 is not set
CONFIG_CRYPTO_SHA3=y
CONFIG_CRYPTO_SHA512_ARM64_CE=m

View File

@ -3,6 +3,11 @@
# environment changes that affect %%install need to go
# here before the %%install macro is pre-built.
# Include Fedora files
%global include_fedora 1
# Include RHEL files
%global include_rhel 1
# Disable LTO in userspace packages.
%global _lto_cflags %{nil}
@ -80,7 +85,7 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 0
%global distro_build 0.rc3.20210930git02d5e016800d.28
%global distro_build 0.rc3.20211001git4de593fb965f.30
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -125,13 +130,13 @@ Summary: The Linux kernel
%define rpmversion 5.15.0
%define patchversion 5.15
%define pkgrelease 0.rc3.20210930git02d5e016800d.28
%define pkgrelease 0.rc3.20211001git4de593fb965f.30
# This is needed to do merge window version magic
%define patchlevel 15
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc3.20210930git02d5e016800d.28%{?buildid}%{?dist}
%define specrelease 0.rc3.20211001git4de593fb965f.30%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@ -672,7 +677,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.15-rc3-135-g02d5e016800d.tar.xz
Source0: linux-5.15-rc3-240-g4de593fb965f.tar.xz
Source1: Makefile.rhelver
@ -685,9 +690,6 @@ Source1: Makefile.rhelver
%define signing_key_filename kernel-signing-s390.cer
%endif
Source8: x509.genkey.rhel
Source9: x509.genkey.fedora
%if %{?released_kernel}
Source10: redhatsecurebootca5.cer
@ -732,63 +734,71 @@ Source13: redhatsecureboot003.cer
# released_kernel
%endif
Source22: mod-extra.list.rhel
Source16: mod-extra.list.fedora
Source17: mod-denylist.sh
Source18: mod-sign.sh
Source79: parallel_xz.sh
Source20: mod-denylist.sh
Source21: mod-sign.sh
Source22: parallel_xz.sh
Source80: filter-x86_64.sh.fedora
Source81: filter-armv7hl.sh.fedora
Source82: filter-i686.sh.fedora
Source83: filter-aarch64.sh.fedora
Source86: filter-ppc64le.sh.fedora
Source87: filter-s390x.sh.fedora
Source89: filter-modules.sh.fedora
%define modsign_cmd %{SOURCE21}
Source90: filter-x86_64.sh.rhel
Source91: filter-armv7hl.sh.rhel
Source92: filter-i686.sh.rhel
Source93: filter-aarch64.sh.rhel
Source96: filter-ppc64le.sh.rhel
Source97: filter-s390x.sh.rhel
Source99: filter-modules.sh.rhel
%define modsign_cmd %{SOURCE18}
%if 0%{?include_rhel}
Source23: x509.genkey.rhel
Source20: kernel-aarch64-rhel.config
Source21: kernel-aarch64-debug-rhel.config
Source30: kernel-ppc64le-rhel.config
Source31: kernel-ppc64le-debug-rhel.config
Source32: kernel-s390x-rhel.config
Source33: kernel-s390x-debug-rhel.config
Source34: kernel-s390x-zfcpdump-rhel.config
Source35: kernel-x86_64-rhel.config
Source36: kernel-x86_64-debug-rhel.config
Source24: kernel-aarch64-rhel.config
Source25: kernel-aarch64-debug-rhel.config
Source26: mod-extra.list.rhel
Source37: kernel-aarch64-fedora.config
Source38: kernel-aarch64-debug-fedora.config
Source39: kernel-armv7hl-fedora.config
Source40: kernel-armv7hl-debug-fedora.config
Source41: kernel-armv7hl-lpae-fedora.config
Source42: kernel-armv7hl-lpae-debug-fedora.config
Source43: kernel-i686-fedora.config
Source44: kernel-i686-debug-fedora.config
Source45: kernel-ppc64le-fedora.config
Source46: kernel-ppc64le-debug-fedora.config
Source47: kernel-s390x-fedora.config
Source48: kernel-s390x-debug-fedora.config
Source49: kernel-x86_64-fedora.config
Source50: kernel-x86_64-debug-fedora.config
Source27: kernel-ppc64le-rhel.config
Source28: kernel-ppc64le-debug-rhel.config
Source29: kernel-s390x-rhel.config
Source30: kernel-s390x-debug-rhel.config
Source31: kernel-s390x-zfcpdump-rhel.config
Source32: kernel-x86_64-rhel.config
Source33: kernel-x86_64-debug-rhel.config
Source34: filter-x86_64.sh.rhel
Source35: filter-armv7hl.sh.rhel
Source36: filter-i686.sh.rhel
Source37: filter-aarch64.sh.rhel
Source38: filter-ppc64le.sh.rhel
Source39: filter-s390x.sh.rhel
Source40: filter-modules.sh.rhel
%endif
%if 0%{?include_fedora}
Source50: x509.genkey.fedora
Source51: mod-extra.list.fedora
Source51: generate_all_configs.sh
Source52: kernel-aarch64-fedora.config
Source53: kernel-aarch64-debug-fedora.config
Source54: kernel-armv7hl-fedora.config
Source55: kernel-armv7hl-debug-fedora.config
Source56: kernel-armv7hl-lpae-fedora.config
Source57: kernel-armv7hl-lpae-debug-fedora.config
Source58: kernel-i686-fedora.config
Source59: kernel-i686-debug-fedora.config
Source60: kernel-ppc64le-fedora.config
Source61: kernel-ppc64le-debug-fedora.config
Source62: kernel-s390x-fedora.config
Source63: kernel-s390x-debug-fedora.config
Source64: kernel-x86_64-fedora.config
Source65: kernel-x86_64-debug-fedora.config
Source52: process_configs.sh
Source56: update_scripts.sh
Source57: generate_crashkernel_default.sh
Source67: filter-x86_64.sh.fedora
Source68: filter-armv7hl.sh.fedora
Source69: filter-i686.sh.fedora
Source70: filter-aarch64.sh.fedora
Source71: filter-ppc64le.sh.fedora
Source72: filter-s390x.sh.fedora
Source73: filter-modules.sh.fedora
%endif
Source54: mod-internal.list
Source80: generate_all_configs.sh
Source81: process_configs.sh
Source82: update_scripts.sh
Source83: generate_crashkernel_default.sh
Source84: mod-internal.list
Source100: rheldup3.x509
Source101: rhelkpatch1.x509
@ -1358,8 +1368,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.15-rc3-135-g02d5e016800d -c
mv linux-5.15-rc3-135-g02d5e016800d linux-%{KVERREL}
%setup -q -n kernel-5.15-rc3-240-g4de593fb965f -c
mv linux-5.15-rc3-240-g4de593fb965f linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -1410,7 +1420,7 @@ cd configs
# Drop some necessary files from the source dir into the buildroot
cp $RPM_SOURCE_DIR/kernel-*.config .
cp %{SOURCE51} .
cp %{SOURCE80} .
# merge.pl
cp %{SOURCE3000} .
# kernel-local
@ -1458,7 +1468,7 @@ done
%endif
%endif
cp %{SOURCE52} .
cp %{SOURCE81} .
OPTS=""
%if %{with_configchecks}
OPTS="$OPTS -w -n -c"
@ -1470,7 +1480,7 @@ done
%endif
./process_configs.sh $OPTS kernel %{rpmversion}
cp %{SOURCE56} .
cp %{SOURCE82} .
RPM_SOURCE_DIR=$RPM_SOURCE_DIR ./update_scripts.sh %{primary_target}
# end of kernel config
@ -1991,9 +2001,9 @@ BuildKernel() {
remove_depmod_files
# Identify modules in the kernel-modules-extras package
%{SOURCE17} $RPM_BUILD_ROOT lib/modules/$KernelVer $RPM_SOURCE_DIR/mod-extra.list
%{SOURCE20} $RPM_BUILD_ROOT lib/modules/$KernelVer $RPM_SOURCE_DIR/mod-extra.list
# Identify modules in the kernel-modules-extras package
%{SOURCE17} $RPM_BUILD_ROOT lib/modules/$KernelVer %{SOURCE54} internal
%{SOURCE20} $RPM_BUILD_ROOT lib/modules/$KernelVer %{SOURCE84} internal
#
# Generate the kernel-core and kernel-modules files lists
@ -2094,7 +2104,7 @@ BuildKernel() {
find $RPM_BUILD_ROOT/usr/src/kernels -name ".*.cmd" -delete
# Generate crashkernel default config
%{SOURCE57} "$KernelVer" "$Arch" "$RPM_BUILD_ROOT"
%{SOURCE83} "$KernelVer" "$Arch" "$RPM_BUILD_ROOT"
# Red Hat UEFI Secure Boot CA cert, which can be used to authenticate the kernel
mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer
@ -2244,7 +2254,7 @@ export BPFTOOL=$(pwd)/tools/bpf/bpftool/bpftool
pushd tools/testing/selftests
# We need to install here because we need to call make with ARCH set which
# doesn't seem possible to do in the install section.
%{make} %{?_smp_mflags} ARCH=$Arch V=1 TARGETS="bpf livepatch net net/forwarding net/mptcp netfilter tc-testing" SKIP_TARGETS="" INSTALL_PATH=%{buildroot}%{_libexecdir}/kselftests VMLINUX_H="${RPM_VMLINUX_H}" install
%{make} %{?_smp_mflags} ARCH=$Arch V=1 TARGETS="bpf livepatch net net/forwarding net/mptcp netfilter tc-testing" SKIP_TARGETS="" FORCE_TARGETS=1 INSTALL_PATH=%{buildroot}%{_libexecdir}/kselftests VMLINUX_H="${RPM_VMLINUX_H}" install
# 'make install' for bpf is broken and upstream refuses to fix it.
# Install the needed files manually.
@ -2958,6 +2968,20 @@ fi
#
#
%changelog
* Fri Oct 01 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc3.20211001git4de593fb965f.30]
- Fix BPF selftests build on ppc64 (Justin M. Forbes)
* Fri Oct 01 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc3.20211001git4de593fb965f.29]
- Change s390x CONFIG_NODES_SHIFT from 4 to 1 (Justin M. Forbes)
- Build CRYPTO_SHA3_*_S390 inline for s390 zfcpdump (Justin M. Forbes)
- redhat: move the DIST variable setting to Makefile.variables (Herton R. Krzesinski)
- redhat/kernel.spec.template: Cleanup source numbering (Prarit Bhargava)
- redhat/kernel.spec.template: Reorganize RHEL and Fedora specific files (Prarit Bhargava)
- redhat/kernel.spec.template: Add include_fedora and include_rhel variables (Prarit Bhargava)
- redhat/Makefile: Make kernel-local global (Prarit Bhargava)
- redhat/Makefile: Use flavors file (Prarit Bhargava)
- Turn on CONFIG_CPU_FREQ_GOV_SCHEDUTIL for x86 (Justin M. Forbes)
* Thu Sep 30 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc3.20210930git02d5e016800d.28]
- redhat/configs: Remove CONFIG_INFINIBAND_I40IW (Kamal Heib)

View File

@ -3050,10 +3050,10 @@ index 9ffa9e9c5c55..36484cc9842d 100644
int security_perf_event_open(struct perf_event_attr *attr, int type)
{
diff --git a/tools/testing/selftests/bpf/Makefile b/tools/testing/selftests/bpf/Makefile
index 866531c08e4f..40dadc919226 100644
index 799b88152e9e..73c687d900c3 100644
--- a/tools/testing/selftests/bpf/Makefile
+++ b/tools/testing/selftests/bpf/Makefile
@@ -425,7 +425,6 @@ $(TRUNNER_TEST_OBJS): $(TRUNNER_OUTPUT)/%.test.o: \
@@ -426,7 +426,6 @@ $(TRUNNER_TEST_OBJS): $(TRUNNER_OUTPUT)/%.test.o: \
$(TRUNNER_BPF_OBJS) \
$(TRUNNER_BPF_SKELS) \
$(TRUNNER_BPF_LSKELS) \

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.15-rc3-135-g02d5e016800d.tar.xz) = 1c8216111188688aa9f5bfa3b66cf0bf16134e758a3faadc788d2fec77bde71aa880e503d746b11472e106fa1e819f348fd749547e0608452ce72affcada60b9
SHA512 (kernel-abi-stablelists-5.15.0-0.rc3.20210930git02d5e016800d.28.tar.bz2) = 031ce0eafd97bf129077a6c0302cba9eea18c104d1ad54b9db0a618aa814c4d2b52a110d0ddb45adcb12139f3c688cb5fbe62a3ba6323f8662894b94a85e7518
SHA512 (kernel-kabi-dw-5.15.0-0.rc3.20210930git02d5e016800d.28.tar.bz2) = de23b27e1d08a2773cf7b6d8da232821a58a02e357923666489ba30ed010b6b6de72fe79cb7905fe1ad2ba783c59945b0b8a0087e52a8614d6b9dcd8f2dba57c
SHA512 (linux-5.15-rc3-240-g4de593fb965f.tar.xz) = c1d3118bc5e407eeed00a295cd181467fa38ecce34011e4dfdc9f17e10723f8902bd9f85c5a63cc13dee6d6fae1067842813217d80ed356641d34d54408376ff
SHA512 (kernel-abi-stablelists-5.15.0-0.rc3.20211001git4de593fb965f.30.tar.bz2) = daa45925e5d59685c85dc8be00f707b8eb722b09cff6a2a086a9c42a501fbf3f6e83fdcb66c7fd4a06975205b2b7df778ce2a220cd63db75b2055d7900264f7c
SHA512 (kernel-kabi-dw-5.15.0-0.rc3.20211001git4de593fb965f.30.tar.bz2) = f9855b89fccf94645d316823ab3a75b5d3a535468e9b962bb9b5478ad8e85e57d82569db2d935e2b33baa9a61a958d1dc10cc2e98a54a4e2d7d8c9c41a006378