Updated to the latest pNFS tag: pnfs-all-2.6.36-rc3-2010-08-30

Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
Steve Dickson 2010-09-01 07:22:19 -04:00
parent c07ce51f85
commit 9ad467a8ec
5 changed files with 30062 additions and 8 deletions

View File

@ -3461,6 +3461,18 @@ CONFIG_NFSD=m
CONFIG_NFSD_V3=y
CONFIG_NFSD_V3_ACL=y
CONFIG_NFSD_V4=y
# Enable pNFS
CONFIG_PNFS=y
CONFIG_PNFSD=y
CONFIG_PNFSD_LOCAL_EXPORT=y
CONFIG_SPNFS=y
CONFIG_SPNFS_LAYOUTSEGMENTS=y
CONFIG_SPNFS_BLOCK=y
CONFIG_PNFS_OBJLAYOUT=m
CONFIG_PNFS_BLOCK=m
CONFIG_PNFS_PANLAYOUT=m
CONFIG_PNFS_FILE_LAYOUT=m
#
CONFIG_NFS_FSCACHE=y
# CONFIG_NFS_USE_LEGACY_DNS is not set
CONFIG_LOCKD=m

View File

@ -23,7 +23,7 @@ Summary: The Linux kernel
#
# (Uncomment the '#' and both spaces below to set the buildid.)
#
# % define buildid .local
%define buildid .pnfs36_rc3.2010.08.30
###################################################################
# The buildid can also be specified on the rpmbuild command line
@ -104,21 +104,21 @@ Summary: The Linux kernel
# kernel-smp (only valid for ppc 32-bit)
%define with_smp %{?_without_smp: 0} %{?!_without_smp: 1}
# kernel-debug
%define with_debug %{?_without_debug: 0} %{?!_without_debug: 1}
%define with_debug %{?_without_debug: 0} %{?!_without_debug: 0}
# kernel-doc
%define with_doc %{?_without_doc: 0} %{?!_without_doc: 1}
%define with_doc %{?_without_doc: 0} %{?!_without_doc: 0}
# kernel-headers
%define with_headers %{?_without_headers: 0} %{?!_without_headers: 1}
%define with_headers %{?_without_headers: 0} %{?!_without_headers: 0}
# kernel-firmware
%define with_firmware %{?_with_firmware: 1} %{?!_with_firmware: 0}
%define with_firmware %{?_with_firmware: 1} %{?!_with_firmware: 1}
# tools/perf
%define with_perf %{?_without_perf: 0} %{?!_without_perf: 1}
%define with_perf %{?_without_perf: 0} %{?!_without_perf: 0}
# kernel-debuginfo
%define with_debuginfo %{?_without_debuginfo: 0} %{?!_without_debuginfo: 1}
%define with_debuginfo %{?_without_debuginfo: 1} %{?!_without_debuginfo: 1}
# kernel-bootwrapper (for creating zImages from kernel + initrd)
%define with_bootwrapper %{?_without_bootwrapper: 0} %{?!_without_bootwrapper: 1}
# Want to build a the vsdo directories installed
%define with_vdso_install %{?_without_vdso_install: 0} %{?!_without_vdso_install: 1}
%define with_vdso_install %{?_without_vdso_install: 0} %{?!_without_vdso_install: 0}
# Build the kernel-doc package, but don't fail the build if it botches.
# Here "true" means "continue" and "false" means "fail the build".
@ -688,6 +688,10 @@ Patch12017: prevent-runtime-conntrack-changes.patch
Patch12018: neuter_intel_microcode_load.patch
Patch30000: pnfs-all-2.6.36-rc3-2010-08-30.patch
Patch30001: linux-2.6-pnfs-compile.patch
Patch30002: linux-2.6.35-inline.patch
%endif
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
@ -1254,6 +1258,10 @@ ApplyPatch disable-i8042-check-on-apple-mac.patch
ApplyPatch neuter_intel_microcode_load.patch
ApplyPatch pnfs-all-2.6.36-rc3-2010-08-30.patch
ApplyPatch linux-2.6-pnfs-compile.patch
ApplyPatch linux-2.6.35-inline.patch
# END OF PATCH APPLICATIONS
%endif
@ -1861,6 +1869,9 @@ fi
# || ||
%changelog
* Wed Sep 1 2010 Steve Dickson <steved@redhat.com>
- Updated to the latest pNFS tag: pnfs-all-2.6.36-rc3-2010-08-30
* Mon Aug 30 2010 Kyle McMartin <kyle@redhat.com> - 2.6.36-0.12.rc3.git0
- Linux 2.6.36-rc3

View File

@ -0,0 +1,13 @@
diff -up linux-2.6.32.x86_64/fs/nfs/objlayout/pnfs_osd_xdr.h.orig linux-2.6.32.x86_64/fs/nfs/objlayout/pnfs_osd_xdr.h
diff -up linux-2.6.32.x86_64/include/net/inet_connection_sock.h.orig linux-2.6.32.x86_64/include/net/inet_connection_sock.h
--- linux-2.6.32.x86_64/include/net/inet_connection_sock.h.orig 2009-12-02 22:51:21.000000000 -0500
+++ linux-2.6.32.x86_64/include/net/inet_connection_sock.h 2010-04-21 14:26:24.475659551 -0400
@@ -23,7 +23,7 @@
#include <net/inet_sock.h>
#include <net/request_sock.h>
-#define INET_CSK_DEBUG 1
+//#define INET_CSK_DEBUG 1
/* Cancel timers, when they are not required. */
#undef INET_CSK_CLEAR_TIMERS

11
linux-2.6.35-inline.patch Normal file
View File

@ -0,0 +1,11 @@
diff -up linux-2.6.34.noarch/arch/x86/Makefile.orig linux-2.6.34.noarch/arch/x86/Makefile
--- linux-2.6.34.noarch/arch/x86/Makefile.orig 2010-07-01 13:33:21.859627499 -0400
+++ linux-2.6.34.noarch/arch/x86/Makefile 2010-07-01 13:36:26.751576450 -0400
@@ -81,6 +81,7 @@ ifdef CONFIG_CC_STACKPROTECTOR
$(warning stack protector enabled but no compiler support)
endif
endif
+KBUILD_CFLAGS += -fno-inline-functions-called-once
# Don't unroll struct assignments with kmemcheck enabled
ifeq ($(CONFIG_KMEMCHECK),y)

File diff suppressed because it is too large Load Diff