- Revise compat-wireless configuration

- Enable with-backports by default
- Update compat-wireless snaptshot from verstion 3.2-rc6-3
This commit is contained in:
John W. Linville 2011-11-22 16:16:30 -05:00
parent e091c2ac6e
commit 98c21d3e9c
5 changed files with 163 additions and 6 deletions

View File

@ -0,0 +1,29 @@
From c5cfdf2d138ba20a648990d9615c44942eef5fd3 Mon Sep 17 00:00:00 2001
From: John W. Linville <linville@tuxdriver.com>
Date: Fri, 18 Nov 2011 13:46:18 -0500
Subject: [PATCH] compat-wireless: change CONFIG_IWLAGN -> CONFIG_IWLWIFI
This Kconfig option changed in the 2.6.32 timeframe.
Signed-off-by: John W. Linville <linville@tuxdriver.com>
Signed-off-by: Luis R. Rodriguez <mcgrof@qca.qualcomm.com>
---
config.mk | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/config.mk b/config.mk
index 0e964a5..05edb79 100644
--- a/config.mk
+++ b/config.mk
@@ -285,7 +285,7 @@ ifdef CONFIG_PCI
CONFIG_ATH5K_PCI=y
CONFIG_ATH9K_PCI=y
-CONFIG_IWLAGN=m
+CONFIG_IWLWIFI=m
# CONFIG_IWLWIFI_DEBUG=y
# CONFIG_IWLWIFI_DEBUGFS=y
# CONFIG_IWLWIFI_DEVICE_TRACING=y
--
1.7.4.4

View File

@ -0,0 +1,64 @@
diff -up compat-wireless-3.2-rc1-1/config.mk.orig compat-wireless-3.2-rc1-1/config.mk
--- compat-wireless-3.2-rc1-1/config.mk.orig 2011-11-22 13:09:50.422879313 -0500
+++ compat-wireless-3.2-rc1-1/config.mk 2011-11-22 13:10:28.870398679 -0500
@@ -14,6 +14,9 @@ else
include $(KLIB_BUILD)/.config
endif
+# Enable SSB module (needs to be visible in compat_autoconf.h)
+CONFIG_SSB=m
+
ifneq ($(wildcard $(KLIB_BUILD)/Makefile),)
COMPAT_LATEST_VERSION = 1
diff -up compat-wireless-3.2-rc1-1/drivers/misc/eeprom/Makefile.orig compat-wireless-3.2-rc1-1/drivers/misc/eeprom/Makefile
--- compat-wireless-3.2-rc1-1/drivers/misc/eeprom/Makefile.orig 2011-11-22 13:09:50.423879301 -0500
+++ compat-wireless-3.2-rc1-1/drivers/misc/eeprom/Makefile 2011-11-22 13:10:28.871398662 -0500
@@ -1,3 +1,3 @@
-obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
+#obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
obj-$(CONFIG_EEPROM_93XX46) += eeprom_93xx46.o
obj-$(CONFIG_EEPROM_DIGSY_MTC_CFG) += digsy_mtc_eeprom.o
diff -up compat-wireless-3.2-rc1-1/drivers/net/ethernet/atheros/Makefile.orig compat-wireless-3.2-rc1-1/drivers/net/ethernet/atheros/Makefile
--- compat-wireless-3.2-rc1-1/drivers/net/ethernet/atheros/Makefile.orig 2011-11-22 13:09:50.423879301 -0500
+++ compat-wireless-3.2-rc1-1/drivers/net/ethernet/atheros/Makefile 2011-11-22 13:10:28.871398662 -0500
@@ -2,7 +2,7 @@
# Makefile for the Atheros network device drivers.
#
-obj-$(CONFIG_ATL1) += atlx/
-obj-$(CONFIG_ATL2) += atlx/
-obj-$(CONFIG_ATL1E) += atl1e/
-obj-$(CONFIG_ATL1C) += atl1c/
+#obj-$(CONFIG_ATL1) += atlx/
+#obj-$(CONFIG_ATL2) += atlx/
+#obj-$(CONFIG_ATL1E) += atl1e/
+#obj-$(CONFIG_ATL1C) += atl1c/
diff -up compat-wireless-3.2-rc1-1/drivers/net/usb/Makefile.orig compat-wireless-3.2-rc1-1/drivers/net/usb/Makefile
--- compat-wireless-3.2-rc1-1/drivers/net/usb/Makefile.orig 2011-11-22 13:09:50.424879289 -0500
+++ compat-wireless-3.2-rc1-1/drivers/net/usb/Makefile 2011-11-22 13:10:28.872398646 -0500
@@ -2,7 +2,7 @@
# Makefile for USB Network drivers
#
-obj-$(CONFIG_USB_NET_COMPAT_CDCETHER) += cdc_ether.o
-obj-$(CONFIG_USB_NET_COMPAT_RNDIS_HOST) += rndis_host.o
-obj-$(CONFIG_USB_COMPAT_USBNET) += usbnet.o
+#obj-$(CONFIG_USB_NET_COMPAT_CDCETHER) += cdc_ether.o
+#obj-$(CONFIG_USB_NET_COMPAT_RNDIS_HOST) += rndis_host.o
+#obj-$(CONFIG_USB_COMPAT_USBNET) += usbnet.o
diff -up compat-wireless-3.2-rc1-1/Makefile.orig compat-wireless-3.2-rc1-1/Makefile
--- compat-wireless-3.2-rc1-1/Makefile.orig 2011-11-22 13:10:37.165294951 -0500
+++ compat-wireless-3.2-rc1-1/Makefile 2011-11-22 13:10:47.335167758 -0500
@@ -41,8 +41,8 @@ endif
endif
-obj-$(CONFIG_COMPAT_BLUETOOTH) += net/bluetooth/
-obj-$(CONFIG_COMPAT_BLUETOOTH_MODULES) += drivers/bluetooth/
+#obj-$(CONFIG_COMPAT_BLUETOOTH) += net/bluetooth/
+#obj-$(CONFIG_COMPAT_BLUETOOTH_MODULES) += drivers/bluetooth/
else

19
config-backports Normal file
View File

@ -0,0 +1,19 @@
# CONFIG_CFG80211 is not set
# CONFIG_LIB80211 is not set
# CONFIG_MAC80211 is not set
# CONFIG_BCMA is not set
#
# ssb and b44 share infrastructure with b43
#
# CONFIG_SSB is not set
# CONFIG_B44 is not set
#
# These have to be turned-on again since compat-wireless does not
# provide them...
#
CONFIG_CRC7=m
CONFIG_AVERAGE=y

View File

@ -158,7 +158,7 @@ Summary: The Linux kernel
%define with_sparse %{?_with_sparse: 1} %{?!_with_sparse: 0}
# Include driver backports (e.g. compat-wireless) in the kernel build.
%define with_backports %{?_with_backports: 1} %{?!_with_backports: 0}
%define with_backports %{?_without_backports: 0} %{?!_without_backports: 1}
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
@ -199,8 +199,18 @@ Summary: The Linux kernel
%define kversion 3.%{base_sublevel}
# The compat-wireless version
# (If this is less than kversion, make sure with_backports is turned-off.)
%define cwversion 3.2-rc1-1
%define cwversion 3.2-rc6-3
#######################################################################
# If cwversion is less than kversion, make sure with_backports is
# turned-off.
#
# For rawhide, disable with_backports immediately after a rebase...
#
# (Uncomment the '#' and both spaces below to disable with_backports.)
#
# % define with_backports 0
#######################################################################
%define make_target bzImage
@ -485,7 +495,7 @@ Summary: The Linux kernel
# Packages that need to be installed before the kernel is, because the %%post
# scripts use them.
#
%define kernel_prereq fileutils, module-init-tools >= 3.16-2, initscripts >= 8.11.1-1, grubby >= 8.3-1
%define kernel_prereq fileutils, module-init-tools >= 3.16-5, initscripts >= 8.11.1-1, grubby >= 8.3-1
%define initrd_prereq dracut >= 001-7
#
@ -598,6 +608,8 @@ Source100: config-arm-generic
Source110: config-arm-omap-generic
Source111: config-arm-tegra
Source200: config-backports
# This file is intentionally left empty in the stock kernel. Its a nicety
# added for those wanting to do custom rebuilds with altered config opts.
Source1000: config-local
@ -815,6 +827,10 @@ Patch21048: b44-Use-dev_kfree_skb_irq-in-b44_tx.patch
#rhbz 746097
Patch21049: tpm_tis-delay-after-aborting-cmd.patch
# compat-wireless patches
Patch50000: compat-wireless-config-fixups.patch
Patch50001: compat-wireless-change-CONFIG_IWLAGN-CONFIG_IWLWIFI.patch
%endif
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
@ -1257,6 +1273,16 @@ cp %{SOURCE15} .
# Dynamically generate kernel .config files from config-* files
make -f %{SOURCE20} VERSION=%{version} configs
%if %{with_backports}
# Turn-off bits provided by compat-wireless
for i in %{all_arch_configs}
do
mv $i $i.tmp
./merge.pl %{SOURCE200} $i.tmp > $i
rm $i.tmp
done
%endif
%if %{?all_arch_configs:1}%{!?all_arch_configs:0}
#if a rhel kernel, apply the rhel config options
%if 0%{?rhel}
@ -1470,10 +1496,12 @@ ApplyPatch ideapad-Check-if-acpi-already-handle-backlight.patch
#rhbz 752176
ApplyPatch sysfs-msi-irq-per-device.patch
%if !%{with_backports}
#backport brcm80211 from 3.2-rc1
ApplyPatch brcm80211.patch
# Remove overlap between bcma/b43 and brcmsmac and reenable bcm4331
ApplyPatch bcma-brcmsmac-compat.patch
%endif
# rhbz 754907
ApplyPatch cciss-fix-irqf-shared.patch
@ -1559,9 +1587,22 @@ cd ..
%if %{with_backports}
# Always start fresh
rm -rf compat-wireless-%{cwversion}
# Extract the compat-wireless bits
%setup -q -n kernel-%{kversion}%{?dist} -T -D -a 1
cd compat-wireless-%{cwversion}
ApplyPatch compat-wireless-config-fixups.patch
ApplyPatch compat-wireless-change-CONFIG_IWLAGN-CONFIG_IWLWIFI.patch
# Remove overlap between bcma/b43 and brcmsmac and reenable bcm4331
ApplyPatch bcma-brcmsmac-compat.patch
cd ..
%endif
###
@ -1798,7 +1839,6 @@ BuildKernel() {
%if %{with_backports}
cd ../compat-wireless-%{cwversion}/
make clean
make KLIB_BUILD=../linux-%{kversion}.%{_target_cpu} \
KMODPATH_ARG="INSTALL_MOD_PATH=$RPM_BUILD_ROOT" \
@ -2233,6 +2273,11 @@ fi
# and build.
%changelog
* Wed Dec 21 2011 John W. Linville <linville@redhat.com>
- Revise compat-wireless configuration
- Enable with-backports by default
- Update compat-wireless snaptshot from verstion 3.2-rc6-3
* Tue Dec 20 2011 Dave Jones <davej@redhat.com>
- Delay after aborting command in tpm_tis (rhbz #746097)

View File

@ -1,3 +1,3 @@
8d43453f8159b2332ad410b19d86a931 linux-3.1.tar.bz2
6693d8c42055f83f5701d9b65d47208a compat-wireless-3.2-rc1-1.tar.bz2
84c040bb8c4f46d351731cb0c05d9474 patch-3.1.5.bz2
656f2b85102dc935039e867abd08b880 compat-wireless-3.2-rc6-3.tar.bz2