Linux 3.3-rc6
This commit is contained in:
parent
ddb2c7e4f3
commit
986c6ceb52
@ -201,6 +201,7 @@ CONFIG_LSM_MMAP_MIN_ADDR=32768
|
||||
# CONFIG_MACH_EUKREA_CPUIMX35SD is not set
|
||||
CONFIG_ARM_ERRATA_720789=y
|
||||
CONFIG_ARM_ERRATA_751472=y
|
||||
CONFIG_OMAP4_ERRATA_I688=y
|
||||
# CONFIG_FB_MX3 is not set
|
||||
# CONFIG_MX3_IPU is not set
|
||||
# CONFIG_MX3_IPU_IRQS is not set
|
||||
|
@ -1,40 +0,0 @@
|
||||
From aed3f09db39596e539f90b11a5016aea4d8442e1 Mon Sep 17 00:00:00 2001
|
||||
From: Alban Browaeys <prahal@yahoo.com>
|
||||
Date: Fri, 24 Feb 2012 17:12:45 +0000
|
||||
Subject: [PATCH] drm/i915: Prevent a machine hang by checking crtc->active
|
||||
before loading lut
|
||||
|
||||
Before loading the lut (gamma), check the active state of intel_crtc,
|
||||
otherwise at least on gen2 hang ensue.
|
||||
|
||||
This is reproducible in Xorg via:
|
||||
xset dpms force off
|
||||
then
|
||||
xgamma -rgamma 2.0 # freeze.
|
||||
|
||||
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=44505
|
||||
Signed-off-by: Alban Browaeys <prahal@yahoo.com>
|
||||
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
|
||||
Reviewed-by: Jesse Barnes <jbarnes@virtuousgeek.org>
|
||||
Cc: stable@kernel.org
|
||||
Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
|
||||
---
|
||||
drivers/gpu/drm/i915/intel_display.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
|
||||
index 4871ba0..f851db7 100644
|
||||
--- a/drivers/gpu/drm/i915/intel_display.c
|
||||
+++ b/drivers/gpu/drm/i915/intel_display.c
|
||||
@@ -6184,7 +6184,7 @@ void intel_crtc_load_lut(struct drm_crtc *crtc)
|
||||
int i;
|
||||
|
||||
/* The clocks have to be on to load the palette. */
|
||||
- if (!crtc->enabled)
|
||||
+ if (!crtc->enabled || !intel_crtc->active)
|
||||
return;
|
||||
|
||||
/* use legacy palette for Ironlake */
|
||||
--
|
||||
1.7.7.6
|
||||
|
17
kernel.spec
17
kernel.spec
@ -54,7 +54,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 2
|
||||
%global baserelease 1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -85,9 +85,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%define rcrev 5
|
||||
%define rcrev 6
|
||||
# The git snapshot level
|
||||
%define gitrev 3
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -708,7 +708,6 @@ Patch1800: drm-vgem.patch
|
||||
# nouveau + drm fixes
|
||||
# intel drm is all merged upstream
|
||||
Patch1824: drm-intel-next.patch
|
||||
Patch1825: drm-intel-crtc-dpms-fix.patch
|
||||
|
||||
Patch1900: linux-2.6-intel-iommu-igfx.patch
|
||||
|
||||
@ -769,9 +768,6 @@ Patch21236: scsi-fix-sd_revalidate_disk-oops.patch
|
||||
Patch21250: mcelog-rcu-splat.patch
|
||||
Patch21260: x86-Avoid-invoking-RCU-when-CPU-is-idle.patch
|
||||
|
||||
#rhbz 790367
|
||||
Patch21270: s390x-enable-keys-compat.patch
|
||||
|
||||
#rhbz 795544
|
||||
Patch21280: ums_realtek-do-not-use-stack-memory-for-DMA-in-__do_.patch
|
||||
|
||||
@ -1449,7 +1445,6 @@ ApplyPatch drm-vgem.patch
|
||||
|
||||
# Intel DRM
|
||||
ApplyOptionalPatch drm-intel-next.patch
|
||||
ApplyPatch drm-intel-crtc-dpms-fix.patch
|
||||
|
||||
ApplyPatch linux-2.6-intel-iommu-igfx.patch
|
||||
|
||||
@ -1500,9 +1495,6 @@ ApplyPatch scsi-fix-sd_revalidate_disk-oops.patch
|
||||
|
||||
ApplyPatch mcelog-rcu-splat.patch
|
||||
|
||||
#rhbz 790367
|
||||
ApplyPatch s390x-enable-keys-compat.patch
|
||||
|
||||
#rhbz 795544
|
||||
ApplyPatch ums_realtek-do-not-use-stack-memory-for-DMA-in-__do_.patch
|
||||
|
||||
@ -2391,6 +2383,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Mar 05 2012 Dave Jones <davej@redhat.com>
|
||||
- Linux 3.3-rc6
|
||||
|
||||
* Mon Mar 05 2012 John W. Linville <linville@redhat.com>
|
||||
- Turn-off CONFIG_B43_BCMA_EXTRA to avoid b43/brcmsmac overlap
|
||||
|
||||
|
@ -1,15 +0,0 @@
|
||||
@@ -, +, @@
|
||||
arch/s390/Kconfig | 3 +++
|
||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
||||
--- a/arch/s390/Kconfig
|
||||
+++ a/arch/s390/Kconfig
|
||||
@@ -227,6 +227,9 @@ config COMPAT
|
||||
config SYSVIPC_COMPAT
|
||||
def_bool y if COMPAT && SYSVIPC
|
||||
|
||||
+config KEYS_COMPAT
|
||||
+ def_bool y if COMPAT && KEYS
|
||||
+
|
||||
config AUDIT_ARCH
|
||||
def_bool y
|
||||
|
3
sources
3
sources
@ -1,4 +1,3 @@
|
||||
364066fa18767ec0ae5f4e4abcf9dc51 linux-3.2.tar.xz
|
||||
19b5b3b5529c1d70463cf1db5177047d patch-3.3-rc5.xz
|
||||
02c210a8fd24acca8c1ac93f6f1d3913 compat-wireless-2012-02-05.tar.bz2
|
||||
85ab3feb862960898ef69e3b0b939564 patch-3.3-rc5-git3.xz
|
||||
cb0886dd96efbacc0c4923d36003b340 patch-3.3-rc6.xz
|
||||
|
Loading…
Reference in New Issue
Block a user