kernel-5.9.0-0.rc6.20200922git98477740630f.13
* Tue Sep 22 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc6.20200922git98477740630f.13] - Merge ark-patches Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
abdc294d6d
commit
975f012f66
@ -1,70 +0,0 @@
|
||||
From 8b8c7d6148bc1bab3cf88cac49038a05db7dd938 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Kara <jack@suse.cz>
|
||||
Date: Mon, 21 Sep 2020 11:33:23 +0200
|
||||
Subject: [PATCH] dax: Fix compilation for CONFIG_DAX && !CONFIG_FS_DAX
|
||||
|
||||
dax_supported() is defined whenever CONFIG_DAX is enabled. So dummy
|
||||
implementation should be defined only in !CONFIG_DAX case, not in
|
||||
!CONFIG_FS_DAX case.
|
||||
|
||||
Fixes: e2ec51282545 ("dm: Call proper helper to determine dax support")
|
||||
Cc: <stable@vger.kernel.org>
|
||||
Reported-by: Geert Uytterhoeven <geert@linux-m68k.org>
|
||||
Reported-by: Naresh Kamboju <naresh.kamboju@linaro.org>
|
||||
Signed-off-by: Jan Kara <jack@suse.cz>
|
||||
---
|
||||
include/linux/dax.h | 17 ++++++++---------
|
||||
1 file changed, 8 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/include/linux/dax.h b/include/linux/dax.h
|
||||
index 497031392e0a..43b39ab9de1a 100644
|
||||
--- a/include/linux/dax.h
|
||||
+++ b/include/linux/dax.h
|
||||
@@ -58,6 +58,8 @@ static inline void set_dax_synchronous(struct dax_device *dax_dev)
|
||||
{
|
||||
__set_dax_synchronous(dax_dev);
|
||||
}
|
||||
+bool dax_supported(struct dax_device *dax_dev, struct block_device *bdev,
|
||||
+ int blocksize, sector_t start, sector_t len);
|
||||
/*
|
||||
* Check if given mapping is supported by the file / underlying device.
|
||||
*/
|
||||
@@ -104,6 +106,12 @@ static inline bool dax_synchronous(struct dax_device *dax_dev)
|
||||
static inline void set_dax_synchronous(struct dax_device *dax_dev)
|
||||
{
|
||||
}
|
||||
+static inline bool dax_supported(struct dax_device *dax_dev,
|
||||
+ struct block_device *bdev, int blocksize, sector_t start,
|
||||
+ sector_t len)
|
||||
+{
|
||||
+ return false;
|
||||
+}
|
||||
static inline bool daxdev_mapping_supported(struct vm_area_struct *vma,
|
||||
struct dax_device *dax_dev)
|
||||
{
|
||||
@@ -130,8 +138,6 @@ static inline bool generic_fsdax_supported(struct dax_device *dax_dev,
|
||||
return __generic_fsdax_supported(dax_dev, bdev, blocksize, start,
|
||||
sectors);
|
||||
}
|
||||
-bool dax_supported(struct dax_device *dax_dev, struct block_device *bdev,
|
||||
- int blocksize, sector_t start, sector_t len);
|
||||
|
||||
static inline void fs_put_dax(struct dax_device *dax_dev)
|
||||
{
|
||||
@@ -159,13 +165,6 @@ static inline bool generic_fsdax_supported(struct dax_device *dax_dev,
|
||||
return false;
|
||||
}
|
||||
|
||||
-static inline bool dax_supported(struct dax_device *dax_dev,
|
||||
- struct block_device *bdev, int blocksize, sector_t start,
|
||||
- sector_t len)
|
||||
-{
|
||||
- return false;
|
||||
-}
|
||||
-
|
||||
static inline void fs_put_dax(struct dax_device *dax_dev)
|
||||
{
|
||||
}
|
||||
--
|
||||
2.16.4
|
||||
|
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 13
|
||||
RHEL_RELEASE = 14
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
32
kernel.spec
32
kernel.spec
@ -30,7 +30,7 @@ Summary: The Linux kernel
|
||||
# For a stable, released kernel, released_kernel should be 1.
|
||||
%global released_kernel 0
|
||||
|
||||
%global distro_build 0.rc6.13
|
||||
%global distro_build 0.rc6.20200922git98477740630f.14
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -69,13 +69,13 @@ Summary: The Linux kernel
|
||||
%endif
|
||||
|
||||
%define rpmversion 5.9.0
|
||||
%define pkgrelease 0.rc6.13
|
||||
%define pkgrelease 0.rc6.20200922git98477740630f.14
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 9
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc6.13%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc6.20200922git98477740630f.14%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -166,7 +166,7 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||
# and 0 for rawhide (all kernels are debug kernels).
|
||||
# See also 'make debug' and 'make release'.
|
||||
%define debugbuildsenabled 1
|
||||
%define debugbuildsenabled 0
|
||||
|
||||
# The kernel tarball/base version
|
||||
%define kversion 5.9
|
||||
@ -181,11 +181,11 @@ Summary: The Linux kernel
|
||||
%define with_ipaclones 0
|
||||
# no whitelist
|
||||
%define with_kernel_abi_whitelists 0
|
||||
%endif
|
||||
# Fedora builds these separately
|
||||
%define with_perf 0
|
||||
%define with_tools 0
|
||||
%define with_bpftool 0
|
||||
%endif
|
||||
|
||||
%if %{with_verbose}
|
||||
%define make_opts V=1
|
||||
@ -566,7 +566,7 @@ BuildRequires: asciidoc
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.9-rc6.tar.xz
|
||||
Source0: linux-20200922git98477740630f.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -789,7 +789,6 @@ Patch72: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
Patch73: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||
Patch74: 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||
Patch75: 0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
|
||||
Patch76: 0001-dax-Fix-compilation-for-CONFIG_DAX-CONFIG_FS_DAX.patch
|
||||
|
||||
%endif
|
||||
|
||||
@ -1285,8 +1284,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.9-rc6 -c
|
||||
mv linux-5.9-rc6 linux-%{KVERREL}
|
||||
%setup -q -n kernel-20200922git98477740630f -c
|
||||
mv linux-20200922git98477740630f linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -1367,7 +1366,6 @@ ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.pat
|
||||
ApplyOptionalPatch 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||
ApplyOptionalPatch 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||
ApplyOptionalPatch 0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
|
||||
ApplyOptionalPatch 0001-dax-Fix-compilation-for-CONFIG_DAX-CONFIG_FS_DAX.patch
|
||||
|
||||
%endif
|
||||
|
||||
@ -2073,6 +2071,7 @@ BuildKernel %make_target %kernel_image %{_use_vdso}
|
||||
%global perf_make \
|
||||
%{__make} -s EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 prefix=%{_prefix} PYTHON=%{__python3}
|
||||
%if %{with_perf}
|
||||
%global _lto_cflags %{nil}
|
||||
# perf
|
||||
# make sure check-headers.sh is executable
|
||||
chmod +x tools/perf/check-headers.sh
|
||||
@ -2796,6 +2795,19 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Tue Sep 22 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc6.20200922git98477740630f.13]
|
||||
- Merge ark-patches
|
||||
|
||||
* Tue Sep 22 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc6.20200922git98477740630f.12.test]
|
||||
- 98477740630f rebase
|
||||
- dax: Fix compilation for CONFIG_DAX && !CONFIG_FS_DAX (Jan Kara)
|
||||
- Updated changelog for the release based on v5.9-rc6 (Fedora Kernel Team)
|
||||
- Revert "KVM: Check the allocation of pv cpu mask" (Vitaly Kuznetsov)
|
||||
- KVM: arm64: Remove S1PTW check from kvm_vcpu_dabt_iswrite() (Marc Zyngier)
|
||||
- KVM: arm64: Assume write fault on S1PTW permission fault on instruction fetch (Marc Zyngier)
|
||||
- rcu-tasks: Prevent complaints of unused show_rcu_tasks_classic_gp_kthread() ("Paul E. McKenney")
|
||||
- docs: kvm: add documentation for KVM_CAP_S390_DIAG318 (Collin Walling)
|
||||
|
||||
* Mon Sep 21 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc6.12]
|
||||
- Merge ark-patches
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.9-rc6.tar.xz) = 08c48757879e1a7a51d2678f332e7c17b07537363500c2104bc4ed21cf028c2457cc4ddb4574985ed999ceaaaebcad38bec4d8d16a448b4bf8f72e6fac908225
|
||||
SHA512 (kernel-abi-whitelists-5.9.0-0.rc6.13.tar.bz2) = dcfaef0d317c318d365a4e79d2e67dfba89e229a704329be7d080076273ede463ee13367a8e528caa75a612b258fb6b1db10a319299dc960459cabcc71679c15
|
||||
SHA512 (kernel-kabi-dw-5.9.0-0.rc6.13.tar.bz2) = d3382010281937e2058ad4ba61c3f033cc8e76cb0543bea2501c8f3b23b5ceccfccc1508df967382f4666ad2a0171fcca2d4843f1334dbd7330fdae6ef891d42
|
||||
SHA512 (linux-20200922git98477740630f.tar.xz) = bf7f78309ed772c6abcd2734f0213289e2786add4a3d19b1001883a17b9052ea1c79c93f548267c285fb337b347b80263ac5789c4134c41396df10d619f3bfe7
|
||||
SHA512 (kernel-abi-whitelists-5.9.0-0.rc6.20200922git98477740630f.14.tar.bz2) = 6951000d72716d8df97d44c9aa69de091ef240a64017537a2f2513d7c6df1d44c59ee93e5aec5d770a74ac318939a4572db486f565be6eabb751ce9561d7cb3f
|
||||
SHA512 (kernel-kabi-dw-5.9.0-0.rc6.20200922git98477740630f.14.tar.bz2) = a7f90cef27fdd551f23787cd9a2d91e003a3a2d1453bbe1f11c5ead8a808bbd12dc06f5ac0d945bdf20984cfd18d0f3f3bcd5c064181c8ab7faf67208ce10c85
|
||||
|
Loading…
Reference in New Issue
Block a user