Linux 3.1-rc7
This commit is contained in:
parent
8674cb1bd8
commit
962393f362
@ -1,67 +0,0 @@
|
||||
Path: news.gmane.org!not-for-mail
|
||||
From: Pieter-Augustijn Van Malleghem <p-a-rJAIWvhRp0CZIoH1IeqzKA@public.gmane.org>
|
||||
Newsgroups: gmane.linux.bluez.kernel
|
||||
Subject: [PATCH] Add MacBookAir4,1 support
|
||||
Date: Wed, 7 Sep 2011 02:28:10 -0400
|
||||
Lines: 18
|
||||
Approved: news@gmane.org
|
||||
Message-ID: <20110907062810.GA4755@Caligula>
|
||||
NNTP-Posting-Host: lo.gmane.org
|
||||
Mime-Version: 1.0
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
X-Trace: dough.gmane.org 1315376918 16651 80.91.229.12 (7 Sep 2011 06:28:38 GMT)
|
||||
X-Complaints-To: usenet@dough.gmane.org
|
||||
NNTP-Posting-Date: Wed, 7 Sep 2011 06:28:38 +0000 (UTC)
|
||||
To: linux-bluetooth-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
|
||||
Original-X-From: linux-bluetooth-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org Wed Sep 07 08:28:35 2011
|
||||
Return-path: <linux-bluetooth-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>
|
||||
Envelope-to: glbk-linux-bluetooth-1dZseelyfdZg9hUCZPvPmw@public.gmane.org
|
||||
Original-Received: from vger.kernel.org ([209.132.180.67])
|
||||
by lo.gmane.org with esmtp (Exim 4.69)
|
||||
(envelope-from <linux-bluetooth-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>)
|
||||
id 1R1Bce-00013w-IP
|
||||
for glbk-linux-bluetooth-1dZseelyfdZg9hUCZPvPmw@public.gmane.org; Wed, 07 Sep 2011 08:28:32 +0200
|
||||
Original-Received: (majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org) by vger.kernel.org via listexpand
|
||||
id S1755760Ab1IGG22 (ORCPT
|
||||
<rfc822;glbk-linux-bluetooth@m.gmane.org>);
|
||||
Wed, 7 Sep 2011 02:28:28 -0400
|
||||
Original-Received: from mail-qy0-f174.google.com ([209.85.216.174]:48109 "EHLO
|
||||
mail-qy0-f174.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org
|
||||
with ESMTP id S1756054Ab1IGG2V (ORCPT
|
||||
<rfc822;linux-bluetooth-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>);
|
||||
Wed, 7 Sep 2011 02:28:21 -0400
|
||||
Original-Received: by qyk7 with SMTP id 7so455185qyk.19
|
||||
for <linux-bluetooth-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>; Tue, 06 Sep 2011 23:28:20 -0700 (PDT)
|
||||
Original-Received: by 10.224.192.6 with SMTP id do6mr4345154qab.189.1315376900296;
|
||||
Tue, 06 Sep 2011 23:28:20 -0700 (PDT)
|
||||
Original-Received: from Caligula ([140.247.187.88])
|
||||
by mx.google.com with ESMTPS id dr7sm2176040qab.26.2011.09.06.23.28.19
|
||||
(version=TLSv1/SSLv3 cipher=OTHER);
|
||||
Tue, 06 Sep 2011 23:28:19 -0700 (PDT)
|
||||
Content-Disposition: inline
|
||||
User-Agent: Mutt/1.5.21 (2010-09-15)
|
||||
Original-Sender: linux-bluetooth-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
|
||||
Precedence: bulk
|
||||
List-ID: <linux-bluetooth.vger.kernel.org>
|
||||
X-Mailing-List: linux-bluetooth-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
|
||||
Xref: news.gmane.org gmane.linux.bluez.kernel:16281
|
||||
Archived-At: <http://permalink.gmane.org/gmane.linux.bluez.kernel/16281>
|
||||
|
||||
This patch against current git adds the hardware ID for the Apple
|
||||
MacBookAir4,1, released in July 2011. The device features a BCM2046
|
||||
USB chip. The patch was inspired by the previous modifications adding
|
||||
support for the MacBookAir3,x.
|
||||
|
||||
Signed-off-by: Pieter-Augustijn Van Malleghem <p-a-rJAIWvhRp0CZIoH1IeqzKA@public.gmane.org>
|
||||
--- linux/drivers/bluetooth/btusb.c 2011-09-06 23:41:57.000000000 -0400
|
||||
+++ patched/drivers/bluetooth/btusb.c 2011-09-06 23:50:27.000000000 -0400
|
||||
@@ -72,6 +72,9 @@
|
||||
/* Apple MacBookAir3,1, MacBookAir3,2 */
|
||||
{ USB_DEVICE(0x05ac, 0x821b) },
|
||||
|
||||
+ /* Apple MacBookAir4,1 */
|
||||
+ { USB_DEVICE(0x05ac, 0x821f) },
|
||||
+
|
||||
/* Apple MacBookPro8,2 */
|
||||
{ USB_DEVICE(0x05ac, 0x821a) },
|
||||
|
@ -1,100 +0,0 @@
|
||||
Path: news.gmane.org!not-for-mail
|
||||
From: Pieter-Augustijn Van Malleghem <p-a@scarlet.be>
|
||||
Newsgroups: gmane.linux.kernel.input
|
||||
Subject: [PATCH] Add MacBookAir4,1 trackpad support
|
||||
Date: Wed, 7 Sep 2011 16:16:39 -0400
|
||||
Lines: 53
|
||||
Approved: news@gmane.org
|
||||
Message-ID: <20110907201639.GA2004@Caligula>
|
||||
NNTP-Posting-Host: lo.gmane.org
|
||||
Mime-Version: 1.0
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
X-Trace: dough.gmane.org 1315427050 14847 80.91.229.12 (7 Sep 2011 20:24:10 GMT)
|
||||
X-Complaints-To: usenet@dough.gmane.org
|
||||
NNTP-Posting-Date: Wed, 7 Sep 2011 20:24:10 +0000 (UTC)
|
||||
To: linux-input@vger.kernel.org
|
||||
Original-X-From: linux-input-owner@vger.kernel.org Wed Sep 07 22:24:06 2011
|
||||
Return-path: <linux-input-owner@vger.kernel.org>
|
||||
Envelope-to: glki-linux-input-2@lo.gmane.org
|
||||
Original-Received: from vger.kernel.org ([209.132.180.67])
|
||||
by lo.gmane.org with esmtp (Exim 4.69)
|
||||
(envelope-from <linux-input-owner@vger.kernel.org>)
|
||||
id 1R1OfE-0003bX-Dq
|
||||
for glki-linux-input-2@lo.gmane.org; Wed, 07 Sep 2011 22:24:04 +0200
|
||||
Original-Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
||||
id S1756616Ab1IGUYD (ORCPT <rfc822;glki-linux-input-2@m.gmane.org>);
|
||||
Wed, 7 Sep 2011 16:24:03 -0400
|
||||
Original-Received: from mail-vx0-f174.google.com ([209.85.220.174]:45534 "EHLO
|
||||
mail-vx0-f174.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org
|
||||
with ESMTP id S1755813Ab1IGUYB (ORCPT
|
||||
<rfc822;linux-input@vger.kernel.org>); Wed, 7 Sep 2011 16:24:01 -0400
|
||||
Original-Received: by vxj15 with SMTP id 15so37615vxj.19
|
||||
for <linux-input@vger.kernel.org>; Wed, 07 Sep 2011 13:24:01 -0700 (PDT)
|
||||
Original-Received: by 10.52.173.49 with SMTP id bh17mr2675458vdc.82.1315426608488;
|
||||
Wed, 07 Sep 2011 13:16:48 -0700 (PDT)
|
||||
Original-Received: from Caligula ([140.247.246.50])
|
||||
by mx.google.com with ESMTPS id da15sm937150vdb.26.2011.09.07.13.16.47
|
||||
(version=TLSv1/SSLv3 cipher=OTHER);
|
||||
Wed, 07 Sep 2011 13:16:47 -0700 (PDT)
|
||||
Content-Disposition: inline
|
||||
User-Agent: Mutt/1.5.21 (2010-09-15)
|
||||
Original-Sender: linux-input-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <linux-input.vger.kernel.org>
|
||||
X-Mailing-List: linux-input@vger.kernel.org
|
||||
Xref: news.gmane.org gmane.linux.kernel.input:21463
|
||||
Archived-At: <http://permalink.gmane.org/gmane.linux.kernel.input/21463>
|
||||
|
||||
This patch adds trackpad support for the MacBookAir4,1, released in July 2011.
|
||||
It is very similar to the MacBookAir4,2 patch submitted by Joshua Dillon and
|
||||
Chase Douglas.
|
||||
|
||||
Signed-off-by: Pieter-Augustijn Van Malleghem <p-a@scarlet.be>
|
||||
--- linux/drivers/input/mouse/bcm5974.c 2011-09-06 23:41:58.000000000 -0400
|
||||
+++ patched/drivers/input/mouse/bcm5974.c 2011-09-07 00:02:44.000000000 -0400
|
||||
@@ -67,6 +67,10 @@
|
||||
#define USB_DEVICE_ID_APPLE_WELLSPRING5_ANSI 0x0245
|
||||
#define USB_DEVICE_ID_APPLE_WELLSPRING5_ISO 0x0246
|
||||
#define USB_DEVICE_ID_APPLE_WELLSPRING5_JIS 0x0247
|
||||
+/* MacbookAir4,1 (unibody, July 2011) */
|
||||
+#define USB_DEVICE_ID_APPLE_WELLSPRING6A_ANSI 0x0249
|
||||
+#define USB_DEVICE_ID_APPLE_WELLSPRING6A_ISO 0x024a
|
||||
+#define USB_DEVICE_ID_APPLE_WELLSPRING6A_JIS 0x024b
|
||||
/* MacbookAir4,2 (unibody, July 2011) */
|
||||
#define USB_DEVICE_ID_APPLE_WELLSPRING6_ANSI 0x024c
|
||||
#define USB_DEVICE_ID_APPLE_WELLSPRING6_ISO 0x024d
|
||||
@@ -112,6 +116,10 @@
|
||||
BCM5974_DEVICE(USB_DEVICE_ID_APPLE_WELLSPRING5_ANSI),
|
||||
BCM5974_DEVICE(USB_DEVICE_ID_APPLE_WELLSPRING5_ISO),
|
||||
BCM5974_DEVICE(USB_DEVICE_ID_APPLE_WELLSPRING5_JIS),
|
||||
+ /* MacbookAir4,1 */
|
||||
+ BCM5974_DEVICE(USB_DEVICE_ID_APPLE_WELLSPRING6A_ANSI),
|
||||
+ BCM5974_DEVICE(USB_DEVICE_ID_APPLE_WELLSPRING6A_ISO),
|
||||
+ BCM5974_DEVICE(USB_DEVICE_ID_APPLE_WELLSPRING6A_JIS),
|
||||
/* MacbookAir4,2 */
|
||||
BCM5974_DEVICE(USB_DEVICE_ID_APPLE_WELLSPRING6_ANSI),
|
||||
BCM5974_DEVICE(USB_DEVICE_ID_APPLE_WELLSPRING6_ISO),
|
||||
@@ -334,6 +342,18 @@
|
||||
{ DIM_X, DIM_X / SN_COORD, -4750, 5280 },
|
||||
{ DIM_Y, DIM_Y / SN_COORD, -150, 6730 }
|
||||
},
|
||||
+ {
|
||||
+ USB_DEVICE_ID_APPLE_WELLSPRING6A_ANSI,
|
||||
+ USB_DEVICE_ID_APPLE_WELLSPRING6A_ISO,
|
||||
+ USB_DEVICE_ID_APPLE_WELLSPRING6A_JIS,
|
||||
+ HAS_INTEGRATED_BUTTON,
|
||||
+ 0x84, sizeof(struct bt_data),
|
||||
+ 0x81, TYPE2, FINGER_TYPE2, FINGER_TYPE2 + SIZEOF_ALL_FINGERS,
|
||||
+ { DIM_PRESSURE, DIM_PRESSURE / SN_PRESSURE, 0, 300 },
|
||||
+ { DIM_WIDTH, DIM_WIDTH / SN_WIDTH, 0, 2048 },
|
||||
+ { DIM_X, DIM_X / SN_COORD, -4620, 5140 },
|
||||
+ { DIM_Y, DIM_Y / SN_COORD, -150, 6600 }
|
||||
+ },
|
||||
{}
|
||||
};
|
||||
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-input" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
||||
|
@ -1,70 +0,0 @@
|
||||
Path: news.gmane.org!not-for-mail
|
||||
From: Anton Blanchard <anton@samba.org>
|
||||
Newsgroups: gmane.linux.network
|
||||
Subject: [PATCH 3/4] ibmveth: Checksum offload is always disabled
|
||||
Date: Thu, 08 Sep 2011 10:41:05 +1000
|
||||
Lines: 23
|
||||
Approved: news@gmane.org
|
||||
Message-ID: <20110908004121.744925909@samba.org>
|
||||
References: <20110908004102.355674129@samba.org>
|
||||
NNTP-Posting-Host: lo.gmane.org
|
||||
X-Trace: dough.gmane.org 1315442745 17939 80.91.229.12 (8 Sep 2011 00:45:45 GMT)
|
||||
X-Complaints-To: usenet@dough.gmane.org
|
||||
NNTP-Posting-Date: Thu, 8 Sep 2011 00:45:45 +0000 (UTC)
|
||||
Cc: netdev@vger.kernel.org
|
||||
To: Santiago Leon <santil@linux.vnet.ibm.com>,
|
||||
brking@linux.vnet.ibm.com, rcj@linux.vnet.ibm.com,
|
||||
mirq-linux@rere.qmqm.pl
|
||||
Original-X-From: netdev-owner@vger.kernel.org Thu Sep 08 02:45:39 2011
|
||||
Return-path: <netdev-owner@vger.kernel.org>
|
||||
Envelope-to: linux-netdev-2@lo.gmane.org
|
||||
Original-Received: from vger.kernel.org ([209.132.180.67])
|
||||
by lo.gmane.org with esmtp (Exim 4.69)
|
||||
(envelope-from <netdev-owner@vger.kernel.org>)
|
||||
id 1R1SkN-0001Tk-2c
|
||||
for linux-netdev-2@lo.gmane.org; Thu, 08 Sep 2011 02:45:39 +0200
|
||||
Original-Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
||||
id S1757675Ab1IHApb (ORCPT <rfc822;linux-netdev-2@m.gmane.org>);
|
||||
Wed, 7 Sep 2011 20:45:31 -0400
|
||||
Original-Received: from ozlabs.org ([203.10.76.45]:45063 "EHLO ozlabs.org"
|
||||
rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP
|
||||
id S1757657Ab1IHAp1 (ORCPT <rfc822;netdev@vger.kernel.org>);
|
||||
Wed, 7 Sep 2011 20:45:27 -0400
|
||||
Original-Received: from localhost (ppp121-44-79-234.lns20.syd6.internode.on.net [121.44.79.234])
|
||||
(using TLSv1 with cipher DHE-RSA-AES128-SHA (128/128 bits))
|
||||
(Client did not present a certificate)
|
||||
by ozlabs.org (Postfix) with ESMTPSA id 17FFBB6F98;
|
||||
Thu, 8 Sep 2011 10:45:26 +1000 (EST)
|
||||
X-Mailbox-Line: From anton@samba.org Thu Sep 8 10:41:21 2011
|
||||
User-Agent: quilt/0.48-1
|
||||
Content-Disposition: inline; filename=ibmveth_fix_csum.patch
|
||||
Original-Sender: netdev-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <netdev.vger.kernel.org>
|
||||
X-Mailing-List: netdev@vger.kernel.org
|
||||
Xref: news.gmane.org gmane.linux.network:205929
|
||||
Archived-At: <http://permalink.gmane.org/gmane.linux.network/205929>
|
||||
|
||||
Commit b9367bf3ee6d (net: ibmveth: convert to hw_features) reversed
|
||||
a check in ibmveth_set_csum_offload that results in checksum offload
|
||||
never being enabled.
|
||||
|
||||
Signed-off-by: Anton Blanchard <anton@samba.org>
|
||||
Cc: <stable@kernel.org> # 3.0+
|
||||
---
|
||||
|
||||
Index: linux-build/drivers/net/ibmveth.c
|
||||
===================================================================
|
||||
--- linux-build.orig/drivers/net/ibmveth.c 2011-09-01 16:02:12.198726425 +1000
|
||||
+++ linux-build/drivers/net/ibmveth.c 2011-09-01 16:05:37.282482851 +1000
|
||||
@@ -812,7 +812,7 @@ static int ibmveth_set_csum_offload(stru
|
||||
} else
|
||||
adapter->fw_ipv6_csum_support = data;
|
||||
|
||||
- if (ret != H_SUCCESS || ret6 != H_SUCCESS)
|
||||
+ if (ret == H_SUCCESS || ret6 == H_SUCCESS)
|
||||
adapter->rx_csum = data;
|
||||
else
|
||||
rc1 = -EIO;
|
||||
|
||||
|
@ -1,78 +0,0 @@
|
||||
Path: news.gmane.org!not-for-mail
|
||||
From: Anton Blanchard <anton@samba.org>
|
||||
Newsgroups: gmane.linux.network
|
||||
Subject: [PATCH 1/4] ibmveth: Fix DMA unmap error
|
||||
Date: Thu, 08 Sep 2011 10:41:03 +1000
|
||||
Lines: 32
|
||||
Approved: news@gmane.org
|
||||
Message-ID: <20110908004121.570234962@samba.org>
|
||||
References: <20110908004102.355674129@samba.org>
|
||||
NNTP-Posting-Host: lo.gmane.org
|
||||
X-Trace: dough.gmane.org 1315442763 18071 80.91.229.12 (8 Sep 2011 00:46:03 GMT)
|
||||
X-Complaints-To: usenet@dough.gmane.org
|
||||
NNTP-Posting-Date: Thu, 8 Sep 2011 00:46:03 +0000 (UTC)
|
||||
Cc: netdev@vger.kernel.org
|
||||
To: Santiago Leon <santil@linux.vnet.ibm.com>,
|
||||
brking@linux.vnet.ibm.com, rcj@linux.vnet.ibm.com
|
||||
Original-X-From: netdev-owner@vger.kernel.org Thu Sep 08 02:45:56 2011
|
||||
Return-path: <netdev-owner@vger.kernel.org>
|
||||
Envelope-to: linux-netdev-2@lo.gmane.org
|
||||
Original-Received: from vger.kernel.org ([209.132.180.67])
|
||||
by lo.gmane.org with esmtp (Exim 4.69)
|
||||
(envelope-from <netdev-owner@vger.kernel.org>)
|
||||
id 1R1Ska-0001cA-40
|
||||
for linux-netdev-2@lo.gmane.org; Thu, 08 Sep 2011 02:45:52 +0200
|
||||
Original-Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
||||
id S1757671Ab1IHAp3 (ORCPT <rfc822;linux-netdev-2@m.gmane.org>);
|
||||
Wed, 7 Sep 2011 20:45:29 -0400
|
||||
Original-Received: from ozlabs.org ([203.10.76.45]:42999 "EHLO ozlabs.org"
|
||||
rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP
|
||||
id S1757658Ab1IHAp1 (ORCPT <rfc822;netdev@vger.kernel.org>);
|
||||
Wed, 7 Sep 2011 20:45:27 -0400
|
||||
Original-Received: from localhost (ppp121-44-79-234.lns20.syd6.internode.on.net [121.44.79.234])
|
||||
(using TLSv1 with cipher DHE-RSA-AES128-SHA (128/128 bits))
|
||||
(Client did not present a certificate)
|
||||
by ozlabs.org (Postfix) with ESMTPSA id ACF33B6F8E;
|
||||
Thu, 8 Sep 2011 10:45:24 +1000 (EST)
|
||||
X-Mailbox-Line: From anton@samba.org Thu Sep 8 10:41:21 2011
|
||||
User-Agent: quilt/0.48-1
|
||||
Content-Disposition: inline; filename=ibmveth_1.patch
|
||||
Original-Sender: netdev-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <netdev.vger.kernel.org>
|
||||
X-Mailing-List: netdev@vger.kernel.org
|
||||
Xref: news.gmane.org gmane.linux.network:205933
|
||||
Archived-At: <http://permalink.gmane.org/gmane.linux.network/205933>
|
||||
|
||||
From: Brian King <brking@linux.vnet.ibm.com>
|
||||
|
||||
Commit 6e8ab30ec677 (ibmveth: Add scatter-gather support) introduced a
|
||||
DMA mapping API inconsistency resulting in dma_unmap_page getting
|
||||
called on memory mapped via dma_map_single. This was seen when
|
||||
CONFIG_DMA_API_DEBUG was enabled. Fix up this API usage inconsistency.
|
||||
|
||||
Signed-off-by: Brian King <brking@linux.vnet.ibm.com>
|
||||
Acked-by: Anton Blanchard <anton@samba.org>
|
||||
Cc: <stable@kernel.org> # v2.6.37+
|
||||
---
|
||||
|
||||
Index: linux-build/drivers/net/ibmveth.c
|
||||
===================================================================
|
||||
--- linux-build.orig/drivers/net/ibmveth.c 2011-09-08 08:00:16.842856634 +1000
|
||||
+++ linux-build/drivers/net/ibmveth.c 2011-09-08 09:45:43.163851274 +1000
|
||||
@@ -1026,7 +1026,12 @@ retry_bounce:
|
||||
netdev->stats.tx_bytes += skb->len;
|
||||
}
|
||||
|
||||
- for (i = 0; i < skb_shinfo(skb)->nr_frags + 1; i++)
|
||||
+ dma_unmap_single(&adapter->vdev->dev,
|
||||
+ descs[0].fields.address,
|
||||
+ descs[0].fields.flags_len & IBMVETH_BUF_LEN_MASK,
|
||||
+ DMA_TO_DEVICE);
|
||||
+
|
||||
+ for (i = 1; i < skb_shinfo(skb)->nr_frags + 1; i++)
|
||||
dma_unmap_page(&adapter->vdev->dev, descs[i].fields.address,
|
||||
descs[i].fields.flags_len & IBMVETH_BUF_LEN_MASK,
|
||||
DMA_TO_DEVICE);
|
||||
|
||||
|
@ -1,93 +0,0 @@
|
||||
Path: news.gmane.org!not-for-mail
|
||||
From: Anton Blanchard <anton@samba.org>
|
||||
Newsgroups: gmane.linux.network
|
||||
Subject: [PATCH 2/4] ibmveth: Fix issue with DMA mapping failure
|
||||
Date: Thu, 08 Sep 2011 10:41:04 +1000
|
||||
Lines: 47
|
||||
Approved: news@gmane.org
|
||||
Message-ID: <20110908004121.669225190@samba.org>
|
||||
References: <20110908004102.355674129@samba.org>
|
||||
NNTP-Posting-Host: lo.gmane.org
|
||||
X-Trace: dough.gmane.org 1315442760 18037 80.91.229.12 (8 Sep 2011 00:46:00 GMT)
|
||||
X-Complaints-To: usenet@dough.gmane.org
|
||||
NNTP-Posting-Date: Thu, 8 Sep 2011 00:46:00 +0000 (UTC)
|
||||
Cc: netdev@vger.kernel.org
|
||||
To: Santiago Leon <santil@linux.vnet.ibm.com>,
|
||||
brking@linux.vnet.ibm.com, rcj@linux.vnet.ibm.com
|
||||
Original-X-From: netdev-owner@vger.kernel.org Thu Sep 08 02:45:55 2011
|
||||
Return-path: <netdev-owner@vger.kernel.org>
|
||||
Envelope-to: linux-netdev-2@lo.gmane.org
|
||||
Original-Received: from vger.kernel.org ([209.132.180.67])
|
||||
by lo.gmane.org with esmtp (Exim 4.69)
|
||||
(envelope-from <netdev-owner@vger.kernel.org>)
|
||||
id 1R1Ska-0001cA-M3
|
||||
for linux-netdev-2@lo.gmane.org; Thu, 08 Sep 2011 02:45:53 +0200
|
||||
Original-Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
||||
id S1757665Ab1IHApa (ORCPT <rfc822;linux-netdev-2@m.gmane.org>);
|
||||
Wed, 7 Sep 2011 20:45:30 -0400
|
||||
Original-Received: from ozlabs.org ([203.10.76.45]:60840 "EHLO ozlabs.org"
|
||||
rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP
|
||||
id S1757659Ab1IHAp1 (ORCPT <rfc822;netdev@vger.kernel.org>);
|
||||
Wed, 7 Sep 2011 20:45:27 -0400
|
||||
Original-Received: from localhost (ppp121-44-79-234.lns20.syd6.internode.on.net [121.44.79.234])
|
||||
(using TLSv1 with cipher DHE-RSA-AES128-SHA (128/128 bits))
|
||||
(Client did not present a certificate)
|
||||
by ozlabs.org (Postfix) with ESMTPSA id 56E01B6F97;
|
||||
Thu, 8 Sep 2011 10:45:25 +1000 (EST)
|
||||
X-Mailbox-Line: From anton@samba.org Thu Sep 8 10:41:21 2011
|
||||
User-Agent: quilt/0.48-1
|
||||
Content-Disposition: inline; filename=ibmveth_dma_mapping_error.patch
|
||||
Original-Sender: netdev-owner@vger.kernel.org
|
||||
Precedence: bulk
|
||||
List-ID: <netdev.vger.kernel.org>
|
||||
X-Mailing-List: netdev@vger.kernel.org
|
||||
Xref: news.gmane.org gmane.linux.network:205931
|
||||
Archived-At: <http://permalink.gmane.org/gmane.linux.network/205931>
|
||||
|
||||
descs[].fields.address is 32bit which truncates any dma mapping
|
||||
errors so dma_mapping_error() fails to catch it.
|
||||
|
||||
Use a dma_addr_t to do the comparison. With this patch I was able
|
||||
to transfer many gigabytes of data with IOMMU fault injection set
|
||||
at 10% probability.
|
||||
|
||||
Signed-off-by: Anton Blanchard <anton@samba.org>
|
||||
Cc: <stable@kernel.org> # v2.6.37+
|
||||
---
|
||||
|
||||
Index: linux-build/drivers/net/ibmveth.c
|
||||
===================================================================
|
||||
--- linux-build.orig/drivers/net/ibmveth.c 2011-09-01 15:01:18.066844039 +1000
|
||||
+++ linux-build/drivers/net/ibmveth.c 2011-09-01 15:03:34.299079796 +1000
|
||||
@@ -930,6 +930,7 @@ static netdev_tx_t ibmveth_start_xmit(st
|
||||
union ibmveth_buf_desc descs[6];
|
||||
int last, i;
|
||||
int force_bounce = 0;
|
||||
+ dma_addr_t dma_addr;
|
||||
|
||||
/*
|
||||
* veth handles a maximum of 6 segments including the header, so
|
||||
@@ -994,17 +995,16 @@ retry_bounce:
|
||||
}
|
||||
|
||||
/* Map the header */
|
||||
- descs[0].fields.address = dma_map_single(&adapter->vdev->dev, skb->data,
|
||||
- skb_headlen(skb),
|
||||
- DMA_TO_DEVICE);
|
||||
- if (dma_mapping_error(&adapter->vdev->dev, descs[0].fields.address))
|
||||
+ dma_addr = dma_map_single(&adapter->vdev->dev, skb->data,
|
||||
+ skb_headlen(skb), DMA_TO_DEVICE);
|
||||
+ if (dma_mapping_error(&adapter->vdev->dev, dma_addr))
|
||||
goto map_failed;
|
||||
|
||||
descs[0].fields.flags_len = desc_flags | skb_headlen(skb);
|
||||
+ descs[0].fields.address = dma_addr;
|
||||
|
||||
/* Map the frags */
|
||||
for (i = 0; i < skb_shinfo(skb)->nr_frags; i++) {
|
||||
- unsigned long dma_addr;
|
||||
skb_frag_t *frag = &skb_shinfo(skb)->frags[i];
|
||||
|
||||
dma_addr = dma_map_page(&adapter->vdev->dev, frag->page,
|
||||
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/drivers/net/wireless/iwlwifi/iwl-agn.c b/drivers/net/wireless/iwlwifi/iwl-agn.c
|
||||
index b0ae4de..afa00ec 100644
|
||||
--- a/drivers/net/wireless/iwlwifi/iwl-agn.c
|
||||
+++ b/drivers/net/wireless/iwlwifi/iwl-agn.c
|
||||
@@ -2140,8 +2140,6 @@ static int iwl_mac_setup_register(struct iwl_priv *priv,
|
||||
IEEE80211_HW_SPECTRUM_MGMT |
|
||||
IEEE80211_HW_REPORTS_TX_ACK_STATUS;
|
||||
|
||||
- hw->max_tx_aggregation_subframes = LINK_QUAL_AGG_FRAME_LIMIT_DEF;
|
||||
-
|
||||
hw->flags |= IEEE80211_HW_SUPPORTS_PS |
|
||||
IEEE80211_HW_SUPPORTS_DYNAMIC_PS;
|
||||
|
19
kernel.spec
19
kernel.spec
@ -82,7 +82,7 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%define rcrev 6
|
||||
%define rcrev 7
|
||||
# The git snapshot level
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
@ -721,19 +721,12 @@ Patch12303: dmar-disable-when-ricoh-multifunction.patch
|
||||
|
||||
Patch13002: revert-efi-rtclock.patch
|
||||
Patch13003: efi-dont-map-boot-services-on-32bit.patch
|
||||
Patch13004: iwlagn-revert-max-aggregate-size.patch
|
||||
Patch13005: ucvideo-fix-crash-when-linking-entities.patch
|
||||
|
||||
Patch13006: add-macbookair41-trackpad.patch
|
||||
Patch13007: add-macbookair41-keyboard.patch
|
||||
Patch13008: add-macbookair41-btusb.patch
|
||||
|
||||
Patch13009: hvcs_pi_buf_alloc.patch
|
||||
|
||||
Patch13010: ibmveth-Fix-DMA-unmap-error.patch
|
||||
Patch13011: ibmveth-Fix-issue-with-DMA-mapping-failure.patch
|
||||
Patch13012: ibmveth-Checksum-offload-is-always-disabled.patch
|
||||
|
||||
Patch13013: powerpc-Fix-deadlock-in-icswx-code.patch
|
||||
|
||||
Patch20000: utrace.patch
|
||||
@ -1341,19 +1334,12 @@ ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
||||
|
||||
ApplyPatch revert-efi-rtclock.patch
|
||||
ApplyPatch efi-dont-map-boot-services-on-32bit.patch
|
||||
ApplyPatch iwlagn-revert-max-aggregate-size.patch
|
||||
ApplyPatch ucvideo-fix-crash-when-linking-entities.patch
|
||||
|
||||
ApplyPatch add-macbookair41-trackpad.patch
|
||||
ApplyPatch add-macbookair41-keyboard.patch
|
||||
ApplyPatch add-macbookair41-btusb.patch
|
||||
|
||||
ApplyPatch hvcs_pi_buf_alloc.patch
|
||||
|
||||
ApplyPatch ibmveth-Fix-DMA-unmap-error.patch
|
||||
ApplyPatch ibmveth-Fix-issue-with-DMA-mapping-failure.patch
|
||||
ApplyPatch ibmveth-Checksum-offload-is-always-disabled.patch
|
||||
|
||||
ApplyPatch powerpc-Fix-deadlock-in-icswx-code.patch
|
||||
|
||||
# utrace.
|
||||
@ -2067,6 +2053,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Wed Sep 21 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Linux 3.1-rc7
|
||||
|
||||
* Tue Sep 20 2011 Dave Jones <davej@redhat.com>
|
||||
- Limit 32-bit x86 kernels to 32 processors.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user