Linux v4.11-rc1
This commit is contained in:
parent
ddbd66fdf6
commit
8e4bbb22f1
1
baseconfig/CONFIG_QEDF
Normal file
1
baseconfig/CONFIG_QEDF
Normal file
@ -0,0 +1 @@
|
||||
CONFIG_QEDF=m
|
@ -1,49 +0,0 @@
|
||||
From 3b30460c5b0ed762be75a004e924ec3f8711e032 Mon Sep 17 00:00:00 2001
|
||||
From: Ard Biesheuvel <ard.biesheuvel@linaro.org>
|
||||
Date: Mon, 27 Feb 2017 15:30:56 +0000
|
||||
Subject: crypto: ccm - move cbcmac input off the stack
|
||||
|
||||
Commit f15f05b0a5de ("crypto: ccm - switch to separate cbcmac driver")
|
||||
refactored the CCM driver to allow separate implementations of the
|
||||
underlying MAC to be provided by a platform. However, in doing so, it
|
||||
moved some data from the linear region to the stack, which violates the
|
||||
SG constraints when the stack is virtually mapped.
|
||||
|
||||
So move idata/odata back to the request ctx struct, of which we can
|
||||
reasonably expect that it has been allocated using kmalloc() et al.
|
||||
|
||||
Reported-by: Johannes Berg <johannes@sipsolutions.net>
|
||||
Fixes: f15f05b0a5de ("crypto: ccm - switch to separate cbcmac driver")
|
||||
Signed-off-by: Ard Biesheuvel <ard.biesheuvel@linaro.org>
|
||||
Tested-by: Johannes Berg <johannes@sipsolutions.net>
|
||||
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
|
||||
---
|
||||
crypto/ccm.c | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/crypto/ccm.c b/crypto/ccm.c
|
||||
index 4428488..1ce37ae 100644
|
||||
--- a/crypto/ccm.c
|
||||
+++ b/crypto/ccm.c
|
||||
@@ -45,6 +45,7 @@ struct crypto_rfc4309_req_ctx {
|
||||
|
||||
struct crypto_ccm_req_priv_ctx {
|
||||
u8 odata[16];
|
||||
+ u8 idata[16];
|
||||
u8 auth_tag[16];
|
||||
u32 flags;
|
||||
struct scatterlist src[3];
|
||||
@@ -183,8 +184,8 @@ static int crypto_ccm_auth(struct aead_request *req, struct scatterlist *plain,
|
||||
AHASH_REQUEST_ON_STACK(ahreq, ctx->mac);
|
||||
unsigned int assoclen = req->assoclen;
|
||||
struct scatterlist sg[3];
|
||||
- u8 odata[16];
|
||||
- u8 idata[16];
|
||||
+ u8 *odata = pctx->odata;
|
||||
+ u8 *idata = pctx->idata;
|
||||
int ilen, err;
|
||||
|
||||
/* format control data for input */
|
||||
--
|
||||
cgit v0.12
|
||||
|
@ -24,7 +24,7 @@ ethdrvs="3com adaptec alteon amd atheros broadcom cadence calxeda chelsio cisco
|
||||
|
||||
inputdrvs="gameport tablet touchscreen"
|
||||
|
||||
scsidrvs="aacraid aic7xxx aic94xx be2iscsi bfa bnx2i bnx2fc csiostor cxgbi esas2r fcoe fnic isci libsas lpfc megaraid mpt2sas mpt3sas mvsas pm8001 qla2xxx qla4xxx sym53c8xx_2 ufs"
|
||||
scsidrvs="aacraid aic7xxx aic94xx be2iscsi bfa bnx2i bnx2fc csiostor cxgbi esas2r fcoe fnic isci libsas lpfc megaraid mpt2sas mpt3sas mvsas pm8001 qla2xxx qla4xxx sym53c8xx_2 ufs qedf"
|
||||
|
||||
usbdrvs="atm image misc serial wusbcore"
|
||||
|
||||
|
@ -4095,6 +4095,7 @@ CONFIG_QCOM_WCNSS_CTRL=m
|
||||
# CONFIG_QCOM_WCNSS_PIL is not set
|
||||
CONFIG_QCOM_WDT=m
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -4073,6 +4073,7 @@ CONFIG_QCOM_WCNSS_CTRL=m
|
||||
# CONFIG_QCOM_WCNSS_PIL is not set
|
||||
CONFIG_QCOM_WDT=m
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -4425,6 +4425,7 @@ CONFIG_QCOM_WCNSS_CTRL=m
|
||||
# CONFIG_QCOM_WCNSS_PIL is not set
|
||||
CONFIG_QCOM_WDT=m
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -4184,6 +4184,7 @@ CONFIG_QCOM_IRQ_COMBINER=y
|
||||
# CONFIG_QCOM_SPMI_TEMP_ALARM is not set
|
||||
# CONFIG_QCOM_SPMI_VADC is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -4162,6 +4162,7 @@ CONFIG_QCOM_IRQ_COMBINER=y
|
||||
# CONFIG_QCOM_SPMI_TEMP_ALARM is not set
|
||||
# CONFIG_QCOM_SPMI_VADC is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -4403,6 +4403,7 @@ CONFIG_QCOM_WCNSS_CTRL=m
|
||||
# CONFIG_QCOM_WCNSS_PIL is not set
|
||||
CONFIG_QCOM_WDT=m
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3921,6 +3921,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3942,6 +3942,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3942,6 +3942,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3921,6 +3921,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3787,6 +3787,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3764,6 +3764,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3727,6 +3727,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3704,6 +3704,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3726,6 +3726,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3703,6 +3703,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3617,6 +3617,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QDIO=m
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3594,6 +3594,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QDIO=m
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3964,6 +3964,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
@ -3943,6 +3943,7 @@ CONFIG_QCOM_ADSP_PIL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QEDE=m
|
||||
CONFIG_QEDF=m
|
||||
CONFIG_QEDI=m
|
||||
CONFIG_QED=m
|
||||
CONFIG_QED_SRIOV=y
|
||||
|
10
kernel.spec
10
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%global rcrev 0
|
||||
%global rcrev 1
|
||||
# The git snapshot level
|
||||
%define gitrev 9
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 4.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -593,9 +593,6 @@ Patch509: MODSIGN-Don-t-try-secure-boot-if-EFI-runtime-is-disa.patch
|
||||
#CVE-2016-3134 rhbz 1317383 1317384
|
||||
Patch665: netfilter-x_tables-deal-with-bogus-nextoffset-values.patch
|
||||
|
||||
#rhbz 1427593
|
||||
Patch666: ccm-stack.patch
|
||||
|
||||
# grabbed from mailing list
|
||||
Patch667: v3-Revert-tty-serial-pl011-add-ttyAMA-for-matching-pl011-console.patch
|
||||
|
||||
@ -2163,6 +2160,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Mar 06 2017 Laura Abbott <labbott@fedoraproject.org> - 4.11.0-0.rc1.git0.1
|
||||
- Linux v4.11-rc1
|
||||
|
||||
* Mon Mar 06 2017 Laura Abbott <labbott@fedoraproject.org>
|
||||
- Disable debugging options.
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-4.10.tar.xz) = c3690125a8402df638095bd98a613fcf1a257b81de7611c84711d315cd11e2634ab4636302b3742aedf1e3ba9ce0fea53fe8c7d48e37865d8ee5db3565220d90
|
||||
SHA512 (perf-man-4.10.tar.gz) = 2c830e06f47211d70a8330961487af73a8bc01073019475e6b6131d3bb8c95658b77ca0ae5f1b44371accf103658bc5a3a4366b3e017a4088a8fd408dd6867e8
|
||||
SHA512 (patch-4.10-git9.xz) = 7e934f2001741547552ace9f4f81da423cc21607c27bcc8c73312a57d7ac29d1f2e191c6739380518cd11828a5b01a36fddb2a4eb5cc214773dff6024279c5cd
|
||||
SHA512 (patch-4.11-rc1.xz) = a7b11ee0f2faedb2415effd3ad49e5309e30b3e57a49106a18d21628f4d08b988112086b080d4620bd9e00b07ec2751a5bfe05c348cfd343020c39d4d18faa81
|
||||
|
Loading…
Reference in New Issue
Block a user