Linux v4.15-rc9
This commit is contained in:
parent
b8d3820c35
commit
8e385c7277
@ -22,7 +22,7 @@ Signed-off-by: Lyude <lyude@redhat.com>
|
||||
3 files changed, 75 insertions(+), 112 deletions(-)
|
||||
|
||||
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
|
||||
index 5b40c26..4aa882c 100644
|
||||
index 0f43c42..3f38872 100644
|
||||
--- a/drivers/hid/hid-rmi.c
|
||||
+++ b/drivers/hid/hid-rmi.c
|
||||
@@ -316,19 +316,12 @@ static int rmi_input_event(struct hid_device *hdev, u8 *data, int size)
|
||||
@ -30,25 +30,25 @@ index 5b40c26..4aa882c 100644
|
||||
struct rmi_data *hdata = hid_get_drvdata(hdev);
|
||||
struct rmi_device *rmi_dev = hdata->xport.rmi_dev;
|
||||
- unsigned long flags;
|
||||
|
||||
|
||||
if (!(test_bit(RMI_STARTED, &hdata->flags)))
|
||||
return 0;
|
||||
|
||||
|
||||
- local_irq_save(flags);
|
||||
-
|
||||
rmi_set_attn_data(rmi_dev, data[1], &data[2], size - 2);
|
||||
|
||||
|
||||
- generic_handle_irq(hdata->rmi_irq);
|
||||
-
|
||||
- local_irq_restore(flags);
|
||||
-
|
||||
return 1;
|
||||
}
|
||||
|
||||
@@ -556,56 +549,6 @@ static const struct rmi_transport_ops hid_rmi_ops = {
|
||||
|
||||
@@ -568,56 +561,6 @@ static const struct rmi_transport_ops hid_rmi_ops = {
|
||||
.reset = rmi_hid_reset,
|
||||
};
|
||||
|
||||
|
||||
-static void rmi_irq_teardown(void *data)
|
||||
-{
|
||||
- struct rmi_data *hdata = data;
|
||||
@ -102,10 +102,10 @@ index 5b40c26..4aa882c 100644
|
||||
static int rmi_probe(struct hid_device *hdev, const struct hid_device_id *id)
|
||||
{
|
||||
struct rmi_data *data = NULL;
|
||||
@@ -677,18 +620,11 @@ static int rmi_probe(struct hid_device *hdev, const struct hid_device_id *id)
|
||||
|
||||
@@ -689,18 +632,11 @@ static int rmi_probe(struct hid_device *hdev, const struct hid_device_id *id)
|
||||
|
||||
mutex_init(&data->page_mutex);
|
||||
|
||||
|
||||
- ret = rmi_setup_irq_domain(hdev);
|
||||
- if (ret) {
|
||||
- hid_err(hdev, "failed to allocate IRQ domain\n");
|
||||
@ -114,26 +114,26 @@ index 5b40c26..4aa882c 100644
|
||||
-
|
||||
if (data->device_flags & RMI_DEVICE_HAS_PHYS_BUTTONS)
|
||||
rmi_hid_pdata.f30_data.disable = true;
|
||||
|
||||
|
||||
data->xport.dev = hdev->dev.parent;
|
||||
data->xport.pdata = rmi_hid_pdata;
|
||||
- data->xport.pdata.irq = data->rmi_irq;
|
||||
data->xport.proto_name = "hid";
|
||||
data->xport.ops = &hid_rmi_ops;
|
||||
|
||||
|
||||
diff --git a/drivers/input/rmi4/rmi_driver.c b/drivers/input/rmi4/rmi_driver.c
|
||||
index 4f2bb59..6d7da84 100644
|
||||
index 141ea22..15b22db 100644
|
||||
--- a/drivers/input/rmi4/rmi_driver.c
|
||||
+++ b/drivers/input/rmi4/rmi_driver.c
|
||||
@@ -209,32 +209,46 @@ void rmi_set_attn_data(struct rmi_device *rmi_dev, unsigned long irq_status,
|
||||
@@ -209,34 +209,47 @@ void rmi_set_attn_data(struct rmi_device *rmi_dev, unsigned long irq_status,
|
||||
attn_data.data = fifo_data;
|
||||
|
||||
|
||||
kfifo_put(&drvdata->attn_fifo, attn_data);
|
||||
+
|
||||
+ schedule_work(&drvdata->attn_work);
|
||||
}
|
||||
EXPORT_SYMBOL_GPL(rmi_set_attn_data);
|
||||
|
||||
|
||||
-static irqreturn_t rmi_irq_fn(int irq, void *dev_id)
|
||||
+static void attn_callback(struct work_struct *work)
|
||||
{
|
||||
@ -144,7 +144,7 @@ index 4f2bb59..6d7da84 100644
|
||||
+ attn_work);
|
||||
struct rmi4_attn_data attn_data = {0};
|
||||
int ret, count;
|
||||
|
||||
|
||||
count = kfifo_get(&drvdata->attn_fifo, &attn_data);
|
||||
- if (count) {
|
||||
- *(drvdata->irq_status) = attn_data.irq_status;
|
||||
@ -152,7 +152,7 @@ index 4f2bb59..6d7da84 100644
|
||||
- }
|
||||
+ if (!count)
|
||||
+ return;
|
||||
|
||||
|
||||
- ret = rmi_process_interrupt_requests(rmi_dev);
|
||||
+ *(drvdata->irq_status) = attn_data.irq_status;
|
||||
+ drvdata->attn_data = attn_data;
|
||||
@ -162,11 +162,14 @@ index 4f2bb59..6d7da84 100644
|
||||
- rmi_dbg(RMI_DEBUG_CORE, &rmi_dev->dev,
|
||||
+ rmi_dbg(RMI_DEBUG_CORE, &drvdata->rmi_dev->dev,
|
||||
"Failed to process interrupt request: %d\n", ret);
|
||||
|
||||
- if (count)
|
||||
|
||||
- if (count) {
|
||||
- kfree(attn_data.data);
|
||||
- attn_data.data = NULL;
|
||||
- }
|
||||
+ kfree(attn_data.data);
|
||||
|
||||
+ attn_data.data = NULL;
|
||||
|
||||
if (!kfifo_is_empty(&drvdata->attn_fifo))
|
||||
- return rmi_irq_fn(irq, dev_id);
|
||||
+ schedule_work(&drvdata->attn_work);
|
||||
@ -181,30 +184,30 @@ index 4f2bb59..6d7da84 100644
|
||||
+ if (ret)
|
||||
+ rmi_dbg(RMI_DEBUG_CORE, &rmi_dev->dev,
|
||||
+ "Failed to process interrupt request: %d\n", ret);
|
||||
|
||||
|
||||
return IRQ_HANDLED;
|
||||
}
|
||||
@@ -242,7 +256,6 @@ static irqreturn_t rmi_irq_fn(int irq, void *dev_id)
|
||||
@@ -244,7 +257,6 @@ static irqreturn_t rmi_irq_fn(int irq, void *dev_id)
|
||||
static int rmi_irq_init(struct rmi_device *rmi_dev)
|
||||
{
|
||||
struct rmi_device_platform_data *pdata = rmi_get_platform_data(rmi_dev);
|
||||
- struct rmi_driver_data *data = dev_get_drvdata(&rmi_dev->dev);
|
||||
int irq_flags = irq_get_trigger_type(pdata->irq);
|
||||
int ret;
|
||||
|
||||
@@ -260,8 +273,6 @@ static int rmi_irq_init(struct rmi_device *rmi_dev)
|
||||
|
||||
@@ -262,8 +274,6 @@ static int rmi_irq_init(struct rmi_device *rmi_dev)
|
||||
return ret;
|
||||
}
|
||||
|
||||
|
||||
- data->enabled = true;
|
||||
-
|
||||
return 0;
|
||||
}
|
||||
|
||||
@@ -910,23 +921,27 @@ void rmi_enable_irq(struct rmi_device *rmi_dev, bool clear_wake)
|
||||
|
||||
@@ -912,23 +922,27 @@ void rmi_enable_irq(struct rmi_device *rmi_dev, bool clear_wake)
|
||||
if (data->enabled)
|
||||
goto out;
|
||||
|
||||
|
||||
- enable_irq(irq);
|
||||
- data->enabled = true;
|
||||
- if (clear_wake && device_may_wakeup(rmi_dev->xport->dev)) {
|
||||
@ -224,7 +227,7 @@ index 4f2bb59..6d7da84 100644
|
||||
+ "Failed to disable irq for wake: %d\n",
|
||||
+ retval);
|
||||
+ }
|
||||
|
||||
|
||||
- /*
|
||||
- * Call rmi_process_interrupt_requests() after enabling irq,
|
||||
- * otherwise we may lose interrupt on edge-triggered systems.
|
||||
@ -242,12 +245,12 @@ index 4f2bb59..6d7da84 100644
|
||||
+ } else {
|
||||
+ data->enabled = true;
|
||||
+ }
|
||||
|
||||
|
||||
out:
|
||||
mutex_unlock(&data->enabled_mutex);
|
||||
@@ -946,20 +961,22 @@ void rmi_disable_irq(struct rmi_device *rmi_dev, bool enable_wake)
|
||||
@@ -948,20 +962,22 @@ void rmi_disable_irq(struct rmi_device *rmi_dev, bool enable_wake)
|
||||
goto out;
|
||||
|
||||
|
||||
data->enabled = false;
|
||||
- disable_irq(irq);
|
||||
- if (enable_wake && device_may_wakeup(rmi_dev->xport->dev)) {
|
||||
@ -280,25 +283,25 @@ index 4f2bb59..6d7da84 100644
|
||||
+ kfree(attn_data.data);
|
||||
+ }
|
||||
}
|
||||
|
||||
|
||||
out:
|
||||
@@ -998,9 +1015,12 @@ EXPORT_SYMBOL_GPL(rmi_driver_resume);
|
||||
@@ -1000,9 +1016,12 @@ EXPORT_SYMBOL_GPL(rmi_driver_resume);
|
||||
static int rmi_driver_remove(struct device *dev)
|
||||
{
|
||||
struct rmi_device *rmi_dev = to_rmi_device(dev);
|
||||
+ struct rmi_driver_data *data = dev_get_drvdata(&rmi_dev->dev);
|
||||
|
||||
|
||||
rmi_disable_irq(rmi_dev, false);
|
||||
|
||||
|
||||
+ cancel_work_sync(&data->attn_work);
|
||||
+
|
||||
rmi_f34_remove_sysfs(rmi_dev);
|
||||
rmi_free_function_list(rmi_dev);
|
||||
|
||||
@@ -1230,9 +1250,15 @@ static int rmi_driver_probe(struct device *dev)
|
||||
|
||||
@@ -1232,9 +1251,15 @@ static int rmi_driver_probe(struct device *dev)
|
||||
}
|
||||
}
|
||||
|
||||
|
||||
- retval = rmi_irq_init(rmi_dev);
|
||||
- if (retval < 0)
|
||||
- goto err_destroy_functions;
|
||||
@ -311,21 +314,18 @@ index 4f2bb59..6d7da84 100644
|
||||
+ data->enabled = true;
|
||||
+
|
||||
+ INIT_WORK(&data->attn_work, attn_callback);
|
||||
|
||||
|
||||
if (data->f01_container->dev.driver) {
|
||||
/* Driver already bound, so enable ATTN now. */
|
||||
diff --git a/include/linux/rmi.h b/include/linux/rmi.h
|
||||
index 64125443..dc90178 100644
|
||||
index 6412544..dc90178 100644
|
||||
--- a/include/linux/rmi.h
|
||||
+++ b/include/linux/rmi.h
|
||||
@@ -364,6 +364,7 @@ struct rmi_driver_data {
|
||||
|
||||
|
||||
struct rmi4_attn_data attn_data;
|
||||
DECLARE_KFIFO(attn_fifo, struct rmi4_attn_data, 16);
|
||||
+ struct work_struct attn_work;
|
||||
};
|
||||
|
||||
int rmi_register_transport_device(struct rmi_transport_dev *xport);
|
||||
--
|
||||
2.9.4
|
||||
|
||||
int rmi_register_transport_device(struct rmi_transport_dev *xport);
|
||||
|
11
kernel.spec
11
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%global rcrev 8
|
||||
%global rcrev 9
|
||||
# The git snapshot level
|
||||
%define gitrev 3
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 4.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -596,10 +596,6 @@ Patch332: arm64-socionext-96b-enablement.patch
|
||||
# https://patchwork.kernel.org/patch/10149775/ MMC support for Synquacer
|
||||
Patch333: arm64-mmc-sdhci_f_sdh30-add-ACPI-support.patch
|
||||
|
||||
# Fix Raspberry Pi and possibly some other dwc2/dwc3 users
|
||||
# https://patchwork.kernel.org/patch/10149439/
|
||||
Patch399: phy-work-around-phys-references-to-usb-phy-devices.patch
|
||||
|
||||
# 400 - IBM (ppc/s390x) patches
|
||||
|
||||
# 500 - Temp fixes/CVEs etc
|
||||
@ -1903,6 +1899,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Jan 22 2018 Justin M. Forbes <jforbes@fedoraproject.org> - 4.15.0-0.rc9.git0.1
|
||||
- Linux v4.15-rc9
|
||||
|
||||
* Mon Jan 22 2018 Justin M. Forbes <jforbes@fedoraproject.org>
|
||||
- Disable debugging options.
|
||||
|
||||
|
@ -1,104 +0,0 @@
|
||||
From patchwork Mon Jan 8 13:01:10 2018
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: phy: work around 'phys' references to usb-phy devices
|
||||
From: Arnd Bergmann <arnd@arndb.de>
|
||||
X-Patchwork-Id: 10149439
|
||||
Message-Id: <20180108130116.80148-1-arnd@arndb.de>
|
||||
To: Kishon Vijay Abraham I <kishon@ti.com>
|
||||
Cc: Stefan Wahren <stefan.wahren@i2se.com>, devicetree@vger.kernel.org,
|
||||
Florian Fainelli <f.fainelli@gmail.com>, Arnd Bergmann <arnd@arndb.de>,
|
||||
Felipe Balbi <balbi@kernel.org>, linux-usb@vger.kernel.org,
|
||||
linux-kernel@vger.kernel.org, stable@vger.kernel.org,
|
||||
Eric Anholt <eric@anholt.net>, Rob Herring <robh+dt@kernel.org>,
|
||||
Andrzej Pietrasiewicz <andrzej.p@samsung.com>,
|
||||
linux-arm-kernel@lists.infradead.org
|
||||
Date: Mon, 8 Jan 2018 14:01:10 +0100
|
||||
|
||||
Stefan Wahren reports a problem with a warning fix that was merged
|
||||
for v4.15: we had lots of device nodes with a 'phys' property pointing
|
||||
to a device node that is not compliant with the binding documented in
|
||||
Documentation/devicetree/bindings/phy/phy-bindings.txt
|
||||
|
||||
This generally works because USB HCD drivers that support both the generic
|
||||
phy subsystem and the older usb-phy subsystem ignore most errors from
|
||||
phy_get() and related calls and then use the usb-phy driver instead.
|
||||
|
||||
However, usb_add_hcd() (along with the respective functions in dwc2 and
|
||||
dwc3) propagate the EPROBE_DEFER return code so we can try again whenever
|
||||
the driver gets loaded. In case the driver is written for the usb-phy
|
||||
subsystem (like usb-generic-phy aka usb-nop-xceiv), we will never load
|
||||
a generic-phy driver for it, and keep failing here.
|
||||
|
||||
There is only a small number of remaining usb-phy drivers that support
|
||||
device tree, so this adds a workaround by providing a full list of the
|
||||
potentially affected drivers, and always failing the probe with -ENODEV
|
||||
here, which is the same behavior that we used to get with incorrect
|
||||
device tree files. Since we generally want older kernels to also want
|
||||
to work with the fixed devicetree files, it would be good to backport
|
||||
the patch into stable kernels as well (3.13+ are possibly affected).
|
||||
Reverting back to the DTS sources that work would in theory fix USB
|
||||
support for now, but in the long run we'd run into the same problem
|
||||
again when the drivers get ported from usb-phy to generic-phy.
|
||||
|
||||
Fixes: 014d6da6cb25 ("ARM: dts: bcm283x: Fix DTC warnings about missing phy-cells")
|
||||
Link: https://marc.info/?l=linux-usb&m=151518314314753&w=2
|
||||
Cc: stable@vger.kernel.org
|
||||
Cc: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
Cc: Felipe Balbi <balbi@kernel.org>
|
||||
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
|
||||
---
|
||||
This obviously needs to be tested, I wrote this up as a reply to
|
||||
Stefan's bug report. I'm fairly sure that I covered all usb-phy
|
||||
driver strings here. My goal is to have a fix merged into 4.15
|
||||
rather than reverting all the DT fixes.
|
||||
---
|
||||
drivers/phy/phy-core.c | 27 +++++++++++++++++++++++++++
|
||||
1 file changed, 27 insertions(+)
|
||||
|
||||
diff --git a/drivers/phy/phy-core.c b/drivers/phy/phy-core.c
|
||||
index b4964b067aec..bb4dd2a2de2d 100644
|
||||
--- a/drivers/phy/phy-core.c
|
||||
+++ b/drivers/phy/phy-core.c
|
||||
@@ -387,6 +387,24 @@ int phy_calibrate(struct phy *phy)
|
||||
}
|
||||
EXPORT_SYMBOL_GPL(phy_calibrate);
|
||||
|
||||
+static struct of_device_id __maybe_unused legacy_usbphy[] = {
|
||||
+ { .compatible = "fsl,imx23-usbphy" },
|
||||
+ { .compatible = "fsl,imx6q-usbphy" },
|
||||
+ { .compatible = "fsl,imx6sl-usbphy" },
|
||||
+ { .compatible = "fsl,imx6sx-usbphy" },
|
||||
+ { .compatible = "fsl,imx6ul-usbphy" },
|
||||
+ { .compatible = "fsl,vf610-usbphy" },
|
||||
+ { .compatible = "nvidia,tegra20-usb-phy" },
|
||||
+ { .compatible = "nvidia,tegra30-usb-phy" },
|
||||
+ { .compatible = "nxp,isp1301" },
|
||||
+ { .compatible = "ti,am335x-usb-ctrl-module" },
|
||||
+ { .compatible = "ti,am335x-usb-phy" },
|
||||
+ { .compatible = "ti,keystone-usbphy" },
|
||||
+ { .compatible = "ti,twl6030-usb" },
|
||||
+ { .compatible = "usb-nop-xceiv" },
|
||||
+ {},
|
||||
+};
|
||||
+
|
||||
/**
|
||||
* _of_phy_get() - lookup and obtain a reference to a phy by phandle
|
||||
* @np: device_node for which to get the phy
|
||||
@@ -410,6 +428,15 @@ static struct phy *_of_phy_get(struct device_node *np, int index)
|
||||
if (ret)
|
||||
return ERR_PTR(-ENODEV);
|
||||
|
||||
+ /*
|
||||
+ * Some USB host controllers use a "phys" property to refer to
|
||||
+ * a device that does not have a generic phy driver but that
|
||||
+ * has a driver for the older usb-phy framework.
|
||||
+ * We must not return -EPROBE_DEFER for those, so bail out early.
|
||||
+ */
|
||||
+ if (of_match_node(legacy_usbphy, args.np))
|
||||
+ return ERR_PTR(-ENODEV);
|
||||
+
|
||||
mutex_lock(&phy_provider_mutex);
|
||||
phy_provider = of_phy_provider_lookup(args.np);
|
||||
if (IS_ERR(phy_provider) || !try_module_get(phy_provider->owner)) {
|
3
sources
3
sources
@ -1,4 +1,3 @@
|
||||
SHA512 (linux-4.14.tar.xz) = 77e43a02d766c3d73b7e25c4aafb2e931d6b16e870510c22cef0cdb05c3acb7952b8908ebad12b10ef982c6efbe286364b1544586e715cf38390e483927904d8
|
||||
SHA512 (perf-man-4.14.tar.gz) = 76a9d8adc284cdffd4b3fbb060e7f9a14109267707ce1d03f4c3239cd70d8d164f697da3a0f90a363fbcac42a61d3c378afbcc2a86f112c501b9cb5ce74ef9f8
|
||||
SHA512 (patch-4.15-rc8.xz) = 1a70ada185b738586ca79cf7497582a3d0198746cebac028fc8e7558d00984e089242e1f3c48cec80eb2baf0ba1b519873a73dd418c9c209dd5568f0c5604634
|
||||
SHA512 (patch-4.15-rc8-git3.xz) = 5db660a60f083cb4cbb85840af0b2a2ffa355a890cdd99ea276ca593955e3407f272e153aefc7cfe74314d7de62124d5fdef8b73533ee82aed164e67e393b50d
|
||||
SHA512 (patch-4.15-rc9.xz) = 1b26350365d680bfa2bd5b38526aed8547e856a84168bdbca6e118b8181a68a2deb5bb5335325a4a2ffe33508eabdb01893bcdc85c90314746e8d399aac33be0
|
||||
|
@ -25,5 +25,5 @@ index ee5466a374bf..b3c683a84d3f 100644
|
||||
"LEN004a", /* W541 */
|
||||
+ "LEN0073", /* X1 Carbon 5 */
|
||||
"LEN200f", /* T450s */
|
||||
"LEN2018", /* T460p */
|
||||
NULL
|
||||
};
|
||||
|
Loading…
Reference in New Issue
Block a user